%%ItemTitle%%

Deltek Advantage 9.0 Database Send comments on this topic.

Deltek Advantage 9.0 Database

Tables

Table | Description
ABRAMapping | Mapping for the ABRA Interface
ADPExport | Work Table for ADP Export
AdvPWPMapping | Advantage to Project Workplace Data Mapping Table
AdvPWPMappingDefault | Advantage to Project Workplace Default Value Data Mapping Table
apControl | Accounts Payable Table - Data Entry Control
apDetail | Accounts Payable Table - Data Entry Detail
apMaster | Accounts Payable Table - Data Entry Master
apppChecks | Accounts Payable Payment Processing Table - Checks
AR | Accounts Receivable Table - Invoice Header
ARC | Accounts Receivable Table - Comments
BIED | Billing Adjustments Table - Expense Detail
BILD | Billing Adjustments Table - Labor Detail
billAddDetail | Invoice Detail Table - Add-On Detail for Prior Billings
billARDetail | Invoice Detail Table - Accounts Receivable Detail for Prior Billings
billBatchList | Invoice Detail Table – Batch Invoice List
billBTDDetail | Invoice Detail Table - Billings-to-date Detail for Prior Billings
billConDetail | Invoice Detail Table - Consultant Detail for Prior Billings
billExpDetail | Invoice Detail Table - Expense Detail for Prior Billings
billFeeDetail | Invoice Detail Table - Fee Detail for Prior Billings
billINDetail | Invoice Detail Table - Invoice Sections for Prior Billings
BillingTemplates | Billing Templates Table
billINMaster | Invoice Detail Table - Invoice Sections Master for Prior Billings
billIntDetail | Invoice Detail Table - Interest Detail for Prior Billings
billInvMaster | Invoice Detail Table – Invoice Master for Prior Billings
billInvSums | Invoice Detail Table - Final Invoice Section Totals for Prior Billings
billLabDetail | Invoice Detail Table - Labor Detail for Prior Billings
billLimDetail | Invoice Detail Table - Limit Detail for Prior Billings
billRetDetail | Invoice Detail Table - Retainage Detail (as processed in Interactive or Batch Billing) for Prior Billings
billTaxDetail | Invoice Detail Table - Tax Detail for Prior Billings
billUnitDetail | Invoice Detail Table - Unit Detail for Prior Billings
BT | Billing Terms Table
BTA | Billing Terms Add-Ons Table
BTBG | Billing Terms Billing Group Table
BTBGSubs | Billing Terms Billing Group Subprojects Table
BTEA | Billing Terms Expense Account Table
BTEAAccts | Billing Terms Expense Account Multipliers Table
BTEC | Billing Terms Expense Category Table
BTECAccts | Billing Terms Expense Category Table - Accounts
BTECCats | Billing Terms Expense Category Table - Categories
BTEV | Billing Terms Expense Vendor Table
BTEVVends | Billing Terms Expense Vendor Table - Multipliers
BTF | Billing Terms Fee Billing Phases Table
BTRCT | Billing Terms Rates Labor Category Table
BTRCTCats | Billing Terms Rates Labor Category Table - Categories and Rates
BTRCTEmpls | Billing Terms Rates Labor Category Table - Employee List
BTRLT | Billing Terms Rates Labor Code Table
BTRLTCodes | Billing Terms Rates Labor Code Table - Masks and Overrides
BTROT | Billing Terms Rates Labor Override Table
BTROTEmpls | Billing Terms Rates Labor Override Table – Employees, Rates, and Categories
BTRRT | Billing Terms Rates Labor Rate Table
BTRRTEmpls | Billing Terms Rates Labor Rate Table – Overrides
CA | Chart of Accounts Table
CAB | Corporate Budgets Table
CABDetail | Corporate Budgets Table - Detail
cdControl | Cash Disbursements Table - Data Entry Control
cdDetail | Cash Disbursements Table - Data Entry Detail
cdMaster | Cash Disbursements Table - Data Entry Master
CFGAccountStatus | Account Status Table
CFGADPLaborCodes | ADP Special Labor Codes Table
CFGAPDiscount | Accounts Payable Setup Table - Discount Codes
CFGAPForm1099 | Accounts Payable Setup Table - Vendor 1099 Forms
CFGAPLiability | Accounts Payable Setup Table - Liability Codes
CFGAPMain | Accounts Payable Setup Table
CFGAPStateID | Accounts Payable Setup Table - State Identification Numbers
CFGAPVendorType | Accounts Payable Setup Table - Vendor Types
CFGARLedgerHeadings | System Setup Table - Accounts Receivable Ledger Headings
CFGARMap | System Setup Table - Accounts Receivable Mapping
CFGBanks | System Setup Table - Bank Codes
CFGBillMain | Billing Setup Table
CFGBillTaxes | Billing Setup Table - Tax Codes
CFGCashAcctSetup | Cash Statement Report Table - Account Setup
CFGCashHeadings | Cash Statement Report Table - Headings
CFGCashSetup | Cash Statement Report Table - Setup
CFGCASortSelect | System Setup Table - Account Sort/Select Field Configuration
CFGClientStatus | Client Status Table
CFGCLSortSelect | System Setup Table - Client Sort/Select Field Configuration
CFGDates | System Setup Table - Dates
CFGEKCategory | System Setup Table - Expensekeeper Categories
CFGEKEmployeeGroup | System Setup Table - Expensekeeper Employee Groups
CFGEmployeeStatus | System Setup Table - Employee Status
CFGEmployeeType | System Setup Table - Employee Types
CFGEMSortSelect | System Setup Table - Employee Sort/Select Field Configuration
CFGETInterface | ET Interface Setup Table
CFGInstall | System Setup Table - Installation
CFGInvMap | System Setup Table - Invoice Mapping Accounts
CFGLabels | System Setup Table - Sort/Select Fields
CFGLC1 | System Setup Table - Labor Code Level 1
CFGLC2 | System Setup Table - Labor Code Level 2
CFGLC3 | System Setup Table - Labor Code Level 3
CFGLC4 | System Setup Table - Labor Code Level 4
CFGLC5 | System Setup Table - Labor Code Level 5
CFGMain | System Setup Table
CFGOHAccounts | System Setup Table - Overhead Allocation Accounts
CFGOHMain | System Setup Table - Overhead Allocation
CFGPCCodes | Profit Center Setup Table - Profit Center Subcodes
CFGPCControl | Profit Center Setup Table - Individual Profit Centers
CFGPCMain | Profit Center Setup Table - Profit Center Reporting
CFGPostControl | System Setup Table - Posting Control Table
CFGProcessQueue | System Setup Table - Process Server Queue
CFGProcessQueueStatus | System Setup Table - Process Server Queue Status
CFGProcessStatus | System Setup Table - Process Server Status
CFGProjectStatus | System Setup Table - Project Status
CFGProjectType | System Setup Table - Project Types
CFGPRSortSelect | System Setup Table - Project Sort/Select Field Configuration
CFGPWPInterface | Project Workplace Interface Setup Table
CFGPYAccruals | Payroll Setup Table - Accrual Codes
CFGPYFormW2 | Payroll Setup Table - W-2 Forms
CFGPYMain | Payroll Setup Table
CFGPYStateID | Payroll Setup Table - State Identification Numbers
CFGPYWHCodes | Payroll Setup Table - Withholding Codes
CFGPYWHMethod | Payroll Setup Table - Withholding Methods
CFGPYWHType | Payroll Setup Table - Withholding Types
CFGReportOptions | System Setup Table - Saved Report Options
CFGRGFormulas | Revenue Generation Setup Table - Formulas
CFGRGMethods | Revenue Generation Setup Table - Methods
CFGTimeAnalysis | Time Analysis Setup Table - Report
CFGTimeAnalysisHeadings | Time Analysis Setup Table - Headings
CFGTKCategory | Timekeeper Setup Table - Categories
CFGTKEmployeeGroup | Timekeeper Setup Table - Employee Groups
CFGTKMain | Timekeeper Setup Table
CFGVendorStatus | Accounts Payable Setup Table - Vendor Status
CFGVESortSelect | System Setup Table - Vendor Sort/Select Field Configuration
CL | Client Table
CLA | Client Address Table
CLInitiation | Client Initiation Table
CR | Bank Transaction Table
crControl | Cash Receipts Table - Data Entry Control
crDetail | Cash Receipts Table - Data Entry Detail
crMaster | Cash Receipts Table - Data Entry Master
cvControl | A/P Disbursements Table - Data Entry Control
cvDetail | A/P Disbursements Table - Data Entry Detail
cvMaster | A/P Disbursements Table - Data Entry Master
EB | Expense Budget Table
ED | Expense Detail Table
ekDetail | Expensekeeper Table - Data Entry Detail
ekMaster | Expensekeeper Table - Data Entry Master
EM | Employee Table
EMInitiation | Employee Initiation Table
EMP | Employee Payroll Table
EMPA | Employee Payroll Table - Accruals
EMPAD | Employee Payroll Table - Accrual Detail
EMPD | Employee Payroll Table - General Detail
EMPE | Employee Payroll Table - Direct Deposit Status/Calculations
EMPED | Employee Payroll Table - Direct Deposit Postings
EMPW | Employee Payroll Table - Withholdings
EMPWD | Employee Payroll Table - Withholding Postings
EMTKGroups | Timekeeper Table – Employee Groups
erControl | Employee Repayment Table - Data Entry Control
erDetail | Employee Repayment Table - Data Entry Detail
erMaster | Employee Repayment Table - Data Entry Master
ETChargeGroupMP | ET Interface Table - Charge Group Mappings
ETLeaveMP | ET Interface Table - Employee Leave Mappings
ETMapping | ET Interface Table - Field Mappings
EX | Expense Report Table
EXAdvance | Employee Advances Table
exChecks | Expense Report Checks Table
exChecksE | Transaction table for Expensekeeper Direct Deposit
exControl | Employee Expenses Table - Data Entry Control
exDetail | Employee Expenses Table - Data Entry Detail
exMaster | Employee Expenses Table - Data Entry Master
Form1099Data | Form 1099 Data Table
Form1099Data2001 | Form 1099 Data Table – 2001 Fields
FormW2Data | Form W-2 Data Table
FormW2Data2001 | Form W-2 Data 2001 Table
GLGroup | General Ledger Table - Account Groups
GLGroupDetail | General Ledger Table - Account Group Detail
GLTable | General Ledger Table - Accounts
inControl | Invoice Table - Data Entry Control
inDetail | Invoice Table - Data Entry Detail
inMaster | Invoice Table - Data Entry Master
jeControl | Journal Entry Table - Data Entry Control
jeDetail | Journal Entry Table - Data Entry Detail
jeMaster | Journal Entry Table - Data Entry Master
laControl | Labor Adjustments Table - Data Entry Control
laDetail | Labor Adjustments Table - Data Entry Detail
laMaster | Labor Adjustments Table - Data Entry Master
LB | Labor Budget Table
LD | Labor Detail Table
miControl | Miscellaneous Expenses Table - Data Entry Control
miDetail | Miscellaneous Expenses Table - Data Entry Detail
miMaster | Miscellaneous Expenses Table - Data Entry Master
OverheadAllocation | Overhead Allocation Report Table
PBLReportColumns | Interactive Project Reporting Columns Table - SQL Server
PBLReportFavorites | Interactive Project Reporting Favorites Table - SQL Server
PBLReportOptions | Interactive Project Reporting Options Table - SQL Server
PBLReportWhere | Interactive Project Reporting WHERE Clause Table - SQL Server
PBLReportWhereDetail | Interactive Project Reporting WHERE Clause Detail Table - SQL Server
PBLSearchCriteria | Interactive Project Reporting Search Criteria Table - SQL Server
plAccountSS | Account Sort/Select Fields List Table
plClientSS | Client Sort/Select Fields List Table
plEmployeeSS | Employee Sort/Select Fields List Table
plProjectSS | Project Sort/Select Fields List Table
plVendorSS | Vendor Sort/Select Fields List Table
PR | Project Table
prControl | Prints/Reproduction Expense Table - Data Entry Control
prDetail | Prints/Reproduction Expense Table - Data Entry Detail
PRF | Project Financial Table
PRInitiation | Project Template Initiation Table
prMaster | Prints/Reproduction Expense Table - Data Entry Master
ProcessPrinters | Process Server Printer List Table
ProcessQueue | Process Server Job History Table
ProjectCloseout | Project Closeout Report Table
PRTemplates | Project Templates Table
pwpMapping | Project Workplace Interface Mapping Table
pwpMappingDefault | Project Workplace Interface Default Mapping Table
PYChecks | Payroll Checks Table
PYChecksA | Payroll Checks Table - Accruals
PYChecksE | Payroll Checks Table - Direct Deposit Amounts
PYChecksW | Payroll Checks Table - Withholdings
RPTActivityList | Projects with Activity Selection List Table
RPTProjectList | Project Selection List Table
SE | Security Table
SEMenu | Security Table - Menu-Level Access
SEPrincipal | Row-Level Security Table - Principal Access
SEProfCtr | Row-Level Security Table – Profit Center Access
SEProjMgr | Row-Level Security Table – Project Manager Access
SESupervisor | Row-Level Security Table - Project Supervisor Access
SEUser | Security Table - Users
TKComments | Timekeeper Table - Comments
tkControl | Timekeeper Table - Data Entry Control
tkDetail | Timekeeper Table - Data Entry Detail
tkMaster | Timekeeper Table - Data Entry Master
TKSecurity | Timekeeper Table - Security
tsControl | Timesheets Table - Data Entry Control
tsDetail | Timesheets Table - Data Entry Detail
tsMaster | Timesheets Table - Data Entry Master
UN | Units Table
unControl | Units Table - Data Entry Control
unDetail | Units Table - Data Entry Detail
unMaster | Units Table - Data Entry Master
VE | Vendor Table
VEA | Vendor Table - Addresses
VEF | Vendor Table - Financials
VEInitiation | Vendors to be Approved Table
VO | Voucher Table
XChargeWk | Cross Charge Work Table

© Deltek Systems, Inc. All Rights Reserved.


%%LocalItemTitle%%

See Also

Deltek Advantage 9.0 Database

See Also Deltek Advantage 9.0 Database Send comments on this topic.

ABRAMapping Table

Description

Mapping for the ABRA Interface

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | EMColumnName | The EM table field name. | VarChar | 40 |
 | EMColumnOrderBY | The column's order in the EM table. | Integer | 4 |
 | ABRAColumnName | The field name in the ABRA HR Personnel Table. | VarChar | 255 |
 | EMDataType | The field's data type in the EM table. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
ABRAMappingPK |  |  |

SQL

CREATE TABLE [ABRAMapping] (
    [EMColumnName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [EMColumnOrderBY] [int] NULL ,
    [ABRAColumnName] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EMDataType] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [ABRAMappingPK] PRIMARY KEY NONCLUSTERED
    (
        [EMColumnName]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ABRAMapping Table | Deltek Advantage 9.0 Database

ABRAMappingPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | EMColumnName |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ABRAMapping Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

ADPExport Table

Description

Work Table for ADP Export

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 8 KB

Columns

Column Name | Description | Datatype | Length | Allow Nulls
Employee | The employee number. | VarChar | 10 |
CompanyCode | The employee's ADP location. | VarChar | 3 |
FileNumber | ADP's employee number. | VarChar | 6 |
BatchDesc | The description for the batch. | VarChar | 20 |
RegHrs | The regular hours worked for the employee. | Double | 9 |
OvtHrs | The overtime hours worked for the employee. | Double | 9 |
Hours3Code | A one or two-character code indicating the type of hours for the employee. | VarChar | 2 |
Hours3Amt | The number of hours corresponding to the Hours3Code. | Double | 9 |
Hours4Code | A one or two-character code indicating the type of hours for the employee. | VarChar | 2 |
Hours4Amt | The number of hours corresponding to the Hours4Code. | Double | 9 |
ErrorMessage | Any error generated for this employee record. | VarChar | 255 |

SQL

CREATE TABLE [ADPExport] (
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CompanyCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FileNumber] [varchar] (6) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BatchDesc] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RegHrs] [float] NULL ,
    [OvtHrs] [float] NULL ,
    [Hours3Code] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Hours3Amt] [float] NULL ,
    [Hours4Code] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Hours4Amt] [float] NULL ,
    [ErrorMessage] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

AdvPWPMapping Table

Description

Advantage to Project Workplace Data Mapping Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 269
Data Space Used | 24 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | advTable | The Advantage table with which the mapping is associated. | VarChar | 50 |
Primary Key | advColumn | The Advantage column with which the mapping is associated. | VarChar | 50 |
 | advLabel | The column's label. | VarChar | 50 |
 | advDataType | The column's data type. | VarChar | 50 |
 | advLength | The column's length. | Integer | 4 |
 | advOrder | The colunn's order. | Integer | 4 |
 | pwpColumn | The Project Workplace column with which the mapping is associated. | VarChar | 50 |
 | pwpDataType | The column's data type. | VarChar | 50 |
 | pwpLength | The column's length. | Integer | 4 |
 | sqlConversion | The SQL string used to map columns in Advantage. | VarChar | 255 |
 | Constant | Variable indicating whether this column has a constant value. | SmallInt | 2 |
 | Mappable | Variable indicating whether this column has a default mapping. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
AdvPWPMappingPK |  |  |

SQL

CREATE TABLE [AdvPWPMapping] (
    [advTable] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [advColumn] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [advLabel] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [advDataType] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [advLength] [int] NULL ,
    [advOrder] [int] NULL ,
    [pwpColumn] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [pwpDataType] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [pwpLength] [int] NULL ,
    [sqlConversion] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Constant] [smallint] NULL ,
    [Mappable] [smallint] NULL ,
    CONSTRAINT [AdvPWPMappingPK] PRIMARY KEY NONCLUSTERED
    (
        [advTable],
        [advColumn]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

AdvPWPMapping Table | Deltek Advantage 9.0 Database

AdvPWPMappingPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | advTable |  | Ascending
Primary Key | advColumn |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

AdvPWPMapping Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

AdvPWPMappingDefault Table

Description

Advantage to Project Workplace Default Value Data Mapping Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 269
Data Space Used | 24 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | advTable | The Advantage table with which the mapping is associated. | VarChar | 50 |
Primary Key | advColumn | The Advantage column with which the mapping is associated. | VarChar | 50 |
 | advLabel | The column's label. | VarChar | 50 |
 | advDataType | The column's data type. | VarChar | 50 |
 | advLength | The column's length. | Integer | 4 |
 | advOrder | The column's order. | Integer | 4 |
 | pwpColumn | The Project Workplace column with which the mapping is associated. | VarChar | 50 |
 | pwpDataType | The column's data type. | VarChar | 50 |
 | pwpLength | The column's length. | Integer | 4 |
 | sqlConversion | The SQL string used for mapping columns in Advantage. | VarChar | 255 |
 | Constant | Variable indicating whether this column is a constant value. | SmallInt | 2 |
 | Mappable | Variable indicating whether this column has a default mapping. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
AdvPWPMappingDefaultPK |  |  |

SQL

CREATE TABLE [AdvPWPMappingDefault] (
    [advTable] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [advColumn] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [advLabel] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [advDataType] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [advLength] [int] NULL ,
    [advOrder] [int] NULL ,
    [pwpColumn] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [pwpDataType] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [pwpLength] [int] NULL ,
    [sqlConversion] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Constant] [smallint] NULL ,
    [Mappable] [smallint] NULL ,
    CONSTRAINT [AdvPWPMappingDefaultPK] PRIMARY KEY NONCLUSTERED
    (
        [advTable],
        [advColumn]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

AdvPWPMappingDefault Table | Deltek Advantage 9.0 Database

AdvPWPMappingDefaultPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | advTable |  | Ascending
Primary Key | advColumn |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

AdvPWPMappingDefault Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

apControl Table

Description

Accounts Payable Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | The name of the data entry transaction file. | VarChar | 15 |
 | Recurring | Flag indicating whether this is a recurring transaction file. | Boolean | 1 |
 | Selected | Flag indicating whether this file has been selected for posting. | Boolean | 1 |
 | Posted | Flag indicating whether this file has been posted. | VarChar | 1 |
 | Creator | The name of the user who created this file. | VarChar | 15 |
 | Period | The fiscal period and year when this file was created. | Integer | 4 |
 | EndDate | The file's end date. | DBTimeStamp | 4 |
 | Total | The total entered for the file. | Double | 9 |
 | DefaultLiab | The default liability code to use for entries in the data entry file. | VarChar | 10 |
 | DefaultBank | The default bank code to use for entries in the file. | VarChar | 10 |
 | DefaultDate | The default date to use for entries in the file. | DBTimeStamp | 4 |
 | DefaultTaxCode | The default tax code to use for entries in the file. | VarChar | 3 |
 | PostPeriod |  | Integer | 4 |
 | PostSeq |  | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
apControlPK |  |  |

SQL

CREATE TABLE [apControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__apControl__Recur__07420643] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__apControl__Selec__08362A7C] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__apControl__Poste__092A4EB5] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [EndDate] [datetime] NULL ,
    [Total] [float] NULL ,
    [DefaultLiab] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DefaultBank] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DefaultDate] [datetime] NULL ,
    [DefaultTaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__apControl__PostP__0A1E72EE] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__apControl__PostS__0B129727] DEFAULT (0),
    CONSTRAINT [apControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

apControl Table | Deltek Advantage 9.0 Database

apControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

apControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

apDetail Table

Description

Accounts Payable Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | The name of the data entry transaction file. | VarChar | 15 |
Primary Key | Vendor | The vendor number. | VarChar | 10 |
Primary Key | InvoiceDate | The invoice date of the transaction for this vendor. | DBTimeStamp | 4 |
Primary Key | Invoice | The invoice number of the transaction for this vendor. | VarChar | 20 |
Primary Key | Seq | The internal sequence number. | Integer | 4 |
 | Description | The description entered for the voucher detail line. | VarChar | 40 |
 | Project | The project number to which the voucher amount applies. | VarChar | 12 |
 | ProjType | Variable indicating the project type. Valid options are R - regular; H - overhead; and P - promotional. | VarChar | 1 |
 | TaskType | Flag indicating whether the proejct has tasks. | VarChar | 1 |
 | Task | The task number to which the voucher applies. | VarChar | 5 |
 | Account | The account number to which to post the voucher. | VarChar | 10 |
 | Amount | The voucher amount. | Double | 9 |
 | SuppressBill | Flag indicating whether to suppress the printing of this transaction on the invoice. | Boolean | 1 |
 | TaxCode | The tax code to associate with the individual line item. | VarChar | 3 |
 | NetAmount | The gross voucher amount less any taz amount applied. | Double | 9 |
 | TaxAmount | The tax amount applied to the voucher. | Double | 9 |

Indexes

Index | Description | Primary | Unique
apDetailPK |  |  |

SQL

CREATE TABLE [apDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Vendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [InvoiceDate] [datetime] NOT NULL ,
    [Invoice] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [SuppressBill] [bit] NOT NULL CONSTRAINT [DF__apDetail__Suppre__1367E606] DEFAULT (0),
    [TaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [NetAmount] [float] NULL ,
    [TaxAmount] [float] NULL ,
    CONSTRAINT [apDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Vendor],
        [InvoiceDate],
        [Invoice],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

apDetail Table | Deltek Advantage 9.0 Database

apDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Vendor |  | Ascending
Primary Key | InvoiceDate |  | Ascending
Primary Key | Invoice |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

apDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

apMaster Table

Description

Accounts Payable Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | The name of the data entry transaction file. | VarChar | 15 |
Primary Key | Vendor | The vendor number. | VarChar | 10 |
Primary Key | InvoiceDate | The invoice date of the transaction for this vendor. | DBTimeStamp | 4 |
Primary Key | Invoice | The invoice number of the transaction for this vendor. | VarChar | 20 |
 | TransDate | The date when the transaction data was entered. | DBTimeStamp | 4 |
 | LiabCode | The liability code to use when posting the voucher. | VarChar | 10 |
 | BankCode | The bank code to use when processing vendor payments. | VarChar | 10 |
 | PayDate | The payment date for the transaction. | VarChar | 11 |
 | Address | The address code to use when processing vendor payments. | VarChar | 10 |
 | Posted | Flag indicating whether the data entry file has been posted. | VarChar | 1 |
 | Seq | The sequence number for sorting data entry screen and transaction lists. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
apMasterPK |  |  |
BankCodeIDX |  |  |
LiabCodeIDX |  |  |

SQL

CREATE TABLE [apMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Vendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [InvoiceDate] [datetime] NOT NULL ,
    [Invoice] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransDate] [datetime] NULL ,
    [LiabCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayDate] [varchar] (11) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Address] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__apMaster__Posted__5EFF0ABF] DEFAULT ('N'),
    [Seq] [int] NULL ,
    CONSTRAINT [apMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Vendor],
        [InvoiceDate],
        [Invoice]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

apMaster Table | Deltek Advantage 9.0 Database

apMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Vendor |  | Ascending
Primary Key | InvoiceDate |  | Ascending
Primary Key | Invoice |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

apMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

apMaster Table | Deltek Advantage 9.0 Database

BankCodeIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
BankCode |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

apMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

apMaster Table | Deltek Advantage 9.0 Database

LiabCodeIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
LiabCode |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

apMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

apppChecks Table

Description

Accounts Payable Payment Processing Table - Checks

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | PostSeq | The posting sequence number. | Integer | 4 |
Primary Key | Seq | The internal sequence number. | Integer | 4 |
 | Printed | Flag indicating whether checks for this bank code have been printed. | Boolean | 1 |
 | Assigned | Flag indicating whether check numbers have been assigned. | Boolean | 1 |
 | BankCode | The checks' bank code. | VarChar | 10 |
 | Sequence | The check's sequence number. | Integer | 4 |
 | CheckNo | The check's check number. | Integer | 4 |
 | CheckDate | The check's date. | DBTimeStamp | 4 |
 | Vendor | The vendor number for which the check was generated. | VarChar | 10 |
 | Name | The vendor name for which the check was generated. | VarChar | 40 |
 | Voucher | The internal voucher number. | VarChar | 7 |
 | Invoice | The invoice number entered for the transaction during data entry. | VarChar | 20 |
 | InvoiceDate | The invoice date entered for the transaction during data entry. | DBTimeStamp | 4 |
 | LiabCode | The transaction's liability code. | VarChar | 10 |
 | DiscCode | The discount code to apply to the vendor. | VarChar | 10 |
 | Address | The address code to use for the vendor. | VarChar | 10 |
 | Line | The voucher line. | SmallInt | 2 |
 | Project | The project to which the original voucher line was charged. | VarChar | 12 |
 | Task | The profit center to which the original voucher line was charged. | VarChar | 5 |
 | Account | The account to which the original voucher line was charged. | VarChar | 10 |
 | ProfCtr | The profit center to which the original voucher line was charged. | VarChar | 8 |
 | Amount | The amount of the original voucher line. | Double | 9 |
 | Discount | The discount applied to the voucher line. | Double | 9 |
 | PrevPay | Any previous payments made to the voucher line. | Double | 9 |
 | Payment | The amount to be paid, prior to applying any discounts. | Double | 9 |
 | PayTerms | Variable indicating the payment terms. Valid optoins are Next, Hold, PWP, Partial, and Date. | VarChar | 7 |
 | TaxCode | The tax code to associate with the transaction. | VarChar | 3 |
 | TaxPayment | The tax amount applied to the transaction. | Double | 9 |
 | TaxDiscount | The tax discount amount applied to the transaction. | Double | 9 |

Indexes

Index | Description | Primary | Unique
apppChecksPK |  |  |

SQL

CREATE TABLE [apppChecks] (
    [PostSeq] [int] NOT NULL ,
    [Seq] [int] NOT NULL ,
    [Printed] [bit] NOT NULL CONSTRAINT [DF__apppCheck__Print__173876EA] DEFAULT (0),
    [Assigned] [bit] NOT NULL CONSTRAINT [DF__apppCheck__Assig__182C9B23] DEFAULT (0),
    [BankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Sequence] [int] NULL ,
    [CheckNo] [int] NULL ,
    [CheckDate] [datetime] NULL ,
    [Vendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Name] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Voucher] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Invoice] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InvoiceDate] [datetime] NULL ,
    [LiabCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DiscCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Address] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Line] [smallint] NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [Discount] [float] NULL ,
    [PrevPay] [float] NULL ,
    [Payment] [float] NULL ,
    [PayTerms] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxPayment] [float] NULL ,
    [TaxDiscount] [float] NULL ,
    CONSTRAINT [apppChecksPK] PRIMARY KEY NONCLUSTERED
    (
        [PostSeq],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

apppChecks Table | Deltek Advantage 9.0 Database

apppChecksPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | PostSeq |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

apppChecks Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

AR Table

Description

Accounts Receivable Table - Invoice Header

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | arProject | The project number. | VarChar | 12 |
Primary Key | arTask | The task number. | VarChar | 5 |
Primary Key | arInvoice | The invoice number. | VarChar | 7 |
 | arPeriod | The period when the invoice was posted. | Integer | 4 |
 | arInvoiceDate | The invoice date. | DBTimeStamp | 4 |
 | arPaidPeriod | The period when the invoice became fully paid. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
ARPK |  |  |
arPaidPeriodIDX |  |  |

SQL

CREATE TABLE [AR] (
    [arProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [arTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [arInvoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [arPeriod] [int] NULL ,
    [arInvoiceDate] [datetime] NULL ,
    [arPaidPeriod] [int] NULL ,
    CONSTRAINT [ARPK] PRIMARY KEY NONCLUSTERED
    (
        [arProject],
        [arTask],
        [arInvoice]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

AR Table | Deltek Advantage 9.0 Database

ARPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | arProject |  | Ascending
Primary Key | arTask |  | Ascending
Primary Key | arInvoice |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

AR Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

AR Table | Deltek Advantage 9.0 Database

arPaidPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
arPaidPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

AR Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

ARC Table

Description

Accounts Receivable Table - Comments

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 24 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | arcClient | The client number for which the comment was entered. | VarChar | 10 |
Primary Key | arcDate | The date when the comment was entered. | DBTimeStamp | 4 |
Primary Key | arcUsername | The Advantage username of the employee entering the comment. | VarChar | 20 |
 | arcProject | The project number associated with the comment. | VarChar | 12 |
 | arcInvoice | The invoice number associated with the comment. | VarChar | 7 |
 | arcComment | The comment entered. | LongVarChar | 16 |

Indexes

Index | Description | Primary | Unique
ARCPK |  |  |

SQL

CREATE TABLE [ARC] (
    [arcClient] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [arcDate] [datetime] NOT NULL ,
    [arcUsername] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [arcProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [arcInvoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [arcComment] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [ARCPK] PRIMARY KEY NONCLUSTERED
    (
        [arcClient],
        [arcDate],
        [arcUsername]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ARC Table | Deltek Advantage 9.0 Database

ARCPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | arcClient |  | Ascending
Primary Key | arcDate |  | Ascending
Primary Key | arcUsername |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ARC Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BIED Table

Description

Billing Adjustments Table - Expense Detail

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | edKey | Internal sequence number. | Integer | 4 |
 | edProject | Project number. | VarChar | 12 |
 | edTask | Task number. | VarChar | 5 |
 | edAccount | Account number. | VarChar | 10 |
 | edProfCtr | The profit center associated with the project for this transaction. | VarChar | 8 |
 | edPeriod | The fiscal year and period when the transaction was posted. | Integer | 4 |
 | edPostSeq | The posting sequence number assigned to the transaction during posting. | SmallInt | 2 |
 | edTransType | The transaction type. | VarChar | 2 |
 | edSubType | The transaction sub-type. | VarChar | 1 |
 | edRefNo | The reference number associated with the transaction during data entry. | VarChar | 7 |
 | edDate | The date entered for the transaction during data entry. | DBTimeStamp | 4 |
 | edDesc1 | The first description entered for the transaction. | VarChar | 40 |
 | edDesc2 | The second description entered for the transaction. | VarChar | 40 |
 | edAmount | The transaction amount for general ledger reporting purposes. | Double | 9 |
 | edCBAmount | The transaction amount on a cash basis. | Double | 9 |
 | edBillExt | The billing extension, for generating project reports at billing rates. | Double | 9 |
 | edProjectCost | Internal flag for project reporting use. | Boolean | 1 |
 | edAutoEntry | Flag indicating whether this transaction is the result of an implicit posting. | Boolean | 1 |
 | edSuppressBill | Flag indicating whether to suppress billing for this transaction. | Boolean | 1 |
 | edBillStatus | The billing status of this expense transaction. | VarChar | 1 |
 | edSkipGL | Flag indicating whether to include this transaction for general ledger reporting. History transactions are not included. | Boolean | 1 |
 | edBankCode | The bank code assigned to this transaction during data entry. | VarChar | 10 |
 | edInvoice | The number of the invoice being paid by this transaction. | VarChar | 7 |
 | edInvoiceSection | Variable indicating the invoice section to which this transaction applies. Valid optons are F - Fee; L - Labor; E - Expense; C - Consultant; U - Unit; A - Add-on. | VarChar | 1 |
 | edVendor | The vendor number. | VarChar | 10 |
 | edLine | The accounts payable voucher line number. | SmallInt | 2 |
 | edPartialPayment | The partial payment amount in the voucher payment record. | Double | 9 |
 | edDiscount | The discount amount in the voucher payment record. | Double | 9 |
 | edVoucher | The voucher number. | VarChar | 7 |
 | edBilledProject | The project with which this transaction was final billed. | VarChar | 12 |
 | edBilledTask | The task with which this transaction was final billed. | VarChar | 5 |
 | edBilledInvoice | The invoice on which this transaction was final billed. | VarChar | 7 |
 | edBilledPeriod | The active period in which the transaction was final billed. | Integer | 4 |
 | edUnit | The unit number. | VarChar | 10 |
 | edUnitTable | The unit table associated with the project to which the unit was charged. | VarChar | 12 |
 | edUnitQuantity | The number of items specified for the unit. | Double | 9 |
 | edUnitCostRate | The unit' s cost rate per unit. the | Double | 9 |
 | edUnitBillingRate | The unit's billing rate per unit. | Double | 9 |
 | edUnitBillExt | The unit billing extension. This amount equals edUnitQuantity * edUnitBillingRate. | Double | 9 |
 | edOriginalKey | Internal sequence number. | Integer | 4 |
 | edXferProject | The project from which the expense detail was transferred. | VarChar | 12 |
 | edXferTask | The task from which the expense detail was transferred. | VarChar | 5 |
 | edXferAccount | The account from which the expense detail was transferred. | VarChar | 10 |
 | edTaxCode | The tax code to associate with the transaction. | VarChar | 3 |
 | edTaxAmount | The tax amount applied to the transaction. | Double | 9 |
 | edTaxCBAmount | The cash basis tax amount, if any, associated with this transaction. | Double | 9 |
 | edTaxBasis | The tax basis, if any, associated with this transaction. | Double | 9 |
 | edTaxCBBasis | The cash basis tax basis, if any, associated with this transaction. | Double | 9 |
 | edBillTaxCodeOverride | The tax code that overrides the standard billing tax code. | VarChar | 3 |
 | edWrittenoffPeriod | The active period when this record was written off (billing status "X.") | Integer | 4 |
 | edPrintedDisbCheck |  | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
BIEDPK |  |  |
edAccountIDX |  |  |
edBankCodeIDX |  |  |
edBillStatusIDX |  |  |
edOriginalKeyIDX |  |  |
edPeriodIDX |  |  |
edProjectedTaskIDX |  |  |
edTaxCodeIDX |  |  |
edTransTypeedSubTypeIDX |  |  |
edVendoredVoucherIDX |  |  |

SQL

CREATE TABLE [BIED] (
    [edKey] [int] NOT NULL ,
    [edProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edPeriod] [int] NULL ,
    [edPostSeq] [smallint] NULL ,
    [edTransType] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edSubType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edRefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edDate] [datetime] NULL ,
    [edDesc1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edDesc2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edAmount] [float] NULL ,
    [edCBAmount] [float] NULL ,
    [edBillExt] [float] NULL ,
    [edProjectCost] [bit] NOT NULL CONSTRAINT [DF__BIED__edProjectC__4FF1D159] DEFAULT (0),
    [edAutoEntry] [bit] NOT NULL CONSTRAINT [DF__BIED__edAutoEntr__50E5F592] DEFAULT (0),
    [edSuppressBill] [bit] NOT NULL CONSTRAINT [DF__BIED__edSuppress__51DA19CB] DEFAULT (0),
    [edBillStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edSkipGL] [bit] NOT NULL CONSTRAINT [DF__BIED__edSkipGL__52CE3E04] DEFAULT (0),
    [edBankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edInvoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edInvoiceSection] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edVendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edLine] [smallint] NULL ,
    [edPartialPayment] [float] NULL ,
    [edDiscount] [float] NULL ,
    [edVoucher] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edBilledProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edBilledTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edBilledInvoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edBilledPeriod] [int] NULL ,
    [edUnit] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edUnitTable] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edUnitQuantity] [float] NULL ,
    [edUnitCostRate] [float] NULL ,
    [edUnitBillingRate] [float] NULL ,
    [edUnitBillExt] [float] NULL ,
    [edOriginalKey] [int] NULL ,
    [edXferProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edXferTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edXferAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edTaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edTaxAmount] [float] NULL ,
    [edTaxCBAmount] [float] NULL ,
    [edTaxBasis] [float] NULL ,
    [edTaxCBBasis] [float] NULL ,
    [edBillTaxCodeOverride] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edWrittenoffPeriod] [int] NULL ,
    [edPrintedDisbCheck] [bit] NOT NULL CONSTRAINT [DF__BIED__edPrintedD__53C2623D] DEFAULT (0),
    CONSTRAINT [BIEDPK] PRIMARY KEY NONCLUSTERED
    (
        [edKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BIED Table | Deltek Advantage 9.0 Database

BIEDPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | edKey |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BIED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BIED Table | Deltek Advantage 9.0 Database

edAccountIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edAccount |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BIED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BIED Table | Deltek Advantage 9.0 Database

edBankCodeIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edBankCode |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BIED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BIED Table | Deltek Advantage 9.0 Database

edBillStatusIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edBillStatus |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BIED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BIED Table | Deltek Advantage 9.0 Database

edOriginalKeyIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edOriginalKey |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BIED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BIED Table | Deltek Advantage 9.0 Database

edPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BIED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BIED Table | Deltek Advantage 9.0 Database

edProjectedTaskIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edProject |  | Ascending
edTask |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BIED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BIED Table | Deltek Advantage 9.0 Database

edTaxCodeIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edTaxCode |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BIED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BIED Table | Deltek Advantage 9.0 Database

edTransTypeedSubTypeIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edTransType |  | Ascending
edSubType |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BIED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BIED Table | Deltek Advantage 9.0 Database

edVendoredVoucherIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edVendor |  | Ascending
edVoucher |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BIED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BILD Table

Description

Billing Adjustments Table - Labor Detail

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 104 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ldKey | Required. Internal sequence number. | Integer | 4 |
 | ldProject | Project number. | VarChar | 12 |
 | ldTask | Task number. | VarChar | 5 |
 | ldLaborCode | Labor code. | VarChar | 5 |
 | ldEmployee | Employee number. | VarChar | 10 |
 | ldTransType | Transaction type. | VarChar | 2 |
 | ldDate | Date entered for the transaction. | DBTimeStamp | 4 |
 | ldPeriod | Fiscal period and year. | Integer | 4 |
 | ldPostSeq | Posting sequence number. | SmallInt | 2 |
 | ldName | Employee’s name. | VarChar | 35 |
 | ldRegHrs | Total regular hours charged to the project. | Double | 9 |
 | ldOvtHrs | Total regular hours charged to the project. | Double | 9 |
 | ldRegAmt | Total regular amount for the employee. | Double | 9 |
 | ldOvtAmt | Total overtime amount for the employee. | Double | 9 |
 | ldBillExt | Extended regular and overtime hours and amounts for the employee/project combination. | Double | 9 |
 | ldRate | Rate at which the employee is billed for regular hours. | Double | 9 |
 | ldOvtPct | Overtime percentage for the employee’s overtime hours. | Double | 9 |
 | ldOvtRate | Rate at which the employee is billed for overtime hours. | Double | 9 |
 | ldEmType | Variable indicating the employee type. Valid options are P - Principal and E - Employee. | VarChar | 1 |
 | ldPool | Not used. | SmallInt | 2 |
 | ldCategory | Labor category to which the employee is assigned. | SmallInt | 2 |
 | ldEmProfCtr | Employee’s profit center. | VarChar | 8 |
 | ldPrProfCtr | Project’s profit center. | VarChar | 8 |
 | ldPrType | Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | ldRateType | Variable indicating the employee’s rate type at the time of posting. Valid options are H - Hourly and S - Salary. | VarChar | 1 |
 | ldDebitEDPtr | Internal field. | Integer | 4 |
 | ldCreditEDPtr | Internal field. | Integer | 4 |
 | ldSuppressBill | Variable indicating whether to suppress the billing for the transaction. | Boolean | 1 |
 | ldBillStatus | Billing status for the labor transaction. | VarChar | 1 |
 | ldComment | Comment entered for the labor transaction. | VarChar | 255 |
 | ldBilledProject | Project with which the transaction was final billed. | VarChar | 12 |
 | ldBilledTask | Task with which the transaction was final billed. | VarChar | 5 |
 | ldBilledInvoice | Invoice on which the transaction was final billed. | VarChar | 7 |
 | ldBilledPeriod | Active period in which the transaction was final billed. | Integer | 4 |
 | ldXferProject | Project from which the labor detail was transferred. | VarChar | 12 |
 | ldXferTask | Task from which the labor detail was transferred. | VarChar | 5 |
 | ldXferLaborCode | Account from which the labor detail was transferred. | VarChar | 10 |
 | ldProjectCost | Variable indicating whether to activate project reporting. | Boolean | 1 |
 | ldBillTaxCodeOverride | Tax code that will override the standard billing tax code. | VarChar | 3 |
 | ldSpecialOvtHrs | Special overtime hours. | Double | 9 |
 | ldSpecialOvtAmt | Special overtime cost amount. | Double | 9 |
 | ldSpecialOvtPct | Special overtime percent. | Double | 9 |
 | ldSpecialOvtRate | Special overtime rate. | Double | 9 |
 | ldWrittenoffPeriod | Active period when this record was written off (Billing status “X”). | Integer | 4 |

Indexes

Index | Description | Primary | Unique
BILDPK |  |  |
ldBillStatusIDX |  |  |
ldLaborCodeIDX |  |  |
ldPeriodIDX |  |  |
ldProjectldTaskIDX |  |  |
ldXferLaborCodeIDX |  |  |

SQL

CREATE TABLE [BILD] (
    [ldKey] [int] NOT NULL ,
    [ldProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldLaborCode] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldTransType] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldDate] [datetime] NULL ,
    [ldPeriod] [int] NULL ,
    [ldPostSeq] [smallint] NULL ,
    [ldName] [varchar] (35) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldRegHrs] [float] NULL ,
    [ldOvtHrs] [float] NULL ,
    [ldRegAmt] [float] NULL ,
    [ldOvtAmt] [float] NULL ,
    [ldBillExt] [float] NULL ,
    [ldRate] [float] NULL ,
    [ldOvtPct] [float] NULL ,
    [ldOvtRate] [float] NULL ,
    [ldEmType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldPool] [smallint] NULL ,
    [ldCategory] [smallint] NULL ,
    [ldEmProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldPrProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldPrType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldRateType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldDebitEDPtr] [int] NULL ,
    [ldCreditEDPtr] [int] NULL ,
    [ldSuppressBill] [bit] NOT NULL CONSTRAINT [DF__BILD__ldSuppress__20C1E124] DEFAULT (0),
    [ldBillStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldComment] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldBilledProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldBilledTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldBilledInvoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldBilledPeriod] [int] NULL ,
    [ldXferProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldXferTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldXferLaborCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldProjectCost] [bit] NOT NULL CONSTRAINT [DF__BILD__ldProjectC__21B6055D] DEFAULT (0),
    [ldBillTaxCodeOverride] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldSpecialOvtHrs] [float] NULL ,
    [ldSpecialOvtAmt] [float] NULL ,
    [ldSpecialOvtPct] [float] NULL ,
    [ldSpecialOvtRate] [float] NULL ,
    [ldWrittenoffPeriod] [int] NULL ,
    CONSTRAINT [BILDPK] PRIMARY KEY NONCLUSTERED
    (
        [ldKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BILD Table | Deltek Advantage 9.0 Database

BILDPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ldKey |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BILD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BILD Table | Deltek Advantage 9.0 Database

ldBillStatusIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
ldBillStatus |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BILD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BILD Table | Deltek Advantage 9.0 Database

ldLaborCodeIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
ldLaborCode |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BILD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BILD Table | Deltek Advantage 9.0 Database

ldPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
ldPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BILD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BILD Table | Deltek Advantage 9.0 Database

ldProjectldTaskIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
ldProject |  | Ascending
ldTask |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BILD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BILD Table | Deltek Advantage 9.0 Database

ldXferLaborCodeIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
ldXferLaborCode |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BILD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billAddDetail Table

Description

Invoice Detail Table - Add-On Detail for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 5 |
 | Sequence | Add-on sequence number. | SmallInt | 2 |
 | Description | Description from the add-on table for the project. | VarChar | 40 |
 | Computation | Computation of the add-on fee. | VarChar | 30 |
 | Amount | Billing amount as it will appear on the invoice. | Double | 9 |
 | Basis | Amount on which the add-on was computed. | Double | 9 |
 | Markup | Markup percentage from the project’s billing terms. | Double | 9 |
Primary Key | RecdSeq | Required. Sequence number to provide unique identification for the record. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
billAddDetailPK |  |  |

SQL

CREATE TABLE [billAddDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Sequence] [smallint] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Computation] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [Basis] [float] NULL ,
    [Markup] [float] NULL ,
    [RecdSeq] [int] NOT NULL ,
    CONSTRAINT [billAddDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [RecdSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billAddDetail Table | Deltek Advantage 9.0 Database

billAddDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | RecdSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billAddDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billARDetail Table

Description

Invoice Detail Table - Accounts Receivable Detail for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 12 |
 | InvoiceNumber | Number of the invoice. | VarChar | 7 |
 | InvoiceDate | Date of the invoice. | DBTimeStamp | 4 |
 | Description | Internal use only. | VarChar | 40 |
 | Balance | Balance on the invoice. | Double | 9 |
 | Invoiced | Original invoice amount. | Double | 9 |
 | Received | Total amount received. | Double | 9 |
Primary Key | RecdSeq | Required. Sequence number to provide unique identification for the record. | Integer | 4 |
 | RetainageFormat | Variable indicating whether the retainage format is to be used. | Boolean | 1 |
 | Retainage | Retainage amount in the invoice (usually negative). | Double | 9 |

Indexes

Index | Description | Primary | Unique
billARDetailPK |  |  |

SQL

CREATE TABLE [billARDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InvoiceNumber] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InvoiceDate] [datetime] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Balance] [float] NULL ,
    [Invoiced] [float] NULL ,
    [Received] [float] NULL ,
    [RecdSeq] [int] NOT NULL ,
    [RetainageFormat] [bit] NOT NULL CONSTRAINT [DF__billARDet__Retai__24927208] DEFAULT (0),
    [Retainage] [float] NULL ,
    CONSTRAINT [billARDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [RecdSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billARDetail Table | Deltek Advantage 9.0 Database

billARDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | RecdSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billARDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billBatchList Table

Description

Invoice Detail Table – Batch Invoice List

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 8 KB

Columns

Column Name | Description | Datatype | Length | Allow Nulls
CurrentUser | The username of the user who processed the batch billing run. | VarChar | 20 |
Invoice | The invoice number when final; <Draft> while in draft status. | VarChar | 7 |
MainProject | The project for which the entire invoice is being created; either the actual project or the main project in a billing group. | VarChar | 12 |
Section | The invoice section to which the amount applies. | VarChar | 10 |
FinalAmount | Total of extensions with all markups; the number printed on the invoice. | Double | 9 |

SQL

CREATE TABLE [billBatchList] (
    [CurrentUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Section] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FinalAmount] [float] NULL
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billBTDDetail Table

Description

Invoice Detail Table - Billings-to-date Detail for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
Primary Key | RecdSeq | Required. Sequence number to provide unique identification for the record. | Integer | 4 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 12 |
 | Fee | Fee from the project record. | Double | 9 |
 | ReimbAllow | Reimbursable allowance from the project record. | Double | 9 |
 | ConsultFee | Consultant fee from the project record. | Double | 9 |
 | Section | Section on the invoice to which the billings-to-date amount applies. | VarChar | 24 |
 | CurrentAmt | Current billings-to-date amounts. | Double | 9 |
 | PriorAmt | Prior billings-to-date amounts. | Double | 9 |
 | Total | Total billings-to-date amounts. This is calculated by adding the current and prior billing-to-date amounts. | Double | 9 |

Indexes

Index | Description | Primary | Unique
billBTDDetailPK |  |  |

SQL

CREATE TABLE [billBTDDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RecdSeq] [int] NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Fee] [float] NULL ,
    [ReimbAllow] [float] NULL ,
    [ConsultFee] [float] NULL ,
    [Section] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CurrentAmt] [float] NULL ,
    [PriorAmt] [float] NULL ,
    [Total] [float] NULL ,
    CONSTRAINT [billBTDDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [RecdSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billBTDDetail Table | Deltek Advantage 9.0 Database

billBTDDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | RecdSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billBTDDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billConDetail Table

Description

Invoice Detail Table - Consultant Detail for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
Primary Key | OriginalTable | Required. Original table. | VarChar | 4 |
Primary Key | OriginalKey | Required. Original key. | Integer | 4 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 5 |
 | PostProject | Project to which the transaction is to be posted. | VarChar | 12 |
 | PostTask | Task to which the transaction is to be posted. | VarChar | 5 |
 | Project | Actual project for the transaction. | VarChar | 12 |
 | Task | Actual task for the transaction. | VarChar | 5 |
 | SortKey | Sort key. | VarChar | 10 |
 | SortLabel | Label for the sort. | VarChar | 40 |
 | TransType | Transaction type. | VarChar | 2 |
 | RefNo | Transaction reference number. | VarChar | 7 |
 | TransDate | Transaction date. | DBTimeStamp | 4 |
 | Description1 | First line of description for the transaction. | VarChar | 40 |
 | Description2 | Second line of description for the transaction. | VarChar | 40 |
 | Amount | Extended amount as it appears on the invoice. | Double | 9 |
 | CostAmount | Cost amount. | Double | 9 |
 | Vendor | Vendor number for accounts payable transactions. | VarChar | 10 |
 | InvoiceNumber | Number of the invoice for the vendor. | VarChar | 20 |
 | InvoiceDate | Date of the invoice for the vendor. | DBTimeStamp | 4 |
 | Method | Variable indicating the expense billing method. Valid options are 0 - No consultant billing; 1 - By Account; 2 - By Category; 3 - By Vendor; and 4 - Bill as Expense. | SmallInt | 2 |
 | Multiplier | Consultant multiplier. | Double | 9 |
 | ExpenseDetail | Variable indicating whether to show the consultant multiplier on the invoice. | Boolean | 1 |
 | ShowMult | Variable indicating whether to show consultant transaction detail on the invoice. | Boolean | 1 |
 | DiffMult | Variable indicating whether the consultant multiplier differs from the expense multiplier. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
billConDetailPK |  |  |

SQL

CREATE TABLE [billConDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [OriginalTable] [varchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [OriginalKey] [int] NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SortKey] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SortLabel] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TransType] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TransDate] [datetime] NULL ,
    [Description1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [CostAmount] [float] NULL ,
    [Vendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InvoiceNumber] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InvoiceDate] [datetime] NULL ,
    [Method] [smallint] NULL ,
    [Multiplier] [float] NULL ,
    [ExpenseDetail] [bit] NOT NULL CONSTRAINT [DF__billConDe__Expen__286302EC] DEFAULT (0),
    [ShowMult] [bit] NOT NULL CONSTRAINT [DF__billConDe__ShowM__29572725] DEFAULT (0),
    [DiffMult] [bit] NOT NULL CONSTRAINT [DF__billConDe__DiffM__2A4B4B5E] DEFAULT (0),
    CONSTRAINT [billConDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [OriginalTable],
        [OriginalKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billConDetail Table | Deltek Advantage 9.0 Database

billConDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | OriginalTable |  | Ascending
Primary Key | OriginalKey |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billConDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billExpDetail Table

Description

Invoice Detail Table - Expense Detail for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
Primary Key | OriginalTable | Required. Original table. | VarChar | 4 |
Primary Key | OriginalKey | Required. Original key. | Integer | 4 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 5 |
 | PostProject | Project to which the transaction is to be posted. | VarChar | 12 |
 | PostTask | Task to which the transaction is to be posted. | VarChar | 5 |
 | Project | Actual project for the transaction. | VarChar | 12 |
 | Task | Actual task for the transaction. | VarChar | 5 |
 | SortKey | Sort key. | VarChar | 10 |
 | SortLabel | Label for the sort. | VarChar | 40 |
 | TransType | Transaction type. | VarChar | 2 |
 | RefNo | Transaction reference number. | VarChar | 7 |
 | TransDate | Transaction date. | DBTimeStamp | 4 |
 | Description1 | First line of description for the transaction. | VarChar | 40 |
 | Description2 | Second line of description for the transaction. | VarChar | 40 |
 | Amount | Extended amount as it appears on the invoice. | Double | 9 |
 | CostAmount | Cost amount. | Double | 9 |
 | Vendor | Vendor number for accounts payable transactions. | VarChar | 10 |
 | InvoiceNumber | Number of the invoice for the vendor. | VarChar | 20 |
 | InvoiceDate | Date of the invoice for the vendor. | DBTimeStamp | 4 |
 | Method | Variable indicating the expense billing method. Valid options are 0 - No consultant billing; 1 - By Account; 2 - By Category; and 3 - By Vendor. | SmallInt | 2 |
 | Multiplier | Expense multiplier. | Double | 9 |
 | ExpenseDetail | Variable indicating whether to show the expense multiplier on the invoice. | Boolean | 1 |
 | ShowMult | Variable indicating whether to show expense transaction detail on the invoice. | Boolean | 1 |
 | DiffMult | Variable indicating whether the expense multiplier is different than the consultant multiplier. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
billExpDetailPK |  |  |

SQL

CREATE TABLE [billExpDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [OriginalTable] [varchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [OriginalKey] [int] NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SortKey] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SortLabel] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TransType] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TransDate] [datetime] NULL ,
    [Description1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [CostAmount] [float] NULL ,
    [Vendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InvoiceNumber] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InvoiceDate] [datetime] NULL ,
    [Method] [smallint] NULL ,
    [Multiplier] [float] NULL ,
    [ExpenseDetail] [bit] NOT NULL CONSTRAINT [DF__billExpDe__Expen__2C3393D0] DEFAULT (0),
    [ShowMult] [bit] NOT NULL CONSTRAINT [DF__billExpDe__ShowM__2D27B809] DEFAULT (0),
    [DiffMult] [bit] NOT NULL CONSTRAINT [DF__billExpDe__DiffM__2E1BDC42] DEFAULT (0),
    CONSTRAINT [billExpDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [OriginalTable],
        [OriginalKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billExpDetail Table | Deltek Advantage 9.0 Database

billExpDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | OriginalTable |  | Ascending
Primary Key | OriginalKey |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billExpDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billFeeDetail Table

Description

Invoice Detail Table - Fee Detail for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12
Primary Key | RecdSeq | Required. Sequence number to provide unique identification for the record. | Integer | 4
BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12
BillTask | Task with which the transaction is to be billed. | VarChar | 5
Project | Actual project for the transaction. | VarChar | 12
Task | Actual task for the transaction. | VarChar | 5
PostProject | The project used during the invoice posting. | VarChar | 12
PostTask | The task used during the invoice posting. | VarChar | 5
Method | Variable indicating the unit billing method. Valid options are 0 - No fee billing; 1 - Overall complete; 2 - complete by phase as percent of fee; 3 - % complete by phase as fixed amount; 4 - Cumulative units or fees; and 5 - Current units or fees. | SmallInt | 2
Basis | Variable indicating the fee basis to use when calculating invoices. Valid options are L - Lump sum; P - Percent of construction; and U - Unit based. | VarChar | 1
UnitLabel | Label for unit-based fee billing. | VarChar | 15
TotalFee | Total fee for the project. | Double | 9
PercentComplete | Percent complete for billing. | Double | 9
EarnedFee | Earned to-date amount. This is calculated by multiplying the fee times the percent complete. | Double | 9
PreviousFee | Fee billings prior to the period. | Double | 9
CurrentFee | Current fee billing. | Double | 9
Factor1 | First fee factor (depending on fee basis). | Double | 9
Factor2 | Second fee factor (depending on fee basis). | Double | 9
Phase | Phase number. | SmallInt | 2
PhaseName | Phase label. | VarChar | 40
PctOfFee | Percent of fee represented by the phase. | Double | 9
Fee | Actual fee for the phase. | Double | 9
PctCpl | Percent complete for the phase. | Double | 9
Earned | Total calculated by multiplying the percent complete by the fee for the phase. | Double | 9
BilledJTD | Total billed since project inception for the phase. | Double | 9
showPhaseBillingsMeth Variable indicating whether and how the fee section of the invoice displays billings by phase. Valid options are 0 – None of these (the default setting);
1 – Display current billings by phase;
2 – Display previous billings by phase; and 3 – Display neither current nor previous billings by phase. 		SmallInt 2

Indexes

Index | Description | Primary | Unique
billFeeDetailPK |  |  |

SQL

CREATE TABLE [billFeeDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RecdSeq] [int] NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Method] [smallint] NULL ,
    [Basis] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnitLabel] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TotalFee] [float] NULL ,
    [PercentComplete] [float] NULL ,
    [EarnedFee] [float] NULL ,
    [PreviousFee] [float] NULL ,
    [CurrentFee] [float] NULL ,
    [Factor1] [float] NULL ,
    [Factor2] [float] NULL ,
    [Phase] [smallint] NULL ,
    [PhaseName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PctOfFee] [float] NULL ,
    [Fee] [float] NULL ,
    [PctCpl] [float] NULL ,
    [Earned] [float] NULL ,
    [BilledJTD] [float] NULL ,
    [showPhaseBillingsMeth] [smallint] NULL ,
    CONSTRAINT [billFeeDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [RecdSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billFeeDetail Table | Deltek Advantage 9.0 Database

billFeeDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | RecdSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billFeeDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billINDetail Table

Description

Invoice Detail Table - Invoice Sections for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 15 |
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | Project | Required. Actual project for the transaction. | VarChar | 12 |
Primary Key | Task | Required. Actual task for the transaction. | VarChar | 5 |
Primary Key | RecdSeq | Required. Sequence number to provide unique identification for the record. | Integer | 4 |
 | InvoiceSection | Section on standard invoice: Labor, Consultant, etc. | VarChar | 1 |
 | Account | Account to which the amount applies. | VarChar | 10 |
 | AccountName | Account name. | VarChar | 40 |
 | Amount | Amount posted. | Double | 9 |
 | RetAmount | Retainage amount (usually negative). | Double | 9 |
 | TaxCode | Tax code associated with the line item. | VarChar | 3 |
 | TaxBasis | Tax basis associated with the line item. | Double | 9 |
 | Retainer | Variable indicating whether this item is an applied retainer. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
billINDetailPK |  |  |

SQL

CREATE TABLE [billINDetail] (
    [MainProject] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RecdSeq] [int] NOT NULL ,
    [InvoiceSection] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [RetAmount] [float] NULL ,
    [TaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxBasis] [float] NULL ,
    [Retainer] [bit] NOT NULL CONSTRAINT [DF__billINDet__Retai__30F848ED] DEFAULT (0),
    CONSTRAINT [billINDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [MainProject],
        [Invoice],
        [Project],
        [Task],
        [RecdSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billINDetail Table | Deltek Advantage 9.0 Database

billINDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | MainProject |  | Ascending
Primary Key | Invoice |  | Ascending
Primary Key | Project |  | Ascending
Primary Key | Task |  | Ascending
Primary Key | RecdSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billINDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BillingTemplates Table

Description

Billing Templates Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TemplateName | Required. The name of the billing template. | VarChar | 50 |
Primary Key | SubReportName | Required. The name of the billing subreport. | VarChar | 50 |
Primary Key | ctrlName | Required. The name of the control. Valid options are Text Box, Label, Image, and Line. | VarChar | 50 |
Primary Key | ctrlProperty | Required. The property of the control. | VarChar | 50 |
 | propValue | The value of the property. | VarChar | 255 |

Indexes

Index | Description | Primary | Unique
BillingTemplatesPK |  |  |

SQL

CREATE TABLE [BillingTemplates] (
    [TemplateName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SubReportName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ctrlName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ctrlProperty] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [propValue] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [BillingTemplatesPK] PRIMARY KEY NONCLUSTERED
    (
        [TemplateName],
        [SubReportName],
        [ctrlName],
        [ctrlProperty]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BillingTemplates Table | Deltek Advantage 9.0 Database

BillingTemplatesPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TemplateName |  | Ascending
Primary Key | SubReportName |  | Ascending
Primary Key | ctrlName |  | Ascending
Primary Key | ctrlProperty |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BillingTemplates Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billINMaster Table

Description

Invoice Detail Table - Invoice Sections Master for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 15 |
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
 | TransDate | Date for the transaction. | DBTimeStamp | 4 |
Primary Key | Project | Required. Actual project for the transaction. | VarChar | 12 |
 | TaskType | Task type. | VarChar | 1 |
Primary Key | Task | Required. Actual task for the transaction. | VarChar | 5 |
 | TransComment | Comment entered for the transaction. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
billINMasterPK |  |  |

SQL

CREATE TABLE [billINMaster] (
    [MainProject] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransDate] [datetime] NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransComment] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [billINMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [MainProject],
        [Invoice],
        [Project],
        [Task]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billINMaster Table | Deltek Advantage 9.0 Database

billINMasterPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | MainProject |  | Ascending
Primary Key | Invoice |  | Ascending
Primary Key | Project |  | Ascending
Primary Key | Task |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billINMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billIntDetail Table

Description

Invoice Detail Table - Interest Detail for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 12 |
 | Interest | Interest billing. | Double | 9 |
 | Balance | Balance of all invoices subject to interest charges. | Double | 9 |
 | GracePeriod | Number of days before interest is charged on an invoice. | Double | 9 |
 | Rate | Interest rate. | Double | 9 |
Primary Key | RecdSeq | Required. Sequence number to provide unique identification for the record. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
billIntDetailPK |  |  |

SQL

CREATE TABLE [billIntDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Interest] [float] NULL ,
    [Balance] [float] NULL ,
    [GracePeriod] [float] NULL ,
    [Rate] [float] NULL ,
    [RecdSeq] [int] NOT NULL ,
    CONSTRAINT [billIntDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [RecdSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billIntDetail Table | Deltek Advantage 9.0 Database

billIntDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | RecdSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billIntDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billInvMaster Table

Description

Invoice Detail Table – Invoice Master for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 24 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
Primary Key | RecdSeq | Required. Sequence number to provide unique identification for the record. | Integer | 4 |
 | InvoiceDate | Invoice date. | DBTimeStamp | 4 |
 | MainName | Project name. | VarChar | 40 |
 | MainType | Variable indicating the project type. Options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | BillGroup | Variable indicating whether this is a billing group. | Boolean | 1 |
 | ConsolidatePrint | Variable indicating whether to consolidate the printing for the billing group. | Boolean | 1 |
 | ARByGroup | Variable indicating whether to print outstanding accounts receivable by billing group. | Boolean | 1 |
 | BTDByGroup | Variable indicating whether to print billings-to-date amounts by billing group. | Boolean | 1 |
 | InterestByGroup | Variable indicating whether to print interest amounts by billing group. | Boolean | 1 |
 | TaxByGroup | Variable indicating whether to print tax amounts by billing group. | Boolean | 1 |
 | ByGroupProject | Internal field. | VarChar | 12 |
 | BillProject | Billing project’s number. | VarChar | 12 |
 | BillName | Billing project’s name. | VarChar | 40 |
 | Description | Description of the project. | LongVarChar | 16 |
 | Footer | Memo field for the text to print at the end of invoices. | VarChar | 255 |
 | ConsolidateTasks | Variable indicating whether to consolidate the printing of tasks on the invoice. | Boolean | 1 |
 | BillTask | Billing task’s number. | VarChar | 5 |
 | BillTaskName | Billing task’s name. | VarChar | 40 |
 | FromDate | Starting date from which to bill the project. | DBTimeStamp | 4 |
 | ToDate | Ending date through which to bill the project. | DBTimeStamp | 4 |
 | Address1 | First line of the address | VarChar | 40 |
 | Address2 | Second line of the address. | VarChar | 40 |
 | Address3 | Third line of the address. | VarChar | 40 |
 | Address4 | Fourth line of the address. | VarChar | 40 |
 | Address5 | Fifth line of the address. | VarChar | 40 |
 | RetByGroup | Variable indicating whether retainage is being done at the group level. | Boolean | 1 |
 | TaskRollup | Position of the task being rolled up on the invoice. | SmallInt | 2 |
 | TaxCountryCode | Client's tax country code. | VarChar | 2 |
 | TaxRegistrationNumber | Client's tax registration number. | VarChar | 15 |

Indexes

Index | Description | Primary | Unique
billInvMasterPK |  |  |

SQL

CREATE TABLE [billInvMaster] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RecdSeq] [int] NOT NULL ,
    [InvoiceDate] [datetime] NULL ,
    [MainName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [MainType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillGroup] [bit] NOT NULL CONSTRAINT [DF__billInvMa__BillG__35BCFE0A] DEFAULT (0),
    [ConsolidatePrint] [bit] NOT NULL CONSTRAINT [DF__billInvMa__Conso__36B12243] DEFAULT (0),
    [ARByGroup] [bit] NOT NULL CONSTRAINT [DF__billInvMa__ARByG__37A5467C] DEFAULT (0),
    [BTDByGroup] [bit] NOT NULL CONSTRAINT [DF__billInvMa__BTDBy__38996AB5] DEFAULT (0),
    [InterestByGroup] [bit] NOT NULL CONSTRAINT [DF__billInvMa__Inter__398D8EEE] DEFAULT (0),
    [TaxByGroup] [bit] NOT NULL CONSTRAINT [DF__billInvMa__TaxBy__3A81B327] DEFAULT (0),
    [ByGroupProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Footer] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ConsolidateTasks] [bit] NOT NULL CONSTRAINT [DF__billInvMa__Conso__3B75D760] DEFAULT (0),
    [BillTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTaskName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FromDate] [datetime] NULL ,
    [ToDate] [datetime] NULL ,
    [Address1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Address2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Address3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Address4] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Address5] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RetByGroup] [bit] NOT NULL CONSTRAINT [DF__billInvMa__RetBy__3C69FB99] DEFAULT (0),
    [TaskRollup] [smallint] NULL ,
    [TaxCountryCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxRegistrationNumber] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [billInvMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [RecdSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billInvMaster Table | Deltek Advantage 9.0 Database

billInvMasterPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | RecdSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billInvMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billInvSums Table

Description

Invoice Detail Table - Final Invoice Section Totals for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
Primary Key | RecdSeq | Required. Sequence number to provide unique identification for the record. | Integer | 4 |
Primary Key | ArrayType | Required. Variable indicating the array type. Valid options are I - Invoice Summary and P - Posting Summary. | VarChar | 1 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 12 |
 | Section | Section of the invoice to which the amount applies. | VarChar | 10 |
 | SubSection | Billing sub-section (e.g., account, sortkey). | VarChar | 10 |
 | BaseAmount | Amount of the detail line, before markups. Not currently used. | Double | 9 |
 | FinalAmount | Total of extensions with all markups. This is the number printed on invoices. | Double | 9 |

Indexes

Index | Description | Primary | Unique
billInvSumsPK |  |  |

SQL

CREATE TABLE [billInvSums] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RecdSeq] [int] NOT NULL ,
    [ArrayType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Section] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SubSection] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BaseAmount] [float] NULL ,
    [FinalAmount] [float] NULL ,
    CONSTRAINT [billInvSumsPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [RecdSeq],
        [ArrayType]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billInvSums Table | Deltek Advantage 9.0 Database

billInvSumsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | RecdSeq |  | Ascending
Primary Key | ArrayType |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billInvSums Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billLabDetail Table

Description

Invoice Detail Table - Labor Detail for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
Primary Key | OriginalTable | Required. Original table. | VarChar | 4 |
Primary Key | OriginalKey | Required. Original key. | Integer | 4 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 5 |
 | PostProject | Project to which the transaction is to be posted. | VarChar | 12 |
 | PostTask | Task to which the transaction is to be posted. | VarChar | 5 |
 | Project | Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | Task | Task for which the entire invoice is being created. | VarChar | 5 |
 | SortKey1 | First labor sort. | VarChar | 5 |
 | SortKey2 | Second labor sort. | VarChar | 5 |
 | SortLabel1 | Label for the first labor sort. | VarChar | 40 |
 | SortLabel2 | Label for the second labor sort. | VarChar | 40 |
 | Employee | Employee number. | VarChar | 10 |
 | Name | Employee name. | VarChar | 35 |
 | OvertimeFlag | Displays “Ovt” or overtime hours. | VarChar | 3 |
 | TimesheetDate | Date entered on timesheet during data entry. | DBTimeStamp | 4 |
 | Hours | Total hours. | Double | 9 |
 | Rate | Employee’s rate as it appears on the labor detail line. | Double | 9 |
 | RateFlag | Places an asterisk beside rates from the override table. | VarChar | 1 |
 | Extension | Total hours times the employee’s rate. | Double | 9 |
 | TransComment | Transaction comment. | VarChar | 255 |
 | OverrideType | Override type. | VarChar | 1 |
 | SubjectToMarkup | Amount subject to markup on total amount. This will be the same as the extension amount without override billing rates for Method 1. | Double | 9 |
 | FullExtension | Extension with all markups. This amount is usually not printed. | Double | 9 |
 | OvertimePremium | Overtime premium; with markup if multiplier not to be shown, otherwise without. | Double | 9 |
 | Method | Variable indicating the labor billing method. Valid options are 0 - No Labor Billing; 1 - Rate Times Multiplier; 2 - Rate Table; 3 - By Category; and 4 - By Labor Code. | SmallInt | 2 |
 | Multiplier1 | Labor multiplier 1. | Double | 9 |
 | Multiplier2 | Labor multiplier 2. | Double | 9 |
 | Multiplier3 | Labor multiplier 3. | Double | 9 |
 | OvtMultiplier | Labor overtime multiplier. | Double | 9 |
 | LaborDetail | Variable indicating whether to display labor detail on the invoice. | Boolean | 1 |
 | ShowComment | Variable indicating whether to print timesheet comments on the invoice. | Boolean | 1 |
 | ShowRate | Variable indicating whether to print the billing rate and extension on the invoice. | Boolean | 1 |
 | ShowDate | Variable indicating whether to print the timesheet date on the invoice. | Boolean | 1 |
 | ShowMults | Variable indicating whether to show the labor multiplier(s) on the invoice. | Boolean | 1 |
 | ShowOvtMult | Variable indicating whether to show the labor overtime multiplier on the invoice. | Boolean | 1 |
 | SortMeth1 | First level sort method. | SmallInt | 2 |
 | SortMeth2 | Second level sort method. | SmallInt | 2 |
 | LaborCode | Labor code from the timesheet. | VarChar | 5 |
 | SpecialOvertimePremium | Special overtime premium amount. | Double | 9 |
 | SpecialOvtMultiplier | Special overtime multiplier. | Double | 9 |

Indexes

Index | Description | Primary | Unique
billLabDetailPK |  |  |

SQL

CREATE TABLE [billLabDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [OriginalTable] [varchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [OriginalKey] [int] NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SortKey1] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SortKey2] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SortLabel1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SortLabel2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Name] [varchar] (35) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OvertimeFlag] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TimesheetDate] [datetime] NULL ,
    [Hours] [float] NULL ,
    [Rate] [float] NULL ,
    [RateFlag] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Extension] [float] NULL ,
    [TransComment] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OverrideType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SubjectToMarkup] [float] NULL ,
    [FullExtension] [float] NULL ,
    [OvertimePremium] [float] NULL ,
    [Method] [smallint] NULL ,
    [Multiplier1] [float] NULL ,
    [Multiplier2] [float] NULL ,
    [Multiplier3] [float] NULL ,
    [OvtMultiplier] [float] NULL ,
    [LaborDetail] [bit] NOT NULL CONSTRAINT [DF__billLabDe__Labor__3F466844] DEFAULT (0),
    [ShowComment] [bit] NOT NULL CONSTRAINT [DF__billLabDe__ShowC__403A8C7D] DEFAULT (0),
    [ShowRate] [bit] NOT NULL CONSTRAINT [DF__billLabDe__ShowR__412EB0B6] DEFAULT (0),
    [ShowDate] [bit] NOT NULL CONSTRAINT [DF__billLabDe__ShowD__4222D4EF] DEFAULT (0),
    [ShowMults] [bit] NOT NULL CONSTRAINT [DF__billLabDe__ShowM__4316F928] DEFAULT (0),
    [ShowOvtMult] [bit] NOT NULL CONSTRAINT [DF__billLabDe__ShowO__440B1D61] DEFAULT (0),
    [SortMeth1] [smallint] NULL ,
    [SortMeth2] [smallint] NULL ,
    [LaborCode] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SpecialOvertimePremium] [float] NULL ,
    [SpecialOvtMultiplier] [float] NULL ,
    CONSTRAINT [billLabDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [OriginalTable],
        [OriginalKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billLabDetail Table | Deltek Advantage 9.0 Database

billLabDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | OriginalTable |  | Ascending
Primary Key | OriginalKey |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billLabDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billLimDetail Table

Description

Invoice Detail Table - Limit Detail for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 12 |
 | Sequence | Internal sequence number. | SmallInt | 2 |
 | Section | Section on the invoice to which the limit applies. | VarChar | 24 |
 | CurrentAmt | Current billing amount as it will appear on the invoice. | Double | 9 |
 | PriorAmt | Prior billings from the accounts receivable table. | Double | 9 |
 | Total | Current plus prior billings. | Double | 9 |
 | Limit | Limit for the section. | Double | 9 |
 | Adjustment | Adjustment if negative, remaining if positive. | Double | 9 |
Primary Key | RecdSeq | Required. Sequence number to provide unique identification for the record. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
billLimDetailPK |  |  |

SQL

CREATE TABLE [billLimDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Sequence] [smallint] NULL ,
    [Section] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CurrentAmt] [float] NULL ,
    [PriorAmt] [float] NULL ,
    [Total] [float] NULL ,
    [Limit] [float] NULL ,
    [Adjustment] [float] NULL ,
    [RecdSeq] [int] NOT NULL ,
    CONSTRAINT [billLimDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [RecdSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billLimDetail Table | Deltek Advantage 9.0 Database

billLimDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | RecdSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billLimDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billRetDetail Table

Description

Invoice Detail Table - Retainage Detail (as processed in Interactive or Batch Billing) for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 12 |
Primary Key | RecdSeq | Required. Sequence number to provide unique identification for the record. | Integer | 4 |
 | Prior | Prior retainage amount. | Double | 9 |
 | Limit | Retainage limit. | Double | 9 |
 | LimitHit | Variable indicating whether the retainage limit been reached. | Boolean | 1 |
 | Pct | Retainage percent. | Double | 9 |
 | Amount | Amount on which retainage is based. | Double | 9 |
 | Retainage | Retainage amount. | Double | 9 |

Indexes

Index | Description | Primary | Unique
billRetDetailPK |  |  |

SQL

CREATE TABLE [billRetDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecdSeq] [int] NOT NULL ,
    [Prior] [float] NULL ,
    [Limit] [float] NULL ,
    [LimitHit] [bit] NOT NULL CONSTRAINT [DF__billRetDe__Limit__46E78A0C] DEFAULT (0),
    [Pct] [float] NULL ,
    [Amount] [float] NULL ,
    [Retainage] [float] NULL ,
    CONSTRAINT [billRetDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [RecdSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billRetDetail Table | Deltek Advantage 9.0 Database

billRetDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | RecdSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billRetDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billTaxDetail Table

Description

Invoice Detail Table - Tax Detail for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 12 |
 | Code | Tax code. | VarChar | 3 |
 | Description | Description of the tax code. | VarChar | 40 |
 | Computation | Tax rate times the total amount to apply. | VarChar | 30 |
 | Amount | Tax amount as it will print on the generated invoice. | Double | 9 |
 | Basis | Amount on which the tax was computed. | Double | 9 |
 | Rate | Tax rate. | Double | 9 |
Primary Key | RecdSeq | Required. Sequence number to provide unique identification for the record. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
billTaxDetailPK |  |  |

SQL

CREATE TABLE [billTaxDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Code] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Computation] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [Basis] [float] NULL ,
    [Rate] [float] NULL ,
    [RecdSeq] [int] NOT NULL ,
    CONSTRAINT [billTaxDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [RecdSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billTaxDetail Table | Deltek Advantage 9.0 Database

billTaxDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | RecdSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billTaxDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

billUnitDetail Table

Description

Invoice Detail Table - Unit Detail for Prior Billings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Invoice | Required. Invoice number. | VarChar | 7 |
Primary Key | MainProject | Required. Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
Primary Key | OriginalTable | Required. Original table. | VarChar | 4 |
Primary Key | OriginalKey | Required. Original key. | Integer | 4 |
 | BillProject | Project with which the transaction is to be billed. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | BillTask | Task with which the transaction is to be billed. | VarChar | 5 |
 | PostProject | Project to which the transaction is to be posted. | VarChar | 12 |
 | PostTask | Task to which the transaction is to be posted. | VarChar | 5 |
 | Project | Project for which the entire invoice is being created. This is either the main project in a billing group or the actual project. | VarChar | 12 |
 | Task | Task for which the entire invoice is being created. | VarChar | 5 |
 | UnitTable | Unit table used for the transaction. | VarChar | 12 |
 | Unit | Unit number. | VarChar | 10 |
 | Account | Account number to which unit billing is posted. | VarChar | 10 |
 | TransDate | Transaction date entered in data entry. | DBTimeStamp | 4 |
 | UnitName | Unit name from the specified table. | VarChar | 40 |
 | Description | Description of the transaction from data entry. | VarChar | 40 |
 | Calculation | Calculation (quantity times rate). | VarChar | 20 |
 | Quantity | Quantity of the unit. | Double | 9 |
 | Rate | Billing rate per unit. | Double | 9 |
 | Amount | Extended unit amount. | Double | 9 |
 | CostRate | Cost rate per unit. | Double | 9 |
 | CostAmount | Cost amount (cost rate times quantity). | Double | 9 |
 | Multiplier | Unit multiplier from the project’s billing terms. | Double | 9 |
 | DispFormat | Level of unit detail to display on the generated invoice. | VarChar | 1 |
 | Summarize | Variable indicating whether to consolidate the detail for the unit. | Boolean | 1 |
 | ShowDate | Variable indicating whether to print the transaction date for the unit on the invoice. | Boolean | 1 |
 | ShowCalc | Variable indicating whether to show the calculation of the extended unit amount on the invoice. | Boolean | 1 |
 | ShowMult | Variable indicating whether to show the unit multiplier on the invoice. | Boolean | 1 |
 | UnitDetail | Variable indicating whether to print transaction detail for the unit section. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
billUnitDetailPK |  |  |

SQL

CREATE TABLE [billUnitDetail] (
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [OriginalTable] [varchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [OriginalKey] [int] NOT NULL ,
    [BillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnitTable] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Unit] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TransDate] [datetime] NULL ,
    [UnitName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Calculation] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Quantity] [float] NULL ,
    [Rate] [float] NULL ,
    [Amount] [float] NULL ,
    [CostRate] [float] NULL ,
    [CostAmount] [float] NULL ,
    [Multiplier] [float] NULL ,
    [DispFormat] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Summarize] [bit] NOT NULL CONSTRAINT [DF__billUnitD__Summa__49C3F6B7] DEFAULT (0),
    [ShowDate] [bit] NOT NULL CONSTRAINT [DF__billUnitD__ShowD__4AB81AF0] DEFAULT (0),
    [ShowCalc] [bit] NOT NULL CONSTRAINT [DF__billUnitD__ShowC__4BAC3F29] DEFAULT (0),
    [ShowMult] [bit] NOT NULL CONSTRAINT [DF__billUnitD__ShowM__4CA06362] DEFAULT (0),
    [UnitDetail] [bit] NOT NULL CONSTRAINT [DF__billUnitD__UnitD__4D94879B] DEFAULT (0),
    CONSTRAINT [billUnitDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Invoice],
        [MainProject],
        [OriginalTable],
        [OriginalKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

billUnitDetail Table | Deltek Advantage 9.0 Database

billUnitDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Invoice |  | Ascending
Primary Key | MainProject |  | Ascending
Primary Key | OriginalTable |  | Ascending
Primary Key | OriginalKey |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

billUnitDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BT Table

Description

Billing Terms Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 3
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | btProject | Required. Project number. | VarChar | 12 |
Primary Key | btTask | Required. Task number. | VarChar | 5 |
 | btUseClientAddress | Variable indicating whether to use the address from client table when billing this project. | Boolean | 1 |
 | btAddress1 | Client’s address line 1. | VarChar | 40 |
 | btAddress2 | Client’s address line 2. | VarChar | 40 |
 | btAddress3 | Client’s address line 3. | VarChar | 40 |
 | btAddress4 | Client’s address line 4. | VarChar | 40 |
 | btCity | Client’s city. | VarChar | 18 |
 | btState | Client’s state. | VarChar | 2 |
 | btZIP | Client’s zip code. | VarChar | 10 |
 | btCountry | Client’s country. | VarChar | 12 |
 | btDescription | Project’s description. | LongVarChar | 16 |
 | btNotes | Memo field. | VarChar | 255 |
 | btTemplate | Name of the billing report template for the project. | VarChar | 40 |
 | btLastInvoice | Last invoice assigned to an invoice (if numbering by project). | Integer | 4 |
 | btDraftPrint | Variable indicating whether to print the project in draft billing runs. | Boolean | 1 |
 | btLabMeth | Variable indicating the labor billing method. Valid options are Valid options are 0 - No Labor Billing; 1 - Rate Times Multiplier; 2 - Rate Table; 3 - By Category; and 4 - By Labor Code. | SmallInt | 2 |
 | btMult1 | Labor multiplier 1. | Double | 9 |
 | btMult2 | Labor multiplier 2. | Double | 9 |
 | btMult3 | Labor multiplier 3. | Double | 9 |
 | btSeparateOvt | Variable indicating the method for calculating separate overtime. Valid options are 0 - No separate overtime; 1 - Separate overtime with employee's overtime pct; and 2 - Separate overtime with the overtime multiplier. | SmallInt | 2 |
 | btOvtMult | Labor overtime multiplier. | Double | 9 |
 | btTable | Labor rate table. | SmallInt | 2 |
 | btORTable | Override table for table billing methods. | SmallInt | 2 |
 | btLabDetail | Variable indicating whether to print labor detail on the invoice. | Boolean | 1 |
 | btShowComment | Variable indicating whether to print timesheet comments on the invoice. | Boolean | 1 |
 | btShowRate | Variable indicating whether to print the billing rate and extension on the invoice. | Boolean | 1 |
 | btShowDate | Variable indicating whether to print the timesheet date on the invoice. | Boolean | 1 |
 | btShowMults | Variable indicating whether to show the labor multiplier(s) on the invoice. | Boolean | 1 |
 | btShowOvtMult | Variable indicating whether to show the labor overtime multiplier on the invoice. | Boolean | 1 |
 | btFlagOverrides | Variable indicating whether to place an asterisk beside rates from the override table. | Boolean | 1 |
 | btSortMeth1 | Sort method for the first labor sort. | SmallInt | 2 |
 | btSortTable1 | Sort table to use for the first labor sort. | SmallInt | 2 |
 | btSortMeth2 | Sort method for the second labor sort. | SmallInt | 2 |
 | btSortTable2 | Sort table to use for the second labor sort. | SmallInt | 2 |
 | btExpMeth | Variable indicating the expense billing method. Valid options include 0 - No Expense Billing; 1 - By Account; 2 - By Category; and 3 - By Vendor. | SmallInt | 2 |
 | btExpMult | Expense multiplier. | Double | 9 |
 | btExpTable | Expense billing table (depending on method). | SmallInt | 2 |
 | btExpShowMult | Variable indicating whether to show the expense multiplier on the invoice. | Boolean | 1 |
 | btExpDetail | Variable indicating whether to show the expense transaction detail on the invoice. | Boolean | 1 |
 | btConMeth | Variable indicating the consultant billing method. Valid options are 0 - No Consultant Billing; 1 - By Account; 2 - By Category; 3 - By Vendor; and 4 - Bill as Expense. | SmallInt | 2 |
 | btConMult | Consultant multiplier. | Double | 9 |
 | btConTable | Consultant billing table (depending on method). | SmallInt | 2 |
 | btConShowMult | Variable indicating whether to show the consultant multiplier on the invoice. | Boolean | 1 |
 | btConDetail | Variable indicating whether to show the consultant transaction detail on the invoice. | Boolean | 1 |
 | btUnitMeth | Variable indicating the unit billing method. Valid options are 0 - No Unit Billing; and 1 - Bill Units. | SmallInt | 2 |
 | btUnitMult | Unit multiplier. | Double | 9 |
 | btUnitShowMult | Variable indicating whether to show the unit multiplier on the invoice. | Boolean | 1 |
 | btUnitDetail | Variable indicating whether to show the unit transaction detail on the invoice. | Boolean | 1 |
 | btFeeMeth | Variable indicating the unit billing method. Valid options are 0 - No fee billing; 1 - Overall complete; 2 - complete by phase as percent of fee; 3 - % complete by phase as fixed amount; 4 - Cumulative units or fees; and 5 - Current units or fees. | SmallInt | 2 |
 | btFeeBasis | Variable indicating the fee basis to use when calculating invoices. Valid options are L - Lump sum; P - Percent of construction; and U - Unit based. | VarChar | 1 |
 | btFeeFactor1 | First fee factor (depending on fee basis). | Double | 9 |
 | btFeeFactor2 | Second fee factor (depending on fee basis). | Double | 9 |
 | btFeePctCpl | Percent complete. | Double | 9 |
 | btFeeLabel | Label for unit-based fee billing. | VarChar | 15 |
 | btPriorFee | Job-to-date fee billing; used as prior fee billing in calculating current billing. | Double | 9 |
 | btAddOns | Variable indicating whether add-on amounts are to be included on the invoice. | Boolean | 1 |
 | btTaxCode1 | First tax code to be applied to the invoice. | VarChar | 3 |
 | btTaxCode2 | Second tax code to be applied to the invoice. | VarChar | 3 |
 | btTaxCode3 | Third tax code to be applied to the invoice. | VarChar | 3 |
 | btARFormat | Level of accounts receivable detail to print on the invoice. | SmallInt | 2 |
 | btInterest | Interest rate to apply to outstanding invoices. | Double | 9 |
 | btGracePd | Grace period before an invoice becomes overdue. | Double | 9 |
 | btBTDFormat | Level of billings-to-date detail to print on the invoice. | SmallInt | 2 |
 | btLimitMeth | Variable indicating the method to use for limit amounts. Valid options are 0 - No limits; 1 - Aggregate; 2 - Individual; 3 - Individual aggregate for sections with limits; and 4 - Individual - aggregate for all sections. | VarChar | 1 |
 | btLabLimit | Limit to apply to labor charges. | Double | 9 |
 | btConLimit | Limit to apply to consultant charges. | Double | 9 |
 | btExpLimit | Limit to apply to expense charges. | Double | 9 |
 | btUnitLimit | Limit to apply to unit charges. | Double | 9 |
 | btAddOnLimit | Limit to apply to add-on charges. | Double | 9 |
 | btFeeLimit | Limit to apply to fee charges. | Double | 9 |
 | btRetainage | Variable indicating whether retainage applies to the invoice. | Boolean | 1 |
 | btRetPct | Retainage percentage. | Double | 9 |
 | btRetLimit | Retainage limit. | Double | 9 |
 | btRetLab | Variable indicating whether to apply retainage to Labor. | Boolean | 1 |
 | btRetExp | Variable indicating whether to apply retainage to Expenses. | Boolean | 1 |
 | btRetCon | Variable indicating whether to apply retainage to Consultants. | Boolean | 1 |
 | btRetFee | Variable indicating whether to apply retainage to Fee. | Boolean | 1 |
 | btRetUnit | Variable indicating whether to apply retainage to Units. | Boolean | 1 |
 | btRetAddOn | Variable indicating whether to apply retainage to Add-ons. | Boolean | 1 |
 | btConsolidateTasks | Variable indicating whether the tasks for the project are to be printed as one. | Boolean | 1 |
 | btTaskTerms | Variable indicating whether you want to specify individual task terms. | Boolean | 1 |
 | btTaskConsPost | Variable indicating whether the tasks for the project are to be posted as one. | Boolean | 1 |
 | btTaskToPost | Task to post if you are consolidating the posting of tasks. | VarChar | 5 |
 | btTaskRollup | Character of the task to rollup on. | SmallInt | 2 |
 | btLimitByTask | Variable indicating whether to apply limits by task. If the response indicates no, limits are applied to the project. | Boolean | 1 |
 | btARByTask | Variable indicating whether to print outstanding accounts receivable detail by task. | Boolean | 1 |
 | btBTDByTask | Variable indicating whether to print billings-to-date detail by task. | Boolean | 1 |
 | btIntByTask | Variable indicating whether to compute interest by task. If the response indicates no, interest is computed by project. | Boolean | 1 |
 | btTaxByTask | Variable indicating whether to compute taxes by task or by project. If the response indicates no, taxes are computed by project. | Boolean | 1 |
 | btRetByTask | Variable indicating whether retainage should be computed by task. If the response indicates no, retainage is computed by project. | Boolean | 1 |
 | btBackup | Variable indicating whether a Billing Backup report should be produced with the bill. | Boolean | 1 |
 | btBackupComments | Variable indicating whether timesheet comments are to be printed on the backup report. | Boolean | 1 |
 | btLabAccount | Revenue account for billing labor. | VarChar | 10 |
 | btConAccount | Revenue account for billing consultants. | VarChar | 10 |
 | btExpAccount | Revenue account for billing expenses. | VarChar | 10 |
 | btUnitAccount | Revenue account for billing units. | VarChar | 10 |
 | btFeeAccount | Revenue account for billing fees. | VarChar | 10 |
 | btAddOnAccount | Revenue account for billing add-ons. | VarChar | 10 |
 | btIntAccount | Account for interest. | VarChar | 10 |
 | btFooter | Memo field for description information to print at the end of invoices. | VarChar | 255 |
 | btLabDefault | Variable indicating whether to use terms for project reporting defaults only. | Boolean | 1 |
 | btExpDefault | Variable indicating whether to use terms for project reporting defaults only. | Boolean | 1 |
 | btConDefault | Variable indicating whether to use terms for project reporting defaults only. | Boolean | 1 |
 | btUnitDefault | Variable indicating whether to use terms for project reporting defaults only. | Boolean | 1 |
 | btPostByPhase | Variable indicating whether to distribute invoice posting to tasks and/or subprojects by phase. | Boolean | 1 |
 | btSpecialOvtMult | Special overtime multiplier. | Double | 9 |
 | btShowPhaseBillingsMeth | Indicates whether and how the fee section of the invoice displays billings by phase. Valid options are 1 - Display current billings by phase; 2 - Display previous billings by phase; 3 - Display neither current nor previous billings by phase; and 0 - Default; none of these. | SmallInt | 2 |
 | btInvTaskBreak | Indicates whether the invoice inserts page breaks between tasks. Valid options are Yes – Invoice page breaks between tasks and No - (default setting) Invoice does not page break between tasks. | Boolean | 1 |
 | btCreateUser | For future use. | VarChar | 20 |
 | btCreateDate | For future use. | DBTimeStamp | 4 |
 | btLastUser | For future use. | VarChar | 20 |
 | btLastUpdateDate | For future use. | DBTimeStamp | 4 |

Indexes

Index | Description | Primary | Unique
BTPK |  |  |

SQL

CREATE TABLE [BT] (
    [btProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [btTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [btUseClientAddress] [bit] NOT NULL CONSTRAINT [DF__BT__btUseClientA__5F3414E9] DEFAULT (0),
    [btAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btAddress3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btAddress4] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btZIP] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btCountry] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btDescription] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btNotes] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btTemplate] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btLastInvoice] [int] NULL ,
    [btDraftPrint] [bit] NOT NULL CONSTRAINT [DF__BT__btDraftPrint__60283922] DEFAULT (0),
    [btLabMeth] [smallint] NULL ,
    [btMult1] [float] NULL ,
    [btMult2] [float] NULL ,
    [btMult3] [float] NULL ,
    [btSeparateOvt] [smallint] NULL ,
    [btOvtMult] [float] NULL ,
    [btTable] [smallint] NULL ,
    [btORTable] [smallint] NULL ,
    [btLabDetail] [bit] NOT NULL CONSTRAINT [DF__BT__btLabDetail__611C5D5B] DEFAULT (0),
    [btShowComment] [bit] NOT NULL CONSTRAINT [DF__BT__btShowCommen__62108194] DEFAULT (0),
    [btShowRate] [bit] NOT NULL CONSTRAINT [DF__BT__btShowRate__6304A5CD] DEFAULT (0),
    [btShowDate] [bit] NOT NULL CONSTRAINT [DF__BT__btShowDate__63F8CA06] DEFAULT (0),
    [btShowMults] [bit] NOT NULL CONSTRAINT [DF__BT__btShowMults__64ECEE3F] DEFAULT (0),
    [btShowOvtMult] [bit] NOT NULL CONSTRAINT [DF__BT__btShowOvtMul__65E11278] DEFAULT (0),
    [btFlagOverrides] [bit] NOT NULL CONSTRAINT [DF__BT__btFlagOverri__66D536B1] DEFAULT (0),
    [btSortMeth1] [smallint] NULL ,
    [btSortTable1] [smallint] NULL ,
    [btSortMeth2] [smallint] NULL ,
    [btSortTable2] [smallint] NULL ,
    [btExpMeth] [smallint] NULL ,
    [btExpMult] [float] NULL ,
    [btExpTable] [smallint] NULL ,
    [btExpShowMult] [bit] NOT NULL CONSTRAINT [DF__BT__btExpShowMul__67C95AEA] DEFAULT (0),
    [btExpDetail] [bit] NOT NULL CONSTRAINT [DF__BT__btExpDetail__68BD7F23] DEFAULT (0),
    [btConMeth] [smallint] NULL ,
    [btConMult] [float] NULL ,
    [btConTable] [smallint] NULL ,
    [btConShowMult] [bit] NOT NULL CONSTRAINT [DF__BT__btConShowMul__69B1A35C] DEFAULT (0),
    [btConDetail] [bit] NOT NULL CONSTRAINT [DF__BT__btConDetail__6AA5C795] DEFAULT (0),
    [btUnitMeth] [smallint] NULL ,
    [btUnitMult] [float] NULL ,
    [btUnitShowMult] [bit] NOT NULL CONSTRAINT [DF__BT__btUnitShowMu__6B99EBCE] DEFAULT (0),
    [btUnitDetail] [bit] NOT NULL CONSTRAINT [DF__BT__btUnitDetail__6C8E1007] DEFAULT (0),
    [btFeeMeth] [smallint] NULL ,
    [btFeeBasis] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btFeeFactor1] [float] NULL ,
    [btFeeFactor2] [float] NULL ,
    [btFeePctCpl] [float] NULL ,
    [btFeeLabel] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btPriorFee] [float] NULL ,
    [btAddOns] [bit] NOT NULL CONSTRAINT [DF__BT__btAddOns__6D823440] DEFAULT (0),
    [btTaxCode1] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btTaxCode2] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btTaxCode3] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btARFormat] [smallint] NULL ,
    [btInterest] [float] NULL ,
    [btGracePd] [float] NULL ,
    [btBTDFormat] [smallint] NULL ,
    [btLimitMeth] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btLabLimit] [float] NULL ,
    [btConLimit] [float] NULL ,
    [btExpLimit] [float] NULL ,
    [btUnitLimit] [float] NULL ,
    [btAddOnLimit] [float] NULL ,
    [btFeeLimit] [float] NULL ,
    [btRetainage] [bit] NOT NULL CONSTRAINT [DF__BT__btRetainage__6E765879] DEFAULT (0),
    [btRetPct] [float] NULL ,
    [btRetLimit] [float] NULL ,
    [btRetLab] [bit] NOT NULL CONSTRAINT [DF__BT__btRetLab__6F6A7CB2] DEFAULT (0),
    [btRetExp] [bit] NOT NULL CONSTRAINT [DF__BT__btRetExp__705EA0EB] DEFAULT (0),
    [btRetCon] [bit] NOT NULL CONSTRAINT [DF__BT__btRetCon__7152C524] DEFAULT (0),
    [btRetFee] [bit] NOT NULL CONSTRAINT [DF__BT__btRetFee__7246E95D] DEFAULT (0),
    [btRetUnit] [bit] NOT NULL CONSTRAINT [DF__BT__btRetUnit__733B0D96] DEFAULT (0),
    [btRetAddOn] [bit] NOT NULL CONSTRAINT [DF__BT__btRetAddOn__742F31CF] DEFAULT (0),
    [btConsolidateTasks] [bit] NOT NULL CONSTRAINT [DF__BT__btConsolidat__75235608] DEFAULT (0),
    [btTaskTerms] [bit] NOT NULL CONSTRAINT [DF__BT__btTaskTerms__76177A41] DEFAULT (0),
    [btTaskConsPost] [bit] NOT NULL CONSTRAINT [DF__BT__btTaskConsPo__770B9E7A] DEFAULT (0),
    [btTaskToPost] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btTaskRollup] [smallint] NULL ,
    [btLimitByTask] [bit] NOT NULL CONSTRAINT [DF__BT__btLimitByTas__77FFC2B3] DEFAULT (0),
    [btARByTask] [bit] NOT NULL CONSTRAINT [DF__BT__btARByTask__78F3E6EC] DEFAULT (0),
    [btBTDByTask] [bit] NOT NULL CONSTRAINT [DF__BT__btBTDByTask__79E80B25] DEFAULT (0),
    [btIntByTask] [bit] NOT NULL CONSTRAINT [DF__BT__btIntByTask__7ADC2F5E] DEFAULT (0),
    [btTaxByTask] [bit] NOT NULL CONSTRAINT [DF__BT__btTaxByTask__7BD05397] DEFAULT (0),
    [btRetByTask] [bit] NOT NULL CONSTRAINT [DF__BT__btRetByTask__7CC477D0] DEFAULT (0),
    [btBackup] [bit] NOT NULL CONSTRAINT [DF__BT__btBackup__7DB89C09] DEFAULT (0),
    [btBackupComments] [bit] NOT NULL CONSTRAINT [DF__BT__btBackupComm__7EACC042] DEFAULT (0),
    [btLabAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btConAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btExpAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btUnitAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btFeeAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btAddOnAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btIntAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btFooter] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btLabDefault] [bit] NOT NULL CONSTRAINT [DF__BT__btLabDefault__7FA0E47B] DEFAULT (0),
    [btExpDefault] [bit] NOT NULL CONSTRAINT [DF__BT__btExpDefault__009508B4] DEFAULT (0),
    [btConDefault] [bit] NOT NULL CONSTRAINT [DF__BT__btConDefault__01892CED] DEFAULT (0),
    [btUnitDefault] [bit] NOT NULL CONSTRAINT [DF__BT__btUnitDefaul__027D5126] DEFAULT (0),
    [btPostByPhase] [bit] NOT NULL CONSTRAINT [DF__BT__btPostByPhas__0371755F] DEFAULT (0),
    [btSpecialOvtMult] [float] NULL ,
    [btShowPhaseBillingsMeth] [smallint] NULL ,
    [btInvTaskBreak] [bit] NOT NULL CONSTRAINT [DF__BT__btInvTaskBre__04659998] DEFAULT (0),
    [btCreateUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btCreateDate] [datetime] NULL ,
    [btLastUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btLastUpdateDate] [datetime] NULL ,
    CONSTRAINT [BTPK] PRIMARY KEY NONCLUSTERED
    (
        [btProject],
        [btTask]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BT Table | Deltek Advantage 9.0 Database

BTPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | btProject |  | Ascending
Primary Key | btTask |  | Ascending

Index Statistics

Average key length | 4.0
Density | 0
Rows in the Table | 3
Rows Sampled | 3
Distribution Steps | 3
Updated | Wednesday, May 03, 2006 12:15

See Also

BT Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTA Table

Description

Billing Terms Add-Ons Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | btaProject | Required. Project number. | VarChar | 12 |
Primary Key | btaTask | Required. Task number. | VarChar | 5 |
Primary Key | btaSequence | Required. Line sequence number for the add-on. | SmallInt | 2 |
 | btaDescription | Description of add-on that you want to print on the invoice. | VarChar | 40 |
 | btaMarkup | Markup percentage of the add-on fee. | Double | 9 |
 | btaShowMult | Variable indicating whether you want to show the markup calculation on the invoice. | Boolean | 1 |
 | btaAddToLab | Variable indicating whether you want to apply the add-on to the labor section of the invoice. | Boolean | 1 |
 | btaAddToExp | Variable indicating whether to apply the add-on to the expense section of the invoice. | Boolean | 1 |
 | btaAddToCon | Variable indicating whether you want to apply the add-on to the consultant section of the invoice. | Boolean | 1 |
 | btaAddToFee | Variable indicating whether you want to apply the add-on to the fee section of the invoice. | Boolean | 1 |
 | btaAddToUnit | Variable indicating whether you want to apply the add-on to the unit section of the invoice. | Boolean | 1 |
 | btaAddToAddOn | Variable indicating whether you want to apply the add-on to the add-ons section of the invoice. | Boolean | 1 |
 | btaAccount | Revenue account to which to post the add-on amounts with the invoice. | VarChar | 10 |
 | btaUseAmount | Variable indicating whether to use the amount instead of the percentage for the add-on fee. | Boolean | 1 |
 | btaRetainer | Variable indicating whether to apply this add-on as a retainer. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
BTAPK |  |  |

SQL

CREATE TABLE [BTA] (
    [btaProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [btaTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [btaSequence] [smallint] NOT NULL ,
    [btaDescription] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btaMarkup] [float] NULL ,
    [btaShowMult] [bit] NOT NULL CONSTRAINT [DF__BTA__btaShowMult__76969D2E] DEFAULT (0),
    [btaAddToLab] [bit] NOT NULL CONSTRAINT [DF__BTA__btaAddToLab__778AC167] DEFAULT (0),
    [btaAddToExp] [bit] NOT NULL CONSTRAINT [DF__BTA__btaAddToExp__787EE5A0] DEFAULT (0),
    [btaAddToCon] [bit] NOT NULL CONSTRAINT [DF__BTA__btaAddToCon__797309D9] DEFAULT (0),
    [btaAddToFee] [bit] NOT NULL CONSTRAINT [DF__BTA__btaAddToFee__7A672E12] DEFAULT (0),
    [btaAddToUnit] [bit] NOT NULL CONSTRAINT [DF__BTA__btaAddToUni__7B5B524B] DEFAULT (0),
    [btaAddToAddOn] [bit] NOT NULL CONSTRAINT [DF__BTA__btaAddToAdd__7C4F7684] DEFAULT (0),
    [btaAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btaUseAmount] [bit] NOT NULL CONSTRAINT [DF__BTA__btaUseAmoun__7D439ABD] DEFAULT (0),
    [btaRetainer] [bit] NOT NULL CONSTRAINT [DF__BTA__btaRetainer__7E37BEF6] DEFAULT (0),
    CONSTRAINT [BTAPK] PRIMARY KEY NONCLUSTERED
    (
        [btaProject],
        [btaTask],
        [btaSequence]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTA Table | Deltek Advantage 9.0 Database

BTAPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | btaProject |  | Ascending
Primary Key | btaTask |  | Ascending
Primary Key | btaSequence |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTA Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTBG Table

Description

Billing Terms Billing Group Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | MainProject | Required. Project for which the entire invoice is being created. | VarChar | 12 |
 | ConsolidatePrint | Variable indicating whether to print all of the projects in the billing group as one project. | Boolean | 1 |
 | SeparateTerms | Variable indicating whether to allow separate billing terms for each project in the billing group. | Boolean | 1 |
 | ConsolidatePost | Variable indicating whether to post all of the sub-projects to the main project in the billing group. | Boolean | 1 |
 | OverallLimit | Variable indicating whether billing limits are specified for the main project in the billing group. | Boolean | 1 |
 | PrintAR | Variable indicating whether to print outstanding accounts receivable for groups or projects. Valid options are G - Group and P - Project. | VarChar | 1 |
 | PrintBTD | Variable indicating whether to print billings-to-date for groups or projects. Valid options are G - Group and P - Project. | VarChar | 1 |
 | PrintInterest | Variable indicating whether to print interest charges for groups or projects. Valid options are G - Group and P - Project. | VarChar | 1 |
 | PrintTax | Variable indicating whether to print taxes for groups or projects. Valid options are G - Group and P - Project. | VarChar | 1 |
 | PrintRet | Variable indicating whether to print retainage for groups or projects. Valid options are G - Group and P - Project. | VarChar | 1 |
 | InvPageBreak | Variable indicating whether the invoice inserts a page break between projects in a billing group. Valid options are Yes – Invoice page breaks between projects in a billing group and No – Invoice does not page break between projects in a billing group (the default setting). | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
BTBGPK |  |  |

SQL

CREATE TABLE [BTBG] (
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ConsolidatePrint] [bit] NOT NULL CONSTRAINT [DF__BTBG__Consolidat__00200768] DEFAULT (0),
    [SeparateTerms] [bit] NOT NULL CONSTRAINT [DF__BTBG__SeparateTe__01142BA1] DEFAULT (0),
    [ConsolidatePost] [bit] NOT NULL CONSTRAINT [DF__BTBG__Consolidat__02084FDA] DEFAULT (0),
    [OverallLimit] [bit] NOT NULL CONSTRAINT [DF__BTBG__OverallLim__02FC7413] DEFAULT (0),
    [PrintAR] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintBTD] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintInterest] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintTax] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintRet] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InvPageBreak] [bit] NOT NULL CONSTRAINT [DF__BTBG__InvPageBre__03F0984C] DEFAULT (0),
    CONSTRAINT [BTBGPK] PRIMARY KEY NONCLUSTERED
    (
        [MainProject]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTBG Table | Deltek Advantage 9.0 Database

BTBGPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | MainProject |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTBG Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTBGSubs Table

Description

Billing Terms Billing Group Subprojects Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | MainProject | Required. Project for which the entire invoice is being created. | VarChar | 12 |
Primary Key | SubProject | Required. Billing subproject number. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
BTBGSubsPK |  |  |
SubProjectIDX |  |  |

SQL

CREATE TABLE [BTBGSubs] (
    [MainProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SubProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    CONSTRAINT [BTBGSubsPK] PRIMARY KEY NONCLUSTERED
    (
        [MainProject],
        [SubProject]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTBGSubs Table | Deltek Advantage 9.0 Database

BTBGSubsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | MainProject |  | Ascending
Primary Key | SubProject |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTBGSubs Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTBGSubs Table | Deltek Advantage 9.0 Database

SubProjectIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SubProject |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTBGSubs Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTEA Table

Description

Billing Terms Expense Account Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the account override table. | SmallInt | 2 |
 | TableName | Name of the account override table. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
BTEAPK |  |  |

SQL

CREATE TABLE [BTEA] (
    [TableNo] [smallint] NOT NULL ,
    [TableName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [BTEAPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTEA Table | Deltek Advantage 9.0 Database

BTEAPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:01

See Also

BTEA Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTEAAccts Table

Description

Billing Terms Expense Account Multipliers Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the account override table. | SmallInt | 2 |
Primary Key | Account | Required. Account number to include in the table. | VarChar | 10 |
 | Multiplier | Multiplier to apply to the account when the table is specified in the project’s billing terms. | Double | 9 |

Indexes

Index | Description | Primary | Unique
BTEAAcctsPK |  |  |

SQL

CREATE TABLE [BTEAAccts] (
    [TableNo] [smallint] NOT NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Multiplier] [float] NULL ,
    CONSTRAINT [BTEAAcctsPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo],
        [Account]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTEAAccts Table | Deltek Advantage 9.0 Database

BTEAAcctsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending
Primary Key | Account |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTEAAccts Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTEC Table

Description

Billing Terms Expense Category Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the category override table. | SmallInt | 2 |
 | TableName | Name of the category override table. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
BTECPK |  |  |

SQL

CREATE TABLE [BTEC] (
    [TableNo] [smallint] NOT NULL ,
    [TableName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [BTECPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTEC Table | Deltek Advantage 9.0 Database

BTECPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTEC Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTECAccts Table

Description

Billing Terms Expense Category Table - Accounts

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the account override table. | SmallInt | 2 |
Primary Key | Category | Required. Category number to which to assign accounts. | SmallInt | 2 |
Primary Key | Account | Required. Account number to include in the category. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
BTECAcctsPK |  |  |

SQL

CREATE TABLE [BTECAccts] (
    [TableNo] [smallint] NOT NULL ,
    [Category] [smallint] NOT NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    CONSTRAINT [BTECAcctsPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo],
        [Category],
        [Account]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTECAccts Table | Deltek Advantage 9.0 Database

BTECAcctsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending
Primary Key | Category |  | Ascending
Primary Key | Account |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTECAccts Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTECCats Table

Description

Billing Terms Expense Category Table - Categories

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the account override table. | SmallInt | 2 |
Primary Key | Category | Required. Category number to which to assign accounts. | SmallInt | 2 |
 | Description | Description of the category that you want to print on the invoice. | VarChar | 40 |
 | Multiplier | Multiplier to apply to the category when the table is specified in the project’s billing terms. | Double | 9 |
 | SortSeq | Sequence number for category sorting on the invoice. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
BTECCatsPK |  |  |

SQL

CREATE TABLE [BTECCats] (
    [TableNo] [smallint] NOT NULL ,
    [Category] [smallint] NOT NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Multiplier] [float] NULL ,
    [SortSeq] [smallint] NULL ,
    CONSTRAINT [BTECCatsPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo],
        [Category]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTECCats Table | Deltek Advantage 9.0 Database

BTECCatsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending
Primary Key | Category |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTECCats Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTEV Table

Description

Billing Terms Expense Vendor Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the expense vendor table. | SmallInt | 2 |
 | TableName | Name of the expense vendor table. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
BTEVPK |  |  |

SQL

CREATE TABLE [BTEV] (
    [TableNo] [smallint] NOT NULL ,
    [TableName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [BTEVPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTEV Table | Deltek Advantage 9.0 Database

BTEVPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTEV Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTEVVends Table

Description

Billing Terms Expense Vendor Table - Multipliers

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the expense vendor table. | SmallInt | 2 |
Primary Key | Vendor | Required. Vendor number to include in the table. | VarChar | 10 |
 | Multiplier | Multiplier to apply to the vendor when the table is specified in the project’s billing terms. | Double | 9 |

Indexes

Index | Description | Primary | Unique
BTEVVendsPK |  |  |

SQL

CREATE TABLE [BTEVVends] (
    [TableNo] [smallint] NOT NULL ,
    [Vendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Multiplier] [float] NULL ,
    CONSTRAINT [BTEVVendsPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo],
        [Vendor]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTEVVends Table | Deltek Advantage 9.0 Database

BTEVVendsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending
Primary Key | Vendor |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTEVVends Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTF Table

Description

Billing Terms Fee Billing Phases Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | btfProject | Required. Project number. | VarChar | 12 |
Primary Key | btfTask | Required. Task number. | VarChar | 5 |
Primary Key | btfSeq | Required. Line sequence number for the phase. | Integer | 4 |
 | btfPhase | Phase number as displayed on the invoice. | SmallInt | 2 |
 | btfName | Name for the phase that you want to print on the invoice. | VarChar | 40 |
 | btfPctComplete | Percent complete for the phase for billing purposes. | Double | 9 |
 | btfPctOfFee | Percent of the total fee that the phase represents. | Double | 9 |
 | btfFee | Fee for the phase, if you are using the Percent Complete by Phase as Percent of Fee method. | Double | 9 |
 | btfBilledJTD | Job-to-date billed amounts for the final invoices. | Double | 9 |
 | btfBilledLast | Amount billed for the phase on the last invoice for the project. | Double | 9 |
 | btfPostProject | The project used during the invoice posting. | VarChar | 12 |
 | btfPostTask | The task used during the invoice posting. | VarChar | 5 |

Indexes

Index | Description | Primary | Unique
BTFPK |  |  |

SQL

CREATE TABLE [BTF] (
    [btfProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [btfTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [btfSeq] [int] NOT NULL ,
    [btfPhase] [smallint] NULL ,
    [btfName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btfPctComplete] [float] NULL ,
    [btfPctOfFee] [float] NULL ,
    [btfFee] [float] NULL ,
    [btfBilledJTD] [float] NULL ,
    [btfBilledLast] [float] NULL ,
    [btfPostProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [btfPostTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [BTFPK] PRIMARY KEY NONCLUSTERED
    (
        [btfProject],
        [btfTask],
        [btfSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTF Table | Deltek Advantage 9.0 Database

BTFPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | btfProject |  | Ascending
Primary Key | btfTask |  | Ascending
Primary Key | btfSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTF Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTRCT Table

Description

Billing Terms Rates Labor Category Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the labor category override table. | SmallInt | 2 |
 | TableName | Name of the category override table. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
BTRCTPK |  |  |

SQL

CREATE TABLE [BTRCT] (
    [TableNo] [smallint] NOT NULL ,
    [TableName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [BTRCTPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTRCT Table | Deltek Advantage 9.0 Database

BTRCTPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTRCT Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTRCTCats Table

Description

Billing Terms Rates Labor Category Table - Categories and Rates

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the labor category override table. | SmallInt | 2 |
Primary Key | Category | Required. Category number to which to assign to employees. | SmallInt | 2 |
 | Rate | Rate to apply to the employees included in the category. | Double | 9 |
 | Description | Description of the category that you want to print on the invoice. | VarChar | 40 |
 | SortSeq | Sequence number for category sorting on the invoice. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
BTRCTCatsPK |  |  |

SQL

CREATE TABLE [BTRCTCats] (
    [TableNo] [smallint] NOT NULL ,
    [Category] [smallint] NOT NULL ,
    [Rate] [float] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SortSeq] [smallint] NULL ,
    CONSTRAINT [BTRCTCatsPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo],
        [Category]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTRCTCats Table | Deltek Advantage 9.0 Database

BTRCTCatsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending
Primary Key | Category |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTRCTCats Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTRCTEmpls Table

Description

Billing Terms Rates Labor Category Table - Employee List

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the labor category override table. | SmallInt | 2 |
Primary Key | Category | Required. Category number to which to assign employees. | SmallInt | 2 |
Primary Key | Employee | Required. Employees included in the category. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
BTRCTEmplsPK |  |  |

SQL

CREATE TABLE [BTRCTEmpls] (
    [TableNo] [smallint] NOT NULL ,
    [Category] [smallint] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    CONSTRAINT [BTRCTEmplsPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo],
        [Category],
        [Employee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTRCTEmpls Table | Deltek Advantage 9.0 Database

BTRCTEmplsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending
Primary Key | Category |  | Ascending
Primary Key | Employee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTRCTEmpls Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTRLT Table

Description

Billing Terms Rates Labor Code Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the labor rate override table. | SmallInt | 2 |
 | TableName | Name of the labor rate override table. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
BTRLTPK |  |  |

SQL

CREATE TABLE [BTRLT] (
    [TableNo] [smallint] NOT NULL ,
    [TableName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [BTRLTPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTRLT Table | Deltek Advantage 9.0 Database

BTRLTPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTRLT Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTRLTCodes Table

Description

Billing Terms Rates Labor Code Table - Masks and Overrides

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the labor rate override table. | SmallInt | 2 |
Primary Key | LaborCodeMask | Required. Labor code mask to which to assign a rate. | VarChar | 5 |
 | Rate | Rate to apply to labor codes included in the mask. | Double | 9 |
 | Description | Description of the labor code mask that you want to appear on the invoice. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
BTRLTCodesPK |  |  |

SQL

CREATE TABLE [BTRLTCodes] (
    [TableNo] [smallint] NOT NULL ,
    [LaborCodeMask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Rate] [float] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [BTRLTCodesPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo],
        [LaborCodeMask]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTRLTCodes Table | Deltek Advantage 9.0 Database

BTRLTCodesPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending
Primary Key | LaborCodeMask |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTRLTCodes Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTROT Table

Description

Billing Terms Rates Labor Override Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the labor override table. | SmallInt | 2 |
 | TableName | Name of the labor override table. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
BTROTPK |  |  |

SQL

CREATE TABLE [BTROT] (
    [TableNo] [smallint] NOT NULL ,
    [TableName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [BTROTPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTROT Table | Deltek Advantage 9.0 Database

BTROTPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTROT Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTROTEmpls Table

Description

Billing Terms Rates Labor Override Table – Employees, Rates, and Categories

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the labor override table. | SmallInt | 2 |
Primary Key | Employee | Required. Employee number to include in the labor override table. | VarChar | 10 |
 | Rate | Rate to assign to employees in the labor override table. | Double | 9 |
 | RateType | Variable indicating the type of rate assigned. Valid options are B - Billing; C - Cost; and M - Cost Max. | VarChar | 1 |
 | Category | Category number to override for the employee. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
BTROTEmplsPK |  |  |

SQL

CREATE TABLE [BTROTEmpls] (
    [TableNo] [smallint] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Rate] [float] NULL ,
    [RateType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Category] [smallint] NULL ,
    CONSTRAINT [BTROTEmplsPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo],
        [Employee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTROTEmpls Table | Deltek Advantage 9.0 Database

BTROTEmplsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending
Primary Key | Employee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTROTEmpls Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTRRT Table

Description

Billing Terms Rates Labor Rate Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the labor rate table. | SmallInt | 2 |
 | TableName | Name of the labor rate table. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
BTRRTPK |  |  |

SQL

CREATE TABLE [BTRRT] (
    [TableNo] [smallint] NOT NULL ,
    [TableName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [BTRRTPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTRRT Table | Deltek Advantage 9.0 Database

BTRRTPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTRRT Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

BTRRTEmpls Table

Description

Billing Terms Rates Labor Rate Table – Overrides

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the labor rate table. | SmallInt | 2 |
Primary Key | Employee | Required. Employee number to include in the labor rate table. | VarChar | 10 |
 | Rate | Rate to assign to employees included in the labor rate table. | Double | 9 |

Indexes

Index | Description | Primary | Unique
BTRRTEmplsPK |  |  |

SQL

CREATE TABLE [BTRRTEmpls] (
    [TableNo] [smallint] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Rate] [float] NULL ,
    CONSTRAINT [BTRRTEmplsPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo],
        [Employee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

BTRRTEmpls Table | Deltek Advantage 9.0 Database

BTRRTEmplsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending
Primary Key | Employee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

BTRRTEmpls Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CA Table

Description

Chart of Accounts Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 100
Data Space Used | 24 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | caAccount | Required. Account number. | VarChar | 10 |
 | caName | Account name. | VarChar | 40 |
 | caCashBasisAccount | Cash-basis account number. | VarChar | 10 |
 | caSelect1 | User definable sort/select field. | VarChar | 20 |
 | caSelect2 | User definable sort/select field. | VarChar | 20 |
 | caSelect3 | User definable sort/select field. | VarChar | 20 |
 | caFASAccount | Stores the account number for the Best Fixed Assets Interface utility. | VarChar | 255 |
 | caStatus | Account status. | VarChar | 1 |
 | caSelect4 | User definable sort/select field. | VarChar | 20 |
 | caSelect5 | User definable sort/select field. | VarChar | 20 |
 | caSelect6 | User definable sort/select field. | VarChar | 20 |
 | caSelect7 | User definable sort/select field. | VarChar | 20 |
 | caSelect8 | User definable sort/select field. | VarChar | 20 |
 | caSelect9 | User definable sort/select field. | VarChar | 20 |
 | caSelect10 | User definable sort/select field. | VarChar | 20 |
 | caSelect11 | User definable sort/select field. | VarChar | 20 |
 | caSelect12 | User definable sort/select field. | VarChar | 20 |
 | caSelect13 | User definable sort/select field. | VarChar | 20 |
 | caSelect14 | User definable sort/select field. | VarChar | 20 |
 | caSelect15 | User definable sort/select field. | VarChar | 20 |
 | caSelect16 | User definable sort/select field. | Double | 9 |
 | caSelect17 | User definable sort/select field. | Double | 9 |
 | caSelect18 | User definable sort/select field. | Double | 9 |
 | caSelect19 | User definable sort/select field. | Double | 9 |
 | caSelect20 | User definable sort/select field. | Double | 9 |
 | caSelect21 | User definable sort/select field. | Double | 9 |
 | caSelect22 | User definable sort/select field. | Double | 9 |
 | caSelect23 | User definable sort/select field. | Double | 9 |
 | caSelect24 | User definable sort/select field. | Double | 9 |
 | caSelect25 | User definable sort/select field. | Double | 9 |
 | caSelect26 | User definable sort/select field. | DBTimeStamp | 4 |
 | caSelect27 | User definable sort/select field. | DBTimeStamp | 4 |
 | caSelect28 | User definable sort/select field. | DBTimeStamp | 4 |
 | caSelect29 | User definable sort/select field. | DBTimeStamp | 4 |
 | caSelect30 | User definable sort/select field. | DBTimeStamp | 4 |
 | caCreateUser | For future use. | VarChar | 20 |
 | caCreateDate | For future use. | DBTimeStamp | 4 |
 | caLastUser | For future use. | VarChar | 20 |
 | caLastUpdateDate | For future use. | DBTimeStamp | 4 |

Indexes

Index | Description | Primary | Unique
CAPK |  |  |

SQL

CREATE TABLE [CA] (
    [caAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [caName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caCashBasisAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect1] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect2] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect3] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caFASAccount] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect4] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect5] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect6] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect7] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect8] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect9] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect10] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect11] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect12] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect13] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect14] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect15] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caSelect16] [float] NULL ,
    [caSelect17] [float] NULL ,
    [caSelect18] [float] NULL ,
    [caSelect19] [float] NULL ,
    [caSelect20] [float] NULL ,
    [caSelect21] [float] NULL ,
    [caSelect22] [float] NULL ,
    [caSelect23] [float] NULL ,
    [caSelect24] [float] NULL ,
    [caSelect25] [float] NULL ,
    [caSelect26] [datetime] NULL ,
    [caSelect27] [datetime] NULL ,
    [caSelect28] [datetime] NULL ,
    [caSelect29] [datetime] NULL ,
    [caSelect30] [datetime] NULL ,
    [caCreateUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caCreateDate] [datetime] NULL ,
    [caLastUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [caLastUpdateDate] [datetime] NULL ,
    CONSTRAINT [CAPK] PRIMARY KEY NONCLUSTERED
    (
        [caAccount]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CA Table | Deltek Advantage 9.0 Database

CAPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | caAccount |  | Ascending

Index Statistics

Average key length | 5.0
Density | 0
Rows in the Table | 100
Rows Sampled | 100
Distribution Steps | 100
Updated | Wednesday, May 03, 2006 12:15

See Also

CA Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CAB Table

Description

Corporate Budgets Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | BudgetName | Required. Budget name. | VarChar | 24 |
 | ProfCtr | Profit center for the budget. | VarChar | 8 |
 | AutoDistribute | Variable indicating whether you want to automatically spread the annual budget evenly over the selected periods. | Boolean | 1 |
 | CompoundPct | Compound the budget by this percentage for the selected periods. | Double | 9 |
 | CompoundAmt | Compound the budget by this amount for the selected periods. | Double | 9 |
 | AdjustPct | Adjust the budget by this percentage for the selected periods. | Double | 9 |
 | AdjustAmt | Adjust the budget by this amount for the selected periods. | Double | 9 |
 | StartPeriod | Starting period for the corporate budget. | SmallInt | 2 |
 | EndPeriod | Ending period for the corporate budget. | SmallInt | 2 |
 | BudgetYear | Budget year. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
CABPK |  |  |

SQL

CREATE TABLE [CAB] (
    [BudgetName] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AutoDistribute] [bit] NOT NULL CONSTRAINT [DF__CAB__AutoDistrib__17F790F9] DEFAULT (0),
    [CompoundPct] [float] NULL ,
    [CompoundAmt] [float] NULL ,
    [AdjustPct] [float] NULL ,
    [AdjustAmt] [float] NULL ,
    [StartPeriod] [smallint] NULL ,
    [EndPeriod] [smallint] NULL ,
    [BudgetYear] [smallint] NULL ,
    CONSTRAINT [CABPK] PRIMARY KEY NONCLUSTERED
    (
        [BudgetName]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CAB Table | Deltek Advantage 9.0 Database

CABPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | BudgetName |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CAB Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CABDetail Table

Description

Corporate Budgets Table - Detail

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | cabBudgetName | Required. Budget name. | VarChar | 24 |
Primary Key | cabAccount | Required. Account number. | VarChar | 10 |
 | cabAccountName | Account name. | VarChar | 40 |
 | cabRefBudget | Reference budget amount. | Double | 9 |
 | cabAnnual | Annual budget amount. | Double | 9 |
 | cabAmount1 | Budget amount for period 1. | Double | 9 |
 | cabAmount2 | Budget amount for period 2. | Double | 9 |
 | cabAmount3 | Budget amount for period 3. | Double | 9 |
 | cabAmount4 | Budget amount for period 4. | Double | 9 |
 | cabAmount5 | Budget amount for period 5. | Double | 9 |
 | cabAmount6 | Budget amount for period 6. | Double | 9 |
 | cabAmount7 | Budget amount for period 7. | Double | 9 |
 | cabAmount8 | Budget amount for period 8. | Double | 9 |
 | cabAmount9 | Budget amount for period 9. | Double | 9 |
 | cabAmount10 | Budget amount for period 10. | Double | 9 |
 | cabAmount11 | Budget amount for period 11. | Double | 9 |
 | cabAmount12 | Budget amount for period 12. | Double | 9 |
 | cabAmount13 | Budget amount for period 13. | Double | 9 |

Indexes

Index | Description | Primary | Unique
CABDetailPK |  |  |

SQL

CREATE TABLE [CABDetail] (
    [cabBudgetName] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [cabAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [cabAccountName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [cabRefBudget] [float] NULL ,
    [cabAnnual] [float] NULL ,
    [cabAmount1] [float] NULL ,
    [cabAmount2] [float] NULL ,
    [cabAmount3] [float] NULL ,
    [cabAmount4] [float] NULL ,
    [cabAmount5] [float] NULL ,
    [cabAmount6] [float] NULL ,
    [cabAmount7] [float] NULL ,
    [cabAmount8] [float] NULL ,
    [cabAmount9] [float] NULL ,
    [cabAmount10] [float] NULL ,
    [cabAmount11] [float] NULL ,
    [cabAmount12] [float] NULL ,
    [cabAmount13] [float] NULL ,
    CONSTRAINT [CABDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [cabBudgetName],
        [cabAccount]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CABDetail Table | Deltek Advantage 9.0 Database

CABDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | cabBudgetName |  | Ascending
Primary Key | cabAccount |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CABDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

cdControl Table

Description

Cash Disbursements Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the cash disbursement data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether this file been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether this transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the file. | VarChar | 15 |
 | Period | Fiscal period and year. | Integer | 4 |
 | EndDate | End date for the transaction file. | DBTimeStamp | 4 |
 | Total | Total entered for the transaction file. | Double | 9 |
 | DefaultBank | Default bank code to use for entries in the data entry file. | VarChar | 10 |
 | DefaultTaxCode | Default tax code to use for entries in the data entry file. | VarChar | 3 |
 | PostPeriod | Period in which the cash disbursement data entry transaction file was posted. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the cash disbursement data entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
cdControlPK |  |  |

SQL

CREATE TABLE [cdControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__cdControl__Recur__0DEF03D2] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__cdControl__Selec__0EE3280B] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__cdControl__Poste__0FD74C44] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [EndDate] [datetime] NULL ,
    [Total] [float] NULL ,
    [DefaultBank] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DefaultTaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__cdControl__PostP__10CB707D] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__cdControl__PostS__11BF94B6] DEFAULT (0),
    CONSTRAINT [cdControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

cdControl Table | Deltek Advantage 9.0 Database

cdControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

cdControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

cdDetail Table

Description

Cash Disbursements Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the cash disbursement data entry transaction file. | VarChar | 15 |
Primary Key | CheckNo | Required. Check number assigned. | VarChar | 7 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | Description | Description of the detail line. | VarChar | 40 |
 | Project | Project to which the cash disbursement amount applies. | VarChar | 12 |
 | ProjType | Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | TaskType | Task type. | VarChar | 1 |
 | Task | Task to which the cash disbursement amount applies. | VarChar | 5 |
 | Account | Account to which the cash disbursement amount applies. | VarChar | 10 |
 | Amount | Amount of cash disbursement detail line. | Double | 9 |
 | TaxCode | Tax code to associate with the individual line item | VarChar | 3 |
 | NetAmount | Gross voucher amount less any tax amount applied. | Double | 9 |
 | TaxAmount | Tax amount applied to the voucher. | Double | 9 |

Indexes

Index | Description | Primary | Unique
cdDetailPK |  |  |

SQL

CREATE TABLE [cdDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [CheckNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [TaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [NetAmount] [float] NULL ,
    [TaxAmount] [float] NULL ,
    CONSTRAINT [cdDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [CheckNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

cdDetail Table | Deltek Advantage 9.0 Database

cdDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | CheckNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

cdDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

cdMaster Table

Description

Cash Disbursements Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the cash disbursement data entry transaction file. | VarChar | 15 |
Primary Key | CheckNo | Required. Check number assigned. | VarChar | 7 |
 | TransDate | Date specified for the cash disbursement. | DBTimeStamp | 4 |
 | BankCode | Bank code to use when posting the data entry file. | VarChar | 10 |
 | Payee | Name of the person receiving the check. | VarChar | 40 |
 | Posted | Variable indicating whether the data entry file has been posted. | VarChar | 1 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |
 | Printed | Variable indicating whether a check was printed for a cash disbursement. | Boolean | 1 |
 | CheckMemo | Text entered in the memo section of a cash disbursement check. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
cdMasterPK |  |  |

SQL

CREATE TABLE [cdMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [CheckNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransDate] [datetime] NULL ,
    [BankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Payee] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__cdMaster__Posted__61DB776A] DEFAULT ('N'),
    [Seq] [int] NULL ,
    [Printed] [bit] NOT NULL CONSTRAINT [DF__cdMaster__Printe__62CF9BA3] DEFAULT (0),
    [CheckMemo] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [cdMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [CheckNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

cdMaster Table | Deltek Advantage 9.0 Database

cdMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | CheckNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

cdMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGAccountStatus Table

Description

Account Status Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 4
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Status | Account status | VarChar | 1 |
 | Label | Description of the account status code. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
CFGAccountStatusPK |  |  |

SQL

CREATE TABLE [CFGAccountStatus] (
    [Status] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGAccountStatusPK] PRIMARY KEY NONCLUSTERED
    (
        [Status]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGAccountStatus Table | Deltek Advantage 9.0 Database

CFGAccountStatusPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Status |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGAccountStatus Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGADPLaborCodes Table

Description

ADP Special Labor Codes Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | LaborCode | Required. Special labor code (with wildcards). | VarChar | 5 |
 | RegCode | ADP processing code for regular hours. | VarChar | 2 |
 | RegFieldID | ADP category to map regular hours. | VarChar | 1 |
 | OvtCode | ADP processing code for overtime hours. | VarChar | 2 |
 | OvtFieldID | ADP category to map overtime hours. | VarChar | 1 |

Indexes

Index | Description | Primary | Unique
CFGADPLaborCodesPK |  |  |

SQL

CREATE TABLE [CFGADPLaborCodes] (
    [LaborCode] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RegCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RegFieldID] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OvtCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OvtFieldID] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGADPLaborCodesPK] PRIMARY KEY NONCLUSTERED
    (
        [LaborCode]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGADPLaborCodes Table | Deltek Advantage 9.0 Database

CFGADPLaborCodesPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | LaborCode |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGADPLaborCodes Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGAPDiscount Table

Description

Accounts Payable Setup Table - Discount Codes

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Discount code. | VarChar | 10 |
 | Project | Project number. | VarChar | 12 |
 | Task | Task number. | VarChar | 5 |
 | Account | Account number to be credited when discount is taken. | VarChar | 10 |
 | Description | Optional. Description for this discount code. | VarChar | 40 |
 | ApplyToTaxes | Optional. Variable indicating whether discounts should be applied to tax transactions. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGAPDiscountPK |  |  |

SQL

CREATE TABLE [CFGAPDiscount] (
    [Code] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ApplyToTaxes] [bit] NOT NULL CONSTRAINT [DF__CFGAPDisc__Apply__22751F6C] DEFAULT (0),
    CONSTRAINT [CFGAPDiscountPK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGAPDiscount Table | Deltek Advantage 9.0 Database

CFGAPDiscountPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGAPDiscount Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGAPForm1099 Table

Description

Accounts Payable Setup Table - Vendor 1099 Forms

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
 | FederalEIN | Federal EIN (Employee Identification Number). | VarChar | 9 |
 | PayerAddress1 | First line of the payer’s address. | VarChar | 40 |
 | PayerAddress2 | Second line of the payer’s address. | VarChar | 40 |
 | PayerCity | Payer’s city. | VarChar | 18 |
 | PayerState | Payer’s state. | VarChar | 2 |
 | PayerZIPCode | Payer’s zip code. | VarChar | 10 |
 | Minimum1099Amount | Minimum paid amount to select vendors for Form 1099 processing. | Double | 9 |
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |

Indexes

Index | Description | Primary | Unique
CFGAPForm1099PK |  |  |

SQL

CREATE TABLE [CFGAPForm1099] (
    [FederalEIN] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayerAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayerAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayerCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayerState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayerZIPCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Minimum1099Amount] [float] NULL ,
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    CONSTRAINT [CFGAPForm1099PK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGAPForm1099 Table | Deltek Advantage 9.0 Database

CFGAPForm1099PK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:01

See Also

CFGAPForm1099 Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGAPLiability Table

Description

Accounts Payable Setup Table - Liability Codes

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 2
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Liability code. | VarChar | 10 |
 | Account | Account to credit when liability code is used. | VarChar | 10 |
 | ProfCtr | Profit center for posting the liability code. | VarChar | 8 |
 | Description | Optional. Description for the liability code. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
CFGAPLiabilityPK |  |  |

SQL

CREATE TABLE [CFGAPLiability] (
    [Code] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGAPLiabilityPK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGAPLiability Table | Deltek Advantage 9.0 Database

CFGAPLiabilityPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 2
Rows Sampled | 2
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:01

See Also

CFGAPLiability Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGAPMain Table

Description

Accounts Payable Setup Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |
 | DefaultTerms | Variable indicating the default payment terms to use for vendors without payment terms defined. Valid options are Next, Hold, and PWP. | VarChar | 4 |
 | LastVoucher | Last voucher number assigned by the system. | Integer | 4 |
 | PrintRemit | Variable indicating when to print the remittance advice. Valid options are A - Always; N - Never; and O - Only if more than n vouchers. | VarChar | 1 |
 | VouchersOnApron | Number of vouchers that can fit on a standard check apron. | SmallInt | 2 |
 | APCheckTemplate | Name of the report template for accounts payable checks. | VarChar | 40 |
 | MemoPrintOnCheck | Variable indicating whether to print the memo field on vendor accounts payable checks. Valid options are Print on Check and Do Not Print. | VarChar | 10 |
 | DisplayWarning | Variable indicating whether a warning message appears when user enters a vendor/invoice combination already posted to the database. | Boolean | 1 |
 | DisplayLastCheckCols | Indicates whether Include Last Check Columns in A/P Voucher Review is selected in A/P Setup. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGAPMainPK |  |  |

SQL

CREATE TABLE [CFGAPMain] (
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [DefaultTerms] [varchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LastVoucher] [int] NULL ,
    [PrintRemit] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [VouchersOnApron] [smallint] NULL ,
    [APCheckTemplate] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [MemoPrintOnCheck] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DisplayWarning] [bit] NOT NULL CONSTRAINT [DF__CFGAPMain__Displ__2645B050] DEFAULT (0),
    [DisplayLastCheckCols] [bit] NOT NULL CONSTRAINT [DF__CFGAPMain__Displ__2739D489] DEFAULT (0),
    CONSTRAINT [CFGAPMainPK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGAPMain Table | Deltek Advantage 9.0 Database

CFGAPMainPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

CFGAPMain Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGAPStateID Table

Description

Accounts Payable Setup Table - State Identification Numbers

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | State | Required. Postal abbreviation for the state. | VarChar | 2 |
 | StateIDNo | Payer’s state identification number for Form 1099 processing. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
CFGAPStateIDPK |  |  |

SQL

CREATE TABLE [CFGAPStateID] (
    [State] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [StateIDNo] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGAPStateIDPK] PRIMARY KEY NONCLUSTERED
    (
        [State]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGAPStateID Table | Deltek Advantage 9.0 Database

CFGAPStateIDPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | State |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGAPStateID Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGAPVendorType Table

Description

Accounts Payable Setup Table - Vendor Types

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 2
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Type | Required. Vendor type. | VarChar | 1 |
 | Description | Description for the vendor type. | VarChar | 16 |
 | LiabCode | Liability code for the vendor type. | VarChar | 10 |
 | PeriodsToRetain | Number of periods the system should retain vouchers. | SmallInt | 2 |
 | ProjectRetain | Variable indicating whether you want to retain vouchers for the life of the project. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGAPVendorTypePK |  |  |

SQL

CREATE TABLE [CFGAPVendorType] (
    [Type] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Description] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LiabCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PeriodsToRetain] [smallint] NULL ,
    [ProjectRetain] [bit] NOT NULL CONSTRAINT [DF__CFGAPVend__Proje__2A164134] DEFAULT (0),
    CONSTRAINT [CFGAPVendorTypePK] PRIMARY KEY NONCLUSTERED
    (
        [Type]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGAPVendorType Table | Deltek Advantage 9.0 Database

CFGAPVendorTypePK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Type |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 2
Rows Sampled | 2
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:02

See Also

CFGAPVendorType Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGARLedgerHeadings Table

Description

System Setup Table - Accounts Receivable Ledger Headings

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 4
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ReportColumn | Required. Column (from CFGInvMap) to be labeled. | SmallInt | 2 |
 | Label | Column heading on the Accounts Receivable Ledger report. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
CFGARLedgerHeadingsPK |  |  |

SQL

CREATE TABLE [CFGARLedgerHeadings] (
    [ReportColumn] [smallint] NOT NULL ,
    [Label] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGARLedgerHeadingsPK] PRIMARY KEY NONCLUSTERED
    (
        [ReportColumn]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGARLedgerHeadings Table | Deltek Advantage 9.0 Database

CFGARLedgerHeadingsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ReportColumn |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 4
Rows Sampled | 4
Distribution Steps | 3
Updated | Monday, January 26, 2004 15:02

See Also

CFGARLedgerHeadings Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGARMap Table

Description

System Setup Table - Accounts Receivable Mapping

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Account | Required. Accounts receivable account to be mapped to the Accounts Receivable Ledger columns. | VarChar | 10 |
 | ARColumn | Variable indicating the column on the Accounts Receivable Ledger for the account. Valid options are 1 - Fees; 2 - Reimb; 3 - Taxes; 4 - Interest. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
CFGARMapPK |  |  |

SQL

CREATE TABLE [CFGARMap] (
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ARColumn] [smallint] NULL ,
    CONSTRAINT [CFGARMapPK] PRIMARY KEY NONCLUSTERED
    (
        [Account]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGARMap Table | Deltek Advantage 9.0 Database

CFGARMapPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Account |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

CFGARMap Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGBanks Table

Description

System Setup Table - Bank Codes

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Bank code. | VarChar | 10 |
 | Account | Account number associated with the bank code. | VarChar | 10 |
 | ProfCtr | Profit center for the bank code. | VarChar | 8 |
 | Description | Description for the bank code. | VarChar | 40 |
 | AccountNumber | Account number at the bank for the bank code. | VarChar | 17 |
 | AccountType | Indicates whether the account is a checking or a savings account. | VarChar | 1 |
 | ImmediateDestination | Immediate Destination number. | VarChar | 9 |
 | ImmediateDestinationName | Immediate Destination name. | VarChar | 23 |
 | ImmediateOrigin | Immediate Origin number. | VarChar | 9 |
 | ImmediateOriginName | Immediate Origin name. | VarChar | 23 |
 | CompanyName | Company name as it will appear on statements. | VarChar | 16 |
 | FederalEIN | Federal Employee Identification Number. | VarChar | 9 |
 | RoutingNumber | Routing transit number of the immediate destination. | VarChar | 8 |
 | EntryDescriptionPY | (Payroll only) Describes the purpose of the entry. | VarChar | 10 |
 | EntryDescriptionEX | (Expensekeeper only) Describes the purpose of the entry. | VarChar | 10 |
 | FileFormat | The type of information in the file for direct deposit. Valid options are 1 - Credit only and 2 - Debit and credit. | SmallInt | 2 |
 | ICD | Identification Code Designator. Valid options are 1 - IRS Employer ID Number (EIN); 3 - Data Universal Numbering Systems (DUNS); and 9 - User-assigned number. | VarChar | 1 |
 | Byte4Char | Specifies the first character in the file header record’s space for immediate destination. | VarChar | 1 |
 | FilePadding | Controls whether the total record count is forced to a multiple of ten. | Boolean | 1 |
 | SeparateBatches | Indicates whether there are separate batches for credit and debit entries. | Boolean | 1 |
 | FileNamePY | Filename and path for the payroll direct deposit file. | VarChar | 100 |
 | FileNameEX | Filename and path for the Expensekeeper direct deposit file. | VarChar | 100 |

Indexes

Index | Description | Primary | Unique
CFGBanksPK |  |  |

SQL

CREATE TABLE [CFGBanks] (
    [Code] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountNumber] [varchar] (17) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ImmediateDestination] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ImmediateDestinationName] [varchar] (23) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ImmediateOrigin] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ImmediateOriginName] [varchar] (23) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CompanyName] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FederalEIN] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RoutingNumber] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EntryDescriptionPY] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EntryDescriptionEX] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FileFormat] [smallint] NULL ,
    [ICD] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Byte4Char] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FilePadding] [bit] NOT NULL CONSTRAINT [DF__CFGBanks__FilePa__2DE6D218] DEFAULT (0),
    [SeparateBatches] [bit] NOT NULL CONSTRAINT [DF__CFGBanks__Separa__2EDAF651] DEFAULT (0),
    [FileNamePY] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FileNameEX] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGBanksPK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGBanks Table | Deltek Advantage 9.0 Database

CFGBanksPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

CFGBanks Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGBillMain Table

Description

Billing Setup Table

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
 | PrintName | Variable indicating whether to print your firm’s name at the top of your invoices. | Boolean | 1 |
 | PrintByline | Variable indicating whether to print a byline at the top of your invoices. | Boolean | 1 |
 | Byline | Firm byline. | VarChar | 42 |
 | PrintAddress | Variable indicating whether to print your firm’s address at the top of your invoices. | Boolean | 1 |
 | Address1 | First line of your firm’s address to print on the invoice. | VarChar | 42 |
 | Address2 | Second line of your firm’s address to print on the invoice. | VarChar | 42 |
 | PrintProjectNo | Variable indicating whether to print the project number on the invoice. | Boolean | 1 |
 | PrintInvoiceNo | Variable indicating whether to print the invoice number on the invoice. | Boolean | 1 |
 | CombineProjectInvoice | Variable indicating whether to combine the project number and the invoice number on the invoice. | Boolean | 1 |
 | PrintProjectName | Variable indicating whether to print the project name on the invoice. | Boolean | 1 |
 | PrintAROnly | Variable indicating whether to print bills that only have outstanding accounts receivable detail. | Boolean | 1 |
 | AddressStart | Number of inches below the standard placement, the address should print. | Single | 4 |
 | Page2Start | Number of inches below the standard placement, an additional page should print. | Single | 4 |
 | NumberMeth | Variable indicating the invoice numbering method. Valid options are P - By project and S - Firmwide. | VarChar | 1 |
 | LastInvoice | Last invoice number assigned by the system. | Integer | 4 |
 | NonBillLaborCode | Mask for the non-billable labor code(s) in your system. | VarChar | 5 |
 | ReleaseHolds | Variable indicating whether to release held transactions after you generate the final invoice. | Boolean | 1 |
 | UserEnteredPriorFee | Variable indicating whether to take the prior fee billing from the Billing Terms record (instead of as billed). | Boolean | 1 |
 | FooterMessage | Message to display in the footer of invoices. | VarChar | 80 |
 | LabAccount | Revenue account for billing labor. | VarChar | 10 |
 | ConAccount | Revenue account for billing consultants. | VarChar | 10 |
 | ExpAccount | Revenue account for billing expenses. | VarChar | 10 |
 | UnitAccount | Revenue account for billing units. | VarChar | 10 |
 | FeeAccount | Revenue account for billing fees. | VarChar | 10 |
 | AddOnAccount | Revenue account for billing add-ons. | VarChar | 10 |
 | IntAccount | Account for billing interest. | VarChar | 10 |
 | FeeLabel | Label to use for the fee section of the billings-to-date section of the invoice. | VarChar | 15 |
 | LabLabel | Label to use for the labor section of the billings-to-date section of the invoice. | VarChar | 15 |
 | ConLabel | Label to use for the consultant expense section of the billings-to-date section of the invoice. | VarChar | 15 |
 | ExpLabel | Label to use for the expense section of the billings-to-date section of the invoice. | VarChar | 15 |
 | UnitLabel | Label to use for the unit section of the billings-to-date section of the invoice. | VarChar | 15 |
 | AddOnLabel | Label to use for the fee section of the billings-to-date section of the invoice. | VarChar | 15 |
 | TaxLabel | Label to use for the tax section of the billings-to-date section of the invoice. | VarChar | 15 |
 | InterestLabel | Label to use for the interest section of the billings-to-date section of the invoice. | VarChar | 15 |
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |
 | PrintTotalNowDue | Variable indicating whether to print the “Total Now Due” line after outstanding invoices. | Boolean | 1 |
 | ExtendAddOn | Variable indicating whether to include add-ons when generating project reports at billing rates. | Boolean | 1 |
 | ShowPhaseBillings | Variable indicating whether the billing terms option is enabled to display either current or previous billings by phase. Valid options are Y - Enabled and No - Not Enabled (default setting). | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGBillMainPK |  |  |

SQL

CREATE TABLE [CFGBillMain] (
    [PrintName] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__Print__30C33EC3] DEFAULT (0),
    [PrintByline] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__Print__31B762FC] DEFAULT (0),
    [Byline] [varchar] (42) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintAddress] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__Print__32AB8735] DEFAULT (0),
    [Address1] [varchar] (42) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Address2] [varchar] (42) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintProjectNo] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__Print__339FAB6E] DEFAULT (0),
    [PrintInvoiceNo] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__Print__3493CFA7] DEFAULT (0),
    [CombineProjectInvoice] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__Combi__3587F3E0] DEFAULT (0),
    [PrintProjectName] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__Print__367C1819] DEFAULT (0),
    [PrintAROnly] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__Print__37703C52] DEFAULT (0),
    [AddressStart] [real] NULL ,
    [Page2Start] [real] NULL ,
    [NumberMeth] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LastInvoice] [int] NULL ,
    [NonBillLaborCode] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ReleaseHolds] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__Relea__3864608B] DEFAULT (0),
    [UserEnteredPriorFee] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__UserE__395884C4] DEFAULT (0),
    [FooterMessage] [varchar] (80) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LabAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ConAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ExpAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnitAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FeeAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AddOnAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [IntAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FeeLabel] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LabLabel] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ConLabel] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ExpLabel] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnitLabel] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AddOnLabel] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxLabel] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InterestLabel] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [PrintTotalNowDue] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__Print__3A4CA8FD] DEFAULT (0),
    [ExtendAddOn] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__Exten__3B40CD36] DEFAULT (0),
    [ShowPhaseBillings] [bit] NOT NULL CONSTRAINT [DF__CFGBillMa__ShowP__3C34F16F] DEFAULT (0),
    CONSTRAINT [CFGBillMainPK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGBillMain Table | Deltek Advantage 9.0 Database

CFGBillMainPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

CFGBillMain Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGBillTaxes Table

Description

Billing Setup Table - Tax Codes

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Tax code. | VarChar | 3 |
 | Description | Description of the tax code which will print on invoices. | VarChar | 40 |
 | Rate | Tax rate as a percentage. This percentage can be four decimals. | Double | 9 |
 | HighRate | Highest effective rate the user can enter manually for tax overrides. | Double | 9 |
 | LowRate | Lowest effective rate the user can enter manually for tax overrides. | Double | 9 |
 | CreditAccount | Account to be credited when billing taxes. | VarChar | 10 |
 | DebitAccount | Account to be debited when billing taxes. | VarChar | 10 |
 | ApplyToLab | Variable indicating whether you want the tax to apply to the labor section of your invoices. | Boolean | 1 |
 | ApplyToCon | Variable indicating whether you want the tax to apply to the consultant section of your invoices. | Boolean | 1 |
 | ApplyToExp | Variable indicating whether you want the tax to apply to the expense section of your invoices. | Boolean | 1 |
 | ApplyToFee | Variable indicating whether you want the tax to apply to the fee section of your invoices. | Boolean | 1 |
 | ApplyToUnit | Variable indicating whether you want the tax to apply to the unit section of your invoices. | Boolean | 1 |
 | ApplyToAddOn | Variable indicating whether you want the tax to apply to the add-ons section of your invoices. | Boolean | 1 |
 | ApplyToTax | Variable indicating whether you want the tax to apply to the taxes section of your invoices. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGBillTaxesPK |  |  |

SQL

CREATE TABLE [CFGBillTaxes] (
    [Code] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Rate] [float] NULL ,
    [HighRate] [float] NULL ,
    [LowRate] [float] NULL ,
    [CreditAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DebitAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ApplyToLab] [bit] NOT NULL CONSTRAINT [DF__CFGBillTa__Apply__3E1D39E1] DEFAULT (0),
    [ApplyToCon] [bit] NOT NULL CONSTRAINT [DF__CFGBillTa__Apply__3F115E1A] DEFAULT (0),
    [ApplyToExp] [bit] NOT NULL CONSTRAINT [DF__CFGBillTa__Apply__40058253] DEFAULT (0),
    [ApplyToFee] [bit] NOT NULL CONSTRAINT [DF__CFGBillTa__Apply__40F9A68C] DEFAULT (0),
    [ApplyToUnit] [bit] NOT NULL CONSTRAINT [DF__CFGBillTa__Apply__41EDCAC5] DEFAULT (0),
    [ApplyToAddOn] [bit] NOT NULL CONSTRAINT [DF__CFGBillTa__Apply__42E1EEFE] DEFAULT (0),
    [ApplyToTax] [bit] NOT NULL CONSTRAINT [DF__CFGBillTa__Apply__43D61337] DEFAULT (0),
    CONSTRAINT [CFGBillTaxesPK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGBillTaxes Table | Deltek Advantage 9.0 Database

CFGBillTaxesPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGBillTaxes Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGCashAcctSetup Table

Description

Cash Statement Report Table - Account Setup

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | StartAccount | Start account for the selected label. | VarChar | 10 |
Primary Key | EndAccount | End account for the selected label. | VarChar | 10 |
 | Label | Description of the range of accounts to appear on the Cash Statement repport. | VarChar | 50 |

Indexes

Index | Description | Primary | Unique
CFGCashAcctSetupPK |  |  |

SQL

CREATE TABLE [CFGCashAcctSetup] (
    [StartAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [EndAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGCashAcctSetupPK] PRIMARY KEY NONCLUSTERED
    (
        [StartAccount],
        [EndAccount]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGCashAcctSetup Table | Deltek Advantage 9.0 Database

CFGCashAcctSetupPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | StartAccount |  | Ascending
Primary Key | EndAccount |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGCashAcctSetup Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGCashHeadings Table

Description

Cash Statement Report Table - Headings

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 4
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ReportColumn | Order that the category displays on the report. | SmallInt | 2 |
 | Heading | Category to be displayed on the Cash Statement report. | VarChar | 30 |

Indexes

Index | Description | Primary | Unique
CFGCashHeadingsPK |  |  |

SQL

CREATE TABLE [CFGCashHeadings] (
    [ReportColumn] [smallint] NOT NULL ,
    [Heading] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGCashHeadingsPK] PRIMARY KEY NONCLUSTERED
    (
        [ReportColumn]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGCashHeadings Table | Deltek Advantage 9.0 Database

CFGCashHeadingsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ReportColumn |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGCashHeadings Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGCashSetup Table

Description

Cash Statement Report Table - Setup

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 3
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Label | Description of the range of accounts to appear on the Cash Statement report. | VarChar | 50 |
 | ReportColumn | Category that the label falls within on the Cash Statement report. | SmallInt | 2 |
 | SortSeq | Order in which the label will appear within the category on the Cash Statement report. | SmallInt | 2 |
 | SystemAccounts | System accounts selected for Accounts Receivable, Accounts Payable, and Net Income calculations on the Cash Statement report. | VarChar | 4 |

Indexes

Index | Description | Primary | Unique
CFGCashSetupPK |  |  |

SQL

CREATE TABLE [CFGCashSetup] (
    [Label] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ReportColumn] [smallint] NULL ,
    [SortSeq] [smallint] NULL ,
    [SystemAccounts] [varchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGCashSetupPK] PRIMARY KEY NONCLUSTERED
    (
        [Label]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGCashSetup Table | Deltek Advantage 9.0 Database

CFGCashSetupPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Label |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGCashSetup Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGCASortSelect Table

Description

System Setup Table - Account Sort/Select Field Configuration

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 30
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SortNo | Required. Primary key corresponding to sort/select field number. | SmallInt | 2 |
 | DataType | Variable indicating the type of data to be input for the sort/select field. Valid options are 1 - Text; 2 - Numeric; and 3 - Date. | SmallInt | 2 |
 | Label | User label for the sort/select field. | VarChar | 20 |
 | InUse | Variable indicating whether the sort/select category is being used. | Boolean | 1 |
 | Required | Variable indicating whether this is a required field in Chart of Accounts Table Maintenance. | Boolean | 1 |
 | LimitToList | Variable indicating whether entry is limited to system setup values (applicable for text data types only). | Boolean | 1 |
 | Uppercase | Variable indicating whether entered values should be converted to all uppercase (applicable for text data types only). | Boolean | 1 |
 | Digits | Maximum number of digits allowed (applicable for numeric data types only). | SmallInt | 2 |
 | Decimals | Maximum number of decimals allowed (applicable for numeric data types only). | SmallInt | 2 |
 | MaxValue | Maximum numeric value allowed (applicable for numeric data types only). | Double | 9 |
 | MinValue | Minimum numeric value allowed (applicable for numeric data types only). | Double | 9 |
 | NullTaskSignificant | Variable indicating whether this value is significant at the project level for a project with tasks (applicable for numeric data types only). | Boolean | 1 |
 | AggregateFlag | Variable indicating whether the numeric gets aggregated during a closeout (applicable for numeric data types only). | Boolean | 1 |
 | MaxDate | Maximum date allowed (applicable for date data types only). | DBTimeStamp | 4 |
 | MinDate | Minimum date allowed (applicable for date data types only). | DBTimeStamp | 4 |
 | HelpMessage | User defined help message to be displayed in status bar text. | VarChar | 100 |

Indexes

Index | Description | Primary | Unique
CFGCASortSelectPK |  |  |

SQL

CREATE TABLE [CFGCASortSelect] (
    [SortNo] [smallint] NOT NULL ,
    [DataType] [smallint] NULL ,
    [Label] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InUse] [bit] NOT NULL CONSTRAINT [DF__CFGCASort__InUse__45BE5BA9] DEFAULT (0),
    [Required] [bit] NOT NULL CONSTRAINT [DF__CFGCASort__Requi__46B27FE2] DEFAULT (0),
    [LimitToList] [bit] NOT NULL CONSTRAINT [DF__CFGCASort__Limit__47A6A41B] DEFAULT (0),
    [Uppercase] [bit] NOT NULL CONSTRAINT [DF__CFGCASort__Upper__489AC854] DEFAULT (0),
    [Digits] [smallint] NULL ,
    [Decimals] [smallint] NULL ,
    [MaxValue] [float] NULL ,
    [MinValue] [float] NULL ,
    [NullTaskSignificant] [bit] NOT NULL CONSTRAINT [DF__CFGCASort__NullT__498EEC8D] DEFAULT (0),
    [AggregateFlag] [bit] NOT NULL CONSTRAINT [DF__CFGCASort__Aggre__4A8310C6] DEFAULT (0),
    [MaxDate] [datetime] NULL ,
    [MinDate] [datetime] NULL ,
    [HelpMessage] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGCASortSelectPK] PRIMARY KEY NONCLUSTERED
    (
        [SortNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGCASortSelect Table | Deltek Advantage 9.0 Database

CFGCASortSelectPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SortNo |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 3
Rows Sampled | 3
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:02

See Also

CFGCASortSelect Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGClientStatus Table

Description

Client Status Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 4
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Status | For future use. | VarChar | 1 |
 | Label | For future use. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
CFGClientStatusPK |  |  |

SQL

CREATE TABLE [CFGClientStatus] (
    [Status] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGClientStatusPK] PRIMARY KEY NONCLUSTERED
    (
        [Status]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGClientStatus Table | Deltek Advantage 9.0 Database

CFGClientStatusPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Status |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGClientStatus Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGCLSortSelect Table

Description

System Setup Table - Client Sort/Select Field Configuration

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 30
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SortNo | Required. Primary key corresponding to the sort/select field number. | SmallInt | 2 |
 | DataType | Variable indicating the type of data to be input for the sort/select field. Valid options are 1 - Text; 2 - Numeric; and 3 - Date. | SmallInt | 2 |
 | Label | User label for the sort/select field. | VarChar | 20 |
 | InUse | Variable indicating whether the sort/select category is being used. | Boolean | 1 |
 | Required | Variable indicating whether this is a required field in Client Table Maintenance. | Boolean | 1 |
 | LimitToList | Variable indicating whether entry is limited to system setup values (applicable for text data types only). | Boolean | 1 |
 | Uppercase | Variable indicating whether entered values should be converted to all uppercase (applicable for text data types only). | Boolean | 1 |
 | Digits | Maximum number of digits allowed (applicable for numeric data types only). | SmallInt | 2 |
 | Decimals | Maximum number of decimals allowed (applicable for numeric data types only). | SmallInt | 2 |
 | MaxValue | Maximum numeric value allowed (applicable for numeric data types only). | Double | 9 |
 | MinValue | Minimum numeric value allowed (applicable for numeric data types only). | Double | 9 |
 | NullTaskSignificant | Variable indicating whether this value is significant at the project level for a project with tasks (for numeric data types only). | Boolean | 1 |
 | AggregateFlag | Variable indicating whether the numeric gets aggregated during a closeout (applicable for numeric data types only). | Boolean | 1 |
 | MaxDate | Maximum date allowed (applicable for date data types only). | DBTimeStamp | 4 |
 | MinDate | Minimum date allowed (applicable for date data types only). | DBTimeStamp | 4 |
 | HelpMessage | User defined help message to be displayed in status bar text. | VarChar | 100 |

Indexes

Index | Description | Primary | Unique
CFGCLSortSelectPK |  |  |

SQL

CREATE TABLE [CFGCLSortSelect] (
    [SortNo] [smallint] NOT NULL ,
    [DataType] [smallint] NULL ,
    [Label] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InUse] [bit] NOT NULL CONSTRAINT [DF__CFGCLSort__InUse__4C6B5938] DEFAULT (0),
    [Required] [bit] NOT NULL CONSTRAINT [DF__CFGCLSort__Requi__4D5F7D71] DEFAULT (0),
    [LimitToList] [bit] NOT NULL CONSTRAINT [DF__CFGCLSort__Limit__4E53A1AA] DEFAULT (0),
    [Uppercase] [bit] NOT NULL CONSTRAINT [DF__CFGCLSort__Upper__4F47C5E3] DEFAULT (0),
    [Digits] [smallint] NULL ,
    [Decimals] [smallint] NULL ,
    [MaxValue] [float] NULL ,
    [MinValue] [float] NULL ,
    [NullTaskSignificant] [bit] NOT NULL CONSTRAINT [DF__CFGCLSort__NullT__503BEA1C] DEFAULT (0),
    [AggregateFlag] [bit] NOT NULL CONSTRAINT [DF__CFGCLSort__Aggre__51300E55] DEFAULT (0),
    [MaxDate] [datetime] NULL ,
    [MinDate] [datetime] NULL ,
    [HelpMessage] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGCLSortSelectPK] PRIMARY KEY NONCLUSTERED
    (
        [SortNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGCLSortSelect Table | Deltek Advantage 9.0 Database

CFGCLSortSelectPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SortNo |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 3
Rows Sampled | 3
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:02

See Also

CFGCLSortSelect Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGDates Table

Description

System Setup Table - Dates

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Period | Required. Current/prior fiscal year and period. | Integer | 4 |
 | AccountPdStart | Current/prior accounting period start dates. | DBTimeStamp | 4 |
 | AccountPdEnd | Current/prior accounting period end dates. | DBTimeStamp | 4 |
 | FYStart | Current/prior fiscal year start dates. | DBTimeStamp | 4 |
 | FYEnd | Current/prior fiscal year end dates. | DBTimeStamp | 4 |
 | LastPostSeq | Sequence number of the last posting done in the period. | SmallInt | 2 |
 | OHAllocNeeded | Variable indicating whether the overhead allocation needs to be run in the period. | Boolean | 1 |
 | RevGenNeeded | Variable indicating whether revenue generation needs to be run in the period. | Boolean | 1 |
 | Closed | Variable indicating whether the period has been closed to regular processing. | Boolean | 1 |
 | Purged | Variable indicating whether the period has been purged. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGDatesPK |  |  |

SQL

CREATE TABLE [CFGDates] (
    [Period] [int] NOT NULL ,
    [AccountPdStart] [datetime] NULL ,
    [AccountPdEnd] [datetime] NULL ,
    [FYStart] [datetime] NULL ,
    [FYEnd] [datetime] NULL ,
    [LastPostSeq] [smallint] NULL ,
    [OHAllocNeeded] [bit] NOT NULL CONSTRAINT [DF__CFGDates__OHAllo__531856C7] DEFAULT (0),
    [RevGenNeeded] [bit] NOT NULL CONSTRAINT [DF__CFGDates__RevGen__540C7B00] DEFAULT (0),
    [Closed] [bit] NOT NULL CONSTRAINT [DF__CFGDates__Closed__55009F39] DEFAULT (0),
    [Purged] [bit] NOT NULL CONSTRAINT [DF__CFGDates__Purged__55F4C372] DEFAULT (0),
    CONSTRAINT [CFGDatesPK] PRIMARY KEY NONCLUSTERED
    (
        [Period]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGDates Table | Deltek Advantage 9.0 Database

CFGDatesPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Period |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGDates Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGEKCategory Table

Description

System Setup Table - Expensekeeper Categories

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Category | Required. Expensekeeper category. | SmallInt | 2 |
Primary Key | EKGroup | Required. Expensekeeper group that the category applies to. | VarChar | 2 |
 | Description | Category description. | VarChar | 40 |
 | DirectAccount | Account for regular, nonbillable projects. | VarChar | 10 |
 | ReimbAccount | Account for regular, billable projects. | VarChar | 10 |
 | IndirectAccount | Account for overhead projects. | VarChar | 10 |
 | DetailType | Detail type for the category. | VarChar | 1 |
 | BillByDefault | Variable indicating whether the category is billable by default. | Boolean | 1 |
 | BillableWarning | Type of message to appear for nonbillable categories. Valid options are E - Error; W - Warning; and N - None. | VarChar | 1 |
 | AllowAccountChange | Variable indicating whether to allow users to change the account for the category. | Boolean | 1 |
 | CompanyPaidProject | Project for posting company paid line items for the category. | VarChar | 12 |
 | CompanyPaidTask | Task for posting company paid line items for the category. | VarChar | 5 |
 | CompanyPaidAccount | Account for posting company paid line items for the category. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
CFGEKCategoryPK |  |  |

SQL

CREATE TABLE [CFGEKCategory] (
    [Category] [smallint] NOT NULL ,
    [EKGroup] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DirectAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ReimbAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [IndirectAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DetailType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillByDefault] [bit] NOT NULL CONSTRAINT [DF__CFGEKCate__BillB__57DD0BE4] DEFAULT (0),
    [BillableWarning] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AllowAccountChange] [bit] NOT NULL CONSTRAINT [DF__CFGEKCate__Allow__58D1301D] DEFAULT (0),
    [CompanyPaidProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CompanyPaidTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CompanyPaidAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGEKCategoryPK] PRIMARY KEY NONCLUSTERED
    (
        [Category],
        [EKGroup]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGEKCategory Table | Deltek Advantage 9.0 Database

CFGEKCategoryPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Category |  | Ascending
Primary Key | EKGroup |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGEKCategory Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGEKEmployeeGroup Table

Description

System Setup Table - Expensekeeper Employee Groups

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | EmployeeGroup | Required. Expensekeeper group. | VarChar | 2 |
 | Description | Group description. | VarChar | 20 |

Indexes

Index | Description | Primary | Unique
CFGEKEmployeeGroupPK |  |  |

SQL

CREATE TABLE [CFGEKEmployeeGroup] (
    [EmployeeGroup] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Description] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGEKEmployeeGroupPK] PRIMARY KEY NONCLUSTERED
    (
        [EmployeeGroup]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGEKEmployeeGroup Table | Deltek Advantage 9.0 Database

CFGEKEmployeeGroupPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | EmployeeGroup |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGEKEmployeeGroup Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGEmployeeStatus Table

Description

System Setup Table - Employee Status

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 3
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Status | Required. Variable indicating the employee status. Valid options are A - Active; I - Inactive; and T - Terminated. | VarChar | 1 |
 | Label | Label for the employee status. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
CFGEmployeeStatusPK |  |  |

SQL

CREATE TABLE [CFGEmployeeStatus] (
    [Status] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGEmployeeStatusPK] PRIMARY KEY NONCLUSTERED
    (
        [Status]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGEmployeeStatus Table | Deltek Advantage 9.0 Database

CFGEmployeeStatusPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Status |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 3
Rows Sampled | 3
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:02

See Also

CFGEmployeeStatus Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGEmployeeType Table

Description

System Setup Table - Employee Types

Properties

Creation Date | Monday, January 26, 2004 15:00
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 2
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Type | Required. Variable indicating the employee type. Valid options are P - Principal and E - Employee. | VarChar | 1 |
 | Label | Label for the employee type. | VarChar | 12 |
 | SortOrder | Sequence number that determines the order in which employee types appear on invoices. | SmallInt | 2 |
 | DirectAccount | Account to debit with direct labor for the employee type. | VarChar | 10 |
 | IndirectAccount | Account to debit with indirect labor for the employee type. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
CFGEmployeeTypePK |  |  |

SQL

CREATE TABLE [CFGEmployeeType] (
    [Type] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SortOrder] [smallint] NULL ,
    [DirectAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [IndirectAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGEmployeeTypePK] PRIMARY KEY NONCLUSTERED
    (
        [Type]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGEmployeeType Table | Deltek Advantage 9.0 Database

CFGEmployeeTypePK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Type |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 2
Rows Sampled | 2
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:02

See Also

CFGEmployeeType Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGEMSortSelect Table

Description

System Setup Table - Employee Sort/Select Field Configuration

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 30
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SortNo | Required. Primary key corresponding to sort/select field number. | SmallInt | 2 |
 | DataType | Variable indicating the type of data to be input for the sort/select field. Valid options are 1 - Text; 2 - Numeric; and 3 - Date. | SmallInt | 2 |
 | Label | User label for the sort/select field. | VarChar | 20 |
 | InUse | Variable indicating whether the sort/select category is being used. | Boolean | 1 |
 | Required | Variable indicating whether this is a required field in Employee Table Maintenance. | Boolean | 1 |
 | LimitToList | Variable indicating whether the entry is limited to system setup values (for text data types only). | Boolean | 1 |
 | Uppercase | Variable indicating whether entered values should be converted to all uppercase (for text data types only). | Boolean | 1 |
 | Digits | Maximum number of digits allowed (for numeric data types only). | SmallInt | 2 |
 | Decimals | Maximum number of decimals allowed (for numeric data types only). | SmallInt | 2 |
 | MaxValue | Maximum numeric value allowed (for numeric data types only). | Double | 9 |
 | MinValue | Minimum numeric value allowed (for numeric data types only). | Double | 9 |
 | NullTaskSignificant | Variable indicating whether this value is significant at the project level for a project with tasks (for numeric data types only). | Boolean | 1 |
 | AggregateFlag | Variable indicating whether the numeric gets aggregated during a closeout (applicable for numeric data types only). | Boolean | 1 |
 | MaxDate | Maximum date allowed (applicable for date data types only). | DBTimeStamp | 4 |
 | MinDate | Minimum date allowed (applicable for date data types only). | DBTimeStamp | 4 |
 | HelpMessage | User defined help message to be displayed in the status bar text. | VarChar | 100 |
 | Flag254 | Variable indicating whether the sort/select field is being used for 254 data. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGEMSortSelectPK |  |  |

SQL

CREATE TABLE [CFGEMSortSelect] (
    [SortNo] [smallint] NOT NULL ,
    [DataType] [smallint] NULL ,
    [Label] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InUse] [bit] NOT NULL CONSTRAINT [DF__CFGEMSort__InUse__5D95E53A] DEFAULT (0),
    [Required] [bit] NOT NULL CONSTRAINT [DF__CFGEMSort__Requi__5E8A0973] DEFAULT (0),
    [LimitToList] [bit] NOT NULL CONSTRAINT [DF__CFGEMSort__Limit__5F7E2DAC] DEFAULT (0),
    [Uppercase] [bit] NOT NULL CONSTRAINT [DF__CFGEMSort__Upper__607251E5] DEFAULT (0),
    [Digits] [smallint] NULL ,
    [Decimals] [smallint] NULL ,
    [MaxValue] [float] NULL ,
    [MinValue] [float] NULL ,
    [NullTaskSignificant] [bit] NOT NULL CONSTRAINT [DF__CFGEMSort__NullT__6166761E] DEFAULT (0),
    [AggregateFlag] [bit] NOT NULL CONSTRAINT [DF__CFGEMSort__Aggre__625A9A57] DEFAULT (0),
    [MaxDate] [datetime] NULL ,
    [MinDate] [datetime] NULL ,
    [HelpMessage] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Flag254] [bit] NOT NULL CONSTRAINT [DF__CFGEMSort__Flag2__634EBE90] DEFAULT (0),
    CONSTRAINT [CFGEMSortSelectPK] PRIMARY KEY NONCLUSTERED
    (
        [SortNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGEMSortSelect Table | Deltek Advantage 9.0 Database

CFGEMSortSelectPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SortNo |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 30
Rows Sampled | 30
Distribution Steps | 16
Updated | Monday, January 26, 2004 15:02

See Also

CFGEMSortSelect Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGETInterface Table

Description

ET Interface Setup Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |
 | ETServer | Name of the server on which ET resides. If blank, ET is considered to be on the same server as Advantage. | VarChar | 20 |
 | ETDB | Database name of the ET database. | VarChar | 20 |
 | ETUser | User name of the ET database (typically DELTEKET). | VarChar | 20 |
 | DownloadSSN | Variable indicating whether the employee’s security number should be downloaded into ET. | Boolean | 1 |
 | TrackingLeave | Variable indicating whether the employee leave is being tracked. | Boolean | 1 |
 | ETDifferentServer | Variable indicating whether the ET database is on a different server than the Advantage database. | Boolean | 1 |
 | LeavePlanOption | Not used at this time. | VarChar | 1 |
 | LCSplit1 | Labor code export field. This field stores the first combination of the labor code split, if any. | VarChar | 5 |
 | LCSplit2 | Labor code export field. This field stores the second combination of the labor code split, if any. | VarChar | 5 |
 | LCSplit3 | Labor code export field. This field stores the third combination of the labor code split, if any. | VarChar | 5 |
 | LCSplit4 | Labor code export field. This field stores the fourth combination of the labor code split, if any. | VarChar | 5 |
 | LCSplit5 | Labor code export field. This field stores the fifth combination of the labor code split, if any. | VarChar | 5 |
 | ETLCTable1 | Name of the ET table in which the LCSplit1 labor code combination will be inserted. Valid options are ET_UDT07; ET_UDT09; ET_UDT03; ET_UDT04; ET_UDT05; and ET_UDT06. | VarChar | 30 |
 | ETLCTable2 | Name of the ET table in which the LCSplit2 labor code combination will be inserted. Valid options are ET_UDT07; ET_UDT09; ET_UDT03; ET_UDT04; ET_UDT05; and ET_UDT06. | VarChar | 30 |
 | ETLCTable3 | Name of the ET table in which the LCSplit3 labor code combination will be inserted. Valid options are ET_UDT07; ET_UDT09; ET_UDT03; ET_UDT04; ET_UDT05; and ET_UDT06. | VarChar | 30 |
 | ETLCTable4 | Name of the ET table in which the LCSplit4 labor code combination will be inserted. Valid options are ET_UDT07; ET_UDT09; ET_UDT03; ET_UDT04; ET_UDT05; and ET_UDT06. | VarChar | 30 |
 | ETLCTable5 | Name of the ET table in which the LCSplit5 labor code combination will be inserted. Valid options are ET_UDT07; ET_UDT09; ET_UDT03; ET_UDT04; ET_UDT05; and ET_UDT06. | VarChar | 30 |
 | LastExportDate | The date and time when the record was last exported. | DBTimeStamp | 4 |

Indexes

Index | Description | Primary | Unique
CFGETInterfacePK |  |  |

SQL

CREATE TABLE [CFGETInterface] (
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ETServer] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ETDB] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ETUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DownloadSSN] [bit] NOT NULL CONSTRAINT [DF__CFGETInte__Downl__65370702] DEFAULT (0),
    [TrackingLeave] [bit] NOT NULL CONSTRAINT [DF__CFGETInte__Track__662B2B3B] DEFAULT (0),
    [ETDifferentServer] [bit] NOT NULL CONSTRAINT [DF__CFGETInte__ETDif__671F4F74] DEFAULT (0),
    [LeavePlanOption] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LCSplit1] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LCSplit2] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LCSplit3] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LCSplit4] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LCSplit5] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ETLCTable1] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ETLCTable2] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ETLCTable3] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ETLCTable4] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ETLCTable5] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LastExportDate] [datetime] NULL ,
    CONSTRAINT [CFGETInterfacePK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGETInterface Table | Deltek Advantage 9.0 Database

CFGETInterfacePK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGETInterface Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGInstall Table

Description

System Setup Table - Installation

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
 | ClientNumber | Your client number. | VarChar | 12 |
 | SystemLevelPassword | Password for the system. | VarChar | 20 |
 | AccountingPassword | Password for the Accounting application. | VarChar | 20 |
 | APPassword | Password for the Accounts Payable application. | VarChar | 20 |
 | BillingPassword | Password for the Billing application. | VarChar | 20 |
 | PayrollPassword | Password for the Payroll application. | VarChar | 20 |
 | ProfCtrPassword | Password for the Profit Center Reporting application. | VarChar | 20 |
 | MultiUserPassword | Password for the Multiuser application. | VarChar | 20 |
 | TimekeeperPassword | Password for the Timekeeper application. | VarChar | 20 |
 | ExpensekeeperPassword | Password for the Expensekeeper application. | VarChar | 20 |
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |

Indexes

Index | Description | Primary | Unique
CFGInstallPK |  |  |

SQL

CREATE TABLE [CFGInstall] (
    [ClientNumber] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SystemLevelPassword] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountingPassword] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [APPassword] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillingPassword] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayrollPassword] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProfCtrPassword] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [MultiUserPassword] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TimekeeperPassword] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ExpensekeeperPassword] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    CONSTRAINT [CFGInstallPK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGInstall Table | Deltek Advantage 9.0 Database

CFGInstallPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

CFGInstall Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGInvMap Table

Description

System Setup Table - Invoice Mapping Accounts

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 3
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Account | Required. Revenue account to be mapped to report columns. | VarChar | 10 |
 | ARAccount | Accounts receivable account to be mapped to report columns. | VarChar | 10 |
 | ARColumn | Variable indicating the column on the Accounts Receivable Ledger to which postings to the revenue account are mapped when printing the report. Valid options are 1 - Fees; 2 - Reimb; 3 - Taxes; and 4 - Interest. | SmallInt | 2 |
 | ProjectColumn | Variable indicating the column on the Office Earnings report to which postings to the revenue account are mapped when printing the report. Valid options are 1 - Fees Billed; 2 - Cons Billed; and 3 - Reimb Billed. | SmallInt | 2 |
 | RetainageAccount | Deferred Retainage account to use for Retainage postings. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
CFGInvMapPK |  |  |

SQL

CREATE TABLE [CFGInvMap] (
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ARAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ARColumn] [smallint] NULL ,
    [ProjectColumn] [smallint] NULL ,
    [RetainageAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGInvMapPK] PRIMARY KEY NONCLUSTERED
    (
        [Account]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGInvMap Table | Deltek Advantage 9.0 Database

CFGInvMapPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Account |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 3
Rows Sampled | 3
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:02

See Also

CFGInvMap Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGLabels Table

Description

System Setup Table - Sort/Select Fields

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |
 | ProjectLabel | Label to substitute for “Project.” | VarChar | 10 |
 | TaskLabel | Label to substitute for “Task.” | VarChar | 6 |
 | PrincipalLabel | Label to substitute for “Principal.” | VarChar | 16 |
 | ProjMgrLabel | Label to substitute for “Project Manager.” | VarChar | 16 |
 | LC1Label | Label for labor code level 1. | VarChar | 18 |
 | LC2Label | Label for labor code level 2. | VarChar | 18 |
 | LC3Label | Label for labor code level 3. | VarChar | 18 |
 | LC4Label | Label for labor code level 4. | VarChar | 18 |
 | LC5Label | Label for labor code level 5. | VarChar | 18 |
 | SupervisorLabel | Label to substitute for project “Supervisor.” | VarChar | 16 |

Indexes

Index | Description | Primary | Unique
CFGLabelsPK |  |  |

SQL

CREATE TABLE [CFGLabels] (
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ProjectLabel] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskLabel] [varchar] (6) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrincipalLabel] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjMgrLabel] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LC1Label] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LC2Label] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LC3Label] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LC4Label] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LC5Label] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SupervisorLabel] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGLabelsPK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGLabels Table | Deltek Advantage 9.0 Database

CFGLabelsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 3.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Wednesday, May 03, 2006 12:15

See Also

CFGLabels Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGLC1 Table

Description

System Setup Table - Labor Code Level 1

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Code for the first labor code level. | VarChar | 5 |
 | Label | Description for the first labor code level. | VarChar | 16 |

Indexes

Index | Description | Primary | Unique
CFGLC1PK |  |  |

SQL

CREATE TABLE [CFGLC1] (
    [Code] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGLC1PK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGLC1 Table | Deltek Advantage 9.0 Database

CFGLC1PK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGLC1 Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGLC2 Table

Description

System Setup Table - Labor Code Level 2

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Code for the second labor code level. | VarChar | 5 |
 | Label | Description for the second labor code level. | VarChar | 16 |

Indexes

Index | Description | Primary | Unique
CFGLC2PK |  |  |

SQL

CREATE TABLE [CFGLC2] (
    [Code] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGLC2PK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGLC2 Table | Deltek Advantage 9.0 Database

CFGLC2PK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGLC2 Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGLC3 Table

Description

System Setup Table - Labor Code Level 3

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Code for the third labor code level. | VarChar | 5 |
 | Label | Description for the third labor code level. | VarChar | 16 |

Indexes

Index | Description | Primary | Unique
CFGLC3PK |  |  |

SQL

CREATE TABLE [CFGLC3] (
    [Code] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGLC3PK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGLC3 Table | Deltek Advantage 9.0 Database

CFGLC3PK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGLC3 Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGLC4 Table

Description

System Setup Table - Labor Code Level 4

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Code for the fourth labor code level. | VarChar | 5 |
 | Label | Description for the fourth labor code level. | VarChar | 16 |

Indexes

Index | Description | Primary | Unique
CFGLC4PK |  |  |

SQL

CREATE TABLE [CFGLC4] (
    [Code] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGLC4PK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGLC4 Table | Deltek Advantage 9.0 Database

CFGLC4PK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGLC4 Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGLC5 Table

Description

System Setup Table - Labor Code Level 5

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Code for the fifth labor code level. | VarChar | 5 |
 | Label | Description for the fifth labor code level. | VarChar | 16 |

Indexes

Index | Description | Primary | Unique
CFGLC5PK |  |  |

SQL

CREATE TABLE [CFGLC5] (
    [Code] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGLC5PK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGLC5 Table | Deltek Advantage 9.0 Database

CFGLC5PK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGLC5 Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGMain Table

Description

System Setup Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |
 | Diag | For internal use only. | Boolean | 1 |
 | Version | Current version of CFMS/Advantage. | VarChar | 8 |
 | FirmName | Firm name. | VarChar | 42 |
 | CurrentPeriod | Current fiscal period. | Integer | 4 |
 | PeriodsPerYear | Variable indicating the number of accounting periods per fiscal year. Valid options are 12 and 13. | SmallInt | 2 |
 | ProjectLength | Length of the project numbers in your database. | SmallInt | 2 |
 | ProjectLeadZeros | Variable indicating whether project numbers should have leading zeros. | Boolean | 1 |
 | ProjectDelimiter1 | First project number delimiter to use. | VarChar | 1 |
 | ProjectDelimiter1Position | Position of the first project delimiter. | SmallInt | 2 |
 | ProjectDelimiter2 | Second project number delimiter to use. | VarChar | 1 |
 | ProjectDelimiter2Position | Position of the second project delimiter. | SmallInt | 2 |
 | TaskLength | Length of the task numbers in your database. | SmallInt | 2 |
 | TaskLeadZeros | Variable indicating whether task numbers should have leading zeros. | Boolean | 1 |
 | PctrLevels | Number of profit center levels defined through Profit Center Setup Maintenance. | SmallInt | 2 |
 | LCLevels | Number of labor code levels defined through the Labor Code Conversion utility. | SmallInt | 2 |
 | LC1Start | Start position of the first level within the labor code. | SmallInt | 2 |
 | LC1Length | Length of the labor code level. | SmallInt | 2 |
 | LC2Start | Start position of the second level within the labor code. | SmallInt | 2 |
 | LC2Length | Length of the labor code level. | SmallInt | 2 |
 | LC3Start | Start position of the third level within the labor code. | SmallInt | 2 |
 | LC3Length | Length of the labor code level. | SmallInt | 2 |
 | LC4Start | Start position of the fourth level within the labor code. | SmallInt | 2 |
 | LC4Length | Length of the labor code level. | SmallInt | 2 |
 | LC5Start | Start position of the fifth level within the labor code. | SmallInt | 2 |
 | LC5Length | Length of the labor code level. | SmallInt | 2 |
 | AccountLength | Length of the account numbers in your database. | SmallInt | 2 |
 | AccountLeadZeros | Variable indicating whether account numbers should have leading zeros. | Boolean | 1 |
 | AccountDelimiter | First account number delimiter to use. | VarChar | 1 |
 | AccountDelimiterPosition | Position of the first account delimiter. | SmallInt | 2 |
 | EmployeeLength | Length of the employee numbers in your database. | SmallInt | 2 |
 | EmployeeLeadZeros | Variable indicating whether employee numbers should have leading zeros. | Boolean | 1 |
 | ClientLength | Length of the client numbers in your database. | SmallInt | 2 |
 | ClientLeadZeros | Variable indicating whether client numbers should have leading zeros. | Boolean | 1 |
 | VendorLength | Length of the vendor numbers in your database. | SmallInt | 2 |
 | VendorLeadZeros | Variable indicating whether vendor numbers should have leading zeros. | Boolean | 1 |
 | UnitLength | Length of the unit numbers in your database. | SmallInt | 2 |
 | UnitLeadZeros | Variable indicating whether unit numbers should have leading zeros. | Boolean | 1 |
 | FirstLiability | First account in the liability account range. | VarChar | 10 |
 | FirstNetWorth | First net worth account in the range. | VarChar | 10 |
 | FirstRevenue | First account in the revenue account range. | VarChar | 10 |
 | FirstReimb | First account in the reimbursable account range. | VarChar | 10 |
 | FirstDirect | First account in the direct expense account range. | VarChar | 10 |
 | FirstIndirect | First account in the indirect consultant expense account range. | VarChar | 10 |
 | FirstOtherCharges | First account in the other charges account range. | VarChar | 10 |
 | StartReimbCons | The account which starts the reimbursable consultant account range. | VarChar | 10 |
 | EndReimbCons | The account which ends the reimbursable consultant account range. | VarChar | 10 |
 | StartDirectCons | The account which starts the direct consultant account range. | VarChar | 10 |
 | EndDirectCons | The account which ends the direct consultant account range. | VarChar | 10 |
 | UninvoicedRevenue | Revenue account used for uninvoiced revenue. | VarChar | 10 |
 | UnbilledServices | Unbilled services account. | VarChar | 10 |
 | AcctsReceivable | Default accounts receivable account. | VarChar | 10 |
 | RetainedEarnCurrent | Current year’s retained earnings account. | VarChar | 10 |
 | RetainedEarnPrevYrs | Prior year’s retained earnings account. | VarChar | 10 |
 | CashBasis | Variable indicating whether to use the cash-basis reporting feature. | Boolean | 1 |
 | JobCostAtSalary | Variable indicating whether to allow employee job cost rates to be salaries. | Boolean | 1 |
 | JobCostFrequency | Variable indicating the job cost frequency. Valid options are M - Monthly; S - Semi-monthly; B - Bi-weekly; and W - Weekly. | VarChar | 1 |
 | MaxHourlyRate | Maximum likely hourly job cost rate for employees. | Double | 9 |
 | LaborCreditProject | Project used for posting the labor distribution. | VarChar | 12 |
 | LaborCreditTask | Task used for posting the labor distribution. | VarChar | 5 |
 | LaborCreditAccount | Account used for posting the labor distribution. | VarChar | 10 |
 | MiscCreditProject | Project for posting the miscellaneous distribution credit. | VarChar | 12 |
 | MiscCreditTask | Task for posting the miscellaneous distribution credit. | VarChar | 5 |
 | MiscCreditAccount | Account for posting the miscellaneous distribution credit. | VarChar | 10 |
 | PrintsCreditProject | Project for posting the prints and reproductions distribution credit. | VarChar | 12 |
 | PrintsCreditTask | Task for posting the prints and reproductions distribution credit. | VarChar | 5 |
 | PrintsCreditAccount | Account for posting the prints and reproductions distribution credit. | VarChar | 10 |
 | RevGenEnabled | Variable indicating whether you want to use the Revenue Generation feature. | Boolean | 1 |
 | GenOHProject | Project used for general overhead charges. | VarChar | 12 |
 | GenOHTask | Task used for general overhead charges. | VarChar | 5 |
 | IgnoreControlTotals | Variable indicating whether to ignore control totals when posting data entry files. | Boolean | 1 |
 | AllowHistory | Variable indicating whether to allow changes to history data. | Boolean | 1 |
 | ReportAtBilling | Variable indicating whether to run project reports at both billing and cost rates. | Boolean | 1 |
 | CashBasisTimePost | Variable indicating whether to post timesheets and labor adjustments as cash-basis. | Boolean | 1 |
 | ConsolidateTimePost | Variable indicating whether to consolidate your timesheet postings. | Boolean | 1 |
 | PreserveTimeComments | Variable indicating whether to preserve your comments when posting timesheets. | Boolean | 1 |
 | ProcessServersEnabled | Variable indicating whether process servers are enabled. | Boolean | 1 |
 | RetainageEnabled | Variable indicating whether the Retainage feature will be used in the Billing System. | Boolean | 1 |
 | EmplExpCreditProject | Project for posting the employee expense distribution credit. | VarChar | 12 |
 | EmplExpCreditTask | Task for posting the employee expense distribution credit. | VarChar | 5 |
 | EmplExpCreditAccount | Account for posting the employee expense distribution credit. | VarChar | 10 |
 | EmplAdvCreditProject | Project for posting the advance distribution credit. | VarChar | 12 |
 | EmplAdvCreditTask | Task for posting the advance distribution credit. | VarChar | 5 |
 | EmplAdvCreditAccount | Account for posting the advance distribution credit. | VarChar | 10 |
 | EmplDefaultBank | Default bank code for posting employee expense and advance checks. | VarChar | 10 |
 | ADPEnabled | Variable indicating whether the ADP feature is enabled. | Boolean | 1 |
 | ADPDefaultCompanyCode | The ADP default company code. | VarChar | 3 |
 | MediumDateStyle | The medium date format. | VarChar | 50 |
 | LongDateStyle | The long date format. | VarChar | 50 |
 | ETEnabled | Variable indicating whether the ET interface is enabled. | Boolean | 1 |
 | XChargeEnabled | Variable indicating whether the cross charge feature is enabled. | Boolean | 1 |
 | TaxAuditingEnabled | Variable indicating whether the full usage of tax codes for tracking taxes on purchases (inputs) and sales (outputs) is enabled. | Boolean | 1 |
 | DefaultTaxCode | Default tax code to use for individual transactions in a data entry file. | VarChar | 3 |
 | DefaultTaxCountryCode | Default tax country code to be used for new vendors and clients. | VarChar | 2 |
 | TaxCountryCode | Your firm’s tax country code. | VarChar | 2 |
 | TaxRegistrationNumber | Your firm's tax registration number. | VarChar | 15 |
 | CurrencyLabel | Label to use for writing out check amounts. | VarChar | 10 |
 | EXCheckTemplate | Updates default for employee expense checks from CheckEXDefault to CheckEX_MainDefault. | VarChar | 40 |
 | XChargeRegLAEnabled | Variable indicating whether to create a labor adjustment to move the labor cost for regular projects. | Boolean | 1 |
 | XChargeRegJEEnabled | Variable indicating whether to create a journal entry to move the labor cost for regular projects. | Boolean | 1 |
 | XChargeOHLAEnabled | Variable indicating whether to create a labor adjustment to move the labor cost for overhead projects. | Boolean | 1 |
 | XChargeOHJEEnabled | Variable indicating whether to create a journal entry to move the labor cost for overhead projects. | Boolean | 1 |
 | XChargeRegMethod | Cross charge method to use for regular projects. Valid options are 1 - Multiplier and 0 - Billing Terms. | SmallInt | 2 |
 | XChargeRegMult | Multiplier to use for regular projects when using the Multiplier cross charge method. | Double | 9 |
 | XChargeOHMult | Multiplier to use for overhead projects when using the Multiplier cross charge method. | Double | 9 |
 | XChargeRegCreditAccount | Credit account to use for regular projects. | VarChar | 10 |
 | XChargeRegDebitAccount | Debit account to use for regular projects. | VarChar | 10 |
 | XChargeOHCreditAccount | Credit account to use for overhead projects. | VarChar | 10 |
 | XChargeOHDebitAccount | Debit account to use for overhead projects. | VarChar | 10 |
 | PWPEnabled | Variable indicating whether the Interface to Project Workplace is enabled. | Boolean | 1 |
 | SpecialOvertimeEnabled | Variable indicating whether to have a separate special overtime field enabled in timesheet entry. | Boolean | 1 |
 | CurrentBenefitAccrualYear | The current benefit accrual year. | SmallInt | 2 |
 | BenefitAccrualByPayroll | Variable indicating whether the benefit accrual is by payroll system. | Boolean | 1 |
 | BenefitAccrualFrequency | The benefit accrual frequency. | VarChar | 1 |
 | BudgetByVendor | Variable indicating whether to enable budgeting by vendor. | Boolean | 1 |
 | ConsAccrProject | Consultant accrual credit project. | VarChar | 12 |
 | ConsAccrTask | Consultant accrual credit task. | VarChar | 5 |
 | ConsAccrAccount | Consultant accrual credit account. | VarChar | 10 |
 | RetainersEnabled | Indicates whether the Retainer feature will be used in the Billing application. | Boolean | 1 |
 | InternationalDateEnabled | Indicates whether the format option dd/mm/yyyy is enabled in Web Timekeeper. | Boolean | 1 |
 | FirstCash | Reserved for future use. | VarChar | 10 |
 | EndCash | Reserved for future use. | VarChar | 10 |
 | FirstProvision | Reserved for future use. | VarChar | 10 |
 | EndProvision | Reserved for future use. | VarChar | 10 |
 | FirstDeprec | Reserved for future use. | VarChar | 10 |
 | EndDeprec | Reserved for future use. | VarChar | 10 |
 | FirstPrePaidExp | Reserved for future use. | VarChar | 10 |
 | EndPrePaidExp | Reserved for future use. | VarChar | 10 |
 | FirstDefIncome | Reserved for future use. | VarChar | 10 |
 | EndDefIncome | Reserved for future use. | VarChar | 10 |
 | DefaultHelpDesk | The e-mail address to which your firm directs support questions, as specified in Default Help Desk on the General tab of System Setup Table Maintenance. | VarChar | 50 |

Indexes

Index | Description | Primary | Unique
CFGMainPK |  |  |

SQL

CREATE TABLE [CFGMain] (
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Diag] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Diag__70A8B9AE] DEFAULT (0),
    [Version] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FirmName] [varchar] (42) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CurrentPeriod] [int] NULL ,
    [PeriodsPerYear] [smallint] NULL ,
    [ProjectLength] [smallint] NULL ,
    [ProjectLeadZeros] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Project__719CDDE7] DEFAULT (0),
    [ProjectDelimiter1] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjectDelimiter1Position] [smallint] NULL ,
    [ProjectDelimiter2] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjectDelimiter2Position] [smallint] NULL ,
    [TaskLength] [smallint] NULL ,
    [TaskLeadZeros] [bit] NOT NULL CONSTRAINT [DF__CFGMain__TaskLea__72910220] DEFAULT (0),
    [PctrLevels] [smallint] NULL ,
    [LCLevels] [smallint] NULL ,
    [LC1Start] [smallint] NULL ,
    [LC1Length] [smallint] NULL ,
    [LC2Start] [smallint] NULL ,
    [LC2Length] [smallint] NULL ,
    [LC3Start] [smallint] NULL ,
    [LC3Length] [smallint] NULL ,
    [LC4Start] [smallint] NULL ,
    [LC4Length] [smallint] NULL ,
    [LC5Start] [smallint] NULL ,
    [LC5Length] [smallint] NULL ,
    [AccountLength] [smallint] NULL ,
    [AccountLeadZeros] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Account__73852659] DEFAULT (0),
    [AccountDelimiter] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountDelimiterPosition] [smallint] NULL ,
    [EmployeeLength] [smallint] NULL ,
    [EmployeeLeadZeros] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Employe__74794A92] DEFAULT (0),
    [ClientLength] [smallint] NULL ,
    [ClientLeadZeros] [bit] NOT NULL CONSTRAINT [DF__CFGMain__ClientL__756D6ECB] DEFAULT (0),
    [VendorLength] [smallint] NULL ,
    [VendorLeadZeros] [bit] NOT NULL CONSTRAINT [DF__CFGMain__VendorL__76619304] DEFAULT (0),
    [UnitLength] [smallint] NULL ,
    [UnitLeadZeros] [bit] NOT NULL CONSTRAINT [DF__CFGMain__UnitLea__7755B73D] DEFAULT (0),
    [FirstLiability] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FirstNetWorth] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FirstRevenue] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FirstReimb] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FirstDirect] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FirstIndirect] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FirstOtherCharges] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [StartReimbCons] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EndReimbCons] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [StartDirectCons] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EndDirectCons] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UninvoicedRevenue] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnbilledServices] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AcctsReceivable] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RetainedEarnCurrent] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RetainedEarnPrevYrs] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CashBasis] [bit] NOT NULL CONSTRAINT [DF__CFGMain__CashBas__7849DB76] DEFAULT (0),
    [JobCostAtSalary] [bit] NOT NULL CONSTRAINT [DF__CFGMain__JobCost__793DFFAF] DEFAULT (0),
    [JobCostFrequency] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [MaxHourlyRate] [float] NULL ,
    [LaborCreditProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LaborCreditTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LaborCreditAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [MiscCreditProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [MiscCreditTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [MiscCreditAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintsCreditProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintsCreditTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintsCreditAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RevGenEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__RevGenE__7A3223E8] DEFAULT (0),
    [GenOHProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [GenOHTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [IgnoreControlTotals] [bit] NOT NULL CONSTRAINT [DF__CFGMain__IgnoreC__7B264821] DEFAULT (0),
    [AllowHistory] [bit] NOT NULL CONSTRAINT [DF__CFGMain__AllowHi__7C1A6C5A] DEFAULT (0),
    [ReportAtBilling] [bit] NOT NULL CONSTRAINT [DF__CFGMain__ReportA__7D0E9093] DEFAULT (0),
    [CashBasisTimePost] [bit] NOT NULL CONSTRAINT [DF__CFGMain__CashBas__7E02B4CC] DEFAULT (0),
    [ConsolidateTimePost] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Consoli__7EF6D905] DEFAULT (0),
    [PreserveTimeComments] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Preserv__7FEAFD3E] DEFAULT (0),
    [ProcessServersEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Process__00DF2177] DEFAULT (0),
    [RetainageEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Retaina__01D345B0] DEFAULT (0),
    [EmplExpCreditProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmplExpCreditTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmplExpCreditAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmplAdvCreditProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmplAdvCreditTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmplAdvCreditAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmplDefaultBank] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ADPEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__ADPEnab__02C769E9] DEFAULT (0),
    [ADPDefaultCompanyCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [MediumDateStyle] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LongDateStyle] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ETEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__ETEnabl__03BB8E22] DEFAULT (0),
    [XChargeEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__XCharge__04AFB25B] DEFAULT (0),
    [TaxAuditingEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__TaxAudi__05A3D694] DEFAULT (0),
    [DefaultTaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DefaultTaxCountryCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxCountryCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxRegistrationNumber] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CurrencyLabel] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EXCheckTemplate] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeRegLAEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__XCharge__0697FACD] DEFAULT (0),
    [XChargeRegJEEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__XCharge__078C1F06] DEFAULT (0),
    [XChargeOHLAEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__XCharge__0880433F] DEFAULT (0),
    [XChargeOHJEEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__XCharge__09746778] DEFAULT (0),
    [XChargeRegMethod] [smallint] NULL ,
    [XChargeRegMult] [float] NULL ,
    [XChargeOHMult] [float] NULL ,
    [XChargeRegCreditAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeRegDebitAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeOHCreditAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeOHDebitAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PWPEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__PWPEnab__0A688BB1] DEFAULT (0),
    [SpecialOvertimeEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Special__0B5CAFEA] DEFAULT (0),
    [CurrentBenefitAccrualYear] [smallint] NULL ,
    [BenefitAccrualByPayroll] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Benefit__0C50D423] DEFAULT (0),
    [BenefitAccrualFrequency] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BudgetByVendor] [bit] NOT NULL CONSTRAINT [DF__CFGMain__BudgetB__0D44F85C] DEFAULT (0),
    [ConsAccrProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ConsAccrTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ConsAccrAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RetainersEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Retaine__0E391C95] DEFAULT (0),
    [InternationalDateEnabled] [bit] NOT NULL CONSTRAINT [DF__CFGMain__Interna__0F2D40CE] DEFAULT (0),
    [FirstCash] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EndCash] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FirstProvision] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EndProvision] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FirstDeprec] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EndDeprec] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FirstPrePaidExp] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EndPrePaidExp] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FirstDefIncome] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EndDefIncome] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DefaultHelpDesk] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGMainPK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGMain Table | Deltek Advantage 9.0 Database

CFGMainPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

CFGMain Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGOHAccounts Table

Description

System Setup Table - Overhead Allocation Accounts

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Account | Required. Accounts to include in the overhead allocation base. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
CFGOHAccountsPK |  |  |

SQL

CREATE TABLE [CFGOHAccounts] (
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    CONSTRAINT [CFGOHAccountsPK] PRIMARY KEY NONCLUSTERED
    (
        [Account]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGOHAccounts Table | Deltek Advantage 9.0 Database

CFGOHAccountsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Account |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGOHAccounts Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGOHMain Table

Description

System Setup Table - Overhead Allocation

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
 | OHProcedure | Variable indicating the overhead allocation procedure. Valid options are N - None; F - Firmwide; and P - Profit Center. | VarChar | 1 |
 | OHAllocMethod | Variable indicating the firmwide overhead allocation method. Valid options are A - Assign and P - Prorata. | VarChar | 1 |
 | OHBasis | Variable indicating the basis for overhead allocation. Valid options are DL - Direct Labor and RV - Revenue. | VarChar | 2 |
 | OHRate | Firmwide budgeted overhead rate used when assigning overhead. | Double | 9 |
 | OHVarianceProject | Project to use when unallocated overhead is posted. | VarChar | 12 |
 | OHVarianceTask | Task to use when unallocated overhead is posted. | VarChar | 5 |
 | OHProvisionalRate | Last rate used in firmwide overhead allocation. | Double | 9 |
 | PlugAmtRev | Difference between revenue in the project and general ledger tables. | Double | 9 |
 | PlugAmtDirLab | Difference between direct labor in the project and general ledger tables. | Double | 9 |
 | PlugAmtDirExp | Difference between direct expenses in the project and general ledger tables. | Double | 9 |
 | PlugAmtIndLab | Difference between indirect labor in the project and general ledger tables. | Double | 9 |
 | PlugAmtIndExp | Difference between indirect expenses in the project and general ledger tables. | Double | 9 |
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |

Indexes

Index | Description | Primary | Unique
CFGOHMainPK |  |  |

SQL

CREATE TABLE [CFGOHMain] (
    [OHProcedure] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OHAllocMethod] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OHBasis] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OHRate] [float] NULL ,
    [OHVarianceProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OHVarianceTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OHProvisionalRate] [float] NULL ,
    [PlugAmtRev] [float] NULL ,
    [PlugAmtDirLab] [float] NULL ,
    [PlugAmtDirExp] [float] NULL ,
    [PlugAmtIndLab] [float] NULL ,
    [PlugAmtIndExp] [float] NULL ,
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    CONSTRAINT [CFGOHMainPK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGOHMain Table | Deltek Advantage 9.0 Database

CFGOHMainPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

CFGOHMain Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPCCodes Table

Description

Profit Center Setup Table - Profit Center Subcodes

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | PctrLevel | Required. Profit center level. | SmallInt | 2 |
Primary Key | Code | Required. Values of the profit center code at this level. | VarChar | 2 |
 | Label | Description of the profit center value at this level. | VarChar | 16 |

Indexes

Index | Description | Primary | Unique
CFGPCCodesPK |  |  |

SQL

CREATE TABLE [CFGPCCodes] (
    [PctrLevel] [smallint] NOT NULL ,
    [Code] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGPCCodesPK] PRIMARY KEY NONCLUSTERED
    (
        [PctrLevel],
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPCCodes Table | Deltek Advantage 9.0 Database

CFGPCCodesPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | PctrLevel |  | Ascending
Primary Key | Code |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGPCCodes Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPCControl Table

Description

Profit Center Setup Table - Individual Profit Centers

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ProfCtr | Required. Profit center. | VarChar | 8 |
 | Label | Description of the profit center combination. | VarChar | 24 |
 | LabDistProject | Project to use for labor distribution to the profit center combination. | VarChar | 12 |
 | LabDistTask | Task to use for labor distribution to the profit center combination. | VarChar | 5 |
 | MiscProject | Project from which to get the location code if posting miscellaneous distribution credit by profit center. | VarChar | 12 |
 | MiscTask | Task from which to get the location code if posting miscellaneous distribution credit by profit center. | VarChar | 5 |
 | UnitsBSProject | Balance sheet project to use for unit postings to the profit center combination. | VarChar | 12 |
 | UnitsBSTask | Balance sheet task to use for unit postings to the profit center combination. | VarChar | 5 |
 | UnitsIndProject | Indirect project to use for unit postings to the profit center combination. | VarChar | 12 |
 | UnitsIndTask | Indirect task to use for unit postings to the profit center combination. | VarChar | 5 |
 | UnitsOtherProject | Other project to use for unit postings to the profit center combination. | VarChar | 12 |
 | UnitsOtherTask | Other task to use for unit postings to the profit center combination. | VarChar | 5 |
 | DistributeOH | Variable indicating whether you want to distribute overhead to the profit center. | Boolean | 1 |
 | DistributeTarget | Variable indicating the profit center(s) to which to distribute the overhead. | VarChar | 8 |
 | DistributePass | Distribution pass to distribute to overhead for the profit center. | SmallInt | 2 |
 | OHAllocMethod | Variable indicating the overhead allocation method. Valid options are A - Assign; P - Prorata; and N - None. | VarChar | 1 |
 | OHBasis | Variable indicating the overhead allocation basis. Valid options are DL - Direct Labor; RV - Revenue; TC - Total Costs; and TL - Total Labor. | VarChar | 2 |
 | OHRate | Budgeted overhead rate for the profit center to use when assigning overhead. | Double | 9 |
 | OHProvisionalRate | Last overhead rate used for the profit center. | Double | 9 |
 | OHVarianceProject | Regular project to which overhead is allocated. | VarChar | 12 |
 | OHVarianceTask | Task (if any) to which overhead is allocated. | VarChar | 5 |
 | PayrollProject | Project to use for all balance sheet payroll transactions posted to the profit center combination. | VarChar | 12 |
 | PayrollTask | Task to use for all balance sheet payroll transactions posted to the profit center combination. | VarChar | 5 |
 | FICAProject | Employer’s FICA expense debit project. | VarChar | 12 |
 | FICATask | Employer’s FICA expense debit task. | VarChar | 5 |
 | PlugAmtRev | Difference between revenue in the project and general ledger tables. | Double | 9 |
 | PlugAmtDirLab | Difference between direct labor in the project and general ledger tables. | Double | 9 |
 | PlugAmtDirExp | Difference between direct expenses in the project and general ledger tables. | Double | 9 |
 | PlugAmtIndLab | Difference between indirect labor in the project and general ledger tables. | Double | 9 |
 | PlugAmtIndExp | Difference between indirect expenses in the project and general ledger tables. | Double | 9 |
 | PrintsProject | Project from which to get the location code if posting prints and reproductions distribution credit by profit center. | VarChar | 12 |
 | PrintsTask | Task (if any) from which to get the location code if posting prints and reproductions distribution credit by profit center. | VarChar | 5 |
 | EmplExpProject | Project from which to get the profit center if you are posting employee expense distribution credit by profit center. | VarChar | 12 |
 | EmplExpTask | Task from which to get the profit center if you are posting employee expense distribution credit by profit center. | VarChar | 5 |
 | EmplAdvProject | Project from which to get the profit center if you are posting employee advance distribution credit by profit center. | VarChar | 12 |
 | EmplAdvTask | Task from which to get the profit center if you are posting employee advance distribution credit by profit center. | VarChar | 5 |
 | EmplDefaultBank | Default bank code for posting employee expense and advance checks. | VarChar | 10 |
 | ADPCompanyCode | ADP company code for this employee profit center. | VarChar | 3 |
 | XChargeDisabled | Variable indicating whether cross charges are disabled for this profit center. | Boolean | 1 |
 | XChargeRegMult | Regular cross charge multiplier if using the Multiplier cross charge method. | Double | 9 |
 | XChargeOHMult | Overhead cross charge multiplier if using the Multiplier cross charge method. | Double | 9 |
 | XChargeRegDebitProject | Regular cross charge debit project. | VarChar | 12 |
 | XChargeRegDebitTask | Regular cross charge debit task. | VarChar | 5 |
 | XChargeRegCreditProject | Regular cross charge credit project. | VarChar | 12 |
 | XChargeRegCreditTask | Regular cross charge credit task. | VarChar | 5 |
 | XChargeOHDebitProject | Overhead cross charge debit project. | VarChar | 12 |
 | XChargeOHDebitTask | Overhead cross charge debit task. | VarChar | 5 |
 | XChargeOHCreditProject | Overhead cross charge credit project. | VarChar | 12 |
 | XChargeOHCreditTask | Overhead cross charge credit task. | VarChar | 5 |
 | XChargeRegFromProject | Regular source project for cross charge labor adjustments. | VarChar | 12 |
 | XChargeRegFromTask | Regular source task for cross charge labor adjustments. | VarChar | 5 |
 | XChargeRegToProject | Regular destination project for cross charge labor adjustments. | VarChar | 12 |
 | XChargeRegToTask | Regular destination task for cross charge labor adjustments. | VarChar | 5 |
 | XChargeOHFromProject | Overhead source project for cross charge labor adjustments. | VarChar | 12 |
 | XChargeOHFromTask | Overhead source task for cross charge labor adjustments. | VarChar | 5 |
 | XChargeOHToProject | Overhead destination project for cross charge labor adjustments. | VarChar | 12 |
 | XChargeOHToTask | Overhead destination task for cross charge labor adjustments. | VarChar | 5 |
 | ConsAccrProject | Consultant accrual credit project. | VarChar | 12 |
 | ConsAccrTask | Consultant accrual credit task. | VarChar | 5 |

Indexes

Index | Description | Primary | Unique
CFGPCControlPK |  |  |

SQL

CREATE TABLE [CFGPCControl] (
    [ProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LabDistProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LabDistTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [MiscProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [MiscTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnitsBSProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnitsBSTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnitsIndProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnitsIndTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnitsOtherProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnitsOtherTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DistributeOH] [bit] NOT NULL CONSTRAINT [DF__CFGPCCont__Distr__13F1F5EB] DEFAULT (0),
    [DistributeTarget] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DistributePass] [smallint] NULL ,
    [OHAllocMethod] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OHBasis] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OHRate] [float] NULL ,
    [OHProvisionalRate] [float] NULL ,
    [OHVarianceProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OHVarianceTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayrollProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayrollTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FICAProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FICATask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PlugAmtRev] [float] NULL ,
    [PlugAmtDirLab] [float] NULL ,
    [PlugAmtDirExp] [float] NULL ,
    [PlugAmtIndLab] [float] NULL ,
    [PlugAmtIndExp] [float] NULL ,
    [PrintsProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintsTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmplExpProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmplExpTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmplAdvProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmplAdvTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmplDefaultBank] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ADPCompanyCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeDisabled] [bit] NOT NULL CONSTRAINT [DF__CFGPCCont__XChar__14E61A24] DEFAULT (0),
    [XChargeRegMult] [float] NULL ,
    [XChargeOHMult] [float] NULL ,
    [XChargeRegDebitProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeRegDebitTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeRegCreditProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeRegCreditTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeOHDebitProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeOHDebitTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeOHCreditProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeOHCreditTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeRegFromProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeRegFromTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeRegToProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeRegToTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeOHFromProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeOHFromTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeOHToProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeOHToTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ConsAccrProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ConsAccrTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGPCControlPK] PRIMARY KEY NONCLUSTERED
    (
        [ProfCtr]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPCControl Table | Deltek Advantage 9.0 Database

CFGPCControlPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ProfCtr |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGPCControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPCMain Table

Description

Profit Center Setup Table - Profit Center Reporting

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
 | ProfCtrLabel | Label to use for the profit center field throughout the database. | VarChar | 16 |
 | DefaultPctr | Default profit center. | VarChar | 8 |
 | BalanceSheet | Variable indicating whether you want to maintain separate balance sheets for each profit center combination. | Boolean | 1 |
 | Label1 | Label for the first level of the profit center. | VarChar | 16 |
 | Label2 | Label for the second level of the profit center. | VarChar | 16 |
 | Label3 | Label for the third level of the profit center. | VarChar | 16 |
 | Label4 | Label for the fourth level of the profit center. | VarChar | 16 |
 | PayrollDefPctr | Default profit center to use for the payroll liability. | VarChar | 8 |
 | LabDist | Variable indicating whether you want to split the labor distribution credit by profit center. | Boolean | 1 |
 | EmplExp | Variable indicating whether you want to split the employee expense credit by profit center. | Boolean | 1 |
 | Prints | Variable indicating whether you want to split the prints/reproduction expense credits by profit center. | Boolean | 1 |
 | Cons | Variable indicating whether you want to split the consultant expense credits by profit center. | Boolean | 1 |
 | Misc | Variable indicating whether you want to split the miscellaneous credits by profit center. | Boolean | 1 |
 | Units | Variable indicating whether you want to split the unit distribution credit by profit center. | Boolean | 1 |
 | Payroll | Variable indicating whether you want to split the payroll liability credit by profit center. | Boolean | 1 |
 | FICA | Variable indicating whether you want to split the FICA expense debit by profit center. | Boolean | 1 |
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |

Indexes

Index | Description | Primary | Unique
CFGPCMainPK |  |  |

SQL

CREATE TABLE [CFGPCMain] (
    [ProfCtrLabel] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DefaultPctr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BalanceSheet] [bit] NOT NULL CONSTRAINT [DF__CFGPCMain__Balan__16CE6296] DEFAULT (0),
    [Label1] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Label2] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Label3] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Label4] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayrollDefPctr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LabDist] [bit] NOT NULL CONSTRAINT [DF__CFGPCMain__LabDi__17C286CF] DEFAULT (0),
    [EmplExp] [bit] NOT NULL CONSTRAINT [DF__CFGPCMain__EmplE__18B6AB08] DEFAULT (0),
    [Prints] [bit] NOT NULL CONSTRAINT [DF__CFGPCMain__Print__19AACF41] DEFAULT (0),
    [Cons] [bit] NOT NULL CONSTRAINT [DF__CFGPCMain__Cons__1A9EF37A] DEFAULT (0),
    [Misc] [bit] NOT NULL CONSTRAINT [DF__CFGPCMain__Misc__1B9317B3] DEFAULT (0),
    [Units] [bit] NOT NULL CONSTRAINT [DF__CFGPCMain__Units__1C873BEC] DEFAULT (0),
    [Payroll] [bit] NOT NULL CONSTRAINT [DF__CFGPCMain__Payro__1D7B6025] DEFAULT (0),
    [FICA] [bit] NOT NULL CONSTRAINT [DF__CFGPCMain__FICA__1E6F845E] DEFAULT (0),
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    CONSTRAINT [CFGPCMainPK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPCMain Table | Deltek Advantage 9.0 Database

CFGPCMainPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

CFGPCMain Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPostControl Table

Description

System Setup Table - Posting Control Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 2
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Period | Required. Fiscal year and period in which the posting occurred. | Integer | 4 |
Primary Key | PostSeq | Required. Posting sequence number. | SmallInt | 2 |
 | UserName | Name of the user who posted the data entry transaction file. | VarChar | 15 |
 | PostDate | Date on which the posting took place. | DBTimeStamp | 4 |
 | TransType | Transaction type. | VarChar | 2 |
 | Completed | Variable indicating whether the posting finished successfully. | Boolean | 1 |
 | Canceled | Variable indicating whether the user cancelled the posting run before it completed. | Boolean | 1 |
 | PostComment | Comment. | VarChar | 255 |
 | RecordCount | Number of transactions/ records posted during the posting run. | SmallInt | 2 |
 | StartDate | Start date specified for all data entry transaction files. | DBTimeStamp | 4 |
 | EndDate | End date specified for all data entry transaction files. | DBTimeStamp | 4 |
 | PaymentDate | Payment date specified for accounts payable transaction files. | DBTimeStamp | 4 |
 | CheckDate | Check date specified for accounts payable vouchers and payment processing files. | DBTimeStamp | 4 |
 | W2Year | Payroll W-2 year in which the posting run was completed. | SmallInt | 2 |
 | W2Quarter | Payroll W-2 quarter in which the posting run was completed. | SmallInt | 2 |
 | BenefitAccrualYear | Payroll accrual year in which the posting run was completed. | SmallInt | 2 |
 | PayrollRunType | Variable indicating the payroll run type. Valid options are R - Regular; A - Adjustments; and B - Bonuses. | VarChar | 1 |
 | QueueName | Process server queue, if any, through which the process was run. | VarChar | 40 |
 | ADPExportStatus | Variable indicating whether data has been exported to ADP. If no posting has been made, this field is blank. Valid options are Y - Exported and I - Incomplete. | VarChar | 1 |
 | XChargeStatus | Cross charge status for the data entry file. Valid options are Null - Not cross charged; Y - Cross charged; and I - Incomplete. | VarChar | 1 |
 | Batch | Batch name for the data entry file. | VarChar | 15 |
 | ASJCStatus | Status of the adjust salary job costing posting. | VarChar | 1 |
 | EFTStatus | Status of electronic fund processing. | VarChar | 1 |
 | Removed | Variable indicating whether the data entry transaction file has been unposted. | VarChar | 1 |

Indexes

Index | Description | Primary | Unique
CFGPostControlPK |  |  |

SQL

CREATE TABLE [CFGPostControl] (
    [Period] [int] NOT NULL ,
    [PostSeq] [smallint] NOT NULL ,
    [UserName] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostDate] [datetime] NULL ,
    [TransType] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Completed] [bit] NOT NULL CONSTRAINT [DF__CFGPostCo__Compl__03A67F89] DEFAULT (0),
    [Canceled] [bit] NOT NULL CONSTRAINT [DF__CFGPostCo__Cance__049AA3C2] DEFAULT (0),
    [PostComment] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecordCount] [smallint] NULL ,
    [StartDate] [datetime] NULL ,
    [EndDate] [datetime] NULL ,
    [PaymentDate] [datetime] NULL ,
    [CheckDate] [datetime] NULL ,
    [W2Year] [smallint] NULL ,
    [W2Quarter] [smallint] NULL ,
    [BenefitAccrualYear] [smallint] NULL ,
    [PayrollRunType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [QueueName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ADPExportStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [XChargeStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ASJCStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EFTStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Removed] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__CFGPostCo__Remov__058EC7FB] DEFAULT ('N'),
    CONSTRAINT [CFGPostControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Period],
        [PostSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPostControl Table | Deltek Advantage 9.0 Database

CFGPostControlPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Period |  | Ascending
Primary Key | PostSeq |  | Ascending

Index Statistics

Average key length | 6.0
Density | 0
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Wednesday, May 03, 2006 12:15

See Also

CFGPostControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGProcessQueue Table

Description

System Setup Table - Process Server Queue

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | QueueID | Required. Unique queue ID. | VarChar | 10 |
 | QueueName | Name of the queue. | VarChar | 40 |
 | QueueStatus | Variable indicating the current status of the queue. Valid options are 0 - Stopped; 1 - Paused; and 2 - Running. | SmallInt | 2 |
 | CurrentServerName | Name of the workstation, if any, currently serving the queue. | VarChar | 15 |
 | PollingFrequency | Number of seconds to wait between polls for processes in the queue. | Integer | 4 |
 | RetainHistory | Variable indicating whether process history should be retained for the queue. | Boolean | 1 |
 | DaysToRetainHistory | Number of days to retain process history for the queue (0=forever). | SmallInt | 2 |
 | RequirePrinter | Require specific printer to be selected when submitting jobs to this queue. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGProcessQueuePK |  |  |

SQL

CREATE TABLE [CFGProcessQueue] (
    [QueueID] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [QueueName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [QueueStatus] [smallint] NULL ,
    [CurrentServerName] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PollingFrequency] [int] NULL ,
    [RetainHistory] [bit] NOT NULL CONSTRAINT [DF__CFGProces__Retai__2334397B] DEFAULT (0),
    [DaysToRetainHistory] [smallint] NULL ,
    [RequirePrinter] [bit] NOT NULL CONSTRAINT [DF__CFGProces__Requi__24285DB4] DEFAULT (0),
    CONSTRAINT [CFGProcessQueuePK] PRIMARY KEY NONCLUSTERED
    (
        [QueueID]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGProcessQueue Table | Deltek Advantage 9.0 Database

CFGProcessQueuePK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | QueueID |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGProcessQueue Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGProcessQueueStatus Table

Description

System Setup Table - Process Server Queue Status

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 3
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Status | Required. Process queue status code. | SmallInt | 2 |
 | Label | Description of the process queue status code. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
CFGProcessQueueStatusPK |  |  |

SQL

CREATE TABLE [CFGProcessQueueStatus] (
    [Status] [smallint] NOT NULL ,
    [Label] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGProcessQueueStatusPK] PRIMARY KEY NONCLUSTERED
    (
        [Status]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGProcessQueueStatus Table | Deltek Advantage 9.0 Database

CFGProcessQueueStatusPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Status |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 3
Rows Sampled | 3
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:02

See Also

CFGProcessQueueStatus Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGProcessStatus Table

Description

System Setup Table - Process Server Status

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 6
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Status | Required. Status code. | SmallInt | 2 |
 | Label | Description of the status code. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
CFGProcessStatusPK |  |  |

SQL

CREATE TABLE [CFGProcessStatus] (
    [Status] [smallint] NOT NULL ,
    [Label] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGProcessStatusPK] PRIMARY KEY NONCLUSTERED
    (
        [Status]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGProcessStatus Table | Deltek Advantage 9.0 Database

CFGProcessStatusPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Status |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 6
Rows Sampled | 6
Distribution Steps | 4
Updated | Monday, January 26, 2004 15:02

See Also

CFGProcessStatus Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGProjectStatus Table

Description

System Setup Table - Project Status

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 4
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Status | Required. Variable indicating the project status. Valid options are A - Active; I - Inactive; D - Dormant; and C - Closeout. | VarChar | 1 |
 | Label | Description of the status code. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
CFGProjectStatusPK |  |  |

SQL

CREATE TABLE [CFGProjectStatus] (
    [Status] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGProjectStatusPK] PRIMARY KEY NONCLUSTERED
    (
        [Status]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGProjectStatus Table | Deltek Advantage 9.0 Database

CFGProjectStatusPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Status |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 4
Rows Sampled | 4
Distribution Steps | 3
Updated | Monday, January 26, 2004 15:02

See Also

CFGProjectStatus Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGProjectType Table

Description

System Setup Table - Project Types

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 3
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Type | Required. Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | Label | Description of the project type. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
CFGProjectTypePK |  |  |

SQL

CREATE TABLE [CFGProjectType] (
    [Type] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGProjectTypePK] PRIMARY KEY NONCLUSTERED
    (
        [Type]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGProjectType Table | Deltek Advantage 9.0 Database

CFGProjectTypePK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Type |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 3
Rows Sampled | 3
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:02

See Also

CFGProjectType Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPRSortSelect Table

Description

System Setup Table - Project Sort/Select Field Configuration

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 30
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SortNo | Required. Primary key corresponding to sort/select field number. | SmallInt | 2 |
 | DataType | Variable indicating the type of data to be input for the sort/select field. Valid options are 1 - Text; 2 - Numeric; and 3 - Date. | SmallInt | 2 |
 | Label | User label for the sort/select field. | VarChar | 20 |
 | InUse | Variable indicating whether the sort/select category is being used. | Boolean | 1 |
 | Required | Variable indicating whether this is a required field in Project Table Maintenance. | Boolean | 1 |
 | LimitToList | Variable indicating whether this entry is limited to system setup values (for text data types only). | Boolean | 1 |
 | Uppercase | Variable indicating whether entered values should be converted to all uppercase (for text data types only). | Boolean | 1 |
 | Digits | Maximum number of digits allowed (for numeric data types only). | SmallInt | 2 |
 | Decimals | Maximum number of decimals allowed (for numeric data types only). | SmallInt | 2 |
 | MaxValue | Maximum numeric value allowed (for numeric data types only). | Double | 9 |
 | MinValue | Minimum numeric value allowed (for numeric data types only). | Double | 9 |
 | NullTaskSignificant | Variable indicating whether this value is significant at the project level for a project with tasks (for numeric data types only). | Boolean | 1 |
 | AggregateFlag | Variable indicating whether the numeric gets aggregated during a closeout (applicable for numeric data types only). | Boolean | 1 |
 | MaxDate | Maximum date allowed (applicable for date data types only). | DBTimeStamp | 4 |
 | MinDate | Minimum date allowed (applicable for date data types only). | DBTimeStamp | 4 |
 | HelpMessage | User defined help message to be displayed in the status bar text. | VarChar | 100 |
 | Flag254 | Variable indicating whether the sort/select field is being used for 254 data. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGPRSortSelectPK |  |  |

SQL

CREATE TABLE [CFGPRSortSelect] (
    [SortNo] [smallint] NOT NULL ,
    [DataType] [smallint] NULL ,
    [Label] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InUse] [bit] NOT NULL CONSTRAINT [DF__CFGPRSort__InUse__29E1370A] DEFAULT (0),
    [Required] [bit] NOT NULL CONSTRAINT [DF__CFGPRSort__Requi__2AD55B43] DEFAULT (0),
    [LimitToList] [bit] NOT NULL CONSTRAINT [DF__CFGPRSort__Limit__2BC97F7C] DEFAULT (0),
    [Uppercase] [bit] NOT NULL CONSTRAINT [DF__CFGPRSort__Upper__2CBDA3B5] DEFAULT (0),
    [Digits] [smallint] NULL ,
    [Decimals] [smallint] NULL ,
    [MaxValue] [float] NULL ,
    [MinValue] [float] NULL ,
    [NullTaskSignificant] [bit] NOT NULL CONSTRAINT [DF__CFGPRSort__NullT__2DB1C7EE] DEFAULT (0),
    [AggregateFlag] [bit] NOT NULL CONSTRAINT [DF__CFGPRSort__Aggre__2EA5EC27] DEFAULT (0),
    [MaxDate] [datetime] NULL ,
    [MinDate] [datetime] NULL ,
    [HelpMessage] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Flag254] [bit] NOT NULL CONSTRAINT [DF__CFGPRSort__Flag2__2F9A1060] DEFAULT (0),
    CONSTRAINT [CFGPRSortSelectPK] PRIMARY KEY NONCLUSTERED
    (
        [SortNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPRSortSelect Table | Deltek Advantage 9.0 Database

CFGPRSortSelectPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SortNo |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 30
Rows Sampled | 30
Distribution Steps | 16
Updated | Monday, January 26, 2004 15:02

See Also

CFGPRSortSelect Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPWPInterface Table

Description

Project Workplace Interface Setup Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |
 | Server | The name of the server on which the Project Workplace database resides. | VarChar | 30 |
 | pwpDataBase | The name of the Project Workplace database. | VarChar | 30 |
 | UserName | The user name for the Project Workplace database. | VarChar | 30 |
 | Password | The password for the Project Workplace database. | VarChar | 30 |
 | diffServer | Is the Project Workplace database on a different server than Advantage. | SmallInt | 2 |
 | LastImport | The date and time of the last import. | DBTimeStamp | 4 |
 | TaskImport | Reserved for future use. | SmallInt | 2 |
 | FutureUse | Reserved for future use. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
CFGPWPInterfacePK |  |  |

SQL

CREATE TABLE [CFGPWPInterface] (
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Server] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [pwpDataBase] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UserName] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Password] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [diffServer] [smallint] NULL ,
    [LastImport] [datetime] NULL ,
    [TaskImport] [smallint] NULL ,
    [FutureUse] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGPWPInterfacePK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPWPInterface Table | Deltek Advantage 9.0 Database

CFGPWPInterfacePK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

CFGPWPInterface Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPYAccruals Table

Description

Payroll Setup Table - Accrual Codes

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 2
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Accrual plan code. | VarChar | 10 |
 | Description | Description of the accrual plan code. | VarChar | 40 |
 | HasCarryoverLimit | Variable indicating whether the accrual code has a limit of hours that can be carried over into a new accrual year. | Boolean | 1 |
 | CarryoverLimit | Limit on the hours that can be carried over into a new accrual year. | Double | 9 |
 | Maximum | Maximum hours allowed to accrue for the accrual code. | Double | 9 |
 | PreAccrue | Variable indicating whether you want to accrue the annual amount at the point of initialization. | Boolean | 1 |
 | PrintOnCheck | Variable indicating whether you want to print the accrual on the employee’s checks. | Boolean | 1 |
 | ShowOnTK | Display the benefit accrual in Web Timekeeper. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGPYAccrualsPK |  |  |

SQL

CREATE TABLE [CFGPYAccruals] (
    [Code] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [HasCarryoverLimit] [bit] NOT NULL CONSTRAINT [DF__CFGPYAccr__HasCa__7DEDA633] DEFAULT (0),
    [CarryoverLimit] [float] NULL ,
    [Maximum] [float] NULL ,
    [PreAccrue] [bit] NOT NULL CONSTRAINT [DF__CFGPYAccr__PreAc__7EE1CA6C] DEFAULT (0),
    [PrintOnCheck] [bit] NOT NULL CONSTRAINT [DF__CFGPYAccr__Print__7FD5EEA5] DEFAULT (0),
    [ShowOnTK] [bit] NOT NULL CONSTRAINT [DF__CFGPYAccr__ShowO__00CA12DE] DEFAULT (0),
    CONSTRAINT [CFGPYAccrualsPK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPYAccruals Table | Deltek Advantage 9.0 Database

CFGPYAccrualsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length | 8.0
Density | 1
Rows in the Table | 2
Rows Sampled | 2
Distribution Steps | 2
Updated | Wednesday, May 03, 2006 12:15

See Also

CFGPYAccruals Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPYFormW2 Table

Description

Payroll Setup Table - W-2 Forms

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
 | FederalEIN | Federal tax identification number. | VarChar | 9 |
 | EmployerAddress1 | First line of the employer’s address. | VarChar | 40 |
 | EmployerAddress2 | Second line of the employer’s address. | VarChar | 40 |
 | EmployerCity | Employer’s city. | VarChar | 18 |
 | EmployerState | Employer’s state. | VarChar | 2 |
 | EmployerZIPCode | Employer’s zip code. | VarChar | 10 |
 | SocialSecurityWageBase | Social security wage base for the current W-2 reporting year. | Double | 9 |
 | SocialSecurityPct | Social security percentage for the current W-2 reporting year (employee portion). | Double | 9 |
 | MedicarePct | Medicare percentage for the current W-2 reporting year (employee portion). | Double | 9 |
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |

Indexes

Index | Description | Primary | Unique
CFGPYFormW2PK |  |  |

SQL

CREATE TABLE [CFGPYFormW2] (
    [FederalEIN] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployerAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployerAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployerCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployerState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployerZIPCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SocialSecurityWageBase] [float] NULL ,
    [SocialSecurityPct] [float] NULL ,
    [MedicarePct] [float] NULL ,
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    CONSTRAINT [CFGPYFormW2PK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPYFormW2 Table | Deltek Advantage 9.0 Database

CFGPYFormW2PK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

CFGPYFormW2 Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPYMain Table

Description

Payroll Setup Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |
 | CurrentW2Year | Current payroll W-2 year. | SmallInt | 2 |
 | CurrentW2Quarter | Current payroll W-2 quarter. | SmallInt | 2 |
 | PayrollPostToBank | Variable indicating whether you want to post payroll directly to the bank rather than to a credit account. | Boolean | 1 |
 | PayrollBankCode | Payroll bank code to use when posting payroll directly to the bank. | VarChar | 10 |
 | PayrollCreditAccount | Salaries payable credit account for payroll postings. | VarChar | 10 |
 | PayrollFrequency | Variable indicating the payroll frequency. Valid options are M - Monthly; S - Semi-Monthly; B - Bi-Weekly; and W - Weekly. | VarChar | 1 |
 | FICAProject | Corporate FICA expense project. | VarChar | 12 |
 | FICATask | Corporate FICA expense task. | VarChar | 5 |
 | FICAAccount | Corporate FICA expense account. | VarChar | 10 |
 | DirectDepositBonusAdj | Variable indicating whether you want to utilize direct deposit for bonuses and adjustments. | Boolean | 1 |
 | AllowPayrollHistory | Variable indicating whether you want to allow changes to employee payroll history. | Boolean | 1 |
 | BonusCostProject | Project for regular bonus amounts. | VarChar | 12 |
 | BonusCostTask | Task for regular bonus amounts. | VarChar | 5 |
 | BonusCostAccount | Debit cost account for regular bonus amounts. | VarChar | 10 |
 | OtherPayCostProject | Project for all other pay amounts. | VarChar | 12 |
 | OtherPayCostTask | Task for all other pay amounts. | VarChar | 5 |
 | OtherPayCostAccount | Account for all other pay amounts. | VarChar | 10 |
 | PrintVoidChecks | Variable indicating whether you want to print voided checks for employees whose check amounts equal zero. | Boolean | 1 |
 | ImmediateDestination | Identification number of the bank to which the file will be sent. | VarChar | 9 |
 | ImmediateDestinationName | Name of the bank to which the file will be sent. | VarChar | 23 |
 | ImmediateOrigin | Company identification number assigned by the bank. | VarChar | 9 |
 | ImmediateOriginName | Name of the company. | VarChar | 23 |
 | CompanyName | Company name as it will appear on statements. | VarChar | 16 |
 | FederalEIN | Federal EIN (Employer Identification Number). | VarChar | 9 |
 | RoutingNumber | Routing transit number of the immediate destination. | VarChar | 8 |
 | EntryDescriptionPY | Description of the purpose of the entry (for example, Payroll or Reg Salary). | VarChar | 10 |
 | PYCheckTemplate | Report template name to use for employee payroll checks. | VarChar | 40 |
 | FileFormat | The type of information in the file for direct deposit. Valid options are 1 - Credit only and 2 - Debit and Credit. | SmallInt | 2 |
 | ICD | Identification Code Designator. Valid options are 1 - IRS Employer ID Number (EIN); 3 - Data Universal Numbering Systems (DUNS); and 9 - User-assigned number. | VarChar | 1 |
 | Byte4Char | Specifies the first character in the file header record’s space for immediate destination. | VarChar | 1 |
 | FilePadding | Controls whether the total record count is forced to a multiple of ten. | Boolean | 1 |
 | SeparateBatches | Indicates whether there are separate batches for credit and debit entries. | Boolean | 1 |
 | FileNamePY | Filename and path for the payroll direct deposit file. | VarChar | 100 |
 | AccountNumber | Account number at the source bank. | VarChar | 17 |
 | AccountType | Indicates whether the source account is a checking or savings account. | VarChar | 1 |
 | SuppressSSN | Suppressing (hiding) the social security number on the Payroll Journal and Employee List reports. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGPYMainPK |  |  |

SQL

CREATE TABLE [CFGPYMain] (
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [CurrentW2Year] [smallint] NULL ,
    [CurrentW2Quarter] [smallint] NULL ,
    [PayrollPostToBank] [bit] NOT NULL CONSTRAINT [DF__CFGPYMain__Payro__0A537D18] DEFAULT (0),
    [PayrollBankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayrollCreditAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayrollFrequency] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FICAProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FICATask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FICAAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DirectDepositBonusAdj] [bit] NOT NULL CONSTRAINT [DF__CFGPYMain__Direc__0B47A151] DEFAULT (0),
    [AllowPayrollHistory] [bit] NOT NULL CONSTRAINT [DF__CFGPYMain__Allow__0C3BC58A] DEFAULT (0),
    [BonusCostProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BonusCostTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BonusCostAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OtherPayCostProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OtherPayCostTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OtherPayCostAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintVoidChecks] [bit] NOT NULL CONSTRAINT [DF__CFGPYMain__Print__0D2FE9C3] DEFAULT (0),
    [ImmediateDestination] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ImmediateDestinationName] [varchar] (23) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ImmediateOrigin] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ImmediateOriginName] [varchar] (23) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CompanyName] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FederalEIN] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RoutingNumber] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EntryDescriptionPY] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PYCheckTemplate] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FileFormat] [smallint] NULL ,
    [ICD] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Byte4Char] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FilePadding] [bit] NOT NULL CONSTRAINT [DF__CFGPYMain__FileP__0E240DFC] DEFAULT (0),
    [SeparateBatches] [bit] NOT NULL CONSTRAINT [DF__CFGPYMain__Separ__0F183235] DEFAULT (0),
    [FileNamePY] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountNumber] [varchar] (17) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SuppressSSN] [bit] NOT NULL CONSTRAINT [DF__CFGPYMain__Suppr__100C566E] DEFAULT (0),
    CONSTRAINT [CFGPYMainPK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPYMain Table | Deltek Advantage 9.0 Database

CFGPYMainPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 3.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Wednesday, May 03, 2006 12:15

See Also

CFGPYMain Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPYStateID Table

Description

Payroll Setup Table - State Identification Numbers

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | State | Required. Postal abbreviation for the state. | VarChar | 2 |
 | StateIDNo | Employer’s state identification number. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
CFGPYStateIDPK |  |  |

SQL

CREATE TABLE [CFGPYStateID] (
    [State] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [StateIDNo] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGPYStateIDPK] PRIMARY KEY NONCLUSTERED
    (
        [State]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPYStateID Table | Deltek Advantage 9.0 Database

CFGPYStateIDPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | State |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGPYStateID Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPYWHCodes Table

Description

Payroll Setup Table - Withholding Codes

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 3
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Withholding code. | VarChar | 10 |
 | Description | Withholding description. | VarChar | 40 |
 | Account | Withholding credit account. | VarChar | 10 |
 | DefaultWH | Variable indicating whether you want to automatically set up the withholding for new employees. | Boolean | 1 |
 | Suppress | Variable indicating whether you want to suppress the withholding and the associated amounts. | Boolean | 1 |
 | Type | Withholding type. | VarChar | 1 |
 | Locale | Locale to be used in the tax table calculation for the withholding. | VarChar | 2 |
 | Method | Variable indicating the withholding calculation method. Valid options are A - Amount; P - Percentage; S - System-wide; and N - None. | VarChar | 1 |
 | AmtPct | Amount or percent to withhold, based on the method. | Double | 9 |
 | Exclude401k | Variable indicating whether you want to exclude the 401(k) withholdings from wages. | Boolean | 1 |
 | ExcludeCafeteria | Variable indicating whether you want to exclude the 125/Cafeteria withholdings from wages. | Boolean | 1 |
 | PrintOnW2 | Variable indicating whether you want to print the breakout of the withholding on W-2 forms. | Boolean | 1 |
 | WageBase | Maximum wages that are subject to a withholding. | Double | 9 |
 | W2LimitReset | Variable indicating whether you want to restart withholding against any limit at the beginning of a new W-2 year. | Boolean | 1 |
 | BonusAutoZero | Variable indicating whether you want to automatically default withholding amounts to zero for bonus runs. | Boolean | 1 |
 | PrintOnCheck | Variable indicating whether you want to print this withholding on paychecks. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGPYWHCodesPK |  |  |

SQL

CREATE TABLE [CFGPYWHCodes] (
    [Code] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DefaultWH] [bit] NOT NULL CONSTRAINT [DF__CFGPYWHCo__Defau__3EDC53F0] DEFAULT (0),
    [Suppress] [bit] NOT NULL CONSTRAINT [DF__CFGPYWHCo__Suppr__3FD07829] DEFAULT (0),
    [Type] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Locale] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Method] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AmtPct] [float] NULL ,
    [Exclude401k] [bit] NOT NULL CONSTRAINT [DF__CFGPYWHCo__Exclu__40C49C62] DEFAULT (0),
    [ExcludeCafeteria] [bit] NOT NULL CONSTRAINT [DF__CFGPYWHCo__Exclu__41B8C09B] DEFAULT (0),
    [PrintOnW2] [bit] NOT NULL CONSTRAINT [DF__CFGPYWHCo__Print__42ACE4D4] DEFAULT (0),
    [WageBase] [float] NULL ,
    [W2LimitReset] [bit] NOT NULL CONSTRAINT [DF__CFGPYWHCo__W2Lim__43A1090D] DEFAULT (0),
    [BonusAutoZero] [bit] NOT NULL CONSTRAINT [DF__CFGPYWHCo__Bonus__44952D46] DEFAULT (0),
    [PrintOnCheck] [bit] NOT NULL CONSTRAINT [DF__CFGPYWHCo__Print__4589517F] DEFAULT (0),
    CONSTRAINT [CFGPYWHCodesPK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPYWHCodes Table | Deltek Advantage 9.0 Database

CFGPYWHCodesPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 3
Rows Sampled | 3
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:02

See Also

CFGPYWHCodes Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPYWHMethod Table

Description

Payroll Setup Table - Withholding Methods

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 4
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Method | Required. Variable indicating the withholding calculation method. Valid options are A - Amount; P - Percentage; S - System-Wide; and N - None. | VarChar | 1 |
 | Label | Description associated with the method. | VarChar | 10 |
 | Seq | Sequence for ordering the withholding methods in lookups. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
CFGPYWHMethodPK |  |  |

SQL

CREATE TABLE [CFGPYWHMethod] (
    [Method] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Seq] [smallint] NULL ,
    CONSTRAINT [CFGPYWHMethodPK] PRIMARY KEY NONCLUSTERED
    (
        [Method]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPYWHMethod Table | Deltek Advantage 9.0 Database

CFGPYWHMethodPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Method |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 4
Rows Sampled | 4
Distribution Steps | 3
Updated | Monday, January 26, 2004 15:02

See Also

CFGPYWHMethod Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGPYWHType Table

Description

Payroll Setup Table - Withholding Types

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 8
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Type | Required. Withholding type. | VarChar | 1 |
 | Label | Description of the withholding type. | VarChar | 10 |
 | Seq | Sequence for ordering the withholding types in lookups. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
CFGPYWHTypePK |  |  |

SQL

CREATE TABLE [CFGPYWHType] (
    [Type] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Seq] [smallint] NULL ,
    CONSTRAINT [CFGPYWHTypePK] PRIMARY KEY NONCLUSTERED
    (
        [Type]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGPYWHType Table | Deltek Advantage 9.0 Database

CFGPYWHTypePK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Type |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 8
Rows Sampled | 8
Distribution Steps | 5
Updated | Monday, January 26, 2004 15:02

See Also

CFGPYWHType Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGReportOptions Table

Description

System Setup Table - Saved Report Options

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 24 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Username | Required. Advantage user name. | VarChar | 20 |
Primary Key | FormName | Required. Name of options form for reports. | VarChar | 64 |
Primary Key | OptionDesc | Required. Not used at this time. All records now appear with a value of Default. | VarChar | 40 |
 | OptionString | “Control name=Value” separated by ^ for all controls on the report options form. | LongVarChar | 16 |
 | DefaultOptions | Variable indicating whether the user is applying the default options to the report. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGReportOptionsPK |  |  |

SQL

CREATE TABLE [CFGReportOptions] (
    [Username] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [FormName] [varchar] (64) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [OptionDesc] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [OptionString] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DefaultOptions] [bit] NOT NULL CONSTRAINT [DF__CFGReport__Defau__4959E263] DEFAULT (0),
    CONSTRAINT [CFGReportOptionsPK] PRIMARY KEY NONCLUSTERED
    (
        [Username],
        [FormName],
        [OptionDesc]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGReportOptions Table | Deltek Advantage 9.0 Database

CFGReportOptionsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Username |  | Ascending
Primary Key | FormName |  | Ascending
Primary Key | OptionDesc |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGReportOptions Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGRGFormulas Table

Description

Revenue Generation Setup Table - Formulas

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 17
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Method | Required. Code for the revenue method. | VarChar | 1 |
Primary Key | Seq | Required. System-assigned number for sorting the fields in lookups and lists. | SmallInt | 2 |
 | RevGenField | Available fields/operators to create a custom revenue method. | VarChar | 15 |

Indexes

Index | Description | Primary | Unique
CFGRGFormulasPK |  |  |

SQL

CREATE TABLE [CFGRGFormulas] (
    [Method] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [smallint] NOT NULL ,
    [RevGenField] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGRGFormulasPK] PRIMARY KEY NONCLUSTERED
    (
        [Method],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGRGFormulas Table | Deltek Advantage 9.0 Database

CFGRGFormulasPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Method |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 17
Rows Sampled | 17
Distribution Steps | 9
Updated | Monday, January 26, 2004 15:02

See Also

CFGRGFormulas Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGRGMethods Table

Description

Revenue Generation Setup Table - Methods

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 6
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Method | Required. Revenue method. | VarChar | 1 |
 | Description | Revenue method description. | VarChar | 30 |

Indexes

Index | Description | Primary | Unique
CFGRGMethodsPK |  |  |

SQL

CREATE TABLE [CFGRGMethods] (
    [Method] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Description] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGRGMethodsPK] PRIMARY KEY NONCLUSTERED
    (
        [Method]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGRGMethods Table | Deltek Advantage 9.0 Database

CFGRGMethodsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Method |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 6
Rows Sampled | 6
Distribution Steps | 4
Updated | Monday, January 26, 2004 15:02

See Also

CFGRGMethods Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGTimeAnalysis Table

Description

Time Analysis Setup Table - Report

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | StartProject | Required. Starting project number that identifies this category. | VarChar | 12 |
Primary Key | EndProject | Ending project number that identifies this category. | VarChar | 12 |
 | Account | Account number. | VarChar | 10 |
 | ReportColumn | Column on the Time Analysis report for this project. | SmallInt | 2 |
 | AccrualCode | Benefit accrual code for this project (for example, Vacation or Sick). | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
CFGTimeAnalysisPK |  |  |

SQL

CREATE TABLE [CFGTimeAnalysis] (
    [StartProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [EndProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ReportColumn] [smallint] NULL ,
    [AccrualCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGTimeAnalysisPK] PRIMARY KEY NONCLUSTERED
    (
        [StartProject],
        [EndProject]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGTimeAnalysis Table | Deltek Advantage 9.0 Database

CFGTimeAnalysisPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | StartProject |  | Ascending
Primary Key | EndProject |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGTimeAnalysis Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGTimeAnalysisHeadings Table

Description

Time Analysis Setup Table - Headings

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 8
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ReportColumn | Required. Report column to which the heading applies. | SmallInt | 2 |
 | Label | Heading to appear on the Time Analysis report. | VarChar | 12 |
 | Benefit | Variable indicating whether the report column should be treated as benefit time for ratio “C”. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGTimeAnalysisHeadingsPK |  |  |

SQL

CREATE TABLE [CFGTimeAnalysisHeadings] (
    [ReportColumn] [smallint] NOT NULL ,
    [Label] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Benefit] [bit] NOT NULL CONSTRAINT [DF__CFGTimeAn__Benef__4E1E9780] DEFAULT (0),
    CONSTRAINT [CFGTimeAnalysisHeadingsPK] PRIMARY KEY NONCLUSTERED
    (
        [ReportColumn]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGTimeAnalysisHeadings Table | Deltek Advantage 9.0 Database

See Also Deltek Advantage 9.0 Database Send comments on this topic.

CFGTimeAnalysisHeadingsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ReportColumn |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 8
Rows Sampled | 8
Distribution Steps | 5
Updated | Monday, January 26, 2004 15:02

See Also

CFGTimeAnalysisHeadings Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGTKCategory Table

Description

Timekeeper Setup Table - Categories

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TKGroup | Required. Timekeeper group category. | VarChar | 2 |
Primary Key | Category | Required. Timekeeper category code (for example, Vacation or Sick). | VarChar | 6 |
 | SortSeq | Sequence for ordering the withholding methods in lookups. | SmallInt | 2 |
 | Description | Description of the category displayed on the timesheet. | VarChar | 12 |
 | Project | Project number. | VarChar | 12 |
 | Task | Task number. | VarChar | 5 |
 | LaborCode | Labor code. | VarChar | 5 |
 | ProjectQuery | Query that returns the selected project(s). | VarChar | 255 |
 | TaskQuery | Query that returns the selected task(s). | VarChar | 255 |
 | LaborCodeQuery | Query that returns the selected labor code(s). | VarChar | 255 |

Indexes

Index | Description | Primary | Unique
CFGTKCategoryPK |  |  |

SQL

CREATE TABLE [CFGTKCategory] (
    [TKGroup] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Category] [varchar] (6) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SortSeq] [smallint] NULL ,
    [Description] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LaborCode] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjectQuery] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskQuery] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LaborCodeQuery] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGTKCategoryPK] PRIMARY KEY NONCLUSTERED
    (
        [TKGroup],
        [Category]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGTKCategory Table | Deltek Advantage 9.0 Database

CFGTKCategoryPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TKGroup |  | Ascending
Primary Key | Category |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGTKCategory Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGTKEmployeeGroup Table

Description

Timekeeper Setup Table - Employee Groups

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | EmployeeGroup | Required. Timekeeper group. | VarChar | 2 |
 | Description | Group description. | VarChar | 20 |

Indexes

Index | Description | Primary | Unique
CFGTKEmployeeGroupPK |  |  |

SQL

CREATE TABLE [CFGTKEmployeeGroup] (
    [EmployeeGroup] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Description] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGTKEmployeeGroupPK] PRIMARY KEY NONCLUSTERED
    (
        [EmployeeGroup]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGTKEmployeeGroup Table | Deltek Advantage 9.0 Database

CFGTKEmployeeGroupPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | EmployeeGroup |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CFGTKEmployeeGroup Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGTKMain Table

Description

Timekeeper Setup Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | AdvKey | Required. Primary key for table entries. | VarChar | 3 |
 | RequirePasswords | Variable indicating whether Timekeeper requires passwords. | Boolean | 1 |
 | AllowTKResubmit | Variable indicating whether users may resubmit their timesheets. | Boolean | 1 |
 | AllowEKResubmit | Variable indicating whether users may resubmit their expense reports. | Boolean | 1 |
 | AmountPerMile | Default amount for mileage reimbursement. | Double | 9 |
 | AllowCompanyPaid | Variable indicating whether to allow company paid amount on expense reports. | Boolean | 1 |
 | AllowAdvances | Variable indicating whether to allow employees to apply advances to expense reports. | Boolean | 1 |
 | DistanceType | Variable indicating how distance is measured. Valid options are M - Mileage and K - Kilometers. | VarChar | 1 |
 | CategoriesRequired | Variable indicating whether categories are required for Expensekeeper. | Boolean | 1 |
 | CheckHours | Variable indicating whether the system should check the hours entered against the expected hours prior to submitting the timesheet. | VarChar | 1 |
 | CheckLaborCodes | Variable indicating whether the system should check labor codes against budgeted labor codes. | VarChar | 1 |
 | CompanyPaidProject | Project for posting company paid line items. | VarChar | 12 |
 | CompanyPaidTask | Task for posting company paid line items. | VarChar | 5 |
 | CompanyPaidAccount | Account for posting company paid line items. | VarChar | 10 |
 | DisableOvertime | Variable indicating whether the entry and printing of overtime hours in Timekeeper has been disabled. | Boolean | 1 |
 | DisableTKLogin | Variable indicating whether to disable all user logins for Timekeeper and Timekeeper Administration. | Boolean | 1 |
 | DisableEKLogin | Variable indicating whether to disable all user logins for Expensekeeper and Expensekeeper Administration. | Boolean | 1 |
 | ApprovalRequired | Indicates whether approval of timesheets is required. | Boolean | 1 |
 | ElectronicSignature | Indicates whether an employee's password is required when submitting timesheets. | Boolean | 1 |
 | AllowSubmitterToApprove | Indicates whether to allow an employee who has submitted their timesheet to approve their timesheet. | Boolean | 1 |
 | TreatInactiveAsDormant | Indicates whether inactive projects are available for selection in Timekeeper. | Boolean | 1 |
 | PrintClientName | Indicates whether the TK Administrator has suppressed printing of the client name on printed timesheets. | Boolean | 1 |
 | PrintComments | Indicates whether the TK Administrator has suppressed printing of comments on printed timesheets. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
CFGTKMainPK |  |  |

SQL

CREATE TABLE [CFGTKMain] (
    [AdvKey] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RequirePasswords] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Requi__51EF2864] DEFAULT (0),
    [AllowTKResubmit] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Allow__52E34C9D] DEFAULT (0),
    [AllowEKResubmit] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Allow__53D770D6] DEFAULT (0),
    [AmountPerMile] [float] NULL ,
    [AllowCompanyPaid] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Allow__54CB950F] DEFAULT (0),
    [AllowAdvances] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Allow__55BFB948] DEFAULT (0),
    [DistanceType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CategoriesRequired] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Categ__56B3DD81] DEFAULT (0),
    [CheckHours] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CheckLaborCodes] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CompanyPaidProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CompanyPaidTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CompanyPaidAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DisableOvertime] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Disab__57A801BA] DEFAULT (0),
    [DisableTKLogin] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Disab__589C25F3] DEFAULT (0),
    [DisableEKLogin] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Disab__59904A2C] DEFAULT (0),
    [ApprovalRequired] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Appro__5A846E65] DEFAULT (0),
    [ElectronicSignature] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Elect__5B78929E] DEFAULT (0),
    [AllowSubmitterToApprove] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Allow__5C6CB6D7] DEFAULT (0),
    [TreatInactiveAsDormant] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Treat__5D60DB10] DEFAULT (0),
    [PrintClientName] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Print__5E54FF49] DEFAULT (0),
    [PrintComments] [bit] NOT NULL CONSTRAINT [DF__CFGTKMain__Print__5F492382] DEFAULT (0),
    CONSTRAINT [CFGTKMainPK] PRIMARY KEY NONCLUSTERED
    (
        [AdvKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGTKMain Table | Deltek Advantage 9.0 Database

CFGTKMainPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | AdvKey |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

CFGTKMain Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGVendorStatus Table

Description

Accounts Payable Setup Table - Vendor Status

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 3
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Status | Required. Variable indicating the vendor status code. Valid options are A - Active; I - Inactive; and D - Dormant. | VarChar | 1 |
 | Label | Description associated with the vendor status code. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
CFGVendorStatusPK |  |  |

SQL

CREATE TABLE [CFGVendorStatus] (
    [Status] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Label] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGVendorStatusPK] PRIMARY KEY NONCLUSTERED
    (
        [Status]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGVendorStatus Table | Deltek Advantage 9.0 Database

CFGVendorStatusPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Status |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 3
Rows Sampled | 3
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:02

See Also

CFGVendorStatus Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CFGVESortSelect Table

Description

System Setup Table - Vendor Sort/Select Field Configuration

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 30
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SortNo | Required. Primary key corresponding to the sort/select field number. | SmallInt | 2 |
 | DataType | Variable indicating the type of data to be input for the sort/select field. Valid options are 1 - Text; 2 - Numeric; and 3 - Date. | SmallInt | 2 |
 | Label | User label for the sort/select field. | VarChar | 20 |
 | InUse | Variable indicating whether the sort/select category is being used. | Boolean | 1 |
 | Required | Variable indicating whether this is a required field in Vendor Table Maintenance. | Boolean | 1 |
 | LimitToList | Variable indicating whether entry is limited to system setup values (for text data types only). | Boolean | 1 |
 | Uppercase | Variable indicating whether entered values should be converted to all uppercase (for text data types only). | Boolean | 1 |
 | Digits | Maximum number of digits allowed (for numeric data types only). | SmallInt | 2 |
 | Decimals | Maximum number of decimals allowed (for numeric data types only). | SmallInt | 2 |
 | MaxValue | Maximum numeric value allowed (for numeric data types only). | Double | 9 |
 | MinValue | Minimum numeric value allowed (for numeric data types only). | Double | 9 |
 | NullTaskSignificant | Variable indicating whether the value is significant at the project level for a project with tasks (for numeric data types only). | Boolean | 1 |
 | AggregateFlag | Variable indicating whether the numeric gets aggregated during a closeout (applicable for numeric data types only). | Boolean | 1 |
 | MaxDate | Maximum date allowed (applicable for date data types only). | DBTimeStamp | 4 |
 | MinDate | Minimum date allowed (applicable for date data types only). | DBTimeStamp | 4 |
 | HelpMessage | User defined help message to be displayed in status bar text. | VarChar | 100 |

Indexes

Index | Description | Primary | Unique
CFGVESortSelectPK |  |  |

SQL

CREATE TABLE [CFGVESortSelect] (
    [SortNo] [smallint] NOT NULL ,
    [DataType] [smallint] NULL ,
    [Label] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InUse] [bit] NOT NULL CONSTRAINT [DF__CFGVESort__InUse__6225902D] DEFAULT (0),
    [Required] [bit] NOT NULL CONSTRAINT [DF__CFGVESort__Requi__6319B466] DEFAULT (0),
    [LimitToList] [bit] NOT NULL CONSTRAINT [DF__CFGVESort__Limit__640DD89F] DEFAULT (0),
    [Uppercase] [bit] NOT NULL CONSTRAINT [DF__CFGVESort__Upper__6501FCD8] DEFAULT (0),
    [Digits] [smallint] NULL ,
    [Decimals] [smallint] NULL ,
    [MaxValue] [float] NULL ,
    [MinValue] [float] NULL ,
    [NullTaskSignificant] [bit] NOT NULL CONSTRAINT [DF__CFGVESort__NullT__65F62111] DEFAULT (0),
    [AggregateFlag] [bit] NOT NULL CONSTRAINT [DF__CFGVESort__Aggre__66EA454A] DEFAULT (0),
    [MaxDate] [datetime] NULL ,
    [MinDate] [datetime] NULL ,
    [HelpMessage] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CFGVESortSelectPK] PRIMARY KEY NONCLUSTERED
    (
        [SortNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CFGVESortSelect Table | Deltek Advantage 9.0 Database

CFGVESortSelectPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SortNo |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 3
Rows Sampled | 3
Distribution Steps | 2
Updated | Monday, January 26, 2004 15:02

See Also

CFGVESortSelect Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CL Table

Description

Client Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | clClient | Required. Client number. | VarChar | 10 |
 | clName | Client name. | VarChar | 40 |
 | clSelect1 | Client sort/select field 1. | VarChar | 20 |
 | clSelect2 | Client sort/select field 2. | VarChar | 20 |
 | clSelect3 | Client sort/select field 3. | VarChar | 20 |
 | clMemo | Memo field for notes regarding the client. | LongVarChar | 16 |
 | clSelect4 | Client sort/select field 4. | VarChar | 20 |
 | clSelect5 | Client sort/select field 5. | VarChar | 20 |
 | clSelect6 | Client sort/select field 6. | VarChar | 20 |
 | clSelect7 | Client sort/select field 7. | VarChar | 20 |
 | clSelect8 | Client sort/select field 8. | VarChar | 20 |
 | clSelect9 | Client sort/select field 9. | VarChar | 20 |
 | clSelect10 | Client sort/select field 10. | VarChar | 20 |
 | clSelect11 | Client sort/select field 11. | VarChar | 20 |
 | clSelect12 | Client sort/select field 12. | VarChar | 20 |
 | clSelect13 | Client sort/select field 13. | VarChar | 20 |
 | clSelect14 | Client sort/select field 14. | VarChar | 20 |
 | clSelect15 | Client sort/select field 15. | VarChar | 20 |
 | clSelect16 | Client sort/select field 16. | Double | 9 |
 | clSelect17 | Client sort/select field 17. | Double | 9 |
 | clSelect18 | Client sort/select field 18. | Double | 9 |
 | clSelect19 | Client sort/select field 19. | Double | 9 |
 | clSelect20 | Client sort/select field 20. | Double | 9 |
 | clSelect21 | Client sort/select field 21. | Double | 9 |
 | clSelect22 | Client sort/select field 22. | Double | 9 |
 | clSelect23 | Client sort/select field 23. | Double | 9 |
 | clSelect24 | Client sort/select field 24. | Double | 9 |
 | clSelect25 | Client sort/select field 25. | Double | 9 |
 | clSelect26 | Client sort/select field 26. | DBTimeStamp | 4 |
 | clSelect27 | Client sort/select field 27. | DBTimeStamp | 4 |
 | clSelect28 | Client sort/select field 28. | DBTimeStamp | 4 |
 | clSelect29 | Client sort/select field 29. | DBTimeStamp | 4 |
 | clSelect30 | Client sort/select field 30. | DBTimeStamp | 4 |
 | clStatus | Reserved for future use. | VarChar | 1 |
 | clCreateUser | Reserved for future use. | VarChar | 20 |
 | clCreateDate | Reserved for future use. | DBTimeStamp | 4 |
 | clLastUser | Reserved for future use. | VarChar | 20 |
 | clLastUpdateDate | Reserved for future use. | DBTimeStamp | 4 |

Indexes

Index | Description | Primary | Unique
CLPK |  |  |

SQL

CREATE TABLE [CL] (
    [clClient] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [clName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect1] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect2] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect3] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clMemo] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect4] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect5] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect6] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect7] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect8] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect9] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect10] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect11] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect12] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect13] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect14] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect15] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect16] [float] NULL ,
    [clSelect17] [float] NULL ,
    [clSelect18] [float] NULL ,
    [clSelect19] [float] NULL ,
    [clSelect20] [float] NULL ,
    [clSelect21] [float] NULL ,
    [clSelect22] [float] NULL ,
    [clSelect23] [float] NULL ,
    [clSelect24] [float] NULL ,
    [clSelect25] [float] NULL ,
    [clSelect26] [datetime] NULL ,
    [clSelect27] [datetime] NULL ,
    [clSelect28] [datetime] NULL ,
    [clSelect29] [datetime] NULL ,
    [clSelect30] [datetime] NULL ,
    [clStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clCreateUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clCreateDate] [datetime] NULL ,
    [clLastUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clLastUpdateDate] [datetime] NULL ,
    CONSTRAINT [CLPK] PRIMARY KEY NONCLUSTERED
    (
        [clClient]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CL Table | Deltek Advantage 9.0 Database

CLPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | clClient |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CL Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CLA Table

Description

Client Address Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | claClient | Required. Client number. | VarChar | 10 |
Primary Key | claAddress | Required. Unique code to identify this address. | VarChar | 10 |
 | claAddressee | Client’s name as you want it to appear on the mailing label. | VarChar | 40 |
 | claAddress1 | First line of the client’s address. | VarChar | 40 |
 | claAddress2 | Second line of the client’s address. | VarChar | 40 |
 | claAddress3 | Third line of the client’s address. | VarChar | 40 |
 | claCity | Client’s city. | VarChar | 18 |
 | claState | Client’s state. | VarChar | 2 |
 | claZIP | Client’s zip code. | VarChar | 10 |
 | claCountry | Client’s country. | VarChar | 12 |
 | claContact | Name of the contact at the client site. | VarChar | 40 |
 | claPhone | Client’s telephone number. | VarChar | 24 |
 | claFAX | Client’s FAX number. | VarChar | 24 |
 | claEMail | Client’s email address. | VarChar | 50 |
 | claTaxCountryCode | Client's tax country code. | VarChar | 2 |
 | claTaxRegistrationNumber | Client's tax registration number. | VarChar | 15 |

Indexes

Index | Description | Primary | Unique
CLAPK |  |  |

SQL

CREATE TABLE [CLA] (
    [claClient] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [claAddress] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [claAddressee] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claAddress3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claZIP] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claCountry] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claContact] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claPhone] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claFAX] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claEMail] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claTaxCountryCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [claTaxRegistrationNumber] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CLAPK] PRIMARY KEY NONCLUSTERED
    (
        [claClient],
        [claAddress]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CLA Table | Deltek Advantage 9.0 Database

CLAPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | claClient |  | Ascending
Primary Key | claAddress |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CLA Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CLInitiation Table

Description

Client Initiation Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | clClient | Required. Client number. | VarChar | 10 |
Primary Key | clAddress | Required. Client address code. | VarChar | 10 |
Primary Key | clRecType | Required. Record type. Valid options are A - Advantage; P - Project Workplace. | VarChar | 1 |
 | clApproved | Required. Variable indicating whether the client has been approved. | Boolean | 1 |
 | clSelected | Required. Variable indicating whether the client has been selected. | Boolean | 1 |
 | clErrorMsg | Error message. | VarChar | 255 |
 | clName | Client name. | VarChar | 40 |
 | clAddressee | Client’s name as you want it to appear on the mailing label. | VarChar | 40 |
 | clAddress1 | First line of the client’s address. | VarChar | 40 |
 | clAddress2 | Second line of the client’s address. | VarChar | 40 |
 | clAddress3 | Third line of the client’s address. | VarChar | 40 |
 | clCity | Client’s city. | VarChar | 18 |
 | clState | Client’s state. | VarChar | 2 |
 | clZIP | Client’s zip code. | VarChar | 10 |
 | clCountry | Client’s country. | VarChar | 12 |
 | clContact | Name of the contact at the client site. | VarChar | 40 |
 | clPhone | Client’s telephone number. | VarChar | 24 |
 | clFAX | Client’s FAX number. | VarChar | 24 |
 | clEMail | Client’s email address. | VarChar | 50 |
 | clSelect1 | Client sort/select field 1. | VarChar | 20 |
 | clSelect2 | Client sort/select field 2. | VarChar | 20 |
 | clSelect3 | Client sort/select field 3. | VarChar | 20 |
 | clMemo | Memo field for notes regarding the client. | LongVarChar | 16 |
 | clTaxCountryCode | Client's tax country code. | VarChar | 2 |
 | clTaxRegistrationNumber | Client's tax registration number. | VarChar | 15 |
 | clSelect4 | Client sort/select field 4. | VarChar | 20 |
 | clSelect5 | Client sort/select field 5. | VarChar | 20 |
 | clSelect6 | Client sort/select field 6. | VarChar | 20 |
 | clSelect7 | Client sort/select field 7. | VarChar | 20 |
 | clSelect8 | Client sort/select field 8. | VarChar | 20 |
 | clSelect9 | Client sort/select field 9. | VarChar | 20 |
 | clSelect10 | Client sort/select field 10. | VarChar | 20 |
 | clSelect11 | Client sort/select field 11. | VarChar | 20 |
 | clSelect12 | Client sort/select field 12. | VarChar | 20 |
 | clSelect13 | Client sort/select field 13. | VarChar | 20 |
 | clSelect14 | Client sort/select field 14. | VarChar | 20 |
 | clSelect15 | Client sort/select field 15. | VarChar | 20 |
 | clSelect16 | Client sort/select field 16. | Double | 9 |
 | clSelect17 | Client sort/select field 17. | Double | 9 |
 | clSelect18 | Client sort/select field 18. | Double | 9 |
 | clSelect19 | Client sort/select field 19. | Double | 9 |
 | clSelect20 | Client sort/select field 20. | Double | 9 |
 | clSelect21 | Client sort/select field 21. | Double | 9 |
 | clSelect22 | Client sort/select field 22. | Double | 9 |
 | clSelect23 | Client sort/select field 23. | Double | 9 |
 | clSelect24 | Client sort/select field 24. | Double | 9 |
 | clSelect25 | Client sort/select field 25. | Double | 9 |
 | clSelect26 | Client sort/select field 26. | DBTimeStamp | 4 |
 | clSelect27 | Client sort/select field 27. | DBTimeStamp | 4 |
 | clSelect28 | Client sort/select field 28. | DBTimeStamp | 4 |
 | clSelect29 | Client sort/select field 29. | DBTimeStamp | 4 |
 | clSelect30 | Client sort/select field 30. | DBTimeStamp | 4 |
 | clStatus | Reserved for future use. | VarChar | 1 |

Indexes

Index | Description | Primary | Unique
CLInitiationPK |  |  |

SQL

CREATE TABLE [CLInitiation] (
    [clClient] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [clAddress] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [clRecType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [clApproved] [bit] NOT NULL CONSTRAINT [DF__CLInitiat__clApp__390E6C01] DEFAULT (0),
    [clSelected] [bit] NOT NULL CONSTRAINT [DF__CLInitiat__clSel__3A02903A] DEFAULT (0),
    [clErrorMsg] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clAddressee] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clAddress3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clZIP] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clCountry] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clContact] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clPhone] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clFAX] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clEMail] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect1] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect2] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect3] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clMemo] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clTaxCountryCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clTaxRegistrationNumber] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect4] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect5] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect6] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect7] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect8] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect9] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect10] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect11] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect12] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect13] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect14] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect15] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [clSelect16] [float] NULL ,
    [clSelect17] [float] NULL ,
    [clSelect18] [float] NULL ,
    [clSelect19] [float] NULL ,
    [clSelect20] [float] NULL ,
    [clSelect21] [float] NULL ,
    [clSelect22] [float] NULL ,
    [clSelect23] [float] NULL ,
    [clSelect24] [float] NULL ,
    [clSelect25] [float] NULL ,
    [clSelect26] [datetime] NULL ,
    [clSelect27] [datetime] NULL ,
    [clSelect28] [datetime] NULL ,
    [clSelect29] [datetime] NULL ,
    [clSelect30] [datetime] NULL ,
    [clStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [CLInitiationPK] PRIMARY KEY NONCLUSTERED
    (
        [clClient],
        [clAddress],
        [clRecType]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CLInitiation Table | Deltek Advantage 9.0 Database

CLInitiationPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | clClient |  | Ascending
Primary Key | clAddress |  | Ascending
Primary Key | clRecType |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CLInitiation Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

CR Table

Description

Bank Transaction Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | crBankCode | Required. Bank code assigned to the transaction. | VarChar | 10 |
Primary Key | crTransType | Required. Transaction type. | VarChar | 2 |
Primary Key | crRefNo | Required. Reference number you associated with the transaction during data entry. | VarChar | 7 |
Primary Key | crSeq | Required. Internal sequence number. | Integer | 4 |
 | crPeriod | Fiscal year and period in which the transaction file was posted. | Integer | 4 |
 | crPostSeq | Posting sequence number assigned during the period. | SmallInt | 2 |
 | crDate | Date on which the transaction file was posted. | DBTimeStamp | 4 |
 | crAmount | Amount of the transaction file. | Double | 9 |
 | crDescription | Description of the transaction. | VarChar | 40 |
 | crStatementDate | Bank statement date for reconciliation purposes. | DBTimeStamp | 4 |
 | crCleared | Variable indicating whether or not the check has cleared. | Boolean | 1 |
 | crVoided | Variable indicating whether or not the check has been voided. | Boolean | 1 |
 | crVoidPeriod | Period in which the check was voided. | Integer | 4 |
 | crVoidPostSeq | Post sequence number assigned to the check when it was voided. | SmallInt | 2 |
 | crVoidAmount | Voided check amount. | Double | 9 |
 | crClearedPeriod | Period in which the check was cleared. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
CRPK |  |  |
crPeriodIDX |  |  |

SQL

CREATE TABLE [CR] (
    [crBankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [crTransType] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [crRefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [crSeq] [int] NOT NULL ,
    [crPeriod] [int] NULL ,
    [crPostSeq] [smallint] NULL ,
    [crDate] [datetime] NULL ,
    [crAmount] [float] NULL ,
    [crDescription] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [crStatementDate] [datetime] NULL ,
    [crCleared] [bit] NOT NULL CONSTRAINT [DF__CR__crCleared__7A1D154F] DEFAULT (0),
    [crVoided] [bit] NOT NULL CONSTRAINT [DF__CR__crVoided__7B113988] DEFAULT (0),
    [crVoidPeriod] [int] NULL ,
    [crVoidPostSeq] [smallint] NULL ,
    [crVoidAmount] [float] NULL ,
    [crClearedPeriod] [int] NULL ,
    CONSTRAINT [CRPK] PRIMARY KEY NONCLUSTERED
    (
        [crBankCode],
        [crTransType],
        [crRefNo],
        [crSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CR Table | Deltek Advantage 9.0 Database

CRPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | crBankCode |  | Ascending
Primary Key | crTransType |  | Ascending
Primary Key | crRefNo |  | Ascending
Primary Key | crSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CR Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

CR Table | Deltek Advantage 9.0 Database

crPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
crPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

CR Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

crControl Table

Description

Cash Receipts Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the cash receipt data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether or not this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether or not the file has been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether or not the transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the file. | VarChar | 15 |
 | Period | Fiscal period and year. | Integer | 4 |
 | EndDate | End date for the transaction file. | DBTimeStamp | 4 |
 | Total | Total entered for the transaction file. | Double | 9 |
 | DefaultBank | Default bank code to use for entries in data entry file. | VarChar | 10 |
 | PostPeriod | Period in which the cash receipt data entry transaction file was posted. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the cash receipt data entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
crControlPK |  |  |

SQL

CREATE TABLE [crControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__crControl__Recur__149C0161] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__crControl__Selec__1590259A] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__crControl__Poste__168449D3] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [EndDate] [datetime] NULL ,
    [Total] [float] NULL ,
    [DefaultBank] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__crControl__PostP__17786E0C] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__crControl__PostS__186C9245] DEFAULT (0),
    CONSTRAINT [crControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

crControl Table | Deltek Advantage 9.0 Database

crControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

crControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

crDetail Table

Description

Cash Receipts Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the cash receipt data entry transaction file. | VarChar | 15 |
Primary Key | RefNo | Required. Reference number assigned. | VarChar | 7 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | Description | Description of the detail line. | VarChar | 40 |
 | Project | Project to which the cash receipt amount applies. | VarChar | 12 |
 | ProjType | Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | TaskType | Variable indicating whether or not the project has tasks. | VarChar | 1 |
 | Task | Task to which the cash receipt amount applies. | VarChar | 5 |
 | Invoice | Final invoice number of the amount being received. | VarChar | 7 |
 | Account | Account to which the cash receipt amount applies. | VarChar | 10 |
 | Amount | Amount of cash receipt detail line. | Double | 9 |
 | Interest | Variable indicating whether or not the line represents an interest amount being paid. | Boolean | 1 |
 | TaxCode | Tax code to associate with the individual line item. | VarChar | 3 |
 | TaxBasis | Tax basis to associate with the individual line item. | Double | 9 |
 | Retainer | Variable indicating whether or not this transaction is a retainer. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
crDetailPK |  |  |

SQL

CREATE TABLE [crDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [Interest] [bit] NOT NULL CONSTRAINT [DF__crDetail__Intere__74444068] DEFAULT (0),
    [TaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxBasis] [float] NULL ,
    [Retainer] [bit] NOT NULL CONSTRAINT [DF__crDetail__Retain__753864A1] DEFAULT (0),
    CONSTRAINT [crDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [RefNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

crDetail Table | Deltek Advantage 9.0 Database

crDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | RefNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

crDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

crMaster Table

Description

Cash Receipts Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the cash receipt data entry transaction file. | VarChar | 15 |
Primary Key | RefNo | Required. Reference number assigned. | VarChar | 7 |
 | TransDate | Date specified for the cash receipt. | DBTimeStamp | 4 |
 | BankCode | Bank code to use when posting the data entry file. | VarChar | 10 |
 | TransComment | Comment for the transaction. This field defaults to “Deposit.” | VarChar | 40 |
 | Posted | Variable indicating whether or not the data entry file has been posted. | VarChar | 1 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
crMasterPK |  |  |

SQL

CREATE TABLE [crMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransDate] [datetime] NULL ,
    [BankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TransComment] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__crMaster__Posted__65AC084E] DEFAULT ('N'),
    [Seq] [int] NULL ,
    CONSTRAINT [crMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [RefNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

crMaster Table | Deltek Advantage 9.0 Database

crMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | RefNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

crMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

cvControl Table

Description

A/P Disbursements Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the accounts payable disbursement data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether or not this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether or not the file has been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether or not the transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the file. | VarChar | 15 |
 | Period | Fiscal period and year. | Integer | 4 |
 | EndDate | End date for the transaction. | DBTimeStamp | 4 |
 | Total | Total entered for the transaction file. | Double | 9 |
 | DefaultLiab | Not used. | VarChar | 10 |
 | DefaultBank | Default bank code to use for entries in the data entry file. | VarChar | 10 |
 | DefaultDate | Default date to use for entries in the data entry file. | DBTimeStamp | 4 |
 | DefaultTaxCode | Default tax code to use for entries in the data entry file. | VarChar | 3 |
 | PostPeriod | Period in which the A/P disbursement data entry transaction file was posted. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the A/P disbursement data entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
cvControlPK |  |  |

SQL

CREATE TABLE [cvControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__cvControl__Recur__1B48FEF0] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__cvControl__Selec__1C3D2329] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__cvControl__Poste__1D314762] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [EndDate] [datetime] NULL ,
    [Total] [float] NULL ,
    [DefaultLiab] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DefaultBank] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DefaultDate] [datetime] NULL ,
    [DefaultTaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__cvControl__PostP__1E256B9B] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__cvControl__PostS__1F198FD4] DEFAULT (0),
    CONSTRAINT [cvControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

cvControl Table | Deltek Advantage 9.0 Database

cvControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

cvControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

cvDetail Table

Description

A/P Disbursements Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the accounts payable disbursement data entry transaction file. | VarChar | 15 |
Primary Key | CheckNo | Required. Check number. | VarChar | 7 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | Description | Description of the detail line. | VarChar | 40 |
 | Project | Project to which the disbursement amount applies. | VarChar | 12 |
 | ProjType | Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | TaskType | Variable indicating whether or not the project has tasks. | VarChar | 1 |
 | Task | Task to which the disbursement amount applies. | VarChar | 5 |
 | Account | Account to which the disbursement amount applies. | VarChar | 10 |
 | Amount | Amount of the disbursement detail line. | Double | 9 |
 | SuppressBill | Variable indicating whether or not you want to suppress the billing of the accounts payable disbursement detail line. | Boolean | 1 |
 | TaxCode | Tax code to associate with the individual line item. | VarChar | 3 |
 | NetAmount | Gross voucher amount less any tax amount applied. | Double | 9 |
 | TaxAmount | Tax amount applied to the voucher. | Double | 9 |

Indexes

Index | Description | Primary | Unique
cvDetailPK |  |  |

SQL

CREATE TABLE [cvDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [CheckNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [SuppressBill] [bit] NOT NULL CONSTRAINT [DF__cvDetail__Suppre__7CD98669] DEFAULT (0),
    [TaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [NetAmount] [float] NULL ,
    [TaxAmount] [float] NULL ,
    CONSTRAINT [cvDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [CheckNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

cvDetail Table | Deltek Advantage 9.0 Database

cvDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | CheckNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

cvDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

cvMaster Table

Description

A/P Disbursements Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the A/P disbursement data entry transaction file. | VarChar | 15 |
Primary Key | CheckNo | Required. Check number. | VarChar | 7 |
 | TransDate | Transaction date. | DBTimeStamp | 4 |
 | Vendor | Vendor number. | VarChar | 10 |
 | InvoiceDate | Invoice date of the transaction for the vendor. | DBTimeStamp | 4 |
 | Invoice | Invoice number of the transaction for the vendor. | VarChar | 20 |
 | BankCode | Bank code to use when posting the data entry file. | VarChar | 10 |
 | Address | Comment. This field defaults to Deposit. | VarChar | 10 |
 | Posted | Variable indicating whether or not the data entry file has been posted. | VarChar | 1 |
 | LiabCode | Not used. | VarChar | 10 |
 | PayDate | Not used. | VarChar | 10 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |
 | Printed | Variable indicating whether the A/P disbursement check was printed. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
cvMasterPK |  |  |

SQL

CREATE TABLE [cvMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [CheckNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransDate] [datetime] NULL ,
    [Vendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InvoiceDate] [datetime] NULL ,
    [Invoice] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Address] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__cvMaster__Posted__688874F9] DEFAULT ('N'),
    [LiabCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayDate] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Seq] [int] NULL ,
    [Printed] [bit] NOT NULL CONSTRAINT [DF__cvMaster__Printe__697C9932] DEFAULT (0),
    CONSTRAINT [cvMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [CheckNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

cvMaster Table | Deltek Advantage 9.0 Database

cvMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | CheckNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

cvMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EB Table

Description

Expense Budget Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ebProject | Required. Project number with budget. | VarChar | 12 |
Primary Key | ebTask | Required. Task number with budget. | VarChar | 5 |
Primary Key | ebAccount | Required. Account number with budget. | VarChar | 10 |
Primary Key | ebVendor | Required. Vendor number with budget. | VarChar | 10 |
 | ebPct | Reported percent complete for the expense budget. | Double | 9 |
 | ebAmtBud | Budgeted cost amount for the account. | Double | 9 |
 | ebBillBud | Budgeted billing amount for the account. | Double | 9 |
 | ebStartDate | Start date for the expense budget. | DBTimeStamp | 4 |
 | ebEndDate | End date for the expense budget. | DBTimeStamp | 4 |
 | ebEtcAmt | Estimate to complete amount for expenses. | Double | 9 |
 | ebEacAmt | Estimate at completion amount for expenses. | Double | 9 |

Indexes

Index | Description | Primary | Unique
EBPK |  |  |

SQL

CREATE TABLE [EB] (
    [ebProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ebTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ebAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ebVendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ebPct] [float] NULL ,
    [ebAmtBud] [float] NULL ,
    [ebBillBud] [float] NULL ,
    [ebStartDate] [datetime] NULL ,
    [ebEndDate] [datetime] NULL ,
    [ebEtcAmt] [float] NULL ,
    [ebEacAmt] [float] NULL ,
    CONSTRAINT [EBPK] PRIMARY KEY NONCLUSTERED
    (
        [ebProject],
        [ebTask],
        [ebAccount],
        [ebVendor]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EB Table | Deltek Advantage 9.0 Database

EBPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ebProject |  | Ascending
Primary Key | ebTask |  | Ascending
Primary Key | ebAccount |  | Ascending
Primary Key | ebVendor |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EB Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

ED Table

Description

Expense Detail Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | edKey | Required. Internal sequence number. | Integer | 4 |
 | edProject | Project number. | VarChar | 12 |
 | edTask | Task number. | VarChar | 5 |
 | edAccount | Account number. | VarChar | 10 |
 | edProfCtr | Profit center. | VarChar | 8 |
 | edPeriod | Fiscal year and period for the expense detail. | Integer | 4 |
 | edPostSeq | Posting sequence number. | SmallInt | 2 |
 | edTransType | Transaction type for the expense detail. | VarChar | 2 |
 | edSubType | Transaction subtype for the expense detail. | VarChar | 1 |
 | edRefNo | Reference number associated with the transaction during data entry. | VarChar | 7 |
 | edDate | Date referenced on the transaction posting. | DBTimeStamp | 4 |
 | edDesc1 | First description for the transaction. | VarChar | 40 |
 | edDesc2 | Second description for the transaction. | VarChar | 40 |
 | edAmount | Amount of the transaction. | Double | 9 |
 | edCBAmount | Cash-basis amount of the transaction. | Double | 9 |
 | edBillExt | Billing extension for project reporting at billing rates. | Double | 9 |
 | edProjectCost | Internal flag for project reporting purposes. | Boolean | 1 |
 | edAutoEntry | Variable indicating whether the transaction is the result of an implicit posting. | Boolean | 1 |
 | edSuppressBill | Variable indicating whether to suppress the billing for the transaction. | Boolean | 1 |
 | edBillStatus | Variable indicating the billing status for the expense transaction. Valid options are B - To be Billed; W - To be written off; H - Held; F - Final Billed; X - Written off; T - Transferred; I - Inserted; and M - Modified. | VarChar | 1 |
 | edSkipGL | Variable indicating whether to include the transaction for general ledger reporting (history transactions are not included). | Boolean | 1 |
 | edBankCode | Bank code assigned to the transaction during data entry. | VarChar | 10 |
 | edInvoice | For cash receipts, the number of the invoice (from Billing) being paid by the transaction. | VarChar | 7 |
 | edInvoiceSection | Corresponding invoice section for the transaction. | VarChar | 1 |
 | edVendor | Vendor number. | VarChar | 10 |
 | edLine | Line number for accounts payable vouchers. | SmallInt | 2 |
 | edPartialPayment | Partial payment amount in the voucher payment records. | Double | 9 |
 | edDiscount | Discount amount in the voucher payment records. | Double | 9 |
 | edVoucher | Voucher number. | VarChar | 7 |
 | edBilledProject | Project on whose invoice the record was final billed. | VarChar | 12 |
 | edBilledTask | Task on whose invoice the record was final billed. | VarChar | 5 |
 | edBilledInvoice | Invoice on which the record was final billed. | VarChar | 7 |
 | edBilledPeriod | Period in which the record was final billed. | Integer | 4 |
 | edUnit | Unit number. | VarChar | 10 |
 | edUnitTable | Unit table. | VarChar | 12 |
 | edUnitQuantity | Number of units. | Double | 9 |
 | edUnitCostRate | Cost rate per unit. | Double | 9 |
 | edUnitBillingRate | Billing rate per unit. | Double | 9 |
 | edUnitBillExt | Total billing amount. This is calculated by multiplying the billing rate per unit by the quantity. | Double | 9 |
 | edOriginalKey | Internal sequence number. | Integer | 4 |
 | edXferProject | Project from which the record was transferred. | VarChar | 12 |
 | edXferTask | Task from which the record was transferred. | VarChar | 5 |
 | edXferAccount | Account from which the record was transferred. | VarChar | 10 |
 | edTaxCode | Tax code to associate with the individual line item. | VarChar | 3 |
 | edTaxAmount | Tax amount to associate with the individual line item. | Double | 9 |
 | edTaxCBAmount | Cash basis tax amount, if any, associated with this transaction. | Double | 9 |
 | edTaxBasis | Tax basis, if any, associated with this transaction. | Double | 9 |
 | edTaxCBBasis | Cash basis tax basis, if any, associated with this transaction. | Double | 9 |
 | edBillTaxCodeOverride | Tax code that will override the standard billing tax code. | VarChar | 3 |
 | edWrittenoffPeriod | Active period when this record was written off (billing status of X.) | Integer | 4 |
 | edPrintedDisbCheck | Variable indicating whether a cash disbursement or A/P disbursement check was printed. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
EDPK |  |  |
edAccountIDX |  |  |
edBillStatusIDX |  |  |
edInvoiceIDX |  |  |
edPeriodedPostSeqIDX |  |  |
edProjectedTaskIDX |  |  |
edTransTypeedSubTypeIDX |  |  |
edVendoredVoucherIDX |  |  |

SQL

CREATE TABLE [ED] (
    [edKey] [int] NOT NULL ,
    [edProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edPeriod] [int] NULL ,
    [edPostSeq] [smallint] NULL ,
    [edTransType] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edSubType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edRefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edDate] [datetime] NULL ,
    [edDesc1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edDesc2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edAmount] [float] NULL ,
    [edCBAmount] [float] NULL ,
    [edBillExt] [float] NULL ,
    [edProjectCost] [bit] NOT NULL CONSTRAINT [DF__ED__edProjectCos__4944D3CA] DEFAULT (0),
    [edAutoEntry] [bit] NOT NULL CONSTRAINT [DF__ED__edAutoEntry__4A38F803] DEFAULT (0),
    [edSuppressBill] [bit] NOT NULL CONSTRAINT [DF__ED__edSuppressBi__4B2D1C3C] DEFAULT (0),
    [edBillStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edSkipGL] [bit] NOT NULL CONSTRAINT [DF__ED__edSkipGL__4C214075] DEFAULT (0),
    [edBankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edInvoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edInvoiceSection] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edVendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edLine] [smallint] NULL ,
    [edPartialPayment] [float] NULL ,
    [edDiscount] [float] NULL ,
    [edVoucher] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edBilledProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edBilledTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edBilledInvoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edBilledPeriod] [int] NULL ,
    [edUnit] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edUnitTable] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edUnitQuantity] [float] NULL ,
    [edUnitCostRate] [float] NULL ,
    [edUnitBillingRate] [float] NULL ,
    [edUnitBillExt] [float] NULL ,
    [edOriginalKey] [int] NULL ,
    [edXferProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edXferTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edXferAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edTaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edTaxAmount] [float] NULL ,
    [edTaxCBAmount] [float] NULL ,
    [edTaxBasis] [float] NULL ,
    [edTaxCBBasis] [float] NULL ,
    [edBillTaxCodeOverride] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [edWrittenoffPeriod] [int] NULL ,
    [edPrintedDisbCheck] [bit] NOT NULL CONSTRAINT [DF__ED__edPrintedDis__4D1564AE] DEFAULT (0),
    CONSTRAINT [EDPK] PRIMARY KEY NONCLUSTERED
    (
        [edKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ED Table | Deltek Advantage 9.0 Database

EDPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | edKey |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ED Table | Deltek Advantage 9.0 Database

edAccountIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edAccount |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ED Table | Deltek Advantage 9.0 Database

edBillStatusIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edBillStatus |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ED Table | Deltek Advantage 9.0 Database

edInvoiceIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edInvoice |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ED Table | Deltek Advantage 9.0 Database

edPeriodedPostSeqIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edPeriod |  | Ascending
edPostSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ED Table | Deltek Advantage 9.0 Database

edProjectedTaskIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edProject |  | Ascending
edTask |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ED Table | Deltek Advantage 9.0 Database

edTransTypeedSubTypeIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edTransType |  | Ascending
edSubType |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ED Table | Deltek Advantage 9.0 Database

edVendoredVoucherIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
edVendor |  | Ascending
edVoucher |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

ekDetail Table

Description

Expensekeeper Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
Primary Key | ReportDate | Required. Date of the expense report. | DBTimeStamp | 4 |
Primary Key | ReportName | Required. Name of the expense report. | VarChar | 40 |
Primary Key | Seq | Required. Sequence for primary key. | Integer | 4 |
 | SortOrder | Order in which lines were entered on the expense report. | Integer | 4 |
 | TransDate | Date of the expense transaction. | DBTimeStamp | 4 |
 | Description | Description of the expense transaction. | VarChar | 40 |
 | Project | Project number associated with expense transaction. | VarChar | 12 |
 | Task | Task number associated with expense transaction. | VarChar | 5 |
 | Category | Expense category. | SmallInt | 2 |
 | Billable | Indicates whether the expense transaction is billable. | VarChar | 1 |
 | CompanyPaid | Indicates whether the company has paid the expense. | VarChar | 1 |
 | Account | Account number associated with the expense transaction. | VarChar | 10 |
 | Amount | Amount of the expense transaction. | Double | 9 |
 | Miles | Total number of miles for the trip. | Double | 9 |
 | AmountPerMile | Amount specified for each mile. | Double | 9 |
 | Reason | Reason for the expense transaction. | VarChar | 255 |
 | Other | Other comments. | VarChar | 255 |

Indexes

Index | Description | Primary | Unique
ekDetailPK |  |  |

SQL

CREATE TABLE [ekDetail] (
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ReportDate] [datetime] NOT NULL ,
    [ReportName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [SortOrder] [int] NULL ,
    [TransDate] [datetime] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Category] [smallint] NULL ,
    [Billable] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CompanyPaid] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [Miles] [float] NULL ,
    [AmountPerMile] [float] NULL ,
    [Reason] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Other] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [ekDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Employee],
        [ReportDate],
        [ReportName],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ekDetail Table | Deltek Advantage 9.0 Database

ekDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Employee |  | Ascending
Primary Key | ReportDate |  | Ascending
Primary Key | ReportName |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ekDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

ekMaster Table

Description

Expensekeeper Table - Data Entry Master

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
Primary Key | ReportDate | Required. Date of the expense report. | DBTimeStamp | 4 |
Primary Key | ReportName | Required. Name of the expense report. | VarChar | 40 |
 | Status | Variable indicating the status of the expense report. Valid options are N, Y, and P. | VarChar | 1 |
 | AdvanceAmount | Advance amount applied to the expense report. | Double | 9 |
 | Selected | Variable indicating whether the expense report has been selected for posting. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
ekMasterPK |  |  |

SQL

CREATE TABLE [ekMaster] (
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ReportDate] [datetime] NOT NULL ,
    [ReportName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Status] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AdvanceAmount] [float] NULL ,
    [Selected] [bit] NOT NULL CONSTRAINT [DF__ekMaster__Select__075714DC] DEFAULT (0),
    CONSTRAINT [ekMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Employee],
        [ReportDate],
        [ReportName]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ekMaster Table | Deltek Advantage 9.0 Database

ekMasterPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Employee |  | Ascending
Primary Key | ReportDate |  | Ascending
Primary Key | ReportName |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ekMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EM Table

Description

Employee Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | emEmployee | Required. Employee number. | VarChar | 10 |
 | emLastName | Employee’s last name. | VarChar | 20 |
 | emFirstName | Employee’s first name. | VarChar | 13 |
 | emJobCostRate | Employee’s job cost rate. | Double | 9 |
 | emJobCostType | Variable indicating the job cost type. Valid options are H - Hourly and S - Salaried. | VarChar | 1 |
 | emJCOvtPct | Overtime percentage. | Double | 9 |
 | emTargetRatio | Percentage of hours that is expected to be charged by the employee. | Double | 9 |
 | emHoursPerDay | Number of hours worked per day. This field is used by the Timekeeper module if you select to check the hours entered by the expected hours for the employee. | Double | 9 |
 | emHireDate | Date of the employee’s hire. | DBTimeStamp | 4 |
 | emRaiseDate | Date of the employee’s next raise. | DBTimeStamp | 4 |
 | emStatus | Variable indicating the employee’s status. Valid options are A - Active; I - Inactive; and T - Terminated. | VarChar | 1 |
 | emType | Variable indicating the employee’s type. Valid options are P - Principal and E - Employee. | VarChar | 1 |
 | emProfCtr | Employee’s profit center. | VarChar | 8 |
 | emBillingCategory | Default category for the employee when using the By Category labor billing method. | SmallInt | 2 |
 | emBillingPool | Not used. | SmallInt | 2 |
 | emSSN | Employee’s social security number. | VarChar | 9 |
 | emAddress1 | First line of the employee’s address. | VarChar | 40 |
 | emAddress2 | Second line of the employee’s address. | VarChar | 40 |
 | emAddress3 | Third line of the employee’s address. | VarChar | 40 |
 | emCity | Employee’s city. | VarChar | 18 |
 | emState | Employee’s state. | VarChar | 2 |
 | emZIP | Employee’s zip code. | VarChar | 10 |
 | emCountry | Employee’s country. | VarChar | 12 |
 | emPhone | Employee’s telephone number. | VarChar | 24 |
 | emFAX | Employee’s telephone number. | VarChar | 24 |
 | emEMail | Employee’s email address. | VarChar | 50 |
 | emSelect1 | Employee sort/select code 1. | VarChar | 20 |
 | emSelect2 | Employee sort/select code 2. | VarChar | 20 |
 | emSelect3 | Employee sort/select code 3. | VarChar | 20 |
 | emSelect4 | Employee sort/select code 4. | VarChar | 20 |
 | emSelect5 | Employee sort/select code 5. | VarChar | 20 |
 | emSelect6 | Employee sort/select code 6. | VarChar | 20 |
 | emSelect7 | Employee sort/select code 7. | VarChar | 20 |
 | emSelect8 | Employee sort/select code 8. | VarChar | 20 |
 | emSelect9 | Employee sort/select code 9. | VarChar | 20 |
 | emSelect10 | Employee sort/select code 10. | VarChar | 20 |
 | emSelect11 | Employee sort/select code 11. | VarChar | 20 |
 | emSelect12 | Employee sort/select code 12. | VarChar | 20 |
 | emSelect13 | Employee sort/select code 13. | VarChar | 20 |
 | emSelect14 | Employee sort/select code 14. | VarChar | 20 |
 | emSelect15 | Employee sort/select code 15. | VarChar | 20 |
 | emSelect16 | Employee sort/select code 16. | Double | 9 |
 | emSelect17 | Employee sort/select code 17. | Double | 9 |
 | emSelect18 | Employee sort/select code 18. | Double | 9 |
 | emSelect19 | Employee sort/select code 19. | Double | 9 |
 | emSelect20 | Employee sort/select code 20. | Double | 9 |
 | emSelect21 | Employee sort/select code 21. | Double | 9 |
 | emSelect22 | Employee sort/select code 22. | Double | 9 |
 | emSelect23 | Employee sort/select code 23. | Double | 9 |
 | emSelect24 | Employee sort/select code 24. | Double | 9 |
 | emSelect25 | Employee sort/select code 25. | Double | 9 |
 | emSelect26 | Employee sort/select code 26. | DBTimeStamp | 4 |
 | emSelect27 | Employee sort/select code 27. | DBTimeStamp | 4 |
 | emSelect28 | Employee sort/select code 28. | DBTimeStamp | 4 |
 | emSelect29 | Employee sort/select code 29. | DBTimeStamp | 4 |
 | emSelect30 | Employee sort/select code 30. | DBTimeStamp | 4 |
 | emTKGroup | Employee’s Timekeeper group. | VarChar | 2 |
 | emTKAdminLevel | Employee’s Timekeeper administration level. | VarChar | 1 |
 | emTKAdminEdit | Variable indicating whether this Timekeeper user can edit timesheets for other employees in the same Timekeeper group. | Boolean | 1 |
 | emEKGroup | Employee’s Expensekeeper group. | VarChar | 2 |
 | emEKAdminLevel | Employee’s Expensekeeper administration level. | VarChar | 1 |
 | emEKAdminEdit | Variable indicating whether this Expensekeeper user can edit other timesheets for employees in the same Expensekeeper group. | Boolean | 1 |
 | emMemo | Memo field for comments on the employee. | LongVarChar | 16 |
 | emADPFileNumber | ADP employee number. | VarChar | 6 |
 | emADPCompanyCode | ADP company code. | VarChar | 3 |
 | emADPRateCode | ADP rate code. | VarChar | 1 |
 | emProvCostRate | Provisional cost rate for unposted time on interactive project reports. | Double | 9 |
 | emProvBillRate | Provisional billing rate for unposted time on Interactive Project reports. | Double | 9 |
 | emProvCostOTPct | Provisional cost rate for unposted overtime on Interactive Project reports. | Double | 9 |
 | emProvBillOTPct | Provisional billing rate for unposted overtime on Interactive Project reports. | Double | 9 |
 | emDefaultLC1 | Level 1 default labor code for Timekeeper timesheets. | VarChar | 5 |
 | emDefaultLC2 | Level 2 default labor code for Timekeeper timesheets. | VarChar | 5 |
 | emDefaultLC3 | Level 3 default labor code for Timekeeper timesheets. | VarChar | 5 |
 | emDefaultLC4 | Level 4 default labor code for Timekeeper timesheets. | VarChar | 5 |
 | emDefaultLC5 | Level 5 default labor code for Timekeeper timesheets. | VarChar | 5 |
 | emChangeDefaultLC | Variable indicating whether the employee can change the default labor code in Timekeeper. | Boolean | 1 |
 | emTerminationDate | The date on which the employee was terminated. | DBTimeStamp | 4 |
 | emTKAdminApproval | Variable indicating whether this employee’s timesheet needs approval. | Boolean | 1 |
 | emUseTotalHrsAsStd | Variable indicating whether to force the standard hours to be the total hours worked by this employee. | Boolean | 1 |
 | emJCSpecialOvtPct | The job costing special overtime percentage. | Double | 9 |
 | emProvCostSpecialOTPct | Provisional cost percentage for unposted special overtime in Interactive Project Reports. | Double | 9 |
 | emProvBillSpecialOTPct | Provisional billing percentage for unposted special overtime in Interactive Project Reports. | Double | 9 |
 | emCellPhone | Employee's cell phone number. | VarChar | 24 |
 | emSupervisor | Reserved for future use. | VarChar | 10 |
 | emCreateUser | Reserved for future use. | VarChar | 20 |
 | emCreateDate | Reserved for future use. | DBTimeStamp | 4 |
 | emLastUser | Reserved for future use. | VarChar | 20 |
 | emLastUpdateDate | Reserved for future use. | DBTimeStamp | 4 |

Indexes

Index | Description | Primary | Unique
EMPK |  |  |

SQL

CREATE TABLE [EM] (
    [emEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [emLastName] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emFirstName] [varchar] (13) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emJobCostRate] [float] NULL ,
    [emJobCostType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emJCOvtPct] [float] NULL ,
    [emTargetRatio] [float] NULL ,
    [emHoursPerDay] [float] NULL ,
    [emHireDate] [datetime] NULL ,
    [emRaiseDate] [datetime] NULL ,
    [emStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emBillingCategory] [smallint] NULL ,
    [emBillingPool] [smallint] NULL ,
    [emSSN] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emAddress3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emZIP] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emCountry] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emPhone] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emFAX] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emEMail] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect1] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect2] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect3] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect4] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect5] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect6] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect7] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect8] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect9] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect10] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect11] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect12] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect13] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect14] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect15] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect16] [float] NULL ,
    [emSelect17] [float] NULL ,
    [emSelect18] [float] NULL ,
    [emSelect19] [float] NULL ,
    [emSelect20] [float] NULL ,
    [emSelect21] [float] NULL ,
    [emSelect22] [float] NULL ,
    [emSelect23] [float] NULL ,
    [emSelect24] [float] NULL ,
    [emSelect25] [float] NULL ,
    [emSelect26] [datetime] NULL ,
    [emSelect27] [datetime] NULL ,
    [emSelect28] [datetime] NULL ,
    [emSelect29] [datetime] NULL ,
    [emSelect30] [datetime] NULL ,
    [emTKGroup] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emTKAdminLevel] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emTKAdminEdit] [bit] NOT NULL CONSTRAINT [DF__EM__emTKAdminEdi__222B06A9] DEFAULT (0),
    [emEKGroup] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emEKAdminLevel] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emEKAdminEdit] [bit] NOT NULL CONSTRAINT [DF__EM__emEKAdminEdi__231F2AE2] DEFAULT (0),
    [emMemo] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emADPFileNumber] [varchar] (6) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emADPCompanyCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emADPRateCode] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emProvCostRate] [float] NULL ,
    [emProvBillRate] [float] NULL ,
    [emProvCostOTPct] [float] NULL ,
    [emProvBillOTPct] [float] NULL ,
    [emDefaultLC1] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emDefaultLC2] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emDefaultLC3] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emDefaultLC4] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emDefaultLC5] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emChangeDefaultLC] [bit] NOT NULL CONSTRAINT [DF__EM__emChangeDefa__24134F1B] DEFAULT (0),
    [emTerminationDate] [datetime] NULL ,
    [emTKAdminApproval] [bit] NOT NULL CONSTRAINT [DF__EM__emTKAdminApp__25077354] DEFAULT (0),
    [emUseTotalHrsAsStd] [bit] NOT NULL CONSTRAINT [DF__EM__emUseTotalHr__25FB978D] DEFAULT (0),
    [emJCSpecialOvtPct] [float] NULL ,
    [emProvCostSpecialOTPct] [float] NULL ,
    [emProvBillSpecialOTPct] [float] NULL ,
    [emCellPhone] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSupervisor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emCreateUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emCreateDate] [datetime] NULL ,
    [emLastUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emLastUpdateDate] [datetime] NULL ,
    CONSTRAINT [EMPK] PRIMARY KEY NONCLUSTERED
    (
        [emEmployee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EM Table | Deltek Advantage 9.0 Database

EMPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | emEmployee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EM Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EMInitiation Table

Description

Employee Initiation Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | emEmployee | Required. Employee number. | VarChar | 10 |
Primary Key | emRecType | Required. Record type. Valid options are A - Advantage and P - Project Workplace. | VarChar | 1 |
 | emApproved | Required. Variable indicating whether the employee has been approved for copying. | Boolean | 1 |
 | emSelected | Required. Variable indicating whether the employee has been selected for copying. | Boolean | 1 |
 | emErrorMsg | Error message. | VarChar | 255 |
 | emLastName | Employee’s last name. | VarChar | 20 |
 | emFirstName | Employee’s first name. | VarChar | 13 |
 | emJobCostRate | Employee’s job cost rate | Double | 9 |
 | emJobCostType | Variable indicating the job cost type. Valid options are H - Hourly and S - Salaried. | VarChar | 1 |
 | emJCOvtPct | Overtime percentage. | Double | 9 |
 | emTargetRatio | Percentage of hours that is expected to be charged by the employee. | Double | 9 |
 | emHoursPerDay | Number of hours worked per day. This field is used by the Timekeeper module if you select to check the hours entered by the expected hours for the employee. | Double | 9 |
 | emHireDate | Date of the employee’s hire. | DBTimeStamp | 4 |
 | emRaiseDate | Date of the employee’s next raise. | DBTimeStamp | 4 |
 | emStatus | Variable indicating the employee’s status. Valid options are A - Active; I - Inactive; and T - Terminated. | VarChar | 1 |
 | emType | Variable indicating the employee’s type. Valid options are P - Principal and E - Employee. | VarChar | 1 |
 | emProfCtr | Employee’s profit center. | VarChar | 8 |
 | emBillingCategory | Default category for the employee when using the By Category labor billing method. | SmallInt | 2 |
 | emBillingPool | Not used. | SmallInt | 2 |
 | emSSN | Employee’s social security number. | VarChar | 9 |
 | emAddress1 | First line of the employee’s address. | VarChar | 40 |
 | emAddress2 | Second line of the employee’s address. | VarChar | 40 |
 | emAddress3 | Third line of the employee’s address. | VarChar | 40 |
 | emCity | Employee’s city. | VarChar | 18 |
 | emState | Employee’s state. | VarChar | 2 |
 | emZIP | Employee’s zip code. | VarChar | 10 |
 | emCountry | Employee’s country. | VarChar | 12 |
 | emPhone | Employee’s telephone number. | VarChar | 24 |
 | emFAX | Employee’s telephone number. | VarChar | 24 |
 | emEMail | Employee’s email address. | VarChar | 50 |
 | emSelect1 | Employee sort/select code 1. | VarChar | 20 |
 | emSelect2 | Employee sort/select code 2. | VarChar | 20 |
 | emSelect3 | Employee sort/select code 3. | VarChar | 20 |
 | emSelect4 | Employee sort/select code 4. | VarChar | 20 |
 | emSelect5 | Employee sort/select code 5. | VarChar | 20 |
 | emSelect6 | Employee sort/select code 6. | VarChar | 20 |
 | emSelect7 | Employee sort/select code 7. | VarChar | 20 |
 | emSelect8 | Employee sort/select code 8. | VarChar | 20 |
 | emSelect9 | Employee sort/select code 9. | VarChar | 20 |
 | emSelect10 | Employee sort/select code 10. | VarChar | 20 |
 | emSelect11 | Employee sort/select code 11. | VarChar | 20 |
 | emSelect12 | Employee sort/select code 12. | VarChar | 20 |
 | emSelect13 | Employee sort/select code 13. | VarChar | 20 |
 | emSelect14 | Employee sort/select code 14. | VarChar | 20 |
 | emSelect15 | Employee sort/select code 15. | VarChar | 20 |
 | emSelect16 | Employee sort/select code 16. | Double | 9 |
 | emSelect17 | Employee sort/select code 17. | Double | 9 |
 | emSelect18 | Employee sort/select code 18. | Double | 9 |
 | emSelect19 | Employee sort/select code 19. | Double | 9 |
 | emSelect20 | Employee sort/select code 20. | Double | 9 |
 | emSelect21 | Employee sort/select code 21. | Double | 9 |
 | emSelect22 | Employee sort/select code 22. | Double | 9 |
 | emSelect23 | Employee sort/select code 23. | Double | 9 |
 | emSelect24 | Employee sort/select code 24. | Double | 9 |
 | emSelect25 | Employee sort/select code 25. | Double | 9 |
 | emSelect26 | Employee sort/select code 26. | DBTimeStamp | 4 |
 | emSelect27 | Employee sort/select code 27. | DBTimeStamp | 4 |
 | emSelect28 | Employee sort/select code 28. | DBTimeStamp | 4 |
 | emSelect29 | Employee sort/select code 29. | DBTimeStamp | 4 |
 | emSelect30 | Employee sort/select code 30. | DBTimeStamp | 4 |
 | emTKGroup | Employee’s Timekeeper group. | VarChar | 2 |
 | emTKAdminLevel | Employee’s Timekeeper administration level. | VarChar | 1 |
 | emTKAdminEdit | Variable indicating whether this Timekeeper user can edit timesheets for other employees in the same Timekeeper group. | Boolean | 1 |
 | emEKGroup | Employee’s Expensekeeper group. | VarChar | 2 |
 | emEKAdminLevel | Employee’s Expensekeeper administration level. | VarChar | 1 |
 | emEKAdminEdit | Variable indicating whether this Expensekeeper user can edit other timesheets for employees in the same Expensekeeper group. | Boolean | 1 |
 | emMemo | Memo field for comments on the employee. | LongVarChar | 16 |
 | emADPFileNumber | ADP employee number. | VarChar | 6 |
 | emADPCompanyCode | ADP company code. | VarChar | 3 |
 | emADPRateCode | ADP rate code. | VarChar | 1 |
 | emProvCostRate | Provisional cost rate for unposted time on interactive project reports. | Double | 9 |
 | emProvBillRate | Provisional billing rate for unposted time on Interactive Project reports. | Double | 9 |
 | emProvCostOTPct | Provisional cost rate for unposted overtime on Interactive Project reports. | Double | 9 |
 | emProvBillOTPct | Provisional billing rate for unposted overtime on Interactive Project reports. | Double | 9 |
 | emDefaultLC1 | Level 1 default labor code for Timekeeper timesheets. | VarChar | 5 |
 | emDefaultLC2 | Level 2 default labor code for Timekeeper timesheets. | VarChar | 5 |
 | emDefaultLC3 | Level 3 default labor code for Timekeeper timesheets. | VarChar | 5 |
 | emDefaultLC4 | Level 4 default labor code for Timekeeper timesheets. | VarChar | 5 |
 | emDefaultLC5 | Level 5 default labor code for Timekeeper timesheets. | VarChar | 5 |
 | emChangeDefaultLC | Variable indicating whether the employee can change the default labor code in Timekeeper. | Boolean | 1 |
 | emTerminationDate | The date on which the employee was terminated. | DBTimeStamp | 4 |
 | emTKAdminApproval | Variable indicating whether this employee’s timesheet needs approval. | Boolean | 1 |
 | emUseTotalHrsAsStd | Variable indicating whether to force the standard hours to be the total hours worked by this employee. | Boolean | 1 |
 | emJCSpecialOvtPct | The job costing special overtime percentage. | Double | 9 |
 | emProvCostSpecialOTPct | Provisional cost percentage for unposted special overtime in Interactive Project Reports. | Double | 9 |
 | emProvBillSpecialOTPct | Provisional billing percentage for unposted special overtime in Interactive Project Reports. | Double | 9 |
 | emCellPhone | Employee's cell phone number. | VarChar | 24 |
 | emSupervisor | Reserved for future use. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
EMInitiationPK |  |  |

SQL

CREATE TABLE [EMInitiation] (
    [emEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [emRecType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [emApproved] [bit] NOT NULL CONSTRAINT [DF__EMInitiat__emApp__28D80438] DEFAULT (0),
    [emSelected] [bit] NOT NULL CONSTRAINT [DF__EMInitiat__emSel__29CC2871] DEFAULT (0),
    [emErrorMsg] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emLastName] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emFirstName] [varchar] (13) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emJobCostRate] [float] NULL ,
    [emJobCostType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emJCOvtPct] [float] NULL ,
    [emTargetRatio] [float] NULL ,
    [emHoursPerDay] [float] NULL ,
    [emHireDate] [datetime] NULL ,
    [emRaiseDate] [datetime] NULL ,
    [emStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emBillingCategory] [smallint] NULL ,
    [emBillingPool] [smallint] NULL ,
    [emSSN] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emAddress3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emZIP] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emCountry] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emPhone] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emFAX] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emEMail] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect1] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect2] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect3] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect4] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect5] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect6] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect7] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect8] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect9] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect10] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect11] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect12] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect13] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect14] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect15] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSelect16] [float] NULL ,
    [emSelect17] [float] NULL ,
    [emSelect18] [float] NULL ,
    [emSelect19] [float] NULL ,
    [emSelect20] [float] NULL ,
    [emSelect21] [float] NULL ,
    [emSelect22] [float] NULL ,
    [emSelect23] [float] NULL ,
    [emSelect24] [float] NULL ,
    [emSelect25] [float] NULL ,
    [emSelect26] [datetime] NULL ,
    [emSelect27] [datetime] NULL ,
    [emSelect28] [datetime] NULL ,
    [emSelect29] [datetime] NULL ,
    [emSelect30] [datetime] NULL ,
    [emTKGroup] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emTKAdminLevel] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emTKAdminEdit] [bit] NOT NULL CONSTRAINT [DF__EMInitiat__emTKA__2AC04CAA] DEFAULT (0),
    [emEKGroup] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emEKAdminLevel] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emEKAdminEdit] [bit] NOT NULL CONSTRAINT [DF__EMInitiat__emEKA__2BB470E3] DEFAULT (0),
    [emMemo] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emADPFileNumber] [varchar] (6) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emADPCompanyCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emADPRateCode] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emProvCostRate] [float] NULL ,
    [emProvBillRate] [float] NULL ,
    [emProvCostOTPct] [float] NULL ,
    [emProvBillOTPct] [float] NULL ,
    [emDefaultLC1] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emDefaultLC2] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emDefaultLC3] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emDefaultLC4] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emDefaultLC5] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emChangeDefaultLC] [bit] NOT NULL CONSTRAINT [DF__EMInitiat__emCha__2CA8951C] DEFAULT (0),
    [emTerminationDate] [datetime] NULL ,
    [emTKAdminApproval] [bit] NOT NULL CONSTRAINT [DF__EMInitiat__emTKA__2D9CB955] DEFAULT (0),
    [emUseTotalHrsAsStd] [bit] NOT NULL CONSTRAINT [DF__EMInitiat__emUse__2E90DD8E] DEFAULT (0),
    [emJCSpecialOvtPct] [float] NULL ,
    [emProvCostSpecialOTPct] [float] NULL ,
    [emProvBillSpecialOTPct] [float] NULL ,
    [emCellPhone] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [emSupervisor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [EMInitiationPK] PRIMARY KEY NONCLUSTERED
    (
        [emEmployee],
        [emRecType]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMInitiation Table | Deltek Advantage 9.0 Database

EMInitiationPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | emEmployee |  | Ascending
Primary Key | emRecType |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMInitiation Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EMP Table

Description

Employee Payroll Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | empEmployee | Required. Employee number. | VarChar | 10 |
 | empSelPeriod | Fiscal period associated with the posting run. | Integer | 4 |
 | empSelPostSeq | Posting sequence number. | SmallInt | 2 |
 | empPayRate | Employee’s pay rate. This field is dependent on the employee’s pay type. | Double | 9 |
 | empPayType | Variable indicating the employee’s pay type. Valid options are H - Hourly and S - Salaried. | VarChar | 1 |
 | empPayOvtPct | Employee’s payroll overtime percentage. | Double | 9 |
 | empUnpaidRegHrs | Regular hours posted since the last processed payroll. | Double | 9 |
 | empRegHrsToBePaid | Regular hours to be paid by the next payroll processing run. | Double | 9 |
 | empRegHrsOverride | Variable indicating whether the regular hours are to be paid a user override. | Boolean | 1 |
 | empCurrentRegPay | Current regular pay. | Double | 9 |
 | empUnpaidOvtHrs | Overtime hours posted since the last processed payroll. | Double | 9 |
 | empOvtHrsToBePaid | Overtime hours to be paid by the next payroll processing run. | Double | 9 |
 | empOvtHrsOverride | Variable indicating whether the overtime hours are to be paid a user override. | Boolean | 1 |
 | empCurrentOvtPay | Current overtime pay. | Double | 9 |
 | empOtherPay | Other pay to include in regular payroll processing runs for the employee. | Double | 9 |
 | empCurrentOtherPay | Other pay to include in this run for the employee. | Double | 9 |
 | empOtherPayOverride | Variable indicating whether the other pay amount to be paid is a user override. | Boolean | 1 |
 | empRegHrsAdjust | Regular hours to include in the next payroll adjustment run. | Double | 9 |
 | empRegPayAdjust | Regular pay to include in the next payroll adjustment run. | Double | 9 |
 | empOvtHrsAdjust | Overtime hours to include in the next payroll adjustment run. | Double | 9 |
 | empOvtPayAdjust | Overtime pay to include in the next payroll adjustment run. | Double | 9 |
 | empOtherPayAdjust | Other pay to include in the next payroll adjustment run. | Double | 9 |
 | empRegPayBonus | Regular pay to include in the next payroll adjustment run. | Double | 9 |
 | empOtherPayBonus | Gross other pay bonus amount for the next bonus run. | Double | 9 |
 | empPaySpecialOvtPct | Special overtime payroll percentage. | Double | 9 |
 | empUnpaidSpecialOvtHrs | Special overtime hours posted since last payroll. | Double | 9 |
 | empSpecialOvtHrsToBePaid | Special overtime hours to be paid by next payroll. | Double | 9 |
 | empSpecialOvtHrsOverride | Variable indicating whether the special overtime hours to be paid are user keyed override. | Boolean | 1 |
 | empCurrentSpecialOvtPay | Current special overtime pay. | Double | 9 |
 | empSpecialOvtHrsAdjust | Special overtime hours for next payroll adjustment. | Double | 9 |
 | empSpecialOvtPayAdjust | Special overtime pay for next payroll adjustment. | Double | 9 |

Indexes

Index | Description | Primary | Unique
EMPPK |  |  |
empSelPeriodIDX |  |  |

SQL

CREATE TABLE [EMP] (
    [empEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empSelPeriod] [int] NULL ,
    [empSelPostSeq] [smallint] NULL ,
    [empPayRate] [float] NULL ,
    [empPayType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empPayOvtPct] [float] NULL ,
    [empUnpaidRegHrs] [float] NULL ,
    [empRegHrsToBePaid] [float] NULL ,
    [empRegHrsOverride] [bit] NOT NULL CONSTRAINT [DF__EMP__empRegHrsOv__1699586C] DEFAULT (0),
    [empCurrentRegPay] [float] NULL ,
    [empUnpaidOvtHrs] [float] NULL ,
    [empOvtHrsToBePaid] [float] NULL ,
    [empOvtHrsOverride] [bit] NOT NULL CONSTRAINT [DF__EMP__empOvtHrsOv__178D7CA5] DEFAULT (0),
    [empCurrentOvtPay] [float] NULL ,
    [empOtherPay] [float] NULL ,
    [empCurrentOtherPay] [float] NULL ,
    [empOtherPayOverride] [bit] NOT NULL CONSTRAINT [DF__EMP__empOtherPay__1881A0DE] DEFAULT (0),
    [empRegHrsAdjust] [float] NULL ,
    [empRegPayAdjust] [float] NULL ,
    [empOvtHrsAdjust] [float] NULL ,
    [empOvtPayAdjust] [float] NULL ,
    [empOtherPayAdjust] [float] NULL ,
    [empRegPayBonus] [float] NULL ,
    [empOtherPayBonus] [float] NULL ,
    [empPaySpecialOvtPct] [float] NULL ,
    [empUnpaidSpecialOvtHrs] [float] NULL ,
    [empSpecialOvtHrsToBePaid] [float] NULL ,
    [empSpecialOvtHrsOverride] [bit] NOT NULL CONSTRAINT [DF__EMP__empSpecialO__1975C517] DEFAULT (0),
    [empCurrentSpecialOvtPay] [float] NULL ,
    [empSpecialOvtHrsAdjust] [float] NULL ,
    [empSpecialOvtPayAdjust] [float] NULL ,
    CONSTRAINT [EMPPK] PRIMARY KEY NONCLUSTERED
    (
        [empEmployee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMP Table | Deltek Advantage 9.0 Database

EMPPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empEmployee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMP Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMP Table | Deltek Advantage 9.0 Database

empSelPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
empSelPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMP Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EMPA Table

Description

Employee Payroll Table - Accruals

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | empaEmployee | Required. Employee name. | VarChar | 10 |
Primary Key | empaCode | Required. Accrual plan code to apply to the employee. | VarChar | 10 |
 | empaHoursPerYear | Number of hours to accrue each benefit year for the employee. | Double | 9 |
 | empaChangeDate | Next change date for the employee accrual. | DBTimeStamp | 4 |
 | empaCurrentEarned | Total hours to accrue by the next regular payroll processing run. | Double | 9 |
 | empaOverride | Variable indicating whether to accrue the hours by the next regular payroll processing run. | Boolean | 1 |
 | empaCurrentTaken | Total hours taken by the employee since the last regular payroll processing run. | Double | 9 |
 | empaAdjust | Total accrual hours to accrue for the next regular payroll processing run. | Double | 9 |
 | empaHoursToAccrue | Hours to accrue since last payroll. | Double | 9 |

Indexes

Index | Description | Primary | Unique
EMPAPK |  |  |

SQL

CREATE TABLE [EMPA] (
    [empaEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empaCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empaHoursPerYear] [float] NULL ,
    [empaChangeDate] [datetime] NULL ,
    [empaCurrentEarned] [float] NULL ,
    [empaOverride] [bit] NOT NULL CONSTRAINT [DF__EMPA__empaOverri__1B5E0D89] DEFAULT (0),
    [empaCurrentTaken] [float] NULL ,
    [empaAdjust] [float] NULL ,
    [empaHoursToAccrue] [float] NULL ,
    CONSTRAINT [EMPAPK] PRIMARY KEY NONCLUSTERED
    (
        [empaEmployee],
        [empaCode]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMPA Table | Deltek Advantage 9.0 Database

EMPAPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empaEmployee |  | Ascending
Primary Key | empaCode |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMPA Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EMPAD Table

Description

Employee Payroll Table - Accrual Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | empadEmployee | Required. Employee number. | VarChar | 10 |
Primary Key | empadCode | Required. Accrual plan code. | VarChar | 10 |
Primary Key | empadPeriod | Required. Fiscal year and period in which the posting occurred. | Integer | 4 |
Primary Key | empadPostSeq | Required. Posting sequence number. | SmallInt | 2 |
 | empadEarned | Hours earned (or accrued) for the payroll processing run. | Double | 9 |
 | empadOverride | Variable indicating whether to accrue hours by the next regular payroll processing run. | Boolean | 1 |
 | empadTaken | Total hours taken since the last regular payroll processing run. | Double | 9 |
 | empadEarnedSinceLastPayroll | Accrual hours earned since the last Payroll Processing run. | Double | 9 |
 | empadTakenSinceLastPayroll | Accrual hours taken since the last Payroll Processing run. | Double | 9 |

Indexes

Index | Description | Primary | Unique
EMPADPK |  |  |
empadPeriodIDX |  |  |

SQL

CREATE TABLE [EMPAD] (
    [empadEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empadCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empadPeriod] [int] NOT NULL ,
    [empadPostSeq] [smallint] NOT NULL ,
    [empadEarned] [float] NULL ,
    [empadOverride] [bit] NOT NULL CONSTRAINT [DF__EMPAD__empadOver__1D4655FB] DEFAULT (0),
    [empadTaken] [float] NULL ,
    [empadEarnedSinceLastPayroll] [float] NULL ,
    [empadTakenSinceLastPayroll] [float] NULL ,
    CONSTRAINT [EMPADPK] PRIMARY KEY NONCLUSTERED
    (
        [empadEmployee],
        [empadCode],
        [empadPeriod],
        [empadPostSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMPAD Table | Deltek Advantage 9.0 Database

EMPADPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empadEmployee |  | Ascending
Primary Key | empadCode |  | Ascending
Primary Key | empadPeriod |  | Ascending
Primary Key | empadPostSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMPAD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMPAD Table | Deltek Advantage 9.0 Database

empadPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empadPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMPAD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EMPD Table

Description

Employee Payroll Table - General Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | empdEmployee | Required. Employee number. | VarChar | 10 |
Primary Key | empdPeriod | Required. Fiscal year and period in which the posting occurred. | Integer | 4 |
Primary Key | empdPostSeq | Required. Posting sequence number. | SmallInt | 2 |
 | empdRegHrs | Regular hours paid. | Double | 9 |
 | empdRegHrsOverride | Variable indicating whether the regular hours are a user-keyed override. | Boolean | 1 |
 | empdOvtHrs | Regular hours paid. | Double | 9 |
 | empdOvtHrsOverride | Variable indicating whether the overtime hours are a user-keyed override. | Boolean | 1 |
 | empdRegPay | Employee’s regular pay. | Double | 9 |
 | empdOvtPay | Employee’s overtime pay. | Double | 9 |
 | empdOtherPay | Employee’s other pay. | Double | 9 |
 | empdOtherPayOverride | Variable indicating whether the other pay amount is a user-keyed override. | Boolean | 1 |
 | empdPayRate | Employee’s pay rate. | Double | 9 |
 | empdPayType | Employee’s pay type. | VarChar | 1 |
 | empdPayOvtPct | Employee’s overtime percentage for payroll. | Double | 9 |
 | empdBankCode | Bank code assigned to the transaction during data entry. | VarChar | 10 |
 | empdCheck | Check number assigned during payroll processing. | VarChar | 7 |
 | empdSpecialOvtHrs | Special overtime hours paid. | Double | 9 |
 | empdSpecialOvtHrsOverride | Variable indicating whether the special overtime hours are a user-keyed override. | Boolean | 1 |
 | empdSpecialOvtPay | Special overtime pay. | Double | 9 |
 | empdPaySpecialOvtPct | Special overtime percentage. | Double | 9 |

Indexes

Index | Description | Primary | Unique
EMPDPK |  |  |
empdPeriodIDX |  |  |

SQL

CREATE TABLE [EMPD] (
    [empdEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empdPeriod] [int] NOT NULL ,
    [empdPostSeq] [smallint] NOT NULL ,
    [empdRegHrs] [float] NULL ,
    [empdRegHrsOverride] [bit] NOT NULL CONSTRAINT [DF__EMPD__empdRegHrs__1F2E9E6D] DEFAULT (0),
    [empdOvtHrs] [float] NULL ,
    [empdOvtHrsOverride] [bit] NOT NULL CONSTRAINT [DF__EMPD__empdOvtHrs__2022C2A6] DEFAULT (0),
    [empdRegPay] [float] NULL ,
    [empdOvtPay] [float] NULL ,
    [empdOtherPay] [float] NULL ,
    [empdOtherPayOverride] [bit] NOT NULL CONSTRAINT [DF__EMPD__empdOtherP__2116E6DF] DEFAULT (0),
    [empdPayRate] [float] NULL ,
    [empdPayType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empdPayOvtPct] [float] NULL ,
    [empdBankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empdCheck] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empdSpecialOvtHrs] [float] NULL ,
    [empdSpecialOvtHrsOverride] [bit] NOT NULL CONSTRAINT [DF__EMPD__empdSpecia__220B0B18] DEFAULT (0),
    [empdSpecialOvtPay] [float] NULL ,
    [empdPaySpecialOvtPct] [float] NULL ,
    CONSTRAINT [EMPDPK] PRIMARY KEY NONCLUSTERED
    (
        [empdEmployee],
        [empdPeriod],
        [empdPostSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMPD Table | Deltek Advantage 9.0 Database

EMPDPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empdEmployee |  | Ascending
Primary Key | empdPeriod |  | Ascending
Primary Key | empdPostSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMPD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMPD Table | Deltek Advantage 9.0 Database

empdPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empdPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMPD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EMPE Table

Description

Employee Payroll Table - Direct Deposit Status/Calculations

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | empeEmployee | Required. Employee number. | VarChar | 10 |
Primary Key | empeSeq | Required. Internal sequence number. | Integer | 4 |
 | empeBankID | Bank identification number. | VarChar | 8 |
 | empeAccount | Bank account number. | VarChar | 17 |
 | empeAccountType | Variable indicating the bank account type. Valid options are C - Checking and S - Savings. | VarChar | 1 |
 | empeMethod | Variable indicating the method used to allocate the direct deposit amount to the account. Valid options are A - Amount; P - Percent; and N - None. | VarChar | 1 |
 | empeAmtPct | Amount/percentage to the net pay to allocate to the account. | Double | 9 |
 | empeStatus | Variable indicating the direct deposit status for the employee. Valid options are A - Add; W - Wait; and A - Active. | VarChar | 1 |
 | empeCurrentAmt | Total current amount to be allocated to the account. | Double | 9 |
 | empeOverride | Variable indicating whether the current amount is a user-keyed override. | Boolean | 1 |
 | empeexMethod | Indicates the calculation method to be used for allocations to this account for employee expense payments. | VarChar | 1 |
 | empeexAmtPct | The amount/percentage of net pay to allocate to this account for employee expense payments. | Double | 9 |

Indexes

Index | Description | Primary | Unique
EMPEPK |  |  |

SQL

CREATE TABLE [EMPE] (
    [empeEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empeSeq] [int] NOT NULL ,
    [empeBankID] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empeAccount] [varchar] (17) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empeAccountType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empeMethod] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empeAmtPct] [float] NULL ,
    [empeStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empeCurrentAmt] [float] NULL ,
    [empeOverride] [bit] NOT NULL CONSTRAINT [DF__EMPE__empeOverri__23F3538A] DEFAULT (0),
    [empeexMethod] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empeexAmtPct] [float] NULL ,
    CONSTRAINT [EMPEPK] PRIMARY KEY NONCLUSTERED
    (
        [empeEmployee],
        [empeSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMPE Table | Deltek Advantage 9.0 Database

EMPEPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empeEmployee |  | Ascending
Primary Key | empeSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMPE Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EMPED Table

Description

Employee Payroll Table - Direct Deposit Postings

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | empedEmployee | Required. Employee number. | VarChar | 10 |
Primary Key | empedSeq | Required. Internal sequence number. | Integer | 4 |
Primary Key | empedPeriod | Required. Fiscal year and period in which the posting occurred. | Integer | 4 |
Primary Key | empedPostSeq | Required. Posting sequence number. | SmallInt | 2 |
 | empedBankID | Bank identification number. | VarChar | 8 |
 | empedAccount | Bank account number. | VarChar | 17 |
 | empedAccountType | Variable indicating the account type. Valid options are C - Checking and S - Savings. | VarChar | 1 |
 | empedMethod | Variable indicating the method used to allocate the direct deposit amount to the account. Valid options are A - Amount; P - Percent; and N - None. | VarChar | 1 |
 | empedAmtPct | Amount/percentage to the net pay to allocate to the account. | Double | 9 |
 | empedStatus | Variable indicating the direct deposit status for the employee. | VarChar | 1 |
 | empedAmount | Total amount to be allocated to the account. | Double | 9 |
 | empedOverride | Variable indicating whether the amount is a user-keyed override. | Boolean | 1 |
 | empedSourceBankCode | Indicates the bank code for the bank sending the payment. Always used for Expensekeeper direct deposit; not always necessary for Payroll direct deposit. | VarChar | 10 |
 | empedCheckRefNo | Indicates the check number associated with this payment. Necessary for Expense Void; not used by Payroll. | VarChar | 7 |

Indexes

Index | Description | Primary | Unique
EMPEDPK |  |  |
empedPeriodIDX |  |  |

SQL

CREATE TABLE [EMPED] (
    [empedEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empedSeq] [int] NOT NULL ,
    [empedPeriod] [int] NOT NULL ,
    [empedPostSeq] [smallint] NOT NULL ,
    [empedBankID] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empedAccount] [varchar] (17) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empedAccountType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empedMethod] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empedAmtPct] [float] NULL ,
    [empedStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empedAmount] [float] NULL ,
    [empedOverride] [bit] NOT NULL CONSTRAINT [DF__EMPED__empedOver__25DB9BFC] DEFAULT (0),
    [empedSourceBankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empedCheckRefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [EMPEDPK] PRIMARY KEY NONCLUSTERED
    (
        [empedEmployee],
        [empedSeq],
        [empedPeriod],
        [empedPostSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMPED Table | Deltek Advantage 9.0 Database

EMPEDPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empedEmployee |  | Ascending
Primary Key | empedSeq |  | Ascending
Primary Key | empedPeriod |  | Ascending
Primary Key | empedPostSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMPED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMPED Table | Deltek Advantage 9.0 Database

empedPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empedPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMPED Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EMPW Table

Description

Employee Payroll Table - Withholdings

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | empwEmployee | Required. Employee number. | VarChar | 10 |
Primary Key | empwCode | Required. Withholding code. | VarChar | 10 |
 | empwMethod | Variable indicating the withholding calculation method. Valid options are A - Amount; P - Percent; S - System; and N - None. | VarChar | 1 |
 | empwAmtPct | Amount/percentage of the net pay to allocate to the withholding. | Double | 9 |
 | empwSuppress | Variable indicating whether to suppress the withholding for the employee. | Boolean | 1 |
 | empwFilingStatus | Filing status for the employee for the withholding, if applicable. | VarChar | 1 |
 | empwExemptions | Number of exemptions for the withholding. | SmallInt | 2 |
 | empwAdditionalAmt | Flat amount to be withheld in addition to the system withheld amount. | Double | 9 |
 | empwOtherExemptions | Number of additional exemptions. | SmallInt | 2 |
 | empwLimit | Limit at which to stop the withholding. | Double | 9 |
 | empwCurrentAmt | Current withholding amount reserved for the next payroll processing run. | Double | 9 |
 | empwOverride | Variable indicating whether the current withholding amount is reserved for the next payroll processing run. | Boolean | 1 |
 | empwAdjust | Variable indicating the withholding adjustment for the next payroll processing run. | Double | 9 |

Indexes

Index | Description | Primary | Unique
EMPWPK |  |  |

SQL

CREATE TABLE [EMPW] (
    [empwEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empwCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empwMethod] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empwAmtPct] [float] NULL ,
    [empwSuppress] [bit] NOT NULL CONSTRAINT [DF__EMPW__empwSuppre__27C3E46E] DEFAULT (0),
    [empwFilingStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empwExemptions] [smallint] NULL ,
    [empwAdditionalAmt] [float] NULL ,
    [empwOtherExemptions] [smallint] NULL ,
    [empwLimit] [float] NULL ,
    [empwCurrentAmt] [float] NULL ,
    [empwOverride] [bit] NOT NULL CONSTRAINT [DF__EMPW__empwOverri__28B808A7] DEFAULT (0),
    [empwAdjust] [float] NULL ,
    CONSTRAINT [EMPWPK] PRIMARY KEY NONCLUSTERED
    (
        [empwEmployee],
        [empwCode]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMPW Table | Deltek Advantage 9.0 Database

EMPWPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empwEmployee |  | Ascending
Primary Key | empwCode |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMPW Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EMPWD Table

Description

Employee Payroll Table - Withholding Postings

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | empwdEmployee | Required. Employee number. | VarChar | 10 |
Primary Key | empwdCode | Required. Withholding code. | VarChar | 10 |
Primary Key | empwdPeriod | Required. Fiscal year and period in which the posting occurred. | Integer | 4 |
Primary Key | empwdPostSeq | Required. Posting sequence number. | SmallInt | 2 |
 | empwdMethod | Variable indicating the withholding calculation method. Valid options are A - Amount; P - Percent; S - System; and N - None. | VarChar | 1 |
 | empwdAmtPct | Amount/percentage to the net pay to allocate to the withholding. | Double | 9 |
 | empwdSuppress | Variable indicating whether to suppress the withholding for the employee. | Boolean | 1 |
 | empwdLimit | Limit at which to stop the withholding. | Double | 9 |
 | empwdGrossPayBasis | Gross pay basis. | Double | 9 |
 | empwdAmount | Total amount withheld. | Double | 9 |
 | empwdOverride | Variable indicating whether the current withholding amount is reserved for the next payroll processing run. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
EMPWDPK |  |  |
empwdPeriodIDX |  |  |

SQL

CREATE TABLE [EMPWD] (
    [empwdEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empwdCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [empwdPeriod] [int] NOT NULL ,
    [empwdPostSeq] [smallint] NOT NULL ,
    [empwdMethod] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [empwdAmtPct] [float] NULL ,
    [empwdSuppress] [bit] NOT NULL CONSTRAINT [DF__EMPWD__empwdSupp__2AA05119] DEFAULT (0),
    [empwdLimit] [float] NULL ,
    [empwdGrossPayBasis] [float] NULL ,
    [empwdAmount] [float] NULL ,
    [empwdOverride] [bit] NOT NULL CONSTRAINT [DF__EMPWD__empwdOver__2B947552] DEFAULT (0),
    CONSTRAINT [EMPWDPK] PRIMARY KEY NONCLUSTERED
    (
        [empwdEmployee],
        [empwdCode],
        [empwdPeriod],
        [empwdPostSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMPWD Table | Deltek Advantage 9.0 Database

EMPWDPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empwdEmployee |  | Ascending
Primary Key | empwdCode |  | Ascending
Primary Key | empwdPeriod |  | Ascending
Primary Key | empwdPostSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMPWD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMPWD Table | Deltek Advantage 9.0 Database

empwdPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | empwdPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMPWD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EMTKGroups Table

Description

Timekeeper Table – Employee Groups

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Employee | Employee number. | VarChar | 10 |
Primary Key | TKGroup | Group number. | VarChar | 2 |
 | AllowEdit | Variable indicating whether the employee has the authority to edit timesheets. | Boolean | 1 |
 | AllowApproval | Variable indicating whether the employee has the authority to approve timesheets. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
EMTKGroupsPK |  |  |

SQL

CREATE TABLE [EMTKGroups] (
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TKGroup] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [AllowEdit] [bit] NOT NULL CONSTRAINT [DF__EMTKGroup__Allow__2D7CBDC4] DEFAULT (0),
    [AllowApproval] [bit] NOT NULL CONSTRAINT [DF__EMTKGroup__Allow__2E70E1FD] DEFAULT (0),
    CONSTRAINT [EMTKGroupsPK] PRIMARY KEY NONCLUSTERED
    (
        [Employee],
        [TKGroup]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EMTKGroups Table | Deltek Advantage 9.0 Database

EMTKGroupsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Employee |  | Ascending
Primary Key | TKGroup |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EMTKGroups Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

erControl Table

Description

Employee Repayment Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether this file has been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether this transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the transaction file. | VarChar | 15 |
 | Period | Fiscal period and year for the transaction file. | Integer | 4 |
 | EndDate | End date for the transaction file. | DBTimeStamp | 4 |
 | Total | Total entered for the transaction file. | Double | 9 |
 | PostPeriod | Period in which the employee repayment data entry transaction file was posted.. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the employee repayment data entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
erControlPK |  |  |

SQL

CREATE TABLE [erControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__erControl__Recur__21F5FC7F] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__erControl__Selec__22EA20B8] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__erControl__Poste__23DE44F1] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [EndDate] [datetime] NULL ,
    [Total] [float] NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__erControl__PostP__24D2692A] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__erControl__PostS__25C68D63] DEFAULT (0),
    CONSTRAINT [erControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

erControl Table | Deltek Advantage 9.0 Database

erControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

erControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

erDetail Table

Description

Employee Repayment Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the data entry transaction file. | VarChar | 15 |
Primary Key | RefNo | Required. Reference number. | VarChar | 7 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | Description | Description entered for the transaction. | VarChar | 40 |
 | Employee | Employee number to which the amount applies. | VarChar | 10 |
 | BankCode | Bank code used for the transaction. | VarChar | 10 |
 | Amount | Amount of the transaction. | Double | 9 |

Indexes

Index | Description | Primary | Unique
erDetailPK |  |  |

SQL

CREATE TABLE [erDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    CONSTRAINT [erDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [RefNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

erDetail Table | Deltek Advantage 9.0 Database

erDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | RefNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

erDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

erMaster Table

Description

Employee Repayment Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the data entry transaction file. | VarChar | 15 |
Primary Key | RefNo | Required. Reference number. | VarChar | 7 |
 | TransDate | Transaction date. | DBTimeStamp | 4 |
 | TransComment | Transaction comment. | VarChar | 40 |
 | Posted | Variable indicating whether the data entry file has been posted. | VarChar | 1 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
erMasterPK |  |  |

SQL

CREATE TABLE [erMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransDate] [datetime] NULL ,
    [TransComment] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__erMaster__Posted__6C5905DD] DEFAULT ('N'),
    [Seq] [int] NULL ,
    CONSTRAINT [erMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [RefNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

erMaster Table | Deltek Advantage 9.0 Database

erMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | RefNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

erMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

ETChargeGroupMP Table

Description

ET Interface Table - Charge Group Mappings

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Seq | Sequence number. | Integer | 4 |
 | Segment1 | Column name in Advantage containing the first part of this charge group. | VarChar | 40 |
 | Segment2 | Column name in Advantage containing the second part of this charge group. | VarChar | 40 |
 | Segment3 | Column name in Advantage containing the third part of this charge group. | VarChar | 40 |
 | Segment4 | Column name in Advantage containing the fourth part of this charge group. | VarChar | 40 |
 | SegmentDesc1 | Column name in Advantage containing the description of the first part of this charge group. | VarChar | 40 |
 | SegmentDesc2 | Column name in Advantage containing the description of the second part of this charge group. | VarChar | 40 |
 | SegmentDesc3 | Column name in Advantage containing the description of the third part of this charge group. | VarChar | 40 |
 | SegmentDesc4 | Column name in Advantage containing the description of the fourth part of this charge group. | VarChar | 40 |
 | AdvTable1 | Expression which contains the FROM portion of a SQL statement to get the information needed for the queries. | VarChar | 255 |
 | AdvTable2 | Expression which contains the FROM portion of a SQL statement to get the information needed for the queries. | VarChar | 255 |
 | AdvTable3 | Expression which contains the FROM portion of a SQL statement to get the information needed for the queries. | VarChar | 255 |
 | AdvTable4 | Expression which contains the FROM portion of a SQL statement to get the information needed for the queries. | VarChar | 255 |
 | WhereClause1 | Optional. Where clause 1. | VarChar | 100 |
 | WhereClause2 | Optional. Where clause 2. | VarChar | 100 |
 | WhereClause3 | Optional. Where clause 3. | VarChar | 100 |
 | WhereClause4 | Optional. Where clause 4. | VarChar | 100 |

Indexes

Index | Description | Primary | Unique
ETChargeGroupMPPK |  |  |

SQL

CREATE TABLE [ETChargeGroupMP] (
    [Seq] [int] NOT NULL ,
    [Segment1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Segment2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Segment3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Segment4] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SegmentDesc1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SegmentDesc2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SegmentDesc3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SegmentDesc4] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AdvTable1] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AdvTable2] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AdvTable3] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AdvTable4] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [WhereClause1] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [WhereClause2] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [WhereClause3] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [WhereClause4] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [ETChargeGroupMPPK] PRIMARY KEY NONCLUSTERED
    (
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ETChargeGroupMP Table | Deltek Advantage 9.0 Database

ETChargeGroupMPPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ETChargeGroupMP Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

ETLeaveMP Table

Description

ET Interface Table - Employee Leave Mappings

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Seq | Required. Sequence number. | Integer | 4 |
 | LeavePlanName | Required. Name of the leave plan. | VarChar | 30 |
 | ProjectTask | Required. Column name in Advantage. It contains a project, plus space, plus task with delimiters. This is the project the employee charges hours for this leave plan. | VarChar | 20 |
 | LeaveDate | Required. Column name in Advantage containing the effective date for this leave plan. | VarChar | 25 |
 | LeaveHrs | Required. Column name in Advantage containing the leave hours balance. | VarChar | 25 |
 | AdvTable | Not used at this time. | VarChar | 255 |

Indexes

Index | Description | Primary | Unique
ETLeaveMPPK |  |  |

SQL

CREATE TABLE [ETLeaveMP] (
    [Seq] [int] NOT NULL ,
    [LeavePlanName] [varchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjectTask] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LeaveDate] [varchar] (25) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LeaveHrs] [varchar] (25) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AdvTable] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [ETLeaveMPPK] PRIMARY KEY NONCLUSTERED
    (
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ETLeaveMP Table | Deltek Advantage 9.0 Database

ETLeaveMPPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ETLeaveMP Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

ETMapping Table

Description

ET Interface Table - Field Mappings

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ETColumnName | Required. Name of the etColumn. | VarChar | 25 |
Primary Key | ETTableName | Required. ET staging table. | VarChar | 25 |
Primary Key | AdvSeq | Required. Sequence number. Used to distinguish sets of mapping fields when many Advantage columns are going into a single set of ET columns. When this is a one to one relationship, the value of this field is always one. | Integer | 4 |
 | ADVColumnName | Name of the Advantage column, or NULL if not mapping. | VarChar | 75 |
 | ETDataType | Data type of this ET column. | VarChar | 25 |

Indexes

Index | Description | Primary | Unique
ETMappingPK |  |  |

SQL

CREATE TABLE [ETMapping] (
    [ETColumnName] [varchar] (25) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ETTableName] [varchar] (25) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [AdvSeq] [int] NOT NULL ,
    [ADVColumnName] [varchar] (75) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ETDataType] [varchar] (25) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [ETMappingPK] PRIMARY KEY NONCLUSTERED
    (
        [ETColumnName],
        [ETTableName],
        [AdvSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ETMapping Table | Deltek Advantage 9.0 Database

ETMappingPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ETColumnName |  | Ascending
Primary Key | ETTableName |  | Ascending
Primary Key | AdvSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ETMapping Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EX Table

Description

Expense Report Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | exEmployee | Required. Employee number. | VarChar | 10 |
Primary Key | exVoucher | Required. Voucher number for the expense report. | VarChar | 7 |
 | exPeriod | Period in which the expense report was posted. | Integer | 4 |
 | exReportName | Name of the expense report. | VarChar | 40 |
 | exReportDate | Date of the expense report. | DBTimeStamp | 4 |
 | exBank | Bank code to be used when paying the expense report. | VarChar | 10 |
 | exAppliedAdvanceOverride | Override for the expense report, entered through employee payment processing (default is Null). | Double | 9 |
 | exSelPeriod | Employee payment processing period in which the expense report has been selected. | Integer | 4 |
 | exSelPostSeq | Employee payment processing posting sequence in which the expense report has been selected. | Integer | 4 |
 | exPaidPeriod | Period in which the expense report was paid (default is Null). | Integer | 4 |

Indexes

Index | Description | Primary | Unique
EXPK |  |  |

SQL

CREATE TABLE [EX] (
    [exEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [exVoucher] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [exPeriod] [int] NULL ,
    [exReportName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [exReportDate] [datetime] NULL ,
    [exBank] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [exAppliedAdvanceOverride] [float] NULL ,
    [exSelPeriod] [int] NULL ,
    [exSelPostSeq] [int] NULL ,
    [exPaidPeriod] [int] NULL ,
    CONSTRAINT [EXPK] PRIMARY KEY NONCLUSTERED
    (
        [exEmployee],
        [exVoucher]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EX Table | Deltek Advantage 9.0 Database

EXPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | exEmployee |  | Ascending
Primary Key | exVoucher |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EX Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

EXAdvance Table

Description

Employee Advances Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Employee | Required. Employee who will receive the advance. | VarChar | 10 |
Primary Key | Period | Required. Period of the employee payment processing run in which the advance will be paid. | Integer | 4 |
Primary Key | PostSeq | Required. Posting sequence of the employee payment processing run in which the advance will be paid. | Integer | 4 |
 | Bank | Bank code for the advance check. | VarChar | 10 |
 | Amount | Amount of the advance. | Double | 9 |

Indexes

Index | Description | Primary | Unique
EXAdvancePK |  |  |

SQL

CREATE TABLE [EXAdvance] (
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Period] [int] NOT NULL ,
    [PostSeq] [int] NOT NULL ,
    [Bank] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    CONSTRAINT [EXAdvancePK] PRIMARY KEY NONCLUSTERED
    (
        [Employee],
        [Period],
        [PostSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

EXAdvance Table | Deltek Advantage 9.0 Database

EXAdvancePK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Employee |  | Ascending
Primary Key | Period |  | Ascending
Primary Key | PostSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

EXAdvance Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

exChecks Table

Description

Expense Report Checks Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Period | Required. Period of the employee payment processing run. | Integer | 4 |
Primary Key | PostSeq | Required. Posting sequence of the employee payment processing run. | Integer | 4 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
Primary Key | Seq | Required. Sequence number for primary key. | Integer | 4 |
 | Voucher | Expense report voucher number. | VarChar | 7 |
 | EmployeeName | Employee name. | VarChar | 40 |
 | Printed | Variable indicating whether the check has been printed. | Boolean | 1 |
 | Assigned | Variable indicating whether the check has been assigned a check number. | Boolean | 1 |
 | BankCode | Bank code for the check. | VarChar | 10 |
 | Sequence | Sequence number for checks (zero balance checks get a sequence number of 0). | Integer | 4 |
 | CheckNo | Actual check number. | Integer | 4 |
 | CheckDate | Check date. | DBTimeStamp | 4 |
 | ReportName | Name of the expense report. | VarChar | 40 |
 | ReportDate | Date for the expense report. | DBTimeStamp | 4 |
 | AppliedAdvance | Advance amount applied to the expense report. | Double | 9 |
 | ProfCtr | Profit Center to which the original voucher line was charged (so A/P credit can go to same). | VarChar | 8 |
 | DetailType | Detail transaction type. Valid options are A - Advance and E - Expense. | VarChar | 1 |
 | Amount | Net amount to be paid (expense amount - applied advance) for the expense report. | Double | 9 |
 | CheckAmt | Amount printed on check. Differs from Amount if there is any direct deposit. | Double | 9 |

Indexes

Index | Description | Primary | Unique
exChecksPK |  |  |

SQL

CREATE TABLE [exChecks] (
    [Period] [int] NOT NULL ,
    [PostSeq] [int] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [Voucher] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Printed] [bit] NOT NULL CONSTRAINT [DF__exChecks__Printe__3BCADD1B] DEFAULT (0),
    [Assigned] [bit] NOT NULL CONSTRAINT [DF__exChecks__Assign__3CBF0154] DEFAULT (0),
    [BankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Sequence] [int] NULL ,
    [CheckNo] [int] NULL ,
    [CheckDate] [datetime] NULL ,
    [ReportName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ReportDate] [datetime] NULL ,
    [AppliedAdvance] [float] NULL ,
    [ProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DetailType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [CheckAmt] [float] NULL ,
    CONSTRAINT [exChecksPK] PRIMARY KEY NONCLUSTERED
    (
        [Period],
        [PostSeq],
        [Employee],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

exChecks Table | Deltek Advantage 9.0 Database

exChecksPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Period |  | Ascending
Primary Key | PostSeq |  | Ascending
Primary Key | Employee |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

exChecks Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

exChecksE Table

Description

Transaction table for Expensekeeper Direct Deposit

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Period | Required. The accounting period when the transaction data entry file was created. | Integer | 4 |
Primary Key | PostSeq | Required. The posting sequence number for the transaction data entry file. | SmallInt | 2 |
Primary Key | Employee | Required. The internal reference number for the employee. | VarChar | 10 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | BankID | Bank or other depository financial institution identification. | VarChar | 8 |
 | Account | Account number. | VarChar | 17 |
 | AccountType | Indicates whether the account is a checking or savings account. | VarChar | 1 |
 | Method | Calculation method used for allocation to this account. | VarChar | 1 |
 | AmtPct | Amount/percentage of net pay allocated to this account. | Double | 9 |
 | Status | Status. Valid opitons are N - No; Y - Yes; A - Add; and W - Wait. | VarChar | 1 |
 | Amount | Amount allocated to this account. | Double | 9 |
 | SourceBankCode | Bank sending the direct deposit. | VarChar | 10 |
 | CheckRefNo | Check that the direct deposit is part of. Necessary for the VOID function. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
exChecksEPK |  |  |

SQL

CREATE TABLE [exChecksE] (
    [Period] [int] NOT NULL ,
    [PostSeq] [smallint] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [BankID] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (17) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Method] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AmtPct] [float] NULL ,
    [Status] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [SourceBankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CheckRefNo] [int] NULL ,
    CONSTRAINT [exChecksEPK] PRIMARY KEY NONCLUSTERED
    (
        [Period],
        [PostSeq],
        [Employee],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

exChecksE Table | Deltek Advantage 9.0 Database

exChecksEPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Period |  | Ascending
Primary Key | PostSeq |  | Ascending
Primary Key | Employee |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

exChecksE Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

exControl Table

Description

Employee Expenses Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether the file has been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether the transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the transaction file. | VarChar | 15 |
 | Period | Fiscal period and year. | Integer | 4 |
 | EndDate | End date for the transaction file. | DBTimeStamp | 4 |
 | Total | Total entered for the transaction file. | Double | 9 |
 | AdvanceAmount | The control advance amount. | Double | 9 |
 | PostPeriod | Period in which the employee expense data entry transaction file was posted. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the employee expense data entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
exControlPK |  |  |

SQL

CREATE TABLE [exControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__exControl__Recur__28A2FA0E] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__exControl__Selec__29971E47] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__exControl__Poste__2A8B4280] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [EndDate] [datetime] NULL ,
    [Total] [float] NULL ,
    [AdvanceAmount] [float] NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__exControl__PostP__2B7F66B9] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__exControl__PostS__2C738AF2] DEFAULT (0),
    CONSTRAINT [exControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

exControl Table | Deltek Advantage 9.0 Database

exControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

exControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

exDetail Table

Description

Employee Expenses Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the data entry transaction file. | VarChar | 15 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | TransDate | Transaction date. | DBTimeStamp | 4 |
 | Project | Project number to which the amount applies. | VarChar | 12 |
 | ProjType | Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | TaskType | Indicates whether the project has tasks. | VarChar | 1 |
 | Task | Task number to which the amount applies. | VarChar | 5 |
 | Account | Account number to which to post the amount. | VarChar | 10 |
 | Amount | Amount of the detail line. | Double | 9 |
 | Description | Description entered for the detail line. | VarChar | 40 |
 | SuppressBill | Indicates whether to suppress the billing of the transaction. | Boolean | 1 |
 | RefNo | The expense report’s reference number. | VarChar | 7 |

Indexes

Index | Description | Primary | Unique
exDetailPK |  |  |

SQL

CREATE TABLE [exDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [TransDate] [datetime] NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SuppressBill] [bit] NOT NULL CONSTRAINT [DF__exDetail__Suppre__436BFEE3] DEFAULT (0),
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [exDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Employee],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

exDetail Table | Deltek Advantage 9.0 Database

exDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Employee |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

exDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

exMaster Table

Description

Employee Expenses Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the expense data entry transaction file. | VarChar | 15 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
Primary Key | ReportDate | Date for the expense report. | DBTimeStamp | 4 |
Primary Key | ReportName | Name of the expense report. | VarChar | 40 |
 | Posted | Indicates whether the data entry file has been posted. | VarChar | 1 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |
 | advanceAmount | The total advance amount for the expense report. | Double | 9 |

Indexes

Index | Description | Primary | Unique
exMasterPK |  |  |

SQL

CREATE TABLE [exMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ReportDate] [datetime] NOT NULL ,
    [ReportName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__exMaster__Posted__6F357288] DEFAULT ('N'),
    [Seq] [int] NULL ,
    [advanceAmount] [float] NULL ,
    CONSTRAINT [exMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Employee],
        [ReportDate],
        [ReportName]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

exMaster Table | Deltek Advantage 9.0 Database

exMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Employee |  | Ascending
Primary Key | ReportDate |  | Ascending
Primary Key | ReportName |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

exMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

Form1099Data Table

Description

Form 1099 Data Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Year | Required. 1099 year. | SmallInt | 2 |
Primary Key | Vendor | Required. Vendor number. | VarChar | 10 |
 | Sequence | Internal sequence number. | Integer | 4 |
 | SortName | Sort name from the vendor table. | VarChar | 40 |
 | Exclude | Variable indicating whether to exclude the employee when printing 1099 forms or reporting via magnetic media. | Boolean | 1 |
 | Void | Variable indicating whether to exclude voided checks when printing W-2 forms or reporting via magnetic media. | Boolean | 1 |
 | Corrected | Variable indicating whether to exclude corrected voided checks when printing W-2 forms or reporting via magnetic media. | Boolean | 1 |
 | RecipientID | Recipient’s identification number. | VarChar | 11 |
 | RecipientName | Recipient’s name. | VarChar | 40 |
 | RecipientAddress1 | Recipient’s address line 1. | VarChar | 40 |
 | RecipientAddress2 | Recipient’s address line 2. | VarChar | 40 |
 | RecipientCity | Recipient’s city. | VarChar | 18 |
 | RecipientState | Recipient’s state. | VarChar | 2 |
 | RecipientZIP | Recipient’s zip code. | VarChar | 10 |
 | AccountNumber | Account number (optional). | VarChar | 20 |
 | SecondTINNot | Variable indicating whether the IRS has reported twice within three years that the taxpayer identification number is incorrect for the payee. | Boolean | 1 |
 | Rents | Amount entered for rent. | Double | 9 |
 | Royalties | Amount entered for royalties. | Double | 9 |
 | OtherIncome | Amount entered for other income. | Double | 9 |
 | FederalTax | Amount entered for federal tax. | Double | 9 |
 | FishingBoatProceeds | Amount entered for fishing boat proceeds. | Double | 9 |
 | MedicalPayments | Amount entered for medical payments. | Double | 9 |
 | NonemployeeCompensation | Amount entered for non-employee compensation. | Double | 9 |
 | SubstitutePayments | Amount entered for substitute payments in lieu of dividends or interest. | Double | 9 |
 | DirectSales | Variable indicating whether the payer made direct sales of $5,000 or more of consumer products to a buyer (recipient) for resale. | Boolean | 1 |
 | CropInsuranceProceeds | Amount entered for crop insurance proceeds. | Double | 9 |
 | StateTax | Amount entered for state income tax. | Double | 9 |
 | State | State. | VarChar | 2 |
 | StateNumber | State identification number. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
Form1099DataPK |  |  |

SQL

CREATE TABLE [Form1099Data] (
    [Year] [smallint] NOT NULL ,
    [Vendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Sequence] [int] NULL ,
    [SortName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Exclude] [bit] NOT NULL CONSTRAINT [DF__Form1099D__Exclu__473C8FC7] DEFAULT (0),
    [Void] [bit] NOT NULL CONSTRAINT [DF__Form1099Da__Void__4830B400] DEFAULT (0),
    [Corrected] [bit] NOT NULL CONSTRAINT [DF__Form1099D__Corre__4924D839] DEFAULT (0),
    [RecipientID] [varchar] (11) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientZIP] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountNumber] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SecondTINNot] [bit] NOT NULL CONSTRAINT [DF__Form1099D__Secon__4A18FC72] DEFAULT (0),
    [Rents] [float] NULL ,
    [Royalties] [float] NULL ,
    [OtherIncome] [float] NULL ,
    [FederalTax] [float] NULL ,
    [FishingBoatProceeds] [float] NULL ,
    [MedicalPayments] [float] NULL ,
    [NonemployeeCompensation] [float] NULL ,
    [SubstitutePayments] [float] NULL ,
    [DirectSales] [bit] NOT NULL CONSTRAINT [DF__Form1099D__Direc__4B0D20AB] DEFAULT (0),
    [CropInsuranceProceeds] [float] NULL ,
    [StateTax] [float] NULL ,
    [State] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [StateNumber] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [Form1099DataPK] PRIMARY KEY NONCLUSTERED
    (
        [Year],
        [Vendor]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Form1099Data Table | Deltek Advantage 9.0 Database

Form1099DataPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Year |  | Ascending
Primary Key | Vendor |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

Form1099Data Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

Form1099Data2001 Table

Description

Form 1099 Data Table – 2001 Fields

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Year | Required. 1099 year. | SmallInt | 2 |
Primary Key | Vendor | Required. Vendor number. | VarChar | 10 |
 | Sequence | Internal sequence number. | Integer | 4 |
 | SortName | Sort name from the vendor table. | VarChar | 40 |
 | Exclude | Variable indicating whether to exclude the employee when printing 1099 forms or reporting via magnetic media. | Boolean | 1 |
 | Void | Variable indicating whether to exclude voided checks when printing 1099 forms or reporting via magnetic media. | Boolean | 1 |
 | Corrected | Variable indicating whether to exclude corrected voided checks when printing 1099 forms or reporting via magnetic media. | Boolean | 1 |
 | RecipientID | Recipient's identification number. | VarChar | 11 |
 | RecipientName | Recipient's name. | VarChar | 40 |
 | RecipientAddress1 | Recipient's address line 1. | VarChar | 40 |
 | RecipientAddress2 | Recipient's address line 2. | VarChar | 40 |
 | RecipientCity | Recipient's city. | VarChar | 18 |
 | RecipientState | Recipient's state. | VarChar | 2 |
 | RecipientZIP | Recipient's zip code. | VarChar | 10 |
 | AccountNumber | Account number (optional). | VarChar | 20 |
 | SecondTINNot | Variable indicating whether the IRS has reported twice within three years that the taxpayer identification number is incorrect for the payee. | Boolean | 1 |
 | Rents | Amount entered for rent. | Double | 9 |
 | Royalties | Amount entered for royalties. | Double | 9 |
 | OtherIncome | Amount entered for other income. | Double | 9 |
 | FederalTax | Amount entered for federal tax. | Double | 9 |
 | FishingBoatProceeds | Amount entered for fishing boat proceeds. | Double | 9 |
 | MedicalPayments | Amount entered for medical payments. | Double | 9 |
 | NonemployeeCompensation | Amount entered for non-employee compensation. | Double | 9 |
 | SubstitutePayments | Amount entered for substitute payments in lieu of dividends or interest. | Double | 9 |
 | DirectSales | Variable indicating whether the payer made direct sales of $5,000 or more of consumer products to a buyer (recipient) for resale. | Boolean | 1 |
 | CropInsuranceProceeds | Amount entered for crop insurance proceeds. | Double | 9 |
 | ExcessGoldenParachutePayments | Amount entered for on Form 1099. | Integer | 4 |
 | GrossProceedsPaidToAnAttorney | Amount entered for on Form 1099. | Double | 9 |
 | StateTax1 | As entered on form 1099 for the first state income tax. | Double | 9 |
 | StateTax2 | As entered on form 1099 for the second state income tax. | Double | 9 |
 | State1 | The state associated with tax 1. | VarChar | 2 |
 | State2 | The state associated with tax 2. | VarChar | 2 |
 | StateNumber1 | The state identification number associated with StateTax1. | VarChar | 12 |
 | StateNumber2 | The state identification number associated with StateTax2. | VarChar | 12 |
 | StateIncome1 | The amount of the state payment for StateTax1. | Double | 9 |
 | StateIncome2 | The amount of the state payment for StateTax2. | Double | 9 |
 | Box15 | The contents of Box 15 on the Form 1099. | LongVarChar | 16 |
 | Section409ADeferrals | Section 409A deferrals amount on the 1099. | Double | 9 |
 | Section409AIncome | Section 409A income amount on the 1099. | Double | 9 |

Indexes

Index | Description | Primary | Unique
Form1099Data2001PK |  |  |
RecipientIDIDX |  |  |

SQL

CREATE TABLE [Form1099Data2001] (
    [Year] [smallint] NOT NULL ,
    [Vendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Sequence] [int] NULL ,
    [SortName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Exclude] [bit] NOT NULL CONSTRAINT [DF__Form1099D__Exclu__4297D63B] DEFAULT (0),
    [Void] [bit] NOT NULL CONSTRAINT [DF__Form1099Da__Void__438BFA74] DEFAULT (0),
    [Corrected] [bit] NOT NULL CONSTRAINT [DF__Form1099D__Corre__44801EAD] DEFAULT (0),
    [RecipientID] [varchar] (11) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RecipientZIP] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountNumber] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SecondTINNot] [bit] NOT NULL CONSTRAINT [DF__Form1099D__Secon__457442E6] DEFAULT (0),
    [Rents] [float] NULL ,
    [Royalties] [float] NULL ,
    [OtherIncome] [float] NULL ,
    [FederalTax] [float] NULL ,
    [FishingBoatProceeds] [float] NULL ,
    [MedicalPayments] [float] NULL ,
    [NonemployeeCompensation] [float] NULL ,
    [SubstitutePayments] [float] NULL ,
    [DirectSales] [bit] NOT NULL CONSTRAINT [DF__Form1099D__Direc__4668671F] DEFAULT (0),
    [CropInsuranceProceeds] [float] NULL ,
    [ExcessGoldenParachutePayments] [int] NULL ,
    [GrossProceedsPaidToAnAttorney] [float] NULL ,
    [StateTax1] [float] NULL ,
    [StateTax2] [float] NULL ,
    [State1] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [State2] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [StateNumber1] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [StateNumber2] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [StateIncome1] [float] NULL ,
    [StateIncome2] [float] NULL ,
    [Box15] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Section409ADeferrals] [float] NULL ,
    [Section409AIncome] [float] NULL ,
    CONSTRAINT [Form1099Data2001PK] PRIMARY KEY NONCLUSTERED
    (
        [Year],
        [Vendor]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Form1099Data2001 Table | Deltek Advantage 9.0 Database

Form1099Data2001PK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Year |  | Ascending
Primary Key | Vendor |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

Form1099Data2001 Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Form1099Data2001 Table | Deltek Advantage 9.0 Database

RecipientIDIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
RecipientID |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

Form1099Data2001 Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

FormW2Data Table

Description

Form W-2 Data Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Year | Required. W-2 year. | SmallInt | 2 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
 | Sequence | Internal sequence number. | Integer | 4 |
 | Exclude | Variable indicating whether to exclude the employee when printing W-2 forms or reporting via magnetic media. | Boolean | 1 |
 | Void | Variable indicating whether to exclude voided checks when printing W-2 forms or reporting via magnetic media. | Boolean | 1 |
 | EmployeeSSN | Employee’s social security number. | VarChar | 9 |
 | EmployeeName | Employee’s name (first, last, and middle initial). | VarChar | 34 |
 | EmployeeAddress1 | First line of the employee’s address. | VarChar | 40 |
 | EmployeeAddress2 | Second line of the employee’s address. | VarChar | 40 |
 | EmployeeAddress3 | Third line of the employee’s address. | VarChar | 40 |
 | EmployeeCity | Employee’s city. | VarChar | 18 |
 | EmployeeState | Employee’s state. | VarChar | 2 |
 | EmployeeZIP | Employee’s zip. | VarChar | 10 |
 | FederalWages | Wages, tips, and other compensation. | Double | 9 |
 | FederalTax | Amount withheld for federal income tax. | Double | 9 |
 | SocialSecurityWages | Social security wages. | Double | 9 |
 | SocialSecurityTax | Amount withheld for social security tax. | Double | 9 |
 | MedicareWages | Medicare wages. | Double | 9 |
 | MedicareTax | Amount withheld for medicare tax. | Double | 9 |
 | SocialSecurityTips | Social security tips. | Double | 9 |
 | AllocatedTips | Allocated tips. | Double | 9 |
 | AdvanceEIC | Advance EIC payments. | Double | 9 |
 | DependentCareBenefits | Dependent care benefits. | Double | 9 |
 | NonqualifiedPlans | Non-qualified plan amounts. | Double | 9 |
 | Benefits | Benefit amounts. | Double | 9 |
 | Box13Code1 | Code associated with the first box 13 amount. | VarChar | 1 |
 | Box13Amount1 | First box 13 amount. | Double | 9 |
 | Box13Code2 | Code associated with the second box 13 amount. | VarChar | 1 |
 | Box13Amount2 | Second box 13 amount. | Double | 9 |
 | Box13Code3 | Code associated with the third box 13 amount. | VarChar | 1 |
 | Box13Amount3 | Third box 13 amount. | Double | 9 |
 | Box14Field1 | Other. | VarChar | 15 |
 | Box14Field2 | Other. | VarChar | 15 |
 | Box14Field3 | Other. | VarChar | 15 |
 | StatutoryEmployee | Variable indicating whether the employee is a statutory employee. | Boolean | 1 |
 | Deceased | Variable indicating whether the employee is deceased. | Boolean | 1 |
 | PensionPlan | Variable indicating whether the employee has a pension plan. | Boolean | 1 |
 | LegalRepresentative | Variable indicating whether the employee a legal representative. | Boolean | 1 |
 | HouseholdEmployee | Variable indicating whether the employee is the head of household. | Boolean | 1 |
 | DeferredCompensation | Variable indicating whether the employee has deferred compensation. | Boolean | 1 |
 | State1 | State. | VarChar | 2 |
 | State1IDNo | State identification number. | VarChar | 12 |
 | State1Wages | State wages and tips, for example. | Double | 9 |
 | State1Tax | State income tax withheld. | Double | 9 |
 | Locality1 | Locality name. | VarChar | 8 |
 | Locality1Wages | Locality wages and tips for example. | Double | 9 |
 | Locality1Tax | Locality income tax withheld. | Double | 9 |
 | State2 | State. | VarChar | 2 |
 | State2IDNo | State identification number. | VarChar | 12 |
 | State2Wages | State wages and tips, for example. | Double | 9 |
 | State2Tax | State income tax withheld. | Double | 9 |
 | Locality2 | Locality name. | VarChar | 8 |
 | Locality2Wages | Locality wages and tips, for example. | Double | 9 |
 | Locality2Tax | Locality income tax withheld. | Double | 9 |

Indexes

Index | Description | Primary | Unique
FormW2DataPK |  |  |

SQL

CREATE TABLE [FormW2Data] (
    [Year] [smallint] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Sequence] [int] NULL ,
    [Exclude] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__Exclu__52AE4273] DEFAULT (0),
    [Void] [bit] NOT NULL CONSTRAINT [DF__FormW2Data__Void__53A266AC] DEFAULT (0),
    [EmployeeSSN] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeName] [varchar] (34) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeAddress3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeZIP] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FederalWages] [float] NULL ,
    [FederalTax] [float] NULL ,
    [SocialSecurityWages] [float] NULL ,
    [SocialSecurityTax] [float] NULL ,
    [MedicareWages] [float] NULL ,
    [MedicareTax] [float] NULL ,
    [SocialSecurityTips] [float] NULL ,
    [AllocatedTips] [float] NULL ,
    [AdvanceEIC] [float] NULL ,
    [DependentCareBenefits] [float] NULL ,
    [NonqualifiedPlans] [float] NULL ,
    [Benefits] [float] NULL ,
    [Box13Code1] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Box13Amount1] [float] NULL ,
    [Box13Code2] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Box13Amount2] [float] NULL ,
    [Box13Code3] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Box13Amount3] [float] NULL ,
    [Box14Field1] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Box14Field2] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Box14Field3] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [StatutoryEmployee] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__Statu__54968AE5] DEFAULT (0),
    [Deceased] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__Decea__558AAF1E] DEFAULT (0),
    [PensionPlan] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__Pensi__567ED357] DEFAULT (0),
    [LegalRepresentative] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__Legal__5772F790] DEFAULT (0),
    [HouseholdEmployee] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__House__58671BC9] DEFAULT (0),
    [DeferredCompensation] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__Defer__595B4002] DEFAULT (0),
    [State1] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [State1IDNo] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [State1Wages] [float] NULL ,
    [State1Tax] [float] NULL ,
    [Locality1] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Locality1Wages] [float] NULL ,
    [Locality1Tax] [float] NULL ,
    [State2] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [State2IDNo] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [State2Wages] [float] NULL ,
    [State2Tax] [float] NULL ,
    [Locality2] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Locality2Wages] [float] NULL ,
    [Locality2Tax] [float] NULL ,
    CONSTRAINT [FormW2DataPK] PRIMARY KEY NONCLUSTERED
    (
        [Year],
        [Employee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

FormW2Data Table | Deltek Advantage 9.0 Database

FormW2DataPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Year |  | Ascending
Primary Key | Employee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

FormW2Data Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

FormW2Data2001 Table

Description

Form W-2 Data 2001 Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Year | Required. W-2 year | SmallInt | 2 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
 | Sequence | Required. Internal sequence number. | Integer | 4 |
 | Exclude | Variable indicating whether to exclude the employee when printing W-2 forms or reporting via magnetic media. | Boolean | 1 |
 | Void | Variable indicating whether to exclude void checks when printing W-2 forms or reporting via magnetic media. | Boolean | 1 |
 | EmployeeSSN | The employee's social security number. | VarChar | 9 |
 | EmployeeFirstName | The employee's first name. | VarChar | 15 |
 | EmployeeMiddleName | The employee's middle name. | VarChar | 15 |
 | EmployeeLastName | The employee's last name. | VarChar | 20 |
 | EmployeeAddress1 | The first line of the employee's address. | VarChar | 40 |
 | EmployeeAddress2 | The second line of the employee's address. | VarChar | 40 |
 | EmployeeAddress3 | The third line of the employee's address. | VarChar | 40 |
 | EmployeeCity | The employee's city. | VarChar | 18 |
 | EmployeeState | The employee's state. | VarChar | 2 |
 | EmployeeZIP | The employee's zip. | VarChar | 10 |
 | FederalWages | Wages, tips, and other compensations. | Double | 9 |
 | FederalTax | The amount withheld for federal income taxes. | Double | 9 |
 | SocialSecurityWages | Social security wages. | Double | 9 |
 | SocialSecurityTax | The amount withheld for social security taxes. | Double | 9 |
 | MedicareWages | Medicare wages. | Double | 9 |
 | MedicareTax | The amount withheld for medicare taxes. | Double | 9 |
 | SocialSecurityTips | Social security tips. | Double | 9 |
 | AllocatedTips | Allocated tips. | Double | 9 |
 | AdvanceEIC | Advance EIC payments. | Double | 9 |
 | DependentCareBenefits | Dependent care benefits. | Double | 9 |
 | NonqualifiedPlans | Non-qualified plan amounts. | Double | 9 |
 | Box12Code1 | The code associated with the first amount in Box 12. | VarChar | 1 |
 | Box12Amount1 | The first amount in Box 12. | Double | 9 |
 | Box12Code2 | The code associated with the second amount in Box 12. | VarChar | 1 |
 | Box12Amount2 | The second amount in Box 12. | Double | 9 |
 | Box12Code3 | The code associated with the third amount in Box 12. | VarChar | 1 |
 | Box12Amount3 | The third amount in Box 12. | Double | 9 |
 | Box12Code4 | The code associated with the fourth amount in Box 12. | VarChar | 1 |
 | Box12Amount4 | The fourth amount in Box 12. | Double | 9 |
 | Box14Field1 | Other information provided to the employee, as specified in the IRS istructions for Box 14 of the For W-2. | VarChar | 15 |
 | Box14Field2 | Other information provided to the employee, as specified in the IRS istructions for Box 14 of the For W-2. | VarChar | 15 |
 | Box14Field3 | Other information provided to the employee, as specified in the IRS istructions for Box 14 of the For W-2. | VarChar | 15 |
 | StatutoryEmployee | Variable indicating whether the employee is a statutory employee. | Boolean | 1 |
 | RetirementPlan | Variable indicating whether the employee has a retirement plan. | Boolean | 1 |
 | ThirdPartySickPay | Variable indicating whether the employee has third-party sick pay. | Boolean | 1 |
 | DeferredCompensation | Variable indicating whether the employee has deferred compensation. | Boolean | 1 |
 | State1 | The first state for which the tax is being withheld. | VarChar | 2 |
 | State1IDNo | The State1 state identification number. | VarChar | 12 |
 | State1Wages | The employee's wages and tips for State1. | Double | 9 |
 | State1Tax | The state income tax withheld for State1. | Double | 9 |
 | Locality1 | The first locality for which tax is being withheld. | VarChar | 8 |
 | Locality1Wages | The employee's wages and tips for Locality1. | Double | 9 |
 | Locality1Tax | The locality income tax withheld for Locality1. | Double | 9 |
 | State2 | The second state for which the tax is being withheld. | VarChar | 2 |
 | State2IDNo | The State2 state identification number. | VarChar | 12 |
 | State2Wages | The employee's wages and tips for State2. | Double | 9 |
 | State2Tax | The state income tax withheld for State2. | Double | 9 |
 | Locality2 | The second locality for which tax is being withheld. | VarChar | 8 |
 | Locality2Wages | The employee's wages and tips for Locality2. | Double | 9 |
 | Locality2Tax | The locality income tax withheld for Locality2. | Double | 9 |

Indexes

Index | Description | Primary | Unique
FormW2Data2001PK |  |  |

SQL

CREATE TABLE [FormW2Data2001] (
    [Year] [smallint] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Sequence] [int] NULL ,
    [Exclude] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__Exclu__5B438874] DEFAULT (0),
    [Void] [bit] NOT NULL CONSTRAINT [DF__FormW2Data__Void__5C37ACAD] DEFAULT (0),
    [EmployeeSSN] [varchar] (9) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeFirstName] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeMiddleName] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeLastName] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeAddress3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeZIP] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FederalWages] [float] NULL ,
    [FederalTax] [float] NULL ,
    [SocialSecurityWages] [float] NULL ,
    [SocialSecurityTax] [float] NULL ,
    [MedicareWages] [float] NULL ,
    [MedicareTax] [float] NULL ,
    [SocialSecurityTips] [float] NULL ,
    [AllocatedTips] [float] NULL ,
    [AdvanceEIC] [float] NULL ,
    [DependentCareBenefits] [float] NULL ,
    [NonqualifiedPlans] [float] NULL ,
    [Box12Code1] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Box12Amount1] [float] NULL ,
    [Box12Code2] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Box12Amount2] [float] NULL ,
    [Box12Code3] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Box12Amount3] [float] NULL ,
    [Box12Code4] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Box12Amount4] [float] NULL ,
    [Box14Field1] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Box14Field2] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Box14Field3] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [StatutoryEmployee] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__Statu__5D2BD0E6] DEFAULT (0),
    [RetirementPlan] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__Retir__5E1FF51F] DEFAULT (0),
    [ThirdPartySickPay] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__Third__5F141958] DEFAULT (0),
    [DeferredCompensation] [bit] NOT NULL CONSTRAINT [DF__FormW2Dat__Defer__60083D91] DEFAULT (0),
    [State1] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [State1IDNo] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [State1Wages] [float] NULL ,
    [State1Tax] [float] NULL ,
    [Locality1] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Locality1Wages] [float] NULL ,
    [Locality1Tax] [float] NULL ,
    [State2] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [State2IDNo] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [State2Wages] [float] NULL ,
    [State2Tax] [float] NULL ,
    [Locality2] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Locality2Wages] [float] NULL ,
    [Locality2Tax] [float] NULL ,
    CONSTRAINT [FormW2Data2001PK] PRIMARY KEY NONCLUSTERED
    (
        [Year],
        [Employee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

FormW2Data2001 Table | Deltek Advantage 9.0 Database

FormW2Data2001PK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Year |  | Ascending
Primary Key | Employee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

FormW2Data2001 Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

GLGroup Table

Description

General Ledger Table - Account Groups

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Code | Required. Code for the general ledger account group. | SmallInt | 2 |
 | Description | Required. Description of the general ledger account group. | VarChar | 40 |
 | GroupType | Required. Type of group. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
GLGroupPK |  |  |

SQL

CREATE TABLE [GLGroup] (
    [Code] [smallint] NOT NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [GroupType] [smallint] NULL ,
    CONSTRAINT [GLGroupPK] PRIMARY KEY NONCLUSTERED
    (
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

GLGroup Table | Deltek Advantage 9.0 Database

GLGroupPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Code |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

GLGroup Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

GLGroupDetail Table

Description

General Ledger Table - Account Group Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Code for the general ledger table. | SmallInt | 2 |
Primary Key | GLGroup | Required. Description of the general ledger group. | SmallInt | 2 |
Primary Key | StartAccount | Required. Starting account number for the range. | VarChar | 10 |
Primary Key | EndAccount | Required. Ending account number for the range. | VarChar | 10 |
 | SortOrder | Optional. Sort order for the account group. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
GLGroupDetailPK |  |  |

SQL

CREATE TABLE [GLGroupDetail] (
    [TableNo] [smallint] NOT NULL ,
    [GLGroup] [smallint] NOT NULL ,
    [StartAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [EndAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SortOrder] [smallint] NULL ,
    CONSTRAINT [GLGroupDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo],
        [GLGroup],
        [StartAccount],
        [EndAccount]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

GLGroupDetail Table | Deltek Advantage 9.0 Database

GLGroupDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending
Primary Key | GLGroup |  | Ascending
Primary Key | StartAccount |  | Ascending
Primary Key | EndAccount |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

GLGroupDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

GLTable Table

Description

General Ledger Table - Accounts

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | TableNo | Required. Number for the general ledger account table. | SmallInt | 2 |
 | TableName | Required. Description of the general ledger account table. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
GLTablePK |  |  |

SQL

CREATE TABLE [GLTable] (
    [TableNo] [smallint] NOT NULL ,
    [TableName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [GLTablePK] PRIMARY KEY NONCLUSTERED
    (
        [TableNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

GLTable Table | Deltek Advantage 9.0 Database

GLTablePK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | TableNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

GLTable Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

inControl Table

Description

Invoice Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the invoice data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether the file has been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether the transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the transaction file. | VarChar | 15 |
 | Period | Fiscal period and year. | Integer | 4 |
 | EndDate | End date for the transaction file. | DBTimeStamp | 4 |
 | Total | Total entered for the transaction file. | Double | 9 |
 | RetTotal | Retainage total (usually negative). | Double | 9 |
 | DefaultTaxCode | Default tax code to use for entries in the data entry file. | VarChar | 3 |
 | PostPeriod | Period in which the invoice data entry transaction file was posted. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the invoice data entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
inControlPK |  |  |

SQL

CREATE TABLE [inControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__inControl__Recur__2F4FF79D] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__inControl__Selec__30441BD6] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__inControl__Poste__3138400F] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [EndDate] [datetime] NULL ,
    [Total] [float] NULL ,
    [RetTotal] [float] NULL ,
    [DefaultTaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__inControl__PostP__322C6448] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__inControl__PostS__33208881] DEFAULT (0),
    CONSTRAINT [inControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

inControl Table | Deltek Advantage 9.0 Database

inControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

inControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

inDetail Table

Description

Invoice Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the invoice data entry transaction file. | VarChar | 15 |
Primary Key | Invoice | Required. Final invoice number. | VarChar | 7 |
Primary Key | Project | Required. Project to which the invoice amount applies. | VarChar | 12 |
Primary Key | Task | Required. Task to which the invoice amount applies. | VarChar | 5 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | InvoiceSection | Section on the invoice to which the amount applies. | VarChar | 1 |
 | Account | Account to which the invoice amount applies. | VarChar | 10 |
 | AccountName | Account name. | VarChar | 40 |
 | Amount | Amount of the invoice transaction. | Double | 9 |
 | RetAmount | Retainage amount (usually negative). | Double | 9 |
 | TaxCode | Optional. Tax code to associate with the individual line item. | VarChar | 3 |
 | TaxBasis | Tax basis to associate with the individual line item. | Double | 9 |
 | Retainer | Variable indicating whether this transaction is an applied retainer. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
inDetailPK |  |  |

SQL

CREATE TABLE [inDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [InvoiceSection] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [RetAmount] [float] NULL ,
    [TaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxBasis] [float] NULL ,
    [Retainer] [bit] NOT NULL CONSTRAINT [DF__inDetail__Retain__689D8392] DEFAULT (0),
    CONSTRAINT [inDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Invoice],
        [Project],
        [Task],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

inDetail Table | Deltek Advantage 9.0 Database

inDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Invoice |  | Ascending
Primary Key | Project |  | Ascending
Primary Key | Task |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

inDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

inMaster Table

Description

Invoice Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the invoice data entry transaction file. | VarChar | 15 |
Primary Key | Invoice | Required. Final invoice number. | VarChar | 7 |
 | TransDate | Date specified for the invoice. | DBTimeStamp | 4 |
Primary Key | Project | Required. Project to which invoice amounts were posted. | VarChar | 12 |
 | TaskType | Variable indicating whether the project has tasks. | VarChar | 1 |
Primary Key | Task | Required. Task to which invoice amounts were posted. | VarChar | 5 |
 | TransComment | Comment. | VarChar | 40 |
 | Posted | Variable indicating whether the data entry file has been posted. | VarChar | 1 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
inMasterPK |  |  |

SQL

CREATE TABLE [inMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Invoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransDate] [datetime] NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransComment] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__inMaster__Posted__7211DF33] DEFAULT ('N'),
    [Seq] [int] NULL ,
    CONSTRAINT [inMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Invoice],
        [Project],
        [Task]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

inMaster Table | Deltek Advantage 9.0 Database

inMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Invoice |  | Ascending
Primary Key | Project |  | Ascending
Primary Key | Task |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

inMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

jeControl Table

Description

Journal Entry Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the journal entry data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether the file has been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether the transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the file. | VarChar | 15 |
 | Period | Fiscal period and year. | Integer | 4 |
 | EndDate | End date for the transaction file. | DBTimeStamp | 4 |
 | Total | Total entered for the transaction file. | Double | 9 |
 | AllowTaxEntries | Variable indicating whether to allow tax amounts in this batch. | Boolean | 1 |
 | PostPeriod | Period in which the journal entry transaction file was posted. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the journal entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
jeControlPK |  |  |

SQL

CREATE TABLE [jeControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__jeControl__Recur__35FCF52C] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__jeControl__Selec__36F11965] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__jeControl__Poste__37E53D9E] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [EndDate] [datetime] NULL ,
    [Total] [float] NULL ,
    [AllowTaxEntries] [bit] NOT NULL CONSTRAINT [DF__jeControl__Allow__38D961D7] DEFAULT (0),
    [PostPeriod] [int] NULL CONSTRAINT [DF__jeControl__PostP__39CD8610] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__jeControl__PostS__3AC1AA49] DEFAULT (0),
    CONSTRAINT [jeControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

jeControl Table | Deltek Advantage 9.0 Database

jeControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

jeControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

jeDetail Table

Description

Journal Entry Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the journal entry data entry transaction file. | VarChar | 15 |
Primary Key | RefNo | Required. Reference number assigned. | VarChar | 7 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | Project | Project to which the journal entry amount applies. | VarChar | 12 |
 | ProjType | Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | TaskType | Variable indicating whether the project has tasks. | VarChar | 1 |
 | Task | Task to which the journal entry amount applies. | VarChar | 5 |
 | Account | Account to which the journal entry amount applies. | VarChar | 10 |
 | Vendor | The vendor number associated with consultant accrual entries. | VarChar | 10 |
 | DebitAmount | Debit amount of the journal entry detail line. | Double | 9 |
 | CreditAmount | Credit amount of the journal entry detail line. | Double | 9 |
 | Description | Journal entry transaction description. | VarChar | 40 |
 | TaxCode | Optional. Tax code to associate with the individual line item. | VarChar | 3 |
 | TaxType | Optional. Tax type. Valid options are I - Input/Purchase and O - Output/Sale. | VarChar | 1 |
 | TaxDebitAmount | Optional. Tax debit amount. | Double | 9 |
 | TaxCreditAmount | Optional. Tax credit amount. | Double | 9 |
 | SuppressBill | Variable indicating whether this transaction should be billed. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
jeDetailPK |  |  |

SQL

CREATE TABLE [jeDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Vendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DebitAmount] [float] NULL ,
    [CreditAmount] [float] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaxDebitAmount] [float] NULL ,
    [TaxCreditAmount] [float] NULL ,
    [SuppressBill] [bit] NOT NULL CONSTRAINT [DF__jeDetail__Suppre__7132C993] DEFAULT (0),
    CONSTRAINT [jeDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [RefNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

jeDetail Table | Deltek Advantage 9.0 Database

jeDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | RefNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

jeDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

jeMaster Table

Description

Journal Entry Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the journal entry data entry transaction file. | VarChar | 15 |
Primary Key | RefNo | Required. Reference number assigned. | VarChar | 7 |
 | TransDate | Date specified for the journal entry. | DBTimeStamp | 4 |
 | Type | Variable indicating the type of journal entry. Valid options are C - Cash; A - Accrual; and B - Both. | VarChar | 1 |
 | Description | Description of the journal entry. | VarChar | 40 |
 | Posted | Variable indicating whether the data entry file has been posted. | VarChar | 1 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |
 | UpdateBilled | Variable indicating whether to update project billings when posting a journal entry to a revenue account. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
jeMasterPK |  |  |

SQL

CREATE TABLE [jeMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransDate] [datetime] NULL ,
    [Type] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__jeMaster__Posted__74EE4BDE] DEFAULT ('N'),
    [Seq] [int] NULL ,
    [UpdateBilled] [bit] NOT NULL CONSTRAINT [DF__jeMaster__Update__75E27017] DEFAULT (0),
    CONSTRAINT [jeMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [RefNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

jeMaster Table | Deltek Advantage 9.0 Database

jeMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | RefNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

jeMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

laControl Table

Description

Labor Adjustments Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the labor adjustment data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether the file has been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether the transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the file. | VarChar | 15 |
 | Period | Fiscal period and year. | Integer | 4 |
 | StartDate | Start date for the transaction file. | DBTimeStamp | 4 |
 | EndDate | End date for the transaction file. | DBTimeStamp | 4 |
 | RegHrsTotal | Regular hours entered for the transaction file. | Double | 9 |
 | OvtHrsTotal | Overtime hours entered for the transaction file. | Double | 9 |
 | RegAmtTotal | Total extended regular amount entered. | Double | 9 |
 | OvtAmtTotal | Total extended overtime amount entered. | Double | 9 |
 | BillExtTotal | Extended billing total (regular and overtime amounts). | Double | 9 |
 | SpecialOvtHrsTotal | Special overtime hours control total. | Double | 9 |
 | SpecialOvtAmtTotal | Special overtime amount control total. | Double | 9 |
 | PostPeriod | Period in which the labor adjustment data entry transaction file was posted. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the labor adjustment data entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
laControlPK |  |  |

SQL

CREATE TABLE [laControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__laControl__Recur__3D9E16F4] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__laControl__Selec__3E923B2D] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__laControl__Poste__3F865F66] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [StartDate] [datetime] NULL ,
    [EndDate] [datetime] NULL ,
    [RegHrsTotal] [float] NULL ,
    [OvtHrsTotal] [float] NULL ,
    [RegAmtTotal] [float] NULL ,
    [OvtAmtTotal] [float] NULL ,
    [BillExtTotal] [float] NULL ,
    [SpecialOvtHrsTotal] [float] NULL ,
    [SpecialOvtAmtTotal] [float] NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__laControl__PostP__407A839F] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__laControl__PostS__416EA7D8] DEFAULT (0),
    CONSTRAINT [laControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

laControl Table | Deltek Advantage 9.0 Database

laControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

laControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

laDetail Table

Description

Labor Adjustments Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the labor adjustment data entry transaction file. | VarChar | 15 |
Primary Key | Employee | Required. Number of the employee whose information you are adjusting. | VarChar | 10 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | TransDate | Date of the transaction. | DBTimeStamp | 4 |
 | Project | Project to which the labor adjustment amount applies. | VarChar | 12 |
 | TaskType | Variable indicating whether the project has tasks. | VarChar | 1 |
 | Task | Task to which the labor adjustment amount applies. | VarChar | 5 |
 | LaborCode | Labor code to which the labor adjustment amount applies. | VarChar | 5 |
 | RegHrs | Regular hours adjusted on the transaction. | Double | 9 |
 | OvtHrs | Overtime hours adjusted on the transaction. | Double | 9 |
 | RegAmt | Regular amount adjusted on the transaction. | Double | 9 |
 | OvtAmt | Overtime amount adjusted on the transaction. | Double | 9 |
 | BillExt | Extended billing amount adjusted on the transaction (regular plus overtime amounts). | Double | 9 |
 | SupprBill | Variable indicating whether to suppress the billing of the transaction. | Boolean | 1 |
 | TransComment | Comment. | VarChar | 255 |
 | SpecialOvtHrs | Special overtime hours detail. | Double | 9 |
 | SpecialOvtAmt | Special overtime amount detail. | Double | 9 |

Indexes

Index | Description | Primary | Unique
laDetailPK |  |  |

SQL

CREATE TABLE [laDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [TransDate] [datetime] NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LaborCode] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RegHrs] [float] NULL ,
    [OvtHrs] [float] NULL ,
    [RegAmt] [float] NULL ,
    [OvtAmt] [float] NULL ,
    [BillExt] [float] NULL ,
    [SupprBill] [bit] NOT NULL CONSTRAINT [DF__laDetail__SupprB__79C80F94] DEFAULT (0),
    [TransComment] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SpecialOvtHrs] [float] NULL ,
    [SpecialOvtAmt] [float] NULL ,
    CONSTRAINT [laDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Employee],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

laDetail Table | Deltek Advantage 9.0 Database

laDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Employee |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

laDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

laMaster Table

Description

Labor Adjustments Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the labor adjustment data entry transaction file. | VarChar | 15 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
 | Posted | Variable indicating whether the data entry file has been posted. | VarChar | 1 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
laMasterPK |  |  |

SQL

CREATE TABLE [laMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__laMaster__Posted__78BEDCC2] DEFAULT ('N'),
    [Seq] [int] NULL ,
    CONSTRAINT [laMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Employee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

laMaster Table | Deltek Advantage 9.0 Database

laMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Employee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

laMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

LB Table

Description

Labor Budget Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | lbProject | Required. Project number. | VarChar | 12 |
Primary Key | lbTask | Required. Task number. | VarChar | 5 |
Primary Key | lbLaborCode | Required. Labor code. | VarChar | 10 |
 | lbPct | Reported labor percent complete. | Double | 9 |
 | lbRate | Budgeted hourly cost rate. | Double | 9 |
 | lbBillRate | Labor rate to use with billing budgets. | Double | 9 |
 | lbHrsBud | Budgeted hours for the labor code. | Double | 9 |
 | lbAmtBud | Budgeted cost amount for the labor code. | Double | 9 |
 | lbBillBud | Budgeted billing amount for the labor code. | Double | 9 |
 | lbStartDate | Start date for the labor budget. | DBTimeStamp | 4 |
 | lbEndDate | End date for the labor budget. | DBTimeStamp | 4 |
 | lbEtcHrs | Estimate to complete the hours. | Double | 9 |
 | lbEtcAmt | Estimate to complete the amount. | Double | 9 |
 | lbEacHrs | Estimate at complete hours. | Double | 9 |
 | lbEacAmt | Estimate at complete amount. | Double | 9 |

Indexes

Index | Description | Primary | Unique
LBPK |  |  |

SQL

CREATE TABLE [LB] (
    [lbProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [lbTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [lbLaborCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [lbPct] [float] NULL ,
    [lbRate] [float] NULL ,
    [lbBillRate] [float] NULL ,
    [lbHrsBud] [float] NULL ,
    [lbAmtBud] [float] NULL ,
    [lbBillBud] [float] NULL ,
    [lbStartDate] [datetime] NULL ,
    [lbEndDate] [datetime] NULL ,
    [lbEtcHrs] [float] NULL ,
    [lbEtcAmt] [float] NULL ,
    [lbEacHrs] [float] NULL ,
    [lbEacAmt] [float] NULL ,
    CONSTRAINT [LBPK] PRIMARY KEY NONCLUSTERED
    (
        [lbProject],
        [lbTask],
        [lbLaborCode]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

LB Table | Deltek Advantage 9.0 Database

LBPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | lbProject |  | Ascending
Primary Key | lbTask |  | Ascending
Primary Key | lbLaborCode |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

LB Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

LD Table

Description

Labor Detail Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 72 KB

Columns

Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ldKey | Required. Internal sequence number. | Integer | 4
ldProject | Project number. | VarChar | 12
ldTask | Task number. | VarChar | 5
ldLaborCode | Labor code. | VarChar | 5
ldEmployee | Employee number. | VarChar | 10
ldTransType | Transaction type. | VarChar | 2
ldDate | Date when the labor transaction was posted. | DBTimeStamp | 4
ldPeriod | Fiscal year and period in which the labor transaction was posted. | Integer | 4
ldPostSeq | Posting sequence number. | SmallInt | 2
ldName | Employee name. | VarChar | 35
ldRegHrs | Regular hours posted. | Double | 9
ldOvtHrs | Overtime hours posted. | Double | 9
ldRegAmt | Regular amount posted. | Double | 9
ldOvtAmt | Overtime amount posted. | Double | 9
ldBillExt | Extended billing amount entered. | Double | 9
ldRate | Employee’s rate. | Double | 9
ldOvtPct | Overtime percentage for the employee. | Double | 9
ldOvtRate | Overtime rate. | Double | 9
ldEmType | Variable indicating the employee type. Valid options are P - Principal and E - Employee. | VarChar | 1
ldPool | Not used. | SmallInt | 2
ldCategory | Default billing category to use when using the By Category labor billing method. | SmallInt | 2
ldEmProfCtr | Employee’s profit center. | VarChar | 8
ldPrProfCtr | Project’s profit center. | VarChar | 8
ldPrType | Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1
ldRateType | Variable indicating the employee’s rate type. Valid options are H - Hourly and S - Salaried. | VarChar | 1
ldDebitEDPtr | Internal field. | Integer | 4
ldCreditEDPtr | Internal field. | Integer | 4
ldSuppressBill | Variable indicating whether to suppress the billing for the transaction. | Boolean | 1
ldBillStatus Variable indicating the billing status for the labor transaction.

R transactions are not applicable to the Billing system. They represent the original billing record only.

Valid options are B - To be Billed; W - To be written off; H - Held; F - Final Billed; X - Written off; T - Transferred; I - Inserted; and M - Modified.

VarChar 1
ldComment | Comment. | VarChar | 255
ldBilledProject | Project with which the labor detail was final billed. | VarChar | 12
ldBilledTask | Task with which the labor detail was final billed. | VarChar | 5
ldBilledInvoice | Invoice on which the labor detail was final billed. | VarChar | 7
ldBilledPeriod | Period in which the labor detail was final billed. | Integer | 4
ldXferProject | Project from which the labor detail was transferred. | VarChar | 12
ldXferTask | Task from which the labor detail was transferred. | VarChar | 5
ldXferLaborCode | Labor code from which the labor detail was transferred. | VarChar | 10
ldProjectCost | Internal flag for interactive project reporting purposes. | Boolean | 1
ldBillTaxCodeOverride | Optional. Tax code that will override standard billing tax code. | VarChar | 3
ldSpecialOvtHrs | Special overtime hours. | Double | 9
ldSpecialOvtAmt | Special overtime cost amount. | Double | 9
ldSpecialOvtPct | Special overtime percent. | Double | 9
ldSpecialOvtRate | Special overtime rate. | Double | 9
ldWrittenoffPeriod | Active period when this record was written off (billing status of X.) | Integer | 4

Indexes

Index | Description | Primary | Unique
LDPK |  |  |
ldBillStatusIDX |  |  |
ldPeriodldPostSeqIDX |  |  |
ldProjectldTaskIDX |  |  |

SQL

CREATE TABLE [LD] (
    [ldKey] [int] NOT NULL ,
    [ldProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldLaborCode] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldEmployee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldTransType] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldDate] [datetime] NULL ,
    [ldPeriod] [int] NULL ,
    [ldPostSeq] [smallint] NULL ,
    [ldName] [varchar] (35) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldRegHrs] [float] NULL ,
    [ldOvtHrs] [float] NULL ,
    [ldRegAmt] [float] NULL ,
    [ldOvtAmt] [float] NULL ,
    [ldBillExt] [float] NULL ,
    [ldRate] [float] NULL ,
    [ldOvtPct] [float] NULL ,
    [ldOvtRate] [float] NULL ,
    [ldEmType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldPool] [smallint] NULL ,
    [ldCategory] [smallint] NULL ,
    [ldEmProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldPrProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldPrType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldRateType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldDebitEDPtr] [int] NULL ,
    [ldCreditEDPtr] [int] NULL ,
    [ldSuppressBill] [bit] NOT NULL CONSTRAINT [DF__LD__ldSuppressBi__7E8CC4B1] DEFAULT (0),
    [ldBillStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldComment] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldBilledProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldBilledTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldBilledInvoice] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldBilledPeriod] [int] NULL ,
    [ldXferProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldXferTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldXferLaborCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldProjectCost] [bit] NOT NULL CONSTRAINT [DF__LD__ldProjectCos__7F80E8EA] DEFAULT (0),
    [ldBillTaxCodeOverride] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ldSpecialOvtHrs] [float] NULL ,
    [ldSpecialOvtAmt] [float] NULL ,
    [ldSpecialOvtPct] [float] NULL ,
    [ldSpecialOvtRate] [float] NULL ,
    [ldWrittenoffPeriod] [int] NULL ,
    CONSTRAINT [LDPK] PRIMARY KEY NONCLUSTERED
    (
        [ldKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

LD Table | Deltek Advantage 9.0 Database

LDPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ldKey |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

LD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

LD Table | Deltek Advantage 9.0 Database

ldBillStatusIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
ldBillStatus |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

LD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

LD Table | Deltek Advantage 9.0 Database

ldPeriodldPostSeqIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
ldPeriod |  | Ascending
ldPostSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

LD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

LD Table | Deltek Advantage 9.0 Database

ldProjectldTaskIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
ldProject |  | Ascending
ldTask |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

LD Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

miControl Table

Description

Miscellaneous Expenses Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the miscellaneous data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether the file has been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether the transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the file. | VarChar | 15 |
 | Period | Fiscal period and year. | Integer | 4 |
 | EndDate | End date for the transaction file. | DBTimeStamp | 4 |
 | Total | Total entered for the transaction file. | Double | 9 |
 | PostPeriod | Period in which the miscellaneous expense data entry transaction file was posted. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the miscellaneous expense data entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
miControlPK |  |  |

SQL

CREATE TABLE [miControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__miControl__Recur__444B1483] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__miControl__Selec__453F38BC] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__miControl__Poste__46335CF5] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [EndDate] [datetime] NULL ,
    [Total] [float] NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__miControl__PostP__4727812E] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__miControl__PostS__481BA567] DEFAULT (0),
    CONSTRAINT [miControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

miControl Table | Deltek Advantage 9.0 Database

miControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

miControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

miDetail Table

Description

Miscellaneous Expenses Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the miscellaneous data entry transaction file. | VarChar | 15 |
Primary Key | RefNo | Required. Reference number assigned. | VarChar | 7 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | Project | Project to which the miscellaneous amount applies. | VarChar | 12 |
 | ProjType | Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | TaskType | Variable indicating whether the project has tasks. | VarChar | 1 |
 | Task | Task to which the miscellaneous amount applies. | VarChar | 5 |
 | Account | Account to which the miscellaneous amount applies. | VarChar | 10 |
 | Amount | Amount of miscellaneous transaction. | Double | 9 |
 | Description | Description of the transaction. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
miDetailPK |  |  |

SQL

CREATE TABLE [miDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [miDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [RefNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

miDetail Table | Deltek Advantage 9.0 Database

miDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | RefNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

miDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

miMaster Table

Description

Miscellaneous Expenses Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the miscellaneous data entry transaction file. | VarChar | 15 |
Primary Key | RefNo | Required. Reference number assigned. | VarChar | 7 |
 | TransDate | Date specified for the miscellaneous transaction. | DBTimeStamp | 4 |
 | Description | Description of the detail line. | VarChar | 40 |
 | Posted | Variable indicating whether the data entry file has been posted. | VarChar | 1 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
miMasterPK |  |  |

SQL

CREATE TABLE [miMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransDate] [datetime] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__miMaster__Posted__7B9B496D] DEFAULT ('N'),
    [Seq] [int] NULL ,
    CONSTRAINT [miMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [RefNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

miMaster Table | Deltek Advantage 9.0 Database

miMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | RefNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

miMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

OverheadAllocation Table

Description

Overhead Allocation Report Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ohKey | Required. Primary key. | Integer | 4 |
 | ohPeriod | Period in which overhead allocation was last run. | Integer | 4 |
 | ohPass | Variable indicating the overhead allocation pass. Valid options are 1, 2, 3, and 4. | SmallInt | 2 |
 | ohProfctrToDistribute | Profit center combinations to which overhead was distributed. | VarChar | 8 |
 | ohDistributionTarget | Distribution target for overhead. | VarChar | 8 |
 | ohProfctr | Profit center. | VarChar | 8 |
 | ohProject | Project receiving overhead. | VarChar | 12 |
 | ohTask | Task receiving overhead. | VarChar | 5 |
 | ohBase | Overhead base amount. | Double | 9 |
 | ohExpenses | Expenses received. | Double | 9 |
 | ohRevenue | Revenue received. | Double | 9 |
 | ohReceived | Overhead received. | Double | 9 |
 | ohRate | Overhead rate used. | Double | 9 |
 | ohOverhead | Overhead amount. | Double | 9 |
 | ohVariance | Variance amount. | Double | 9 |
 | ohVarianceProject | Overhead variance project. | VarChar | 12 |
 | ohMethod | Overhead method. | VarChar | 1 |
 | ohBasis | Overhead basis. | VarChar | 2 |

Indexes

Index | Description | Primary | Unique
OverheadAllocationPK |  |  |

SQL

CREATE TABLE [OverheadAllocation] (
    [ohKey] [int] NOT NULL ,
    [ohPeriod] [int] NULL ,
    [ohPass] [smallint] NULL ,
    [ohProfctrToDistribute] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ohDistributionTarget] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ohProfctr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ohProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ohTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ohBase] [float] NULL ,
    [ohExpenses] [float] NULL ,
    [ohRevenue] [float] NULL ,
    [ohReceived] [float] NULL ,
    [ohRate] [float] NULL ,
    [ohOverhead] [float] NULL ,
    [ohVariance] [float] NULL ,
    [ohVarianceProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ohMethod] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ohBasis] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [OverheadAllocationPK] PRIMARY KEY NONCLUSTERED
    (
        [ohKey]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

OverheadAllocation Table | Deltek Advantage 9.0 Database

OverheadAllocationPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ohKey |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

OverheadAllocation Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PBLReportColumns Table

Description

Interactive Project Reporting Columns Table - SQL Server

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 4
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ReportName | Required. Project report name. | VarChar | 50 |
Primary Key | Username | Required. Advantage user name. | VarChar | 20 |
Primary Key | SaveName | Required. Name for the option set being saved. | VarChar | 50 |
Primary Key | SelectSeq | Required. Sequence for the primary key. | SmallInt | 2 |
 | ColumnName | Required. Name of the column to be selected for this saved option. | VarChar | 50 |
 | UseLabel | Variable indicating whether this column requires a custom label. | VarChar | 1 |
 | Label1 | Custom column heading label. | VarChar | 40 |
 | Label2 | Custom column heading label. | VarChar | 40 |
 | UseParm1 | Variable indicating whether this column requires a parameter. | VarChar | 1 |
 | Parm1 | Parameter 1. | VarChar | 40 |
 | UseParm2 | Variable indicating whether this column requires a parameter. | VarChar | 1 |
 | Parm2 | Parameter 2. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
PBLReportColumnsPK |  |  |

SQL

CREATE TABLE [PBLReportColumns] (
    [ReportName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Username] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SaveName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SelectSeq] [smallint] NOT NULL ,
    [ColumnName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UseLabel] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Label1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Label2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UseParm1] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Parm1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UseParm2] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Parm2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [PBLReportColumnsPK] PRIMARY KEY NONCLUSTERED
    (
        [ReportName],
        [Username],
        [SaveName],
        [SelectSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PBLReportColumns Table | Deltek Advantage 9.0 Database

PBLReportColumnsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ReportName |  | Ascending
Primary Key | Username |  | Ascending
Primary Key | SaveName |  | Ascending
Primary Key | SelectSeq |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 4
Rows Sampled | 4
Distribution Steps | 3
Updated | Monday, January 26, 2004 15:02

See Also

PBLReportColumns Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PBLReportFavorites Table

Description

Interactive Project Reporting Favorites Table - SQL Server

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ApplicationName | Interactive reporting application name. | VarChar | 50 |
Primary Key | ReportName | Project report name. | VarChar | 50 |
Primary Key | UserName | The Advantage user name. | VarChar | 20 |
Primary Key | SaveName | The name for the option set being saved. | VarChar | 50 |
 | Description | Description for the favorite. | VarChar | 100 |
 | SavedOptions | Saved options for the favorite. | VarChar | 50 |
 | SavedWhereClause | Saved selection criteria for the favorite. | VarChar | 50 |
 | SavedSearchIndex | Internal field. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
PBLReportFavoritesPK |  |  |

SQL

CREATE TABLE [PBLReportFavorites] (
    [ApplicationName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ReportName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [UserName] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SaveName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Description] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SavedOptions] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SavedWhereClause] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SavedSearchIndex] [int] NULL ,
    CONSTRAINT [PBLReportFavoritesPK] PRIMARY KEY NONCLUSTERED
    (
        [ApplicationName],
        [ReportName],
        [UserName],
        [SaveName]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PBLReportFavorites Table | Deltek Advantage 9.0 Database

PBLReportFavoritesPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ApplicationName |  | Ascending
Primary Key | ReportName |  | Ascending
Primary Key | UserName |  | Ascending
Primary Key | SaveName |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

PBLReportFavorites Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PBLReportOptions Table

Description

Interactive Project Reporting Options Table - SQL Server

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 45
Data Space Used | 32 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ReportName | Required. Project report name. | VarChar | 50 |
Primary Key | Username | Required. Advantage user name. | VarChar | 20 |
Primary Key | SaveName | Required. Name for the option set being saved. | VarChar | 50 |
Primary Key | ColumnName | Required. Name of the column to be selected for this saved option. | VarChar | 50 |
 | StringValue | String value, if the column is string type. | LongVarChar | 16 |
 | NumberValue | Number value, if the column is number type. | Double | 9 |
 | DateValue | Date value, if the column is date type. | DBTimeStamp | 4 |
 | UseAsDefault | Variable indicating whether to use this set of reporting options as the default options. | VarChar | 1 |

Indexes

Index | Description | Primary | Unique
PBLReportOptionsPK |  |  |

SQL

CREATE TABLE [PBLReportOptions] (
    [ReportName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Username] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SaveName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ColumnName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [StringValue] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [NumberValue] [float] NULL ,
    [DateValue] [datetime] NULL ,
    [UseAsDefault] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [PBLReportOptionsPK] PRIMARY KEY NONCLUSTERED
    (
        [ReportName],
        [Username],
        [SaveName],
        [ColumnName]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PBLReportOptions Table | Deltek Advantage 9.0 Database

PBLReportOptionsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ReportName |  | Ascending
Primary Key | Username |  | Ascending
Primary Key | SaveName |  | Ascending
Primary Key | ColumnName |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 45
Rows Sampled | 45
Distribution Steps | 23
Updated | Monday, January 26, 2004 15:02

See Also

PBLReportOptions Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PBLReportWhere Table

Description

Interactive Project Reporting WHERE Clause Table - SQL Server

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 24 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SearchType | Required. Search type for this WHERE clause. | VarChar | 60 |
Primary Key | Username | Required. Advantage user name. | VarChar | 20 |
Primary Key | SaveName | Required. Name for the option set being saved. | VarChar | 50 |
 | WhereClause | WHERE clause for this report. | LongVarChar | 16 |

Indexes

Index | Description | Primary | Unique
PBLReportWherePK |  |  |

SQL

CREATE TABLE [PBLReportWhere] (
    [SearchType] [varchar] (60) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Username] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SaveName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [WhereClause] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [PBLReportWherePK] PRIMARY KEY NONCLUSTERED
    (
        [SearchType],
        [Username],
        [SaveName]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PBLReportWhere Table | Deltek Advantage 9.0 Database

PBLReportWherePK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SearchType |  | Ascending
Primary Key | Username |  | Ascending
Primary Key | SaveName |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

PBLReportWhere Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PBLReportWhereDetail Table

Description

Interactive Project Reporting WHERE Clause Detail Table - SQL Server

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 24 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SearchType | Search type for this WHERE clause. | VarChar | 60 |
Primary Key | Username | Advantage user name. | VarChar | 20 |
Primary Key | SaveName | Name for the option set being saved. | VarChar | 50 |
Primary Key | SelectOrder | Order of the column being saved. | Integer | 4 |
 | SearchID | Name of the column being used in this selection. | VarChar | 6 |
 | SearchString | List of criteria for this search item. | LongVarChar | 16 |

Indexes

Index | Description | Primary | Unique
PBLReportWhereDetailPK |  |  |

SQL

CREATE TABLE [PBLReportWhereDetail] (
    [SearchType] [varchar] (60) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Username] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SaveName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SelectOrder] [int] NOT NULL ,
    [SearchID] [varchar] (6) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SearchString] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [PBLReportWhereDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [SearchType],
        [Username],
        [SaveName],
        [SelectOrder]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PBLReportWhereDetail Table | Deltek Advantage 9.0 Database

PBLReportWhereDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SearchType |  | Ascending
Primary Key | Username |  | Ascending
Primary Key | SaveName |  | Ascending
Primary Key | SelectOrder |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

PBLReportWhereDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PBLSearchCriteria Table

Description

Interactive Project Reporting Search Criteria Table - SQL Server

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 38
Data Space Used | 32 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SearchType | Required. Search type for this WHERE clause. | VarChar | 60 |
Primary Key | SortSeq | Required. Sequence number. | VarChar | 6 |
 | LabelString | Label used for the search criteria. | VarChar | 60 |
 | FieldName | Field used for searching. | VarChar | 60 |
 | OtherFieldName | Any other field displayed in the result list. | VarChar | 60 |
 | SortFieldName | Field by which report results will be sorted. | VarChar | 60 |
 | DataType | Data type for the search field. | VarChar | 1 |
 | SelectQuery | Query to be used for lookups in the selection list. | LongVarChar | 16 |
 | BuildColumn | Column to use when building a WHERE clause. | VarChar | 60 |
 | IntSelectOrder | Optional. Order of the columns in the selection list. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
PBLSearchCriteriaPK |  |  |

SQL

CREATE TABLE [PBLSearchCriteria] (
    [SearchType] [varchar] (60) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SortSeq] [varchar] (6) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [LabelString] [varchar] (60) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FieldName] [varchar] (60) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [OtherFieldName] [varchar] (60) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SortFieldName] [varchar] (60) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DataType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SelectQuery] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BuildColumn] [varchar] (60) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [IntSelectOrder] [int] NULL ,
    CONSTRAINT [PBLSearchCriteriaPK] PRIMARY KEY NONCLUSTERED
    (
        [SearchType],
        [SortSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PBLSearchCriteria Table | Deltek Advantage 9.0 Database

PBLSearchCriteriaPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SearchType |  | Ascending
Primary Key | SortSeq |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 38
Rows Sampled | 38
Distribution Steps | 20
Updated | Monday, January 26, 2004 15:02

See Also

PBLSearchCriteria Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

plAccountSS Table

Description

Account Sort/Select Fields List Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SortNo | Required. Number corresponding to the sort/select field number. | SmallInt | 2 |
Primary Key | Seq | Required. Internally generated for primary key uniqueness. | Integer | 4 |
 | UserSeq | User-defined sequence number. | Integer | 4 |
 | SortVal | Pick list value. | VarChar | 20 |
 | Description | Additional description for the value. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
plAccountSSPK |  |  |

SQL

CREATE TABLE [plAccountSS] (
    [SortNo] [smallint] NOT NULL ,
    [Seq] [int] NOT NULL ,
    [UserSeq] [int] NULL ,
    [SortVal] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [plAccountSSPK] PRIMARY KEY NONCLUSTERED
    (
        [SortNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

plAccountSS Table | Deltek Advantage 9.0 Database

plAccountSSPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SortNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

plAccountSS Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

plClientSS Table

Description

Client Sort/Select Fields List Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SortNo | Required. Number corresponding to the sort/select field number. | SmallInt | 2 |
Primary Key | Seq | Required. Internally generated for primary key uniqueness. | Integer | 4 |
 | UserSeq | User-defined sequence number. | Integer | 4 |
 | SortVal | Pick list value. | VarChar | 20 |
 | Description | Additional description for the value. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
plClientSSPK |  |  |

SQL

CREATE TABLE [plClientSS] (
    [SortNo] [smallint] NOT NULL ,
    [Seq] [int] NOT NULL ,
    [UserSeq] [int] NULL ,
    [SortVal] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [plClientSSPK] PRIMARY KEY NONCLUSTERED
    (
        [SortNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

plClientSS Table | Deltek Advantage 9.0 Database

plClientSSPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SortNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

plClientSS Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

plEmployeeSS Table

Description

Employee Sort/Select Fields List Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SortNo | Required. Number corresponding to the sort/select field number. | SmallInt | 2 |
Primary Key | Seq | Required. Internally generated for primary key uniqueness. | Integer | 4 |
 | UserSeq | User-defined sequence number. | Integer | 4 |
 | SortVal | Pick list value. | VarChar | 20 |
 | Description | Additional description for the value. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
plEmployeeSSPK |  |  |

SQL

CREATE TABLE [plEmployeeSS] (
    [SortNo] [smallint] NOT NULL ,
    [Seq] [int] NOT NULL ,
    [UserSeq] [int] NULL ,
    [SortVal] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [plEmployeeSSPK] PRIMARY KEY NONCLUSTERED
    (
        [SortNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

plEmployeeSS Table | Deltek Advantage 9.0 Database

plEmployeeSSPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SortNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

plEmployeeSS Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

plProjectSS Table

Description

Project Sort/Select Fields List Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SortNo | Required. Number corresponding to the sort/select field number. | SmallInt | 2 |
Primary Key | Seq | Required. Internally generated for primary key uniqueness. | Integer | 4 |
 | UserSeq | User-defined sequence number. | Integer | 4 |
 | SortVal | Pick list value. | VarChar | 20 |
 | Description | Additional description for the value. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
plProjectSSPK |  |  |

SQL

CREATE TABLE [plProjectSS] (
    [SortNo] [smallint] NOT NULL ,
    [Seq] [int] NOT NULL ,
    [UserSeq] [int] NULL ,
    [SortVal] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [plProjectSSPK] PRIMARY KEY NONCLUSTERED
    (
        [SortNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

plProjectSS Table | Deltek Advantage 9.0 Database

plProjectSSPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SortNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

plProjectSS Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

plVendorSS Table

Description

Vendor Sort/Select Fields List Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | SortNo | Required. Number corresponding to the sort/select field number. | SmallInt | 2 |
Primary Key | Seq | Required. Internally generated for primary key uniqueness. | Integer | 4 |
 | UserSeq | User-defined sequence number. | Integer | 4 |
 | SortVal | Pick list value. | VarChar | 20 |
 | Description | Additional description for the value. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
plVendorSSPK |  |  |

SQL

CREATE TABLE [plVendorSS] (
    [SortNo] [smallint] NOT NULL ,
    [Seq] [int] NOT NULL ,
    [UserSeq] [int] NULL ,
    [SortVal] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [plVendorSSPK] PRIMARY KEY NONCLUSTERED
    (
        [SortNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

plVendorSS Table | Deltek Advantage 9.0 Database

plVendorSSPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | SortNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

plVendorSS Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PR Table

Description

Project Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 4
Data Space Used | 8 KB
Index Space Used | 72 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | prProject | Required. Project number. | VarChar | 12 |
Primary Key | prTask | Required. Task number. | VarChar | 5 |
 | prName | Project name. | VarChar | 40 |
 | prType | Required. Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | prTaskType | Required. Variable indicating whether the project has tasks. | VarChar | 1 |
 | prPrincipal | Principal’s employee number. | VarChar | 10 |
 | prProjMgr | Project manager’s employee number. | VarChar | 10 |
 | prSupervisor | Employee number of the project or task supervisor. | VarChar | 10 |
 | prClient | Client number. | VarChar | 10 |
 | prFee | Project’s total fee. | Double | 9 |
 | prReimbAllow | Reimbursable allowance for the project. | Double | 9 |
 | prConsultFee | Consultant fee for the project. | Double | 9 |
 | prBudOHRate | Budgeted overhead rate for the project. | Double | 9 |
 | prStatus | Required. Variable indicating the project status. Valid options are A - Active; I - Inactive; and D - Dormant. | VarChar | 1 |
 | prRevType | Revenue method for the project. | VarChar | 1 |
 | prMultAmt | Multiplier or amount to use with revenue generation for the project. | Double | 9 |
 | prProfCtr | Required, if Profit Center Reporting is installed; the Project’s profit center. | VarChar | 8 |
 | prUnitTable | Default unit table to use for the project. | VarChar | 12 |
 | prStartDate | Expected start date for the project. | DBTimeStamp | 4 |
 | prEndDate | Expected end date for the project. | DBTimeStamp | 4 |
 | prPctComp | Estimated overall percent complete for the project. | Double | 9 |
 | prLabPctComp | Estimated labor percent complete for the project. | Double | 9 |
 | prExpPctComp | Estimated expense percent complete for the project. | Double | 9 |
 | prBillByDefault | Variable indicating the project’s default billing status. Valid options are Y - Billable; N - Non-Billable; and C - Category Specific. | VarChar | 1 |
 | prBillableWarning | Type of message to appear for non-billable categories. Valid options are E - Error; W - Warning; and N - None. | VarChar | 1 |
 | prSelect1 | Project sort/select code 1. | VarChar | 20 |
 | prSelect2 | Project sort/select code 2. | VarChar | 20 |
 | prSelect3 | Project sort/select code 3. | VarChar | 20 |
 | prSelect4 | Project sort/select code 4. | VarChar | 20 |
 | prSelect5 | Project sort/select code 5. | VarChar | 20 |
 | prSelect6 | Project sort/select code 6. | VarChar | 20 |
 | prSelect7 | Project sort/select code 7. | VarChar | 20 |
 | prSelect8 | Project sort/select code 8. | VarChar | 20 |
 | prSelect9 | Project sort/select code 9. | VarChar | 20 |
 | prSelect10 | Project sort/select code 10. | VarChar | 20 |
 | prSelect11 | Project sort/select code 11. | VarChar | 20 |
 | prSelect12 | Project sort/select code 12. | VarChar | 20 |
 | prSelect13 | Project sort/select code 13. | VarChar | 20 |
 | prSelect14 | Project sort/select code 14. | VarChar | 20 |
 | prSelect15 | Project sort/select code 15. | VarChar | 20 |
 | prSelect16 | Project sort/select code 16. | Double | 9 |
 | prSelect17 | Project sort/select code 17. | Double | 9 |
 | prSelect18 | Project sort/select code 18. | Double | 9 |
 | prSelect19 | Project sort/select code 19. | Double | 9 |
 | prSelect20 | Project sort/select code 20 | Double | 9 |
 | prSelect21 | Project sort/select code 21. | Double | 9 |
 | prSelect22 | Project sort/select code 22. | Double | 9 |
 | prSelect23 | Project sort/select code 23. | Double | 9 |
 | prSelect24 | Project sort/select code 24. | Double | 9 |
 | prSelect25 | Project sort/select code 25. | Double | 9 |
 | prSelect26 | Project sort/select code 26. | DBTimeStamp | 4 |
 | prSelect27 | Project sort/select code 27. | DBTimeStamp | 4 |
 | prSelect28 | Project sort/select code 28. | DBTimeStamp | 4 |
 | prSelect29 | Project sort/select code 29. | DBTimeStamp | 4 |
 | prSelect30 | Project sort/select code 30. | DBTimeStamp | 4 |
 | prMemo | Memo field for comments on the project. | LongVarChar | 16 |
 | prADPSpecial | Variable indicating whether this is a special project for ADP. | Boolean | 1 |
 | prADPRegCode | ADP processing code for regular hours, if this is a special project. | VarChar | 2 |
 | prADPRegFieldID | ADP bucket (3 or 4) in which to map regular hours, if this is a special project. | VarChar | 1 |
 | prADPOvtCode | ADP processing code for overtime hours, if this is a special project. | VarChar | 2 |
 | prADPOvtFieldID | ADP bucket (3 or 4) in which to map overtime hours, if this is a special project. | VarChar | 1 |
 | prBudgetedFlag | Budgeted labor code check for timesheets. Valid options are N - None; W - Warning; and E - Error. | VarChar | 1 |
 | prBudgetedLevels | Budgeted labor code levels for this project. | VarChar | 5 |
 | prBillProject | Reference project for Unbilled Detail report. | VarChar | 12 |
 | prBillTask | Reference task for the Unbilled Detail report. | VarChar | 5 |
 | prXCharge | Required. Setting to use for cross charges to the project. Valid options are G - Global; N - None; and P - Project. | VarChar | 1 |
 | prXChargeMethod | Required. Cross charge method for this project. | SmallInt | 2 |
 | prXChargeMult | Required. Cross charge multiplier for this project. | Double | 9 |
 | prAddress | Client address code. | VarChar | 10 |
 | prTaskExport | Indicates whether Export Task Data to CRM is selected for the project. | SmallInt | 2 |
 | prSumComp | For a project with tasks, and Export Task Data to CRM unselected, indicates whether the sum of all the tasks’ compensation amounts becomes the project’s compensation amount once the project is exported to CRM. | SmallInt | 2 |
 | prAppendTeam | For a project with tasks, and Export Task Data to CRM unselected, indicates whether, once the project is exported to CRM, all employees who posted time to any of the project’s tasks appear on the project’s Team tab in CRM, and whether all consultants who posted time to any of the tasks appear on the project’s Consultant tab in CRM. | SmallInt | 2 |
 | prCreateUser | Reserved for future use. | VarChar | 20 |
 | prCreateDate | Reserved for future use. | DBTimeStamp | 4 |
 | prLastUser | Reserved for future use. | VarChar | 20 |
 | prLastUpdateDate | Reserved for future use. | DBTimeStamp | 4 |

Indexes

Index | Description | Primary | Unique
PRPK |  |  |
prPrincipalIDX |  |  |
prProfCtrIDX |  |  |
prProjMgrIDX |  |  |

SQL

CREATE TABLE [PR] (
    [prProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [prTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [prName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prTaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prPrincipal] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prProjMgr] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSupervisor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prClient] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prFee] [float] NULL ,
    [prReimbAllow] [float] NULL ,
    [prConsultFee] [float] NULL ,
    [prBudOHRate] [float] NULL ,
    [prStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prRevType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prMultAmt] [float] NULL ,
    [prProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prUnitTable] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prStartDate] [datetime] NULL ,
    [prEndDate] [datetime] NULL ,
    [prPctComp] [float] NULL ,
    [prLabPctComp] [float] NULL ,
    [prExpPctComp] [float] NULL ,
    [prBillByDefault] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBillableWarning] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect1] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect2] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect3] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect4] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect5] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect6] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect7] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect8] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect9] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect10] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect11] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect12] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect13] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect14] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect15] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect16] [float] NULL ,
    [prSelect17] [float] NULL ,
    [prSelect18] [float] NULL ,
    [prSelect19] [float] NULL ,
    [prSelect20] [float] NULL ,
    [prSelect21] [float] NULL ,
    [prSelect22] [float] NULL ,
    [prSelect23] [float] NULL ,
    [prSelect24] [float] NULL ,
    [prSelect25] [float] NULL ,
    [prSelect26] [datetime] NULL ,
    [prSelect27] [datetime] NULL ,
    [prSelect28] [datetime] NULL ,
    [prSelect29] [datetime] NULL ,
    [prSelect30] [datetime] NULL ,
    [prMemo] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPSpecial] [bit] NOT NULL CONSTRAINT [DF__PR__prADPSpecial__569ECEE8] DEFAULT (0),
    [prADPRegCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPRegFieldID] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPOvtCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPOvtFieldID] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBudgetedFlag] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBudgetedLevels] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBillTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prXCharge] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prXChargeMethod] [smallint] NULL ,
    [prXChargeMult] [float] NULL ,
    [prAddress] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prTaskExport] [smallint] NULL ,
    [prSumComp] [smallint] NULL ,
    [prAppendTeam] [smallint] NULL ,
    [prCreateUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prCreateDate] [datetime] NULL ,
    [prLastUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prLastUpdateDate] [datetime] NULL ,
    CONSTRAINT [PRPK] PRIMARY KEY NONCLUSTERED
    (
        [prProject],
        [prTask]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PR Table | Deltek Advantage 9.0 Database

PRPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | prProject |  | Ascending
Primary Key | prTask |  | Ascending

Index Statistics

Average key length | 8.0
Density | 0
Rows in the Table | 4
Rows Sampled | 4
Distribution Steps | 4
Updated | Wednesday, May 03, 2006 12:15

See Also

PR Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PR Table | Deltek Advantage 9.0 Database

prPrincipalIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
prPrincipal |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 4
Rows Sampled | 4
Distribution Steps | 0
Updated | Wednesday, May 03, 2006 12:15

See Also

PR Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PR Table | Deltek Advantage 9.0 Database

prProfCtrIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
prProfCtr |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 4
Rows Sampled | 4
Distribution Steps | 0
Updated | Wednesday, May 03, 2006 12:15

See Also

PR Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PR Table | Deltek Advantage 9.0 Database

prProjMgrIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
prProjMgr |  | Ascending

Index Statistics

Average key length | 0.0
Density | 0
Rows in the Table | 4
Rows Sampled | 4
Distribution Steps | 0
Updated | Wednesday, May 03, 2006 12:15

See Also

PR Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

prControl Table

Description

Prints/Reproduction Expense Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the prints/reproductions data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether the file has been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether the transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the file. | VarChar | 15 |
 | Period | Fiscal period and year. | Integer | 4 |
 | EndDate | End date for the transaction file. | DBTimeStamp | 4 |
 | Total | Total entered for the transaction file. | Double | 9 |
 | PostPeriod | Period in which the prints/reproductions data entry transaction file was posted. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the prints/reproductions data entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
prControlPK |  |  |

SQL

CREATE TABLE [prControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__prControl__Recur__4AF81212] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__prControl__Selec__4BEC364B] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__prControl__Poste__4CE05A84] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [EndDate] [datetime] NULL ,
    [Total] [float] NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__prControl__PostP__4DD47EBD] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__prControl__PostS__4EC8A2F6] DEFAULT (0),
    CONSTRAINT [prControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

prControl Table | Deltek Advantage 9.0 Database

prControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

prControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

prDetail Table

Description

Prints/Reproduction Expense Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the prints/reproduction data entry transaction file. | VarChar | 15 |
Primary Key | RefNo | Required. Reference number assigned. | VarChar | 7 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | Originals | Number of originals. | SmallInt | 2 |
 | Copies | Number of copies needed. | SmallInt | 2 |
 | Project | Project to which the labor adjustment amount applies. | VarChar | 12 |
 | ProjType | Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | TaskType | Task to which the labor adjustment amount applies. | VarChar | 1 |
 | Task | Task to which the prints/ reproduction amount applies. | VarChar | 5 |
 | Account | Account to which the prints/ reproduction amount applies. | VarChar | 10 |
 | Amount | Amount of the prints/ reproduction transaction. | Double | 9 |
 | Description | Description of the transaction. | VarChar | 40 |

Indexes

Index | Description | Primary | Unique
prDetailPK |  |  |

SQL

CREATE TABLE [prDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [Originals] [smallint] NULL ,
    [Copies] [smallint] NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [prDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [RefNo],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

prDetail Table | Deltek Advantage 9.0 Database

prDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | RefNo |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

prDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PRF Table

Description

Project Financial Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | prfProject | Required. Project number. | VarChar | 12 |
Primary Key | prfTask | Required. Task number. | VarChar | 5 |
Primary Key | prfPeriod | Required. Fiscal year and period. | Integer | 4 |
 | prfRegOH | Regular overhead amount. | Double | 9 |
 | prfGandAOH | General and administrative overhead amount. | Double | 9 |

Indexes

Index | Description | Primary | Unique
PRFPK |  |  |
prfPeriodIDX |  |  |

SQL

CREATE TABLE [PRF] (
    [prfProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [prfTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [prfPeriod] [int] NOT NULL ,
    [prfRegOH] [float] NULL ,
    [prfGandAOH] [float] NULL ,
    CONSTRAINT [PRFPK] PRIMARY KEY NONCLUSTERED
    (
        [prfProject],
        [prfTask],
        [prfPeriod]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PRF Table | Deltek Advantage 9.0 Database

PRFPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | prfProject |  | Ascending
Primary Key | prfTask |  | Ascending
Primary Key | prfPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

PRF Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PRF Table | Deltek Advantage 9.0 Database

prfPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | prfPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

PRF Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PRInitiation Table

Description

Project Template Initiation Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 24 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | prProject | Required. Project number. | VarChar | 12 |
Primary Key | prTask | Required. Task number. | VarChar | 5 |
Primary Key | prRecType | Required. Record type. Valid options are A - Advantage and P - Project workplace. | VarChar | 1 |
 | prApproved | Required. Variable indicating whether the template has been approved for copying. | Boolean | 1 |
 | prSelected | Required. Variable indicating whether the task has been selected for copying. | Boolean | 1 |
 | prErrorMsg | Error message. | VarChar | 255 |
 | prName | Project name. | VarChar | 40 |
 | prType | Required. Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | prTaskType | Required. Variable indicating whether the project has tasks. | VarChar | 1 |
 | prPrincipal | Principal’s employee number. | VarChar | 10 |
 | prProjMgr | Project manager’s employee number. | VarChar | 10 |
 | prSupervisor | Employee number of the project or task supervisor. | VarChar | 10 |
 | prClient | Client number. | VarChar | 10 |
 | prFee | Project’s total fee. | Double | 9 |
 | prReimbAllow | Reimbursable allowance for the project. | Double | 9 |
 | prConsultFee | Consultant fee for the project. | Double | 9 |
 | prBudOHRate | Budgeted overhead rate for the project. | Double | 9 |
 | prStatus | Required. Variable indicating the project status.Valid options are A - Active; I - Inactive; and D - Dormant. | VarChar | 1 |
 | prRevType | Revenue method for the project. | VarChar | 1 |
 | prMultAmt | Multiplier or amount to use with revenue generation for the project. | Double | 9 |
 | prProfCtr | Required, if Profit Center Reporting is installed Project’s profit center. | VarChar | 8 |
 | prUnitTable | Default unit table to use for the project. | VarChar | 12 |
 | prStartDate | Expected start date for the project. | DBTimeStamp | 4 |
 | prEndDate | Expected end date for the project. | DBTimeStamp | 4 |
 | prPctComp | Estimated overall percent complete for the project. | Double | 9 |
 | prLabPctComp | Estimated labor percent complete for the project. | Double | 9 |
 | prExpPctComp | Estimated expense percent complete for the project. | Double | 9 |
 | prBillByDefault | Variable indicating the project’s default billing status. Valid options are Y - Billable; N - Non-Billable; and C - Category Specific. | VarChar | 1 |
 | prBillableWarning | Type of message to appear for nonbillable categories. Valid options are E - Error; W - Warning; and N - None. | VarChar | 1 |
 | prSelect1 | Project sort/select code 1. | VarChar | 20 |
 | prSelect2 | Project sort/select code 2. | VarChar | 20 |
 | prSelect3 | Project sort/select code 3. | VarChar | 20 |
 | prSelect4 | Project sort/select code 4. | VarChar | 20 |
 | prSelect5 | Project sort/select code 5. | VarChar | 20 |
 | prSelect6 | Project sort/select code 6. | VarChar | 20 |
 | prSelect7 | Project sort/select code 7. | VarChar | 20 |
 | prSelect8 | Project sort/select code 8. | VarChar | 20 |
 | prSelect9 | Project sort/select code 9. | VarChar | 20 |
 | prSelect10 | Project sort/select code 10. | VarChar | 20 |
 | prSelect11 | Project sort/select code 11. | VarChar | 20 |
 | prSelect12 | Project sort/select code 12. | VarChar | 20 |
 | prSelect13 | Project sort/select code 13. | VarChar | 20 |
 | prSelect14 | Project sort/select code 14. | VarChar | 20 |
 | prSelect15 | Project sort/select code 15. | VarChar | 20 |
 | prSelect16 | Project sort/select code 16. | Double | 9 |
 | prSelect17 | Project sort/select code 17. | Double | 9 |
 | prSelect18 | Project sort/select code 18. | Double | 9 |
 | prSelect19 | Project sort/select code 19. | Double | 9 |
 | prSelect20 | Project sort/select code 20. | Double | 9 |
 | prSelect21 | Project sort/select code 21. | Double | 9 |
 | prSelect22 | Project sort/select code 22. | Double | 9 |
 | prSelect23 | Project sort/select code 23. | Double | 9 |
 | prSelect24 | Project sort/select code 24. | Double | 9 |
 | prSelect25 | Project sort/select code 25. | Double | 9 |
 | prSelect26 | Project sort/select code 26. | DBTimeStamp | 4 |
 | prSelect27 | Project sort/select code 27. | DBTimeStamp | 4 |
 | prSelect28 | Project sort/select code 28. | DBTimeStamp | 4 |
 | prSelect29 | Project sort/select code 29. | DBTimeStamp | 4 |
 | prSelect30 | Project sort/select code 30. | DBTimeStamp | 4 |
 | prMemo | Memo field for comments on the project. | LongVarChar | 16 |
 | prADPSpecial | Variable indicating whether this is a special project for ADP. | Boolean | 1 |
 | prADPRegCode | ADP processing code for regular hours, if this is a special project. | VarChar | 2 |
 | prADPRegFieldID | ADP bucket (3 or 4) in which to map regular hours, if this is a special project. | VarChar | 1 |
 | prADPOvtCode | ADP processing code for overtime hours, if this is a special project. | VarChar | 2 |
 | prADPOvtFieldID | ADP bucket (3 or 4) in which to map overtime hours, if this is a special project. | VarChar | 1 |
 | prBudgetedFlag | Budgeted labor code check for timesheets. Valid options are N - None; W - Warning; and E - Error. | VarChar | 1 |
 | prBudgetedLevels | Budgeted labor code levels for this project. | VarChar | 5 |
 | prBillProject | Reference project for Unbilled Detail report. | VarChar | 12 |
 | prBillTask | Reference task for Unbilled Detail report. | VarChar | 5 |
 | prXCharge | Required. Setting to use for cross charges to the project. Valid options are G - Global; N - None; and P - Project. | VarChar | 1 |
 | prXChargeMethod | Required. Cross charge method for this project. | VarChar | 1 |
 | prXChargeMult | Required. Cross charge multiplier for this project. | Double | 9 |
 | prAddress | Client address code. | VarChar | 10 |
 | prTaskExport | Indicates whether Export Task Data to CRM is selected for the project. | SmallInt | 2 |
 | prSumComp | For a project with tasks, and Export Task Data to CRM unselected, indicates whether the sum of all the tasks’ compensation amounts becomes the project’s compensation amount once the project is exported to CRM. | SmallInt | 2 |
 | prAppendTeam | For a project with tasks, and Export Task Data to CRM unselected, indicates whether, once the project is exported to CRM, all employees who posted time to any of the project’s tasks appear on the project’s Team tab in CRM, and whether all consultants who posted time to any of the tasks appear on the project’s Consultant tab in CRM. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
PRInitiationPK |  |  |

SQL

CREATE TABLE [PRInitiation] (
    [prProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [prTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [prRecType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [prApproved] [bit] NOT NULL CONSTRAINT [DF__PRInitiat__prApp__1B29035F] DEFAULT (0),
    [prSelected] [bit] NOT NULL CONSTRAINT [DF__PRInitiat__prSel__1C1D2798] DEFAULT (0),
    [prErrorMsg] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prTaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prPrincipal] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prProjMgr] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSupervisor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prClient] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prFee] [float] NULL ,
    [prReimbAllow] [float] NULL ,
    [prConsultFee] [float] NULL ,
    [prBudOHRate] [float] NULL ,
    [prStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prRevType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prMultAmt] [float] NULL ,
    [prProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prUnitTable] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prStartDate] [datetime] NULL ,
    [prEndDate] [datetime] NULL ,
    [prPctComp] [float] NULL ,
    [prLabPctComp] [float] NULL ,
    [prExpPctComp] [float] NULL ,
    [prBillByDefault] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBillableWarning] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect1] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect2] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect3] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect4] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect5] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect6] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect7] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect8] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect9] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect10] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect11] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect12] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect13] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect14] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect15] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect16] [float] NULL ,
    [prSelect17] [float] NULL ,
    [prSelect18] [float] NULL ,
    [prSelect19] [float] NULL ,
    [prSelect20] [float] NULL ,
    [prSelect21] [float] NULL ,
    [prSelect22] [float] NULL ,
    [prSelect23] [float] NULL ,
    [prSelect24] [float] NULL ,
    [prSelect25] [float] NULL ,
    [prSelect26] [datetime] NULL ,
    [prSelect27] [datetime] NULL ,
    [prSelect28] [datetime] NULL ,
    [prSelect29] [datetime] NULL ,
    [prSelect30] [datetime] NULL ,
    [prMemo] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPSpecial] [bit] NOT NULL CONSTRAINT [DF__PRInitiat__prADP__1D114BD1] DEFAULT (0),
    [prADPRegCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPRegFieldID] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPOvtCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPOvtFieldID] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBudgetedFlag] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBudgetedLevels] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBillTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prXCharge] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prXChargeMethod] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prXChargeMult] [float] NULL ,
    [prAddress] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prTaskExport] [smallint] NULL ,
    [prSumComp] [smallint] NULL ,
    [prAppendTeam] [smallint] NULL ,
    CONSTRAINT [PRInitiationPK] PRIMARY KEY NONCLUSTERED
    (
        [prProject],
        [prTask],
        [prRecType]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PRInitiation Table | Deltek Advantage 9.0 Database

PRInitiationPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | prProject |  | Ascending
Primary Key | prTask |  | Ascending
Primary Key | prRecType |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

PRInitiation Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

prMaster Table

Description

Prints/Reproduction Expense Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the prints/reproduction data entry transaction file. | VarChar | 15 |
Primary Key | RefNo | Required. Reference number assigned. | VarChar | 7 |
 | TransDate | Date specified for the prints/reproduction transaction. | DBTimeStamp | 4 |
 | Description | Description of the transaction. | VarChar | 40 |
 | Posted | Variable indicating whether the data entry file has been posted. | VarChar | 1 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
prMasterPK |  |  |

SQL

CREATE TABLE [prMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [RefNo] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [TransDate] [datetime] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__prMaster__Posted__7E77B618] DEFAULT ('N'),
    [Seq] [int] NULL ,
    CONSTRAINT [prMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [RefNo]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

prMaster Table | Deltek Advantage 9.0 Database

prMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | RefNo |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

prMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

ProcessPrinters Table

Description

Process Server Printer List Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

Column Name | Description | Datatype | Length | Allow Nulls
QueueID | Name of the queue to which the process has been submitted. | VarChar | 10 |
PrinterName | Name of the printer to which the process has been submitted. | VarChar | 255 |

Indexes

Index | Description | Primary | Unique
QueueIDIDX |  |  |

SQL

CREATE TABLE [ProcessPrinters] (
    [QueueID] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrinterName] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ProcessPrinters Table | Deltek Advantage 9.0 Database

QueueIDIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
QueueID |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ProcessPrinters Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

ProcessQueue Table

Description

Process Server Job History Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 24 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | QueueID | Required. Name of the queue to which the process has been submitted. | VarChar | 10 |
Primary Key | ProcessID | Required. Unique number assigned to the process. | Integer | 4 |
 | ProcessType | Variable indicating the type of process. Valid options are 1 - File Posting; 2 - Report; 3 - Batch Billing; and 4 - Revenue Generation. | SmallInt | 2 |
 | Period | Fiscal period in which to run the process. | Integer | 4 |
 | Description | Description of the process. | VarChar | 40 |
 | Submitter | Name of the user who submitted the process. | VarChar | 20 |
 | TimeSubmitted | Date and time when the process was submitted. | DBTimeStamp | 4 |
 | RunAfter | Specific date and time, if any, until which, running of the process should be deferred. | DBTimeStamp | 4 |
 | TimeStarted | Date and time when the process started. | DBTimeStamp | 4 |
 | TimeEnded | Date and time when the process ended. | DBTimeStamp | 4 |
 | ProcessStatus | Variable indicating the current status of the process. Valid options are 0 - Waiting; 1 - Running; 2 - Completed; 3 - Cancelled; and 4 - Failed. | SmallInt | 2 |
 | AlertPending | Variable indicating whether notification of completion or failure of the process to the submitter is pending. | Boolean | 1 |
 | TerminationMessage | Message regarding the outcome of the process. | VarChar | 50 |
 | PrinterParameters | Specific network printer port and driver, if any, to be used for printer output. | VarChar | 255 |
 | TransType | Transaction type, if process type is a transaction file posting. | VarChar | 2 |
 | Batch | Name of data entry transaction file, if process type is a transaction file posting. | VarChar | 15 |
 | PrintPostingLog | Variable indicating whether any posting log(s) for the process automatically should be printed. | Boolean | 1 |
 | FormName | Form to be opened, if applicable. | VarChar | 64 |
 | ReportName | Report to be opened, if process type is a report. | VarChar | 64 |
 | ReportCopies | Number of report copies to print. | SmallInt | 2 |
 | ProcessParameters | Parameters, if any, applicable to the process. | LongVarChar | 16 |

Indexes

Index | Description | Primary | Unique
ProcessQueuePK |  |  |

SQL

CREATE TABLE [ProcessQueue] (
    [QueueID] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [ProcessID] [int] NOT NULL ,
    [ProcessType] [smallint] NULL ,
    [Period] [int] NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Submitter] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TimeSubmitted] [datetime] NULL ,
    [RunAfter] [datetime] NULL ,
    [TimeStarted] [datetime] NULL ,
    [TimeEnded] [datetime] NULL ,
    [ProcessStatus] [smallint] NULL ,
    [AlertPending] [bit] NOT NULL CONSTRAINT [DF__ProcessQu__Alert__21D600EE] DEFAULT (0),
    [TerminationMessage] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrinterParameters] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TransType] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrintPostingLog] [bit] NOT NULL CONSTRAINT [DF__ProcessQu__Print__22CA2527] DEFAULT (0),
    [FormName] [varchar] (64) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ReportName] [varchar] (64) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ReportCopies] [smallint] NULL ,
    [ProcessParameters] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [ProcessQueuePK] PRIMARY KEY NONCLUSTERED
    (
        [QueueID],
        [ProcessID]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ProcessQueue Table | Deltek Advantage 9.0 Database

ProcessQueuePK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | QueueID |  | Ascending
Primary Key | ProcessID |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ProcessQueue Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

ProjectCloseout Table

Description

Project Closeout Report Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | ClosingProject | Project that was closed. | VarChar | 12 |
Primary Key | Period | Period in which the project was closed. | Integer | 4 |
Primary Key | PostSeq | Post sequence number of the closeout. | Integer | 4 |
 | ReceivingProject | Project that received all postings from the closed project. | VarChar | 12 |
 | ARAmount | Reserved for future use. | Double | 9 |
 | RetainageAmount | Reserved for future use. | Double | 9 |
 | CurrentUser | User who closed the project. | VarChar | 20 |

Indexes

Index | Description | Primary | Unique
ProjectCloseoutPK |  |  |

SQL

CREATE TABLE [ProjectCloseout] (
    [ClosingProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Period] [int] NOT NULL ,
    [PostSeq] [int] NOT NULL ,
    [ReceivingProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ARAmount] [float] NULL ,
    [RetainageAmount] [float] NULL ,
    [CurrentUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [ProjectCloseoutPK] PRIMARY KEY NONCLUSTERED
    (
        [ClosingProject],
        [Period],
        [PostSeq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

ProjectCloseout Table | Deltek Advantage 9.0 Database

ProjectCloseoutPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | ClosingProject |  | Ascending
Primary Key | Period |  | Ascending
Primary Key | PostSeq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

ProjectCloseout Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PRTemplates Table

Description

Project Templates Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 24 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | prProject | Required. Project number. | VarChar | 12 |
Primary Key | prTask | Required. Task number. | VarChar | 5 |
 | prDefault | Required. Variable indicating which template is the default when adding new templates. | Boolean | 1 |
 | prName | Project name. | VarChar | 40 |
 | prType | Required. Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | prTaskType | Required. Variable indicating whether the project has tasks. | VarChar | 1 |
 | prPrincipal | Principal’s employee number. | VarChar | 10 |
 | prProjMgr | Project manager’s employee number. | VarChar | 10 |
 | prSupervisor | Employee number of the project or task supervisor. | VarChar | 10 |
 | prClient | Client number. | VarChar | 10 |
 | prFee | Project’s total fee. | Double | 9 |
 | prReimbAllow | Reimbursable allowance for the project. | Double | 9 |
 | prConsultFee | Consultant fee for the project. | Double | 9 |
 | prBudOHRate | Budgeted overhead rate for the project. | Double | 9 |
 | prStatus | Required. Variable indicating the project status. Valid options are A - Active; I - Inactive; and D - Dormant. | VarChar | 1 |
 | prRevType | Revenue method for the project. | VarChar | 1 |
 | prMultAmt | Multiplier or amount to use with revenue generation for the project. | Double | 9 |
 | prProfCtr | Required, if Profit Center Reporting is installed Project’s profit center. | VarChar | 8 |
 | prUnitTable | Default unit table to use for the project. | VarChar | 12 |
 | prStartDate | Expected start date for the project. | DBTimeStamp | 4 |
 | prEndDate | Expected end date for the project. | DBTimeStamp | 4 |
 | prPctComp | Estimated overall percent complete for the project. | Double | 9 |
 | prLabPctComp | Estimated labor percent complete for the project. | Double | 9 |
 | prExpPctComp | Estimated expense percent complete for the project. | Double | 9 |
 | prBillByDefault | Variable indicating the project’s default billing status. Valid options are Y - Billable; N - Non-Billable; C - Category Specific. | VarChar | 1 |
 | prBillableWarning | Variable indicating the type of message to appear for nonbillable categories. Valid options are E - Error; W - Warning; and N - None. | VarChar | 1 |
 | prSelect1 | Project sort/select code 1. | VarChar | 20 |
 | prSelect2 | Project sort/select code 2. | VarChar | 20 |
 | prSelect3 | Project sort/select code 3. | VarChar | 20 |
 | prSelect4 | Project sort/select code 4. | VarChar | 20 |
 | prSelect5 | Project sort/select code 5. | VarChar | 20 |
 | prSelect6 | Project sort/select code 6. | VarChar | 20 |
 | prSelect7 | Project sort/select code 7. | VarChar | 20 |
 | prSelect8 | Project sort/select code 8. | VarChar | 20 |
 | prSelect9 | Project sort/select code 9. | VarChar | 20 |
 | prSelect10 | Project sort/select code 10. | VarChar | 20 |
 | prSelect11 | Project sort/select code 11. | VarChar | 20 |
 | prSelect12 | Project sort/select code 12. | VarChar | 20 |
 | prSelect13 | Project sort/select code 13. | VarChar | 20 |
 | prSelect14 | Project sort/select code 14. | VarChar | 20 |
 | prSelect15 | Project sort/select code 15. | VarChar | 20 |
 | prSelect16 | Project sort/select code 16. | Double | 9 |
 | prSelect17 | Project sort/select code 17. | Double | 9 |
 | prSelect18 | Project sort/select code 18. | Double | 9 |
 | prSelect19 | Project sort/select code 19. | Double | 9 |
 | prSelect20 | Project sort/select code 20. | Double | 9 |
 | prSelect21 | Project sort/select code 21. | Double | 9 |
 | prSelect22 | Project sort/select code 22. | Double | 9 |
 | prSelect23 | Project sort/select code 23. | Double | 9 |
 | prSelect24 | Project sort/select code 24. | Double | 9 |
 | prSelect25 | Project sort/select code 25. | Double | 9 |
 | prSelect26 | Project sort/select code 26. | DBTimeStamp | 4 |
 | prSelect27 | Project sort/select code 27. | DBTimeStamp | 4 |
 | prSelect28 | Project sort/select code 28. | DBTimeStamp | 4 |
 | prSelect29 | Project sort/select code 29. | DBTimeStamp | 4 |
 | prSelect30 | Project sort/select code 30. | DBTimeStamp | 4 |
 | prMemo | Memo field for comments on the project. | LongVarChar | 16 |
 | prADPSpecial | Variable indicating whether this is a special project for ADP. | Boolean | 1 |
 | prADPRegCode | ADP processing code for regular hours, if this is a special project. | VarChar | 2 |
 | prADPRegFieldID | ADP bucket (3 or 4) in which to map regular hours, if this is a special project. | VarChar | 1 |
 | prADPOvtCode | ADP processing code for overtime hours, if this is a special project. | VarChar | 2 |
 | prADPOvtFieldID | ADP bucket (3 or 4) in which to map overtime hours, if this is a special project. | VarChar | 1 |
 | prBudgetedFlag | Budgeted labor code check for timesheets. Valid options are N - None; W - Warning; and E - Error. | VarChar | 1 |
 | prBudgetedLevels | Budgeted labor code levels for this project. | VarChar | 5 |
 | prBillProject | Reference project for Unbilled Detail report. | VarChar | 12 |
 | prBillTask | Reference task for Unbilled Detail report. | VarChar | 5 |
 | prXCharge | Required. Variable indicating which setting to use for cross charges to the project. Valid options are G - Global; N - None; and P - Project. | VarChar | 1 |
 | prXChargeMethod | Required. Cross charge method for this project. | VarChar | 1 |
 | prXChargeMult | Required. Cross charge multiplier for this project. | Double | 9 |
 | prAddress | Set to <Default> address. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
PRTemplatesPK |  |  |

SQL

CREATE TABLE [PRTemplates] (
    [prProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [prTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [prDefault] [bit] NOT NULL CONSTRAINT [DF__PRTemplat__prDef__24B26D99] DEFAULT (0),
    [prName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prTaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prPrincipal] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prProjMgr] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSupervisor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prClient] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prFee] [float] NULL ,
    [prReimbAllow] [float] NULL ,
    [prConsultFee] [float] NULL ,
    [prBudOHRate] [float] NULL ,
    [prStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prRevType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prMultAmt] [float] NULL ,
    [prProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prUnitTable] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prStartDate] [datetime] NULL ,
    [prEndDate] [datetime] NULL ,
    [prPctComp] [float] NULL ,
    [prLabPctComp] [float] NULL ,
    [prExpPctComp] [float] NULL ,
    [prBillByDefault] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBillableWarning] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect1] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect2] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect3] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect4] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect5] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect6] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect7] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect8] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect9] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect10] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect11] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect12] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect13] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect14] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect15] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prSelect16] [float] NULL ,
    [prSelect17] [float] NULL ,
    [prSelect18] [float] NULL ,
    [prSelect19] [float] NULL ,
    [prSelect20] [float] NULL ,
    [prSelect21] [float] NULL ,
    [prSelect22] [float] NULL ,
    [prSelect23] [float] NULL ,
    [prSelect24] [float] NULL ,
    [prSelect25] [float] NULL ,
    [prSelect26] [datetime] NULL ,
    [prSelect27] [datetime] NULL ,
    [prSelect28] [datetime] NULL ,
    [prSelect29] [datetime] NULL ,
    [prSelect30] [datetime] NULL ,
    [prMemo] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPSpecial] [bit] NOT NULL CONSTRAINT [DF__PRTemplat__prADP__25A691D2] DEFAULT (0),
    [prADPRegCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPRegFieldID] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPOvtCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prADPOvtFieldID] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBudgetedFlag] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBudgetedLevels] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBillProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prBillTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prXCharge] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prXChargeMethod] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [prXChargeMult] [float] NULL ,
    [prAddress] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [PRTemplatesPK] PRIMARY KEY NONCLUSTERED
    (
        [prProject],
        [prTask]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PRTemplates Table | Deltek Advantage 9.0 Database

PRTemplatesPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | prProject |  | Ascending
Primary Key | prTask |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

PRTemplates Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

pwpMapping Table

Description

Project Workplace Interface Mapping Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 136
Data Space Used | 16 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | pwpTable | Required. The Project Workplace table with which the mapping is associated. | VarChar | 50 |
Primary Key | pwpColumn | Required. The Project Workplace column with which the mapping is associated. | VarChar | 50 |
 | pwpLabel | The label of the column. | VarChar | 50 |
 | pwpDataType | The data type of the column. | VarChar | 50 |
 | pwpLength | The length of the column. | Integer | 4 |
 | pwpOrder | The order of the column. | Integer | 4 |
 | advColumn | The Advantage column with which the mapping is associated. | VarChar | 50 |
 | advDataType | The data type of the column. | VarChar | 50 |
 | advLength | The length of the column. | Integer | 4 |
 | sqlConversion | The SQL string used for mapping columns in Advantage. | VarChar | 255 |
 | Constant | Variable indicating whether this column is a constant value. | SmallInt | 2 |
 | Mappable | Variable indicating whether this column has a default mapping. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
pwpMappingPK |  |  |

SQL

CREATE TABLE [pwpMapping] (
    [pwpTable] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [pwpColumn] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [pwpLabel] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [pwpDataType] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [pwpLength] [int] NULL ,
    [pwpOrder] [int] NULL ,
    [advColumn] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [advDataType] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [advLength] [int] NULL ,
    [sqlConversion] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Constant] [smallint] NULL ,
    [Mappable] [smallint] NULL ,
    CONSTRAINT [pwpMappingPK] PRIMARY KEY NONCLUSTERED
    (
        [pwpTable],
        [pwpColumn]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

pwpMapping Table | Deltek Advantage 9.0 Database

pwpMappingPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | pwpTable |  | Ascending
Primary Key | pwpColumn |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

pwpMapping Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

pwpMappingDefault Table

Description

Project Workplace Interface Default Mapping Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 136
Data Space Used | 16 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | pwpTable | Required. The Project Workplace table with which the mapping is associated. | VarChar | 50 |
Primary Key | pwpColumn | Required. The Project Workplace column with which the mapping is associated. | VarChar | 50 |
 | pwpLabel | The label of the column. | VarChar | 50 |
 | pwpDataType | The data type of the column. | VarChar | 50 |
 | pwpLength | The length of the column. | Integer | 4 |
 | pwpOrder | The order of the column. | Integer | 4 |
 | advColumn | The Advantage column with which the mapping is associated. | VarChar | 50 |
 | advDataType | The data type of the column. | VarChar | 50 |
 | advLength | The length of the column. | Integer | 4 |
 | sqlConversion | The SQL string used for mapping columns in Advantage. | VarChar | 255 |
 | Constant | Variable indicating whether this column is a constant value. | SmallInt | 2 |
 | Mappable | Variable indicating whether this column has a default mapping. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
pwpMappingDefaultPK |  |  |

SQL

CREATE TABLE [pwpMappingDefault] (
    [pwpTable] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [pwpColumn] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [pwpLabel] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [pwpDataType] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [pwpLength] [int] NULL ,
    [pwpOrder] [int] NULL ,
    [advColumn] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [advDataType] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [advLength] [int] NULL ,
    [sqlConversion] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Constant] [smallint] NULL ,
    [Mappable] [smallint] NULL ,
    CONSTRAINT [pwpMappingDefaultPK] PRIMARY KEY NONCLUSTERED
    (
        [pwpTable],
        [pwpColumn]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

pwpMappingDefault Table | Deltek Advantage 9.0 Database

pwpMappingDefaultPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | pwpTable |  | Ascending
Primary Key | pwpColumn |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

pwpMappingDefault Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PYChecks Table

Description

Payroll Checks Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Period | Required. Fiscal period and year. | Integer | 4 |
Primary Key | PostSeq | Required. Posting sequence number. | SmallInt | 2 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
 | Printed | Variable indicating whether checks for the bank code have been printed. | Boolean | 1 |
 | Assigned | Variable indicating whether check numbers have been assigned. | Boolean | 1 |
 | BankCode | Bank code for the checks. | VarChar | 10 |
 | Sequence | Check sequence number. | Integer | 4 |
 | CheckNo | Actual check number. | Integer | 4 |
 | CheckDate | Check date. | DBTimeStamp | 4 |
 | PayRate | Employee’s pay rate in effect at the time of the payroll processing run. | Double | 9 |
 | PayType | Variable indicating the employee’s pay type at the time of the payroll processing run. Valid options are H - Hourly and S - Salaried. | VarChar | 1 |
 | PayOvtPct | Employee’s payroll overtime percentage at the time of the payroll processing run. | Double | 9 |
 | EndDate | Payroll period ending date. | DBTimeStamp | 4 |
 | NetPay | Net pay amount for the employee in the payroll processing run. | Double | 9 |
 | CheckAmt | Total amount of the check. | Double | 9 |
 | RegPay | Regular pay for the employee in the payroll processing run. | Double | 9 |
 | QTDRegPay | Quarter-to-date regular pay (including the amount being paid in the run). | Double | 9 |
 | YTDRegPay | Year-to-date regular pay (including the amount being paid in the run). | Double | 9 |
 | OvtPay | Overtime pay for the employee in the payroll processing run. | Double | 9 |
 | QTDOvtPay | Quarter-to-date overtime pay (including the amount being paid in the run). | Double | 9 |
 | YTDOvtPay | Year-to-date overtime pay (including the amount being paid in the run). | Double | 9 |
 | OtherPay | Other pay for the employee in the payroll processing run. | Double | 9 |
 | OtherPayOverride | Variable indicating whether the other pay amount is a user- keyed override. | Boolean | 1 |
 | QTDOtherPay | Quarter-to-date other pay (including the amount being paid in the run). | Double | 9 |
 | YTDOtherPay | Year-to-date other pay (including the amount being paid in the run). | Double | 9 |
 | RegHrs | Regular hours posted by the employee. | Double | 9 |
 | RegHrsOverride | Variable indicating whether the regular hours are a user-keyed override. | Boolean | 1 |
 | QTDRegHrs | Quarter-to-date regular hours (including the hours being paid in the run). | Double | 9 |
 | YTDRegHrs | Year-to-date regular hours (including the hours being paid in the run). | Double | 9 |
 | OvtHrs | Overtime hours posted by the employee. | Double | 9 |
 | OvtHrsOverride | Variable indicating whether the overtime hours are a user- keyed override. | Boolean | 1 |
 | QTDOvtHrs | Quarter-to-date overtime hours (including the hours being paid in the run). | Double | 9 |
 | YTDOvtHrs | Year-to-date overtime hours (including the hours being paid in the run). | Double | 9 |
 | PaySpecialOvtPct | Special overtime payroll percentage at time of run. | Double | 9 |
 | SpecialOvtPay | Special overtime pay for this run. | Double | 9 |
 | QTDSpecialOvtPay | Quarter-to-date special overtime pay, including this run. | Double | 9 |
 | YTDSpecialOvtPay | Year-to-date special overtime pay, including this run. | Double | 9 |
 | SpecialOvtHrs | Special overtime hours for this run. | Double | 9 |
 | SpecialOvtHrsOverride | Variable indicating whether special overtime hours are a user keyed override. | Boolean | 1 |
 | QTDSpecialOvtHrs | Quarter-to-date special overtime hours, including this run. | Double | 9 |
 | YTDSpecialOvtHrs | Year-to-date special overtime hours, including this run. | Double | 9 |

Indexes

Index | Description | Primary | Unique
PYChecksPK |  |  |

SQL

CREATE TABLE [PYChecks] (
    [Period] [int] NOT NULL ,
    [PostSeq] [smallint] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Printed] [bit] NOT NULL CONSTRAINT [DF__PYChecks__Printe__297722B6] DEFAULT (0),
    [Assigned] [bit] NOT NULL CONSTRAINT [DF__PYChecks__Assign__2A6B46EF] DEFAULT (0),
    [BankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Sequence] [int] NULL ,
    [CheckNo] [int] NULL ,
    [CheckDate] [datetime] NULL ,
    [PayRate] [float] NULL ,
    [PayType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayOvtPct] [float] NULL ,
    [EndDate] [datetime] NULL ,
    [NetPay] [float] NULL ,
    [CheckAmt] [float] NULL ,
    [RegPay] [float] NULL ,
    [QTDRegPay] [float] NULL ,
    [YTDRegPay] [float] NULL ,
    [OvtPay] [float] NULL ,
    [QTDOvtPay] [float] NULL ,
    [YTDOvtPay] [float] NULL ,
    [OtherPay] [float] NULL ,
    [OtherPayOverride] [bit] NOT NULL CONSTRAINT [DF__PYChecks__OtherP__2B5F6B28] DEFAULT (0),
    [QTDOtherPay] [float] NULL ,
    [YTDOtherPay] [float] NULL ,
    [RegHrs] [float] NULL ,
    [RegHrsOverride] [bit] NOT NULL CONSTRAINT [DF__PYChecks__RegHrs__2C538F61] DEFAULT (0),
    [QTDRegHrs] [float] NULL ,
    [YTDRegHrs] [float] NULL ,
    [OvtHrs] [float] NULL ,
    [OvtHrsOverride] [bit] NOT NULL CONSTRAINT [DF__PYChecks__OvtHrs__2D47B39A] DEFAULT (0),
    [QTDOvtHrs] [float] NULL ,
    [YTDOvtHrs] [float] NULL ,
    [PaySpecialOvtPct] [float] NULL ,
    [SpecialOvtPay] [float] NULL ,
    [QTDSpecialOvtPay] [float] NULL ,
    [YTDSpecialOvtPay] [float] NULL ,
    [SpecialOvtHrs] [float] NULL ,
    [SpecialOvtHrsOverride] [bit] NOT NULL CONSTRAINT [DF__PYChecks__Specia__2E3BD7D3] DEFAULT (0),
    [QTDSpecialOvtHrs] [float] NULL ,
    [YTDSpecialOvtHrs] [float] NULL ,
    CONSTRAINT [PYChecksPK] PRIMARY KEY NONCLUSTERED
    (
        [Period],
        [PostSeq],
        [Employee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PYChecks Table | Deltek Advantage 9.0 Database

PYChecksPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Period |  | Ascending
Primary Key | PostSeq |  | Ascending
Primary Key | Employee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

PYChecks Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PYChecksA Table

Description

Payroll Checks Table - Accruals

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Period | Required. Fiscal period and year. | Integer | 4 |
Primary Key | PostSeq | Required. Posting sequence number. | SmallInt | 2 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
Primary Key | Code | Required. Accrual plan code. | VarChar | 10 |
 | Earned | Hours earned (or accrued) for the payroll processing run. | Double | 9 |
 | Override | Variable indicating whether the hours earned for the payroll processing run are a user-keyed override. | Boolean | 1 |
 | YTDEarned | Year-to-date hours earned (including the hours earned in the payroll processing run). | Double | 9 |
 | Taken | Number of hours taken since the last regular payroll processing run. | Double | 9 |
 | YTDTaken | Year-to-date hours taken (including the hours earned in the payroll processing run). | Double | 9 |
 | Balance | Current balance (including the hours earned/taken in the payroll processing run). | Double | 9 |
 | HoursToAccrue | Hours to accrue for this payroll run. | Double | 9 |

Indexes

Index | Description | Primary | Unique
PYChecksAPK |  |  |

SQL

CREATE TABLE [PYChecksA] (
    [Period] [int] NOT NULL ,
    [PostSeq] [smallint] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Code] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Earned] [float] NULL ,
    [Override] [bit] NOT NULL CONSTRAINT [DF__PYChecksA__Overr__30242045] DEFAULT (0),
    [YTDEarned] [float] NULL ,
    [Taken] [float] NULL ,
    [YTDTaken] [float] NULL ,
    [Balance] [float] NULL ,
    [HoursToAccrue] [float] NULL ,
    CONSTRAINT [PYChecksAPK] PRIMARY KEY NONCLUSTERED
    (
        [Period],
        [PostSeq],
        [Employee],
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PYChecksA Table | Deltek Advantage 9.0 Database

PYChecksAPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Period |  | Ascending
Primary Key | PostSeq |  | Ascending
Primary Key | Employee |  | Ascending
Primary Key | Code |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

PYChecksA Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PYChecksE Table

Description

Payroll Checks Table - Direct Deposit Amounts

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Period | Required. Fiscal period and year. | Integer | 4 |
Primary Key | PostSeq | Required. Posting sequence number. | SmallInt | 2 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | BankID | Bank identification number. | VarChar | 8 |
 | Account | Account number. | VarChar | 17 |
 | AccountType | Variable indicating the account type. Valid options are C - Checking and S - Savings. | VarChar | 1 |
 | Method | Calculation method to use when determining what portion of the employee’s pay is to be directly deposited. | VarChar | 1 |
 | AmtPct | Amount/percent of the employee’s net pay to be directly deposited. | Double | 9 |
 | Status | Variable indicating the direct deposit status for the employee. Valid options are A - Add; W - Wait; Y - Yes; and N - No. | VarChar | 1 |
 | Amount | Amount to directly deposit. | Double | 9 |
 | Override | Variable indicating whether the amount to be directly deposited is a user-keyed override. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
PYChecksEPK |  |  |

SQL

CREATE TABLE [PYChecksE] (
    [Period] [int] NOT NULL ,
    [PostSeq] [smallint] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [BankID] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (17) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AccountType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Method] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AmtPct] [float] NULL ,
    [Status] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Amount] [float] NULL ,
    [Override] [bit] NOT NULL CONSTRAINT [DF__PYChecksE__Overr__320C68B7] DEFAULT (0),
    CONSTRAINT [PYChecksEPK] PRIMARY KEY NONCLUSTERED
    (
        [Period],
        [PostSeq],
        [Employee],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PYChecksE Table | Deltek Advantage 9.0 Database

PYChecksEPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Period |  | Ascending
Primary Key | PostSeq |  | Ascending
Primary Key | Employee |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

PYChecksE Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

PYChecksW Table

Description

Payroll Checks Table - Withholdings

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Period | Required. Fiscal period and year. | Integer | 4 |
Primary Key | PostSeq | Required. Posting sequence number. | SmallInt | 2 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
Primary Key | Code | Required. Withholding code. | VarChar | 10 |
 | Method | Calculation method to use when determining the withholding amount. | VarChar | 1 |
 | AmtPct | Amount/percent of the employee’s net pay to withhold. | Double | 9 |
 | Suppress | Variable indicating whether you want to suppress the withholding at the time of posting. | Boolean | 1 |
 | Limit | Limit for the withholding in effect at the time of posting. | Double | 9 |
 | Amount | Withholding amount. | Double | 9 |
 | Override | Variable indicating whether the amount withheld is a user-keyed override. | Boolean | 1 |
 | QTDAmt | Quarter-to-date amount (including the amount posted in the payroll processing run). | Double | 9 |
 | YTDAmt | Year-to-date amount (including the amount posted in the payroll processing run). | Double | 9 |

Indexes

Index | Description | Primary | Unique
PYChecksWPK |  |  |

SQL

CREATE TABLE [PYChecksW] (
    [Period] [int] NOT NULL ,
    [PostSeq] [smallint] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Code] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Method] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [AmtPct] [float] NULL ,
    [Suppress] [bit] NOT NULL CONSTRAINT [DF__PYChecksW__Suppr__33F4B129] DEFAULT (0),
    [Limit] [float] NULL ,
    [Amount] [float] NULL ,
    [Override] [bit] NOT NULL CONSTRAINT [DF__PYChecksW__Overr__34E8D562] DEFAULT (0),
    [QTDAmt] [float] NULL ,
    [YTDAmt] [float] NULL ,
    CONSTRAINT [PYChecksWPK] PRIMARY KEY NONCLUSTERED
    (
        [Period],
        [PostSeq],
        [Employee],
        [Code]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

PYChecksW Table | Deltek Advantage 9.0 Database

PYChecksWPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Period |  | Ascending
Primary Key | PostSeq |  | Ascending
Primary Key | Employee |  | Ascending
Primary Key | Code |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

PYChecksW Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

RPTActivityList Table

Description

Projects with Activity Selection List Table

Properties

Creation Date | Monday, January 26, 2004 15:02
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

Column Name | Description | Datatype | Length | Allow Nulls
Username | For internal use only. | VarChar | 20 |
Project | For internal use only. | VarChar | 12 |
Task | For internal use only. | VarChar | 5 |

Indexes

Index | Description | Primary | Unique
UsernameIDX |  |  |

SQL

CREATE TABLE [RPTActivityList] (
    [Username] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

RPTActivityList Table | Deltek Advantage 9.0 Database

UsernameIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
Username |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

RPTActivityList Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

RPTProjectList Table

Description

Project Selection List Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

Column Name | Description | Datatype | Length | Allow Nulls
Username | For internal use only. | VarChar | 20 |
Project | For internal use only. | VarChar | 12 |
Task | For internal use only. | VarChar | 5 |

Indexes

Index | Description | Primary | Unique
UsernameIDX |  |  |

SQL

CREATE TABLE [RPTProjectList] (
    [Username] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

RPTProjectList Table | Deltek Advantage 9.0 Database

UsernameIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
Username |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

RPTProjectList Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

SE Table

Description

Security Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Workgroup | Required. Name of the security workgroup. | VarChar | 20 |
 | SeeCostRates | Variable indicating whether to allow access to employee job cost rates for the workgroup. | Boolean | 1 |
 | ProjectMaintAccess | Variable indicating the access level for Project Table Maintenance. Valid options are F - Full; R - Review; and M - Modify. | VarChar | 1 |
 | EmployeeMaintAccess | Variable indicating the access level for Employee Table Maintenance. Valid options are F - Full; R - Review; and M - Modify. | VarChar | 1 |
 | EmployeeMaintPayroll | Variable indicating whether to allow access to employee payroll information for the workgroup. | Boolean | 1 |
 | AccountMaintAccess | Variable indicating the access level for Account Table Maintenance. Valid options are F - Full; R - Review; and M - Modify. | VarChar | 1 |
 | ClientMaintAccess | Variable indicating the access level for Client Table Maintenance. Valid options are F - Full; R - Review; and M - Modify. | VarChar | 1 |
 | VendorMaintAccess | Variable indicating the access level for Vendor Table Maintenance. Valid options are F - Full; R - Review; and M - Modify. | VarChar | 1 |
 | UnitMaintAccess | Variable indicating the access level for Unit Table Maintenance. Valid options are F - Full; R - Review; and M - Modify. | VarChar | 1 |
 | BillingMaintAccess | Variable indicating the access level for Billing Table Maintenance. Valid options are F - Full; R - Review; and M - Modify. | VarChar | 1 |
 | ProjectBudgetAccess | Variable indicating the access level for the Project Budget Worksheet. Valid options are F - Full; R - Review; P - Percent Completes; and B - Budgets. | VarChar | 1 |
 | PayrollCheckRec | Variable indicating whether to allow access to the payroll bank code for bank reconciliation for the workgroup. | Boolean | 1 |
 | VoucherReviewModify | Variable indicating whether to allow modifications in voucher review for the workgroup. | Boolean | 1 |
 | ProcessClosedPeriods | Variable indicating whether to allow processing in closed periods for the workgroup. | Boolean | 1 |
 | ReportingToolkitAccess | Variable indicating your access level for the Custom Reporting Toolkit. Valid options are N - No access; R - Read-only access; and F - Full access. | VarChar | 1 |
 | ProjMgrSecurity | Variable indicating whether to use project manager row level security for this security workgroup. | Boolean | 1 |
 | ProjMgrList | List of project manager employee numbers if using project manager row level security. | VarChar | 255 |
 | ProjMgrNames | List of project manager employee names, if using project manager row level security. | VarChar | 255 |
 | PrincipalSecurity | Variable indicating whether to use principal row level security for this security workgroup. | Boolean | 1 |
 | PrincipalList | List of principal employee numbers, if using principal row level security. | VarChar | 255 |
 | PrincipalNames | List of principal employee names, if using principal row level security. | VarChar | 255 |
 | ProfCtrSecurity | Variable indicating whether to use profit center row level security for this security workgroup. | Boolean | 1 |
 | ProfCtrList | List of profit centers, if using profit center row level security. | VarChar | 255 |
 | BillingRow | Variable indicating whether to adhere to row level security in Billing for this security workgroup. | Boolean | 1 |
 | BillingGroupRow | Variable indicating whether to adhere to row level security in Billing Groups Maintenance for this security workgroup. | Boolean | 1 |
 | IntProjReportAccess | Variable indicating whether to allow access to the Interactive Project Reporting application for this security workgroup. Valid options are A - Administrator; U - User; and N - No Access. | VarChar | 1 |
 | IntGLReportAccess | Level of access to the Interactive General Ledger Reporting application for this security workgroup. Valid options are A - Administrator; U - User; and N - No Access. | VarChar | 1 |
 | PWPAdmin | Variable indicating whether this security workgroup has system administration access to the Project Workplace Interface. | Boolean | 1 |
 | IntARReportAccess | Interactive A/R Reporting access. Valid options are A - Administrator; U - User; and N - No Access. | VarChar | 1 |
 | IntARCommentReview | Interactive A/R Reporting comment read access. Valid options are A - Administrator; U - User; and N - No Access. | VarChar | 1 |
 | IntARCommentUpdate | Interactive A/R Reporting comment update access. Valid options are A - Administrator; U - User; and N - No Access. | VarChar | 1 |
 | InteractiveBillingAccess | The security access level for Interactive Billing. If Interactive Billing is enabled, the default is F; otherwise R. Valid options are R - Review; M - Modify; and F - Full Access. | VarChar | 1 |
 | DeleteInvoices | Indicates whether users can delete invoices from Invoices on File in Interactive Billing. | Boolean | 1 |
 | IntProjBudWAccess | The security access level for Interactive Project Budget Worksheet. Valid options are A - Admin; U - Gen. User; H - Hours Only (with billing amounts); B - Hrs Only (no labor amounts); and N - No access. | VarChar | 1 |
 | IntEmpReportAccess | The security access level for Interactive Employee Reports. | VarChar | 1 |
 | SupervisorSecurity | Variable indicating whether to use project supervisor row level security for the security workgroup. | Boolean | 1 |
 | SupervisorList | List of supervisor employee numbers if using project supervisor row level security. | VarChar | 255 |
 | SupervisorNames | List of supervisor employee names if using project supervisor row level security. | VarChar | 20 |
 | ProcessDisbCheck | Indicates whether to allow printing of checks for either cash disbursements or A/P disbursements. | Boolean | 1 |

Indexes

Index | Description | Primary | Unique
SEPK |  |  |

SQL

CREATE TABLE [SE] (
    [Workgroup] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [SeeCostRates] [bit] NOT NULL CONSTRAINT [DF__SE__SeeCostRates__12E8C319] DEFAULT (0),
    [ProjectMaintAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeMaintAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [EmployeeMaintPayroll] [bit] NOT NULL CONSTRAINT [DF__SE__EmployeeMain__13DCE752] DEFAULT (0),
    [AccountMaintAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ClientMaintAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [VendorMaintAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [UnitMaintAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillingMaintAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjectBudgetAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PayrollCheckRec] [bit] NOT NULL CONSTRAINT [DF__SE__PayrollCheck__14D10B8B] DEFAULT (0),
    [VoucherReviewModify] [bit] NOT NULL CONSTRAINT [DF__SE__VoucherRevie__15C52FC4] DEFAULT (0),
    [ProcessClosedPeriods] [bit] NOT NULL CONSTRAINT [DF__SE__ProcessClose__16B953FD] DEFAULT (0),
    [ReportingToolkitAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjMgrSecurity] [bit] NOT NULL CONSTRAINT [DF__SE__ProjMgrSecur__17AD7836] DEFAULT (0),
    [ProjMgrList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjMgrNames] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrincipalSecurity] [bit] NOT NULL CONSTRAINT [DF__SE__PrincipalSec__18A19C6F] DEFAULT (0),
    [PrincipalList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PrincipalNames] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProfCtrSecurity] [bit] NOT NULL CONSTRAINT [DF__SE__ProfCtrSecur__1995C0A8] DEFAULT (0),
    [ProfCtrList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [BillingRow] [bit] NOT NULL CONSTRAINT [DF__SE__BillingRow__1A89E4E1] DEFAULT (0),
    [BillingGroupRow] [bit] NOT NULL CONSTRAINT [DF__SE__BillingGroup__1B7E091A] DEFAULT (0),
    [IntProjReportAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [IntGLReportAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [PWPAdmin] [bit] NOT NULL CONSTRAINT [DF__SE__PWPAdmin__1C722D53] DEFAULT (0),
    [IntARReportAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [IntARCommentReview] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [IntARCommentUpdate] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [InteractiveBillingAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DeleteInvoices] [bit] NOT NULL CONSTRAINT [DF__SE__DeleteInvoic__1D66518C] DEFAULT (0),
    [IntProjBudWAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [IntEmpReportAccess] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SupervisorSecurity] [bit] NOT NULL CONSTRAINT [DF__SE__SupervisorSe__1E5A75C5] DEFAULT (0),
    [SupervisorList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SupervisorNames] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProcessDisbCheck] [bit] NOT NULL CONSTRAINT [DF__SE__ProcessDisbC__1F4E99FE] DEFAULT (0),
    CONSTRAINT [SEPK] PRIMARY KEY NONCLUSTERED
    (
        [Workgroup]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

SE Table | Deltek Advantage 9.0 Database

SEPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Workgroup |  | Ascending

Index Statistics

Average key length | 7.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Wednesday, May 03, 2006 12:15

See Also

SE Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

SEMenu Table

Description

Security Table - Menu-Level Access

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Workgroup | Required. Name of the security workgroup. | VarChar | 20 |
Primary Key | MenuText | Required. Disabled menu items. | VarChar | 100 |

Indexes

Index | Description | Primary | Unique
SEMenuPK |  |  |

SQL

CREATE TABLE [SEMenu] (
    [Workgroup] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [MenuText] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    CONSTRAINT [SEMenuPK] PRIMARY KEY NONCLUSTERED
    (
        [Workgroup],
        [MenuText]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

SEMenu Table | Deltek Advantage 9.0 Database

SEMenuPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Workgroup |  | Ascending
Primary Key | MenuText |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

SEMenu Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

SEPrincipal Table

Description

Row-Level Security Table - Principal Access

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

Column Name | Description | Datatype | Length | Allow Nulls
Workgroup | Name of the security workgroup. | VarChar | 20 |
Principal | The project principal to whom to allow access. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
WorkgroupIDX |  |  |

SQL

CREATE TABLE [SEPrincipal] (
    [Workgroup] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Principal] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

SEPrincipal Table | Deltek Advantage 9.0 Database

WorkgroupIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
Workgroup |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

SEPrincipal Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

SEProfCtr Table

Description

Row-Level Security Table – Profit Center Access

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

Column Name | Description | Datatype | Length | Allow Nulls
Workgroup | Name of the security workgroup. | VarChar | 20 |
ProfCtr | The profit center to whom to allow access. | VarChar | 8 |

Indexes

Index | Description | Primary | Unique
WorkgroupIDX |  |  |

SQL

CREATE TABLE [SEProfCtr] (
    [Workgroup] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

SEProfCtr Table | Deltek Advantage 9.0 Database

WorkgroupIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
Workgroup |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

SEProfCtr Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

SEProjMgr Table

Description

Row-Level Security Table – Project Manager Access

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

Column Name | Description | Datatype | Length | Allow Nulls
Workgroup | Name of the security workgroup. | VarChar | 20 |
ProjMgr | The project manager to whom to allow access. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
WorkgroupIDX |  |  |

SQL

CREATE TABLE [SEProjMgr] (
    [Workgroup] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjMgr] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

SEProjMgr Table | Deltek Advantage 9.0 Database

WorkgroupIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
Workgroup |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

SEProjMgr Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

SESupervisor Table

Description

Row-Level Security Table - Project Supervisor Access

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

Column Name | Description | Datatype | Length | Allow Nulls
Workgroup | Name of the security workgroup. | VarChar | 20 |
Supervisor | The project supervisor to whom to allow access. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
WorkgroupIDX |  |  |

SQL

CREATE TABLE [SESupervisor] (
    [Workgroup] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Supervisor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

SESupervisor Table | Deltek Advantage 9.0 Database

WorkgroupIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
Workgroup |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

SESupervisor Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

SEUser Table

Description

Security Table - Users

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 1
Data Space Used | 8 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Workgroup | Required. Name of the security workgroup. | VarChar | 20 |
Primary Key | Username | Required. Advantage username. | VarChar | 20 |
 | Password | Advantage password. | VarChar | 16 |
 | DisableLogin | Variable indicating whether to disable Advantage logins. | Boolean | 1 |
 | ProcessAlertsEnabled | Variable indicating whether to monitor process queues in the background to detect and report previously unreported completed and failed processes. | Boolean | 1 |
 | ProcessAlertsPollingFrequency | Number of milliseconds between polling for process alerts, if process alerts are enabled. | Integer | 4 |
 | DefaultProcessQueueID | Default process queue for user. | VarChar | 10 |
 | ProcessServerPrintOption | Printer to use when printing reports and invoices from the process server. Valid options are 0 - Use Windows default; 1 - Use process server's default; and 2 - Specify printer. | SmallInt | 2 |
 | ProcessServerDefaultPrinter | Process server default printer (if specifying a default printer). | VarChar | 40 |
 | SupportUsername | The employee’s username for logging onto the Deltek Support site. | VarChar | 12 |
 | SupportPassword | The SupportUsername’s password for logging onto the Deltek Support site. | VarChar | 12 |

Indexes

Index | Description | Primary | Unique
SEUserPK |  |  |
DefaultProcessQueueIDIDX |  |  |

SQL

CREATE TABLE [SEUser] (
    [Workgroup] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Username] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Password] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DisableLogin] [bit] NOT NULL CONSTRAINT [DF__SEUser__DisableL__47FBA9D6] DEFAULT (0),
    [ProcessAlertsEnabled] [bit] NOT NULL CONSTRAINT [DF__SEUser__ProcessA__48EFCE0F] DEFAULT (0),
    [ProcessAlertsPollingFrequency] [int] NULL ,
    [DefaultProcessQueueID] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProcessServerPrintOption] [smallint] NULL ,
    [ProcessServerDefaultPrinter] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SupportUsername] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SupportPassword] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [SEUserPK] PRIMARY KEY NONCLUSTERED
    (
        [Workgroup],
        [Username]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

SEUser Table | Deltek Advantage 9.0 Database

SEUserPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Workgroup |  | Ascending
Primary Key | Username |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

SEUser Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

SEUser Table | Deltek Advantage 9.0 Database

DefaultProcessQueueIDIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
DefaultProcessQueueID |  | Ascending

Index Statistics

Average key length | 0.0
Density | 1
Rows in the Table | 1
Rows Sampled | 1
Distribution Steps | 1
Updated | Monday, January 26, 2004 15:02

See Also

SEUser Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

TKComments Table

Description

Timekeeper Table - Comments

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | TransComment | Timekeeper comments to be used by all Timekeeper users. | VarChar | 255 |

Indexes

Index | Description | Primary | Unique
TKCommentsPK |  |  |

SQL

CREATE TABLE [TKComments] (
    [Seq] [int] NOT NULL ,
    [TransComment] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [TKCommentsPK] PRIMARY KEY NONCLUSTERED
    (
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

TKComments Table | Deltek Advantage 9.0 Database

TKCommentsPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

TKComments Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

tkControl Table

Description

Timekeeper Table - Data Entry Control

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | EndDate | Required. Timesheet period end date. | DBTimeStamp | 4 |
 | StartDate | Timesheet period start date. | DBTimeStamp | 4 |
 | Closed | Variable indicating status of the timesheet period. Valid options are Y - Closed; G - Closed for group administrators; and S - Closed for staff only. | VarChar | 1 |

Indexes

Index | Description | Primary | Unique
tkControlPK |  |  |

SQL

CREATE TABLE [tkControl] (
    [EndDate] [datetime] NOT NULL ,
    [StartDate] [datetime] NULL ,
    [Closed] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [tkControlPK] PRIMARY KEY NONCLUSTERED
    (
        [EndDate]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

tkControl Table | Deltek Advantage 9.0 Database

tkControlPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | EndDate |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

tkControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

tkDetail Table

Description

Timekeeper Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | EndDate | Required. Timesheet period end date. | DBTimeStamp | 4 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
Primary Key | TransDate | Required. Transaction date. | DBTimeStamp | 4 |
 | Category | Timekeeper category code (for example, Vacation, Sick). | VarChar | 6 |
 | Project | Project number. | VarChar | 12 |
 | Task | Task number. | VarChar | 5 |
 | LaborCode | Labor code. | VarChar | 5 |
 | RegHrs | Regular hours entered for the employee. | Double | 9 |
 | OvtHrs | Overtime hours entered for the employee. | Double | 9 |
 | SpecialOvtHrs | Special overtime hours entered for the employee. | Double | 9 |
 | TransComment | Comment. | VarChar | 255 |

Indexes

Index | Description | Primary | Unique
tkDetailPK |  |  |

SQL

CREATE TABLE [tkDetail] (
    [EndDate] [datetime] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [TransDate] [datetime] NOT NULL ,
    [Category] [varchar] (6) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LaborCode] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RegHrs] [float] NULL ,
    [OvtHrs] [float] NULL ,
    [SpecialOvtHrs] [float] NULL ,
    [TransComment] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [tkDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [EndDate],
        [Employee],
        [Seq],
        [TransDate]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

tkDetail Table | Deltek Advantage 9.0 Database

tkDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | EndDate |  | Ascending
Primary Key | Employee |  | Ascending
Primary Key | Seq |  | Ascending
Primary Key | TransDate |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

tkDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

tkMaster Table

Description

Timekeeper Table - Data Entry Master

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | EndDate | Required. Timesheet period end date. | DBTimeStamp | 4 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
 | Submitted | Variable indicating the status of the timesheet submitted. Valid options are Y - Submitted; N - Not Submitted; and P - Posted. | VarChar | 1 |
 | Selected | Variable indicating whether the employee’s timesheet has been selected for posting. | Boolean | 1 |
 | SubmittedBy | Number of the employee who submitted the timesheet. | VarChar | 10 |
 | ApprovedBy | Number of the employee who approved the timesheet. | VarChar | 10 |

Indexes

Index | Description | Primary | Unique
tkMasterPK |  |  |

SQL

CREATE TABLE [tkMaster] (
    [EndDate] [datetime] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Submitted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Selected] [bit] NOT NULL CONSTRAINT [DF__tkMaster__Select__4DB4832C] DEFAULT (0),
    [SubmittedBy] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ApprovedBy] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [tkMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [EndDate],
        [Employee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

tkMaster Table | Deltek Advantage 9.0 Database

tkMasterPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | EndDate |  | Ascending
Primary Key | Employee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

tkMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

TKSecurity Table

Description

Timekeeper Table - Security

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
 | Password | Employee’s Timekeeper password. | VarChar | 16 |
 | CheckHours | Variable indicating whether the system should check the hours entered against the expected hours in the employee table. | VarChar | 1 |
 | CheckLaborCodes | Variable indicating whether the system should check the labor codes against the budgeted labor codes. | VarChar | 1 |

Indexes

Index | Description | Primary | Unique
TKSecurityPK |  |  |

SQL

CREATE TABLE [TKSecurity] (
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Password] [varchar] (16) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CheckHours] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CheckLaborCodes] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [TKSecurityPK] PRIMARY KEY NONCLUSTERED
    (
        [Employee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

TKSecurity Table | Deltek Advantage 9.0 Database

TKSecurityPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Employee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

TKSecurity Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

tsControl Table

Description

Timesheets Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the timesheets data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether the file has been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether the transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the file. | VarChar | 15 |
 | Period | Fiscal period and year. | Integer | 4 |
 | StartDate | Start date for the transaction file. | DBTimeStamp | 4 |
 | EndDate | End date for the transaction file. | DBTimeStamp | 4 |
 | RegHrsTotal | Regular hours entered for the transaction file. | Double | 9 |
 | OvtHrsTotal | Overtime hours entered for the transaction file. | Double | 9 |
 | SpecialOvtHrsTotal | Special overtime hours control total. | Double | 9 |
 | PostPeriod | Period in which the timesheet data entry file was posted. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the timesheet data entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
tsControlPK |  |  |

SQL

CREATE TABLE [tsControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__tsControl__Recur__51A50FA1] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__tsControl__Selec__529933DA] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__tsControl__Poste__538D5813] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [StartDate] [datetime] NULL ,
    [EndDate] [datetime] NULL ,
    [RegHrsTotal] [float] NULL ,
    [OvtHrsTotal] [float] NULL ,
    [SpecialOvtHrsTotal] [float] NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__tsControl__PostP__54817C4C] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__tsControl__PostS__5575A085] DEFAULT (0),
    CONSTRAINT [tsControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

tsControl Table | Deltek Advantage 9.0 Database

tsControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

tsControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

tsDetail Table

Description

Timesheets Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the timesheet data entry transaction file. | VarChar | 15 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | TransDate | Date on the transaction detail line. | DBTimeStamp | 4 |
 | Project | Project to which the timesheet amount applies. | VarChar | 12 |
 | TaskType | Variable indicating whether the project has tasks. | VarChar | 1 |
 | Task | Task to which the timesheet amount applies. | VarChar | 5 |
 | LaborCode | Labor code to which the timesheet amount applies. | VarChar | 5 |
 | RegHrs | Regular hours adjusted on the detail line. | Double | 9 |
 | OvtHrs | Overtime hours adjusted on the detail line. | Double | 9 |
 | TransComment | Comment. | VarChar | 255 |
 | SpecialOvtHrs | Special overtime hours. | Double | 9 |

Indexes

Index | Description | Primary | Unique
tsDetailPK |  |  |

SQL

CREATE TABLE [tsDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [TransDate] [datetime] NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [LaborCode] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RegHrs] [float] NULL ,
    [OvtHrs] [float] NULL ,
    [TransComment] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SpecialOvtHrs] [float] NULL ,
    CONSTRAINT [tsDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Employee],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

tsDetail Table | Deltek Advantage 9.0 Database

tsDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Employee |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

tsDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

tsMaster Table

Description

Timesheets Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the timesheet data entry transaction file. | VarChar | 15 |
Primary Key | Employee | Required. Employee number. | VarChar | 10 |
 | Posted | Variable indicating whether the data entry file has been posted. | VarChar | 1 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
tsMasterPK |  |  |

SQL

CREATE TABLE [tsMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__tsMaster__Posted__015422C3] DEFAULT ('N'),
    [Seq] [int] NULL ,
    CONSTRAINT [tsMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Employee]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

tsMaster Table | Deltek Advantage 9.0 Database

tsMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Employee |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

tsMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

UN Table

Description

Units Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | unTable | Required. Unit table. | VarChar | 12 |
Primary Key | unUnit | Required. Unit number. | VarChar | 10 |
 | unName | Unit name. | VarChar | 40 |
 | unSingleLabel | Label to use when just one unit is specified. | VarChar | 10 |
 | unPluralLabel | Label to use when more than one unit is specified. | VarChar | 10 |
 | unBillingRate | Billing rate per unit to use. | Double | 9 |
 | unFormat | Variable indicating the billing line format. Valid options are 1 - Name Only; 2 - Name and Detail; and 3 - Detail Only. | VarChar | 1 |
 | unConsolBill | Variable indicating whether you want to consolidate the billing detail on the invoice. | Boolean | 1 |
 | unShowDate | Variable indicating whether you want to show the transaction date on the invoice. | Boolean | 1 |
 | unShowCalc | Variable indicating whether you want to show calculations on the invoice. | Boolean | 1 |
 | unPostAccount | Posting account to use when generating the invoice. | VarChar | 10 |
 | unCostRate | Cost rate per unit to use. | Double | 9 |
 | unRegAccount | Default account to use when a regular project is specified in data entry. | VarChar | 10 |
 | unOHAccount | Default account to use when an overhead project is specified in data entry. | VarChar | 10 |
 | unCreditProject | Project to credit with the sum of costs to the unit. | VarChar | 12 |
 | unCreditTask | Task to credit with the sum of costs to the unit. | VarChar | 5 |
 | unCreditAccount | Account to credit with the sum of costs to the unit. | VarChar | 10 |
 | unConsolCost | Variable indicating whether you want to consolidate the cost detail on the invoice. | Boolean | 1 |
 | unCreateUser | Reserved for future use. | VarChar | 20 |
 | unCreateDate | Reserved for future use. | DBTimeStamp | 4 |
 | unLastUser | Reserved for future use. | VarChar | 20 |
 | unLastUpdateDate | Reserved for future use. | DBTimeStamp | 4 |

Indexes

Index | Description | Primary | Unique
UNPK |  |  |

SQL

CREATE TABLE [UN] (
    [unTable] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [unUnit] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [unName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unSingleLabel] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unPluralLabel] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unBillingRate] [float] NULL ,
    [unFormat] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unConsolBill] [bit] NOT NULL CONSTRAINT [DF__UN__unConsolBill__597B3B93] DEFAULT (0),
    [unShowDate] [bit] NOT NULL CONSTRAINT [DF__UN__unShowDate__5A6F5FCC] DEFAULT (0),
    [unShowCalc] [bit] NOT NULL CONSTRAINT [DF__UN__unShowCalc__5B638405] DEFAULT (0),
    [unPostAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unCostRate] [float] NULL ,
    [unRegAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unOHAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unCreditProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unCreditTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unCreditAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unConsolCost] [bit] NOT NULL CONSTRAINT [DF__UN__unConsolCost__5C57A83E] DEFAULT (0),
    [unCreateUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unCreateDate] [datetime] NULL ,
    [unLastUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [unLastUpdateDate] [datetime] NULL ,
    CONSTRAINT [UNPK] PRIMARY KEY NONCLUSTERED
    (
        [unTable],
        [unUnit]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

UN Table | Deltek Advantage 9.0 Database

UNPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | unTable |  | Ascending
Primary Key | unUnit |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

UN Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

unControl Table

Description

Units Table - Data Entry Control

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the unit data entry transaction file. | VarChar | 15 |
 | Recurring | Variable indicating whether this is a recurring transaction file. | Boolean | 1 |
 | Selected | Variable indicating whether the file has been selected for posting. | Boolean | 1 |
 | Posted | Variable indicating whether the transaction file has been posted. | VarChar | 1 |
 | Creator | Name of the user who created the file. | VarChar | 15 |
 | Period | Fiscal period and year. | Integer | 4 |
 | EndDate | End date for the transaction file. | DBTimeStamp | 4 |
 | Total | Total quantity entered for the transaction file. | Double | 9 |
 | PostPeriod | Period in which the unit data entry transaction file was posted. | Integer | 4 |
 | PostSeq | Post sequence number assigned to the unit data entry transaction file. | SmallInt | 2 |

Indexes

Index | Description | Primary | Unique
unControlPK |  |  |

SQL

CREATE TABLE [unControl] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Recurring] [bit] NOT NULL CONSTRAINT [DF__unControl__Recur__58520D30] DEFAULT (0),
    [Selected] [bit] NOT NULL CONSTRAINT [DF__unControl__Selec__59463169] DEFAULT (0),
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__unControl__Poste__5A3A55A2] DEFAULT ('N'),
    [Creator] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Period] [int] NULL ,
    [EndDate] [datetime] NULL ,
    [Total] [float] NULL ,
    [PostPeriod] [int] NULL CONSTRAINT [DF__unControl__PostP__5B2E79DB] DEFAULT (0),
    [PostSeq] [smallint] NULL CONSTRAINT [DF__unControl__PostS__5C229E14] DEFAULT (0),
    CONSTRAINT [unControlPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

unControl Table | Deltek Advantage 9.0 Database

unControlPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

unControl Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

unDetail Table

Description

Units Table - Data Entry Detail

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the unit data entry transaction file. | VarChar | 15 |
Primary Key | Unit | Required. Unit number. | VarChar | 10 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | TransDate | Date of the transaction. | DBTimeStamp | 4 |
 | Project | Project to which the unit amount applies. | VarChar | 12 |
 | ProjType | Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | TaskType | Variable indicating whether the project has tasks. | VarChar | 1 |
 | Task | Task to which the timesheet amount applies. | VarChar | 5 |
 | TableNo | Unit table to use for the transaction. | VarChar | 12 |
 | Account | Account to which the unit amount applies. | VarChar | 10 |
 | Description | Unit description. | VarChar | 40 |
 | Quantity | Unit quantity. | Double | 9 |

Indexes

Index | Description | Primary | Unique
unDetailPK |  |  |

SQL

CREATE TABLE [unDetail] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Unit] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Seq] [int] NOT NULL ,
    [TransDate] [datetime] NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TaskType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TableNo] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Account] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Description] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Quantity] [float] NULL ,
    CONSTRAINT [unDetailPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Unit],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

unDetail Table | Deltek Advantage 9.0 Database

unDetailPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Unit |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

unDetail Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

unMaster Table

Description

Units Table - Data Entry Master

Properties

Creation Date | Wednesday, May 03, 2006 12:16
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Batch | Required. Name of the unit data entry transaction file. | VarChar | 15 |
Primary Key | Unit | Required. Unit number. | VarChar | 10 |
 | Posted | Variable indicating whether the data entry file has been posted. | VarChar | 1 |
 | Seq | Sequence number for sorting data entry screen and transaction lists. | Integer | 4 |

Indexes

Index | Description | Primary | Unique
unMasterPK |  |  |

SQL

CREATE TABLE [unMaster] (
    [Batch] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Unit] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [Posted] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL CONSTRAINT [DF__unMaster__Posted__04308F6E] DEFAULT ('N'),
    [Seq] [int] NULL ,
    CONSTRAINT [unMasterPK] PRIMARY KEY NONCLUSTERED
    (
        [Batch],
        [Unit]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

unMaster Table | Deltek Advantage 9.0 Database

unMasterPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Batch |  | Ascending
Primary Key | Unit |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

unMaster Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

VE Table

Description

Vendor Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | veVendor | Required. Vendor number. | VarChar | 10 |
 | veName | Vendor name. | VarChar | 40 |
 | veSortName | Vendor sort name. | VarChar | 40 |
 | veType | Variable indicating the vendor type. Valid options are C - Consultant; T - Trade; and E - Employee. | VarChar | 1 |
 | veStatus | Variable indicating the vendor status. Valid options are A - Active; I - Inactive; and D - Dormant. | VarChar | 1 |
 | ve1099Req | Variable indicating whether a 1099 Form is required for the vendor. | Boolean | 1 |
 | veFedID | Federal taxpayer identification number for the vendor. | VarChar | 11 |
 | vePayTerms | Variable indicating the default payment terms for the vendor. Valid options are Number of Days; Hold; Next; and PWP. | VarChar | 4 |
 | veDiscPct | Discount percent for the vendor. | Double | 9 |
 | veDiscPeriod | Days in which payment must be received for the discount to apply. | SmallInt | 2 |
 | veDiscCode | Discount code for the vendor. | VarChar | 10 |
 | veOHAccount | Default account to use for overhead projects in data entry. | VarChar | 10 |
 | veRegAccount | Default account to use for regular projects in data entry. | VarChar | 10 |
 | veReimbAccount | Default account to use for reimbursable projects in data entry. | VarChar | 10 |
 | veProfCtr | Profit center for the vendor. Used for sorting purposes only. | VarChar | 8 |
 | veCheckPerVoucher | Variable indicating whether you want to print a separate check for each voucher for the vendor. | Boolean | 1 |
 | veThisYear1099 | Amount paid to the vendor since the last 1099 initialization. | Double | 9 |
 | veLastYear1099 | 1099 amount for last year. The 1099 form for the vendor should match the amount. | Double | 9 |
 | veSelect1 | Vendor sort/select code 1. | VarChar | 20 |
 | veSelect2 | Vendor sort/select code 2. | VarChar | 20 |
 | veSelect3 | Vendor sort/select code 3. | VarChar | 20 |
 | veMemo | Memo field for comments regarding the vendor. | LongVarChar | 16 |
 | veMemoPrintOnCheck | Indicates whether to print the memo field on A/P checks for this vendor. A “Y” setting here overrides an “N” setting in MemoPrintOnCheck in the CFGAPMain Table. If the setting here is “D,” Advantage uses the setting there. Valid options are D - Default; Y - Print on check; and N - Do not print on check. | VarChar | 10 |
 | veSelect4 | Vendor sort/select code 4. | VarChar | 20 |
 | veSelect5 | Vendor sort/select code 5. | VarChar | 20 |
 | veSelect6 | Vendor sort/select code 6. | VarChar | 20 |
 | veSelect7 | Vendor sort/select code 7. | VarChar | 20 |
 | veSelect8 | Vendor sort/select code 8. | VarChar | 20 |
 | veSelect9 | Vendor sort/select code 9. | VarChar | 20 |
 | veSelect10 | Vendor sort/select code 10. | VarChar | 20 |
 | veSelect11 | Vendor sort/select code 11. | VarChar | 20 |
 | veSelect12 | Vendor sort/select code 12. | VarChar | 20 |
 | veSelect13 | Vendor sort/select code 13. | VarChar | 20 |
 | veSelect14 | Vendor sort/select code 14. | VarChar | 20 |
 | veSelect15 | Vendor sort/select code 15. | VarChar | 20 |
 | veSelect16 | Vendor sort/select code 16. | Double | 9 |
 | veSelect17 | Vendor sort/select code 17. | Double | 9 |
 | veSelect18 | Vendor sort/select code 18. | Double | 9 |
 | veSelect19 | Vendor sort/select code 19. | Double | 9 |
 | veSelect20 | Vendor sort/select code 20 | Double | 9 |
 | veSelect21 | Vendor sort/select code 21. | Double | 9 |
 | veSelect22 | Vendor sort/select code 22. | Double | 9 |
 | veSelect23 | Vendor sort/select code 23. | Double | 9 |
 | veSelect24 | Vendor sort/select code 24. | Double | 9 |
 | veSelect25 | Vendor sort/select code 25. | Double | 9 |
 | veSelect26 | Vendor sort/select code 26. | DBTimeStamp | 4 |
 | veSelect27 | Vendor sort/select code 27. | DBTimeStamp | 4 |
 | veSelect28 | Vendor sort/select code 28. | DBTimeStamp | 4 |
 | veSelect29 | Vendor sort/select code 29. | DBTimeStamp | 4 |
 | veSelect30 | Vendor sort/select code 30. | DBTimeStamp | 4 |
 | veCreateUser | Reserved for future use. | VarChar | 20 |
 | veCreateDate | Reserved for future use. | DBTimeStamp | 4 |
 | veLastUser | Reserved for future use. | VarChar | 20 |
 | veLastUpdateDate | Reserved for future use. | DBTimeStamp | 4 |

Indexes

Index | Description | Primary | Unique
VEPK |  |  |
veDiscCodeIDX |  |  |
veFedIDIDX |  |  |

SQL

CREATE TABLE [VE] (
    [veVendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [veName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSortName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ve1099Req] [bit] NOT NULL CONSTRAINT [DF__VE__ve1099Req__353DDB1D] DEFAULT (0),
    [veFedID] [varchar] (11) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [vePayTerms] [varchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veDiscPct] [float] NULL ,
    [veDiscPeriod] [smallint] NULL ,
    [veDiscCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veOHAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veRegAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veReimbAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veCheckPerVoucher] [bit] NOT NULL CONSTRAINT [DF__VE__veCheckPerVo__3631FF56] DEFAULT (0),
    [veThisYear1099] [float] NULL ,
    [veLastYear1099] [float] NULL ,
    [veSelect1] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect2] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect3] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veMemo] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veMemoPrintOnCheck] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect4] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect5] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect6] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect7] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect8] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect9] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect10] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect11] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect12] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect13] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect14] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect15] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect16] [float] NULL ,
    [veSelect17] [float] NULL ,
    [veSelect18] [float] NULL ,
    [veSelect19] [float] NULL ,
    [veSelect20] [float] NULL ,
    [veSelect21] [float] NULL ,
    [veSelect22] [float] NULL ,
    [veSelect23] [float] NULL ,
    [veSelect24] [float] NULL ,
    [veSelect25] [float] NULL ,
    [veSelect26] [datetime] NULL ,
    [veSelect27] [datetime] NULL ,
    [veSelect28] [datetime] NULL ,
    [veSelect29] [datetime] NULL ,
    [veSelect30] [datetime] NULL ,
    [veCreateUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veCreateDate] [datetime] NULL ,
    [veLastUser] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veLastUpdateDate] [datetime] NULL ,
    CONSTRAINT [VEPK] PRIMARY KEY NONCLUSTERED
    (
        [veVendor]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

VE Table | Deltek Advantage 9.0 Database

VEPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | veVendor |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

VE Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

VE Table | Deltek Advantage 9.0 Database

veDiscCodeIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
veDiscCode |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

VE Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

VE Table | Deltek Advantage 9.0 Database

veFedIDIDX Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
veFedID |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

VE Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

VEA Table

Description

Vendor Table - Addresses

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | veaVendor | Required. Vendor number. | VarChar | 10 |
Primary Key | veaAddress | Required. Vendor address code. | VarChar | 10 |
 | veaAddress1 | First line of the vendor’s address. | VarChar | 40 |
 | veaAddress2 | Second line of the vendor’s address. | VarChar | 40 |
 | veaAddress3 | Third line of the vendor’s address. | VarChar | 40 |
 | veaAddress4 | Fourth line of the vendor’s address. | VarChar | 40 |
 | veaCity | Vendor’s city. | VarChar | 18 |
 | veaState | Vendor’s state. | VarChar | 2 |
 | veaZIP | Vendor’s zip code. | VarChar | 10 |
 | veaCountry | Vendor’s country. | VarChar | 12 |
 | veaContact | Name of the vendor contact. | VarChar | 40 |
 | veaPhone | Vendor’s telephone number. | VarChar | 24 |
 | veaFAX | Vendor’s FAX number. | VarChar | 24 |
 | veaEMail | Vendor’s e-mail address. | VarChar | 50 |
 | veaDefaultTaxCode | Default tax code for transactions charged to this vendor. | VarChar | 3 |
 | veaTaxCountryCode | Vendor's tax country code. | VarChar | 2 |
 | veaTaxRegistrationNumber | Vendor's tax registration number. | VarChar | 15 |

Indexes

Index | Description | Primary | Unique
VEAPK |  |  |

SQL

CREATE TABLE [VEA] (
    [veaVendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [veaAddress] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [veaAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaAddress3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaAddress4] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaZIP] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaCountry] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaContact] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaPhone] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaFAX] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaEMail] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaDefaultTaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaTaxCountryCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veaTaxRegistrationNumber] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    CONSTRAINT [VEAPK] PRIMARY KEY NONCLUSTERED
    (
        [veaVendor],
        [veaAddress]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

VEA Table | Deltek Advantage 9.0 Database

VEAPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | veaVendor |  | Ascending
Primary Key | veaAddress |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

VEA Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

VEF Table

Description

Vendor Table - Financials

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 40 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | vefVendor | Required. Vendor number. | VarChar | 10 |
Primary Key | vefPeriod | Required. Fiscal year and period. | Integer | 4 |
 | vefBilled | Amount billed by the vendor in the period. | Double | 9 |
 | vefPaid | Total of all checks written to the vendor in the period. | Double | 9 |

Indexes

Index | Description | Primary | Unique
VEFPK |  |  |
vefPeriodIDX |  |  |

SQL

CREATE TABLE [VEF] (
    [vefVendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [vefPeriod] [int] NOT NULL ,
    [vefBilled] [float] NULL ,
    [vefPaid] [float] NULL ,
    CONSTRAINT [VEFPK] PRIMARY KEY NONCLUSTERED
    (
        [vefVendor],
        [vefPeriod]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

VEF Table | Deltek Advantage 9.0 Database

VEFPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | vefVendor |  | Ascending
Primary Key | vefPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

VEF Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

VEF Table | Deltek Advantage 9.0 Database

vefPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | vefPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

VEF Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

VEInitiation Table

Description

Vendors to be Approved Table

Properties

Creation Date | Wednesday, May 03, 2006 12:15
Owner | dbo
File Group | PRIMARY
Text File Group | PRIMARY
System Object |
Published for Replication |
Rows | 0
Data Space Used | 0 KB
Index Space Used | 0 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | veVendor | Required. Vendor number. | VarChar | 10 |
Primary Key | veAddress | Required. Vendor address code. | VarChar | 10 |
Primary Key | veRecType | Required. Internal record type. | VarChar | 1 |
 | veApproved | Required. Variable indicating whether the vendor has been approved. | Boolean | 1 |
 | veSelected | Required. Variable indicating whether the vendor has been approved. | Boolean | 1 |
 | veErrorMsg | Error message. | VarChar | 255 |
 | veName | Vendor name. | VarChar | 40 |
 | veSortName | Vendor sort name. | VarChar | 40 |
 | veType | Variable indicating the vendor type. Valid options are C - Consultant; T - Trade; and E - Employee. | VarChar | 1 |
 | veStatus | Variable indicating the vendor status. Valid options are A - Active; I - Interactive; and D - Dormant. | VarChar | 1 |
 | ve1099Req | Variable indicating whether a 1099 form is required for the vendor. | Boolean | 1 |
 | veFedID | Federal taxpayer identification number for the vendor. | VarChar | 11 |
 | vePayTerms | Variable indicating the default payment terms for the vendor. Valid options are Number of Days; Hold; Next; and PWP. | VarChar | 4 |
 | veDiscPct | Discount percent for the vendor. | Double | 9 |
 | veDiscPeriod | Days in which payment must be received for the discount to apply. | SmallInt | 2 |
 | veDiscCode | Discount code for the vendor. | VarChar | 10 |
 | veOHAccount | Default account to use for overhead projects in data entry. | VarChar | 10 |
 | veRegAccount | Default account to use for regular projects in data entry. | VarChar | 10 |
 | veReimbAccount | Default account to use for reimbursable projects in data entry. | VarChar | 10 |
 | veProfCtr | Profit center for the vendor. Used for sorting purposes only. | VarChar | 8 |
 | veCheckPerVoucher | Variable indicating whether to print a separate check for each voucher for the vendor. | Boolean | 1 |
 | veThisYear1099 | Amount paid to the vendor since the last 1099 initialization. | Double | 9 |
 | veLastYear1099 | Amount paid to the vendor last year. This should match the amount on the 1099 form for the vendor. | Double | 9 |
 | veSelect1 | Vendor sort/select code 1. | VarChar | 20 |
 | veSelect2 | Vendor sort/select code 2. | VarChar | 20 |
 | veSelect3 | Vendor sort/select code 3. | VarChar | 20 |
 | veAddress1 | First line of the vendor’s address. | VarChar | 40 |
 | veAddress2 | Second line of the vendor’s address. | VarChar | 40 |
 | veAddress3 | Third line of the vendor’s address. | VarChar | 40 |
 | veAddress4 | Fourth line of the vendor’s address. | VarChar | 40 |
 | veCity | Vendor’s city. | VarChar | 18 |
 | veState | Vendor’s state. | VarChar | 2 |
 | veZIP | Vendor’s zip code. | VarChar | 10 |
 | veCountry | Vendor’s country. | VarChar | 12 |
 | veContact | Name of vendor contact. | VarChar | 40 |
 | vePhone | Vendor’s telephone number. | VarChar | 24 |
 | veFAX | Vendor’s fax number. | VarChar | 24 |
 | veEMail | Vendor’s e-mail address. | VarChar | 50 |
 | veDefaultTaxCode | Default tax code for transactions charged to this vendor. | VarChar | 3 |
 | veTaxCountryCode | Vendor’s tax country code. | VarChar | 2 |
 | veTaxRegistrationNumber | Vendor’s tax registration number. | VarChar | 15 |
 | veMemo | Memo field for comments on the vendor. | LongVarChar | 16 |
 | veMemoPrintOnCheck | Indicates whether to print the memo field on A/P checks for this vendor. A “Y” setting here overrides an “N” setting in MemoPrintOnCheck in the CFGAPMain Table. If the setting here is “D,” Advantage uses the setting there. Valid options are D - Default; Y - Print on check; and N - Do not print on check. | VarChar | 10 |
 | veSelect4 | Vendor sort/select code 4. | VarChar | 20 |
 | veSelect5 | Vendor sort/select code 5. | VarChar | 20 |
 | veSelect6 | Vendor sort/select code 6. | VarChar | 20 |
 | veSelect7 | Vendor sort/select code 7. | VarChar | 20 |
 | veSelect8 | Vendor sort/select code 8. | VarChar | 20 |
 | veSelect9 | Vendor sort/select code 9. | VarChar | 20 |
 | veSelect10 | Vendor sort/select code 10. | VarChar | 20 |
 | veSelect11 | Vendor sort/select code 11. | VarChar | 20 |
 | veSelect12 | Vendor sort/select code 12. | VarChar | 20 |
 | veSelect13 | Vendor sort/select code 13. | VarChar | 20 |
 | veSelect14 | Vendor sort/select code 14. | VarChar | 20 |
 | veSelect15 | Vendor sort/select code 15. | VarChar | 20 |
 | veSelect16 | Vendor sort/select code 16. | Double | 9 |
 | veSelect17 | Vendor sort/select code 17. | Double | 9 |
 | veSelect18 | Vendor sort/select code 18. | Double | 9 |
 | veSelect19 | Vendor sort/select code 19. | Double | 9 |
 | veSelect20 | Vendor sort/select code 20. | Double | 9 |
 | veSelect21 | Vendor sort/select code 21. | Double | 9 |
 | veSelect22 | Vendor sort/select code 22. | Double | 9 |
 | veSelect23 | Vendor sort/select code 23. | Double | 9 |
 | veSelect24 | Vendor sort/select code 24. | Double | 9 |
 | veSelect25 | Vendor sort/select code 25. | Double | 9 |
 | veSelect26 | Vendor sort/select code 26. | DBTimeStamp | 4 |
 | veSelect27 | Vendor sort/select code 27. | DBTimeStamp | 4 |
 | veSelect28 | Vendor sort/select code 28. | DBTimeStamp | 4 |
 | veSelect29 | Vendor sort/select code 29. | DBTimeStamp | 4 |
 | veSelect30 | Vendor sort/select code 30. | DBTimeStamp | 4 |

Indexes

Index | Description | Primary | Unique
VEInitiationPK |  |  |

SQL

CREATE TABLE [VEInitiation] (
    [veVendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [veAddress] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [veRecType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [veApproved] [bit] NOT NULL CONSTRAINT [DF__VEInitiat__veApp__3CDEFCE5] DEFAULT (0),
    [veSelected] [bit] NOT NULL CONSTRAINT [DF__VEInitiat__veSel__3DD3211E] DEFAULT (0),
    [veErrorMsg] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSortName] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veStatus] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ve1099Req] [bit] NOT NULL CONSTRAINT [DF__VEInitiat__ve109__3EC74557] DEFAULT (0),
    [veFedID] [varchar] (11) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [vePayTerms] [varchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veDiscPct] [float] NULL ,
    [veDiscPeriod] [smallint] NULL ,
    [veDiscCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veOHAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veRegAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veReimbAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veCheckPerVoucher] [bit] NOT NULL CONSTRAINT [DF__VEInitiat__veChe__3FBB6990] DEFAULT (0),
    [veThisYear1099] [float] NULL ,
    [veLastYear1099] [float] NULL ,
    [veSelect1] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect2] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect3] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veAddress1] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veAddress2] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veAddress3] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veAddress4] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veCity] [varchar] (18) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veState] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veZIP] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veCountry] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veContact] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [vePhone] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veFAX] [varchar] (24) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veEMail] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veDefaultTaxCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veTaxCountryCode] [varchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veTaxRegistrationNumber] [varchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veMemo] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veMemoPrintOnCheck] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect4] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect5] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect6] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect7] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect8] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect9] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect10] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect11] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect12] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect13] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect14] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect15] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [veSelect16] [float] NULL ,
    [veSelect17] [float] NULL ,
    [veSelect18] [float] NULL ,
    [veSelect19] [float] NULL ,
    [veSelect20] [float] NULL ,
    [veSelect21] [float] NULL ,
    [veSelect22] [float] NULL ,
    [veSelect23] [float] NULL ,
    [veSelect24] [float] NULL ,
    [veSelect25] [float] NULL ,
    [veSelect26] [datetime] NULL ,
    [veSelect27] [datetime] NULL ,
    [veSelect28] [datetime] NULL ,
    [veSelect29] [datetime] NULL ,
    [veSelect30] [datetime] NULL ,
    CONSTRAINT [VEInitiationPK] PRIMARY KEY NONCLUSTERED
    (
        [veVendor],
        [veAddress],
        [veRecType]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

VEInitiation Table | Deltek Advantage 9.0 Database

VEInitiationPK Index

Properties

File Group | PRIMARY
Space Used | 0 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | veVendor |  | Ascending
Primary Key | veAddress |  | Ascending
Primary Key | veRecType |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

VEInitiation Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

VO Table

Description

Voucher Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 56 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | voVendor | Required. Vendor number. | VarChar | 10 |
Primary Key | voVoucher | Required. Voucher number. | VarChar | 7 |
 | voPeriod | Fiscal year and period in which the posting occurred. | Integer | 4 |
 | voDate | Voucher date. | DBTimeStamp | 4 |
 | voInvoiceDate | Vendor’s invoice date. | DBTimeStamp | 4 |
 | voInvoice | Vendor’s invoice number. | VarChar | 20 |
 | voBankCode | Bank code assigned to the transaction during data entry. | VarChar | 10 |
 | voLiabCode | Liability code assigned to the transaction during data entry. | VarChar | 10 |
 | voAddress | Address code for the vendor’s voucher. | VarChar | 10 |
 | voSelected | Internal sequence number. | SmallInt | 2 |
 | voPaidPeriod | Accounting period in which the voucher was paid in full. | Integer | 4 |
 | voPayTerms | Variable indicating the payment terms. Valid optioins are Next, Hold, PWP, Partial, and Date. | VarChar | 7 |
 | voPaymentDate | Payment due date if voPayTerms is ‘Date’. | DBTimeStamp | 4 |

Indexes

Index | Description | Primary | Unique
VOPK |  |  |
voPaidPeriodIDX |  |  |
voSelectedIDX |  |  |

SQL

CREATE TABLE [VO] (
    [voVendor] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [voVoucher] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
    [voPeriod] [int] NULL ,
    [voDate] [datetime] NULL ,
    [voInvoiceDate] [datetime] NULL ,
    [voInvoice] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [voBankCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [voLiabCode] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [voAddress] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [voSelected] [smallint] NULL ,
    [voPaidPeriod] [int] NULL ,
    [voPayTerms] [varchar] (7) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [voPaymentDate] [datetime] NULL ,
    CONSTRAINT [VOPK] PRIMARY KEY NONCLUSTERED
    (
        [voVendor],
        [voVoucher]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

VO Table | Deltek Advantage 9.0 Database

VOPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | voVendor |  | Ascending
Primary Key | voVoucher |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

VO Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

VO Table | Deltek Advantage 9.0 Database

voPaidPeriodIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
voPaidPeriod |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

VO Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

VO Table | Deltek Advantage 9.0 Database

voSelectedIDX Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

Column | Description | Sort Order
voSelected |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

VO Table | Deltek Advantage 9.0 Database


%%LocalItemTitle%%

Deltek Advantage 9.0 Database

XChargeWk Table

Description

Cross Charge Work Table

Properties

Creation Date | Monday, January 26, 2004 15:01
Owner | dbo
File Group | PRIMARY
Text File Group |
System Object |
Published for Replication |
Rows | 0
Data Space Used | 8 KB
Index Space Used | 24 KB

Columns

 | Column Name | Description | Datatype | Length | Allow Nulls
Primary Key | Period | Required. Fiscal year and period in which the labor transaction was posted. | Integer | 4 |
Primary Key | Seq | Required. Internal sequence number. | Integer | 4 |
 | Employee | Employee number. | VarChar | 10 |
 | Project | Project number. | VarChar | 12 |
 | Task | Task number. | VarChar | 5 |
 | TransDate | Date on which the labor transaction was posted. | DBTimeStamp | 4 |
 | LaborCode | Labor code. | VarChar | 5 |
 | RegAmt | Regular amount posted. | Double | 9 |
 | OvtAmt | Overtime amount posted. | Double | 9 |
 | EmpProfCtr | Employee’s profit center. | VarChar | 8 |
 | ProjProfCtr | Project’s profit center. | VarChar | 8 |
 | Multiplier | Multiplier specified for the project, profit center, or system. | Double | 9 |
 | Method | Method to use for cross charging. Valid options are 0 - Multiplier and 1 - Billing Terms. | SmallInt | 2 |
 | MethodSource | Source of the cross charge method: project or profit center. | VarChar | 1 |
 | RegHrs | Regular hours posted. | Double | 9 |
 | OvtHrs | Overtime hours posted. | Double | 9 |
 | Rate | Employee’s rate. | Double | 9 |
 | OvtPct | Overtime percentage for the employee. | Double | 9 |
 | BillingCategory | Default billing category to use when using the By Category labor billing method. | SmallInt | 2 |
 | ProjectType | Variable indicating the project type. Valid options are R - Regular; H - Overhead; and P - Promotional. | VarChar | 1 |
 | CreditProject | Credit project used for posting the cross charge. | VarChar | 12 |
 | CreditTask | Credit task used for posting the cross charge. | VarChar | 5 |
 | DebitProject | Debit project used for posting the cross charge. | VarChar | 12 |
 | DebitTask | Debit task used for posting the cross charge. | VarChar | 5 |
 | FromProject | .Project from which the employee is cross charging. | VarChar | 12 |
 | FromTask | Task from which the employee is cross charging | VarChar | 5 |
 | ToProject | Project to which the employee is cross charging. | VarChar | 12 |
 | ToTask | Task to which the employee is cross charging. | VarChar | 5 |
 | DebitAmt | Debit amount of the cross charge. | Double | 9 |
 | CreditAmt | Credit amount of the cross charge. | Double | 9 |
 | DebitAccount | Debit account for the cross charge amount | VarChar | 10 |
 | CreditAccount | Credit account for the cross charge amount | VarChar | 10 |
 | ChargeType | Variable indicating the type of cross charge. Valid options are J - Journal Entry; L - Labor Adjustment; and B - Both. | VarChar | 1 |
 | ErrorMsg | Cross charge error message. | VarChar | 255 |
 | SpecialOvtAmt | Special overtime amount. | Double | 9 |
 | SpecialOvtHrs | Special overtime hours. | Double | 9 |
 | SpecialOvtPct | Special overtime percentage. | Double | 9 |

Indexes

Index | Description | Primary | Unique
XChargeWkPK |  |  |

SQL

CREATE TABLE [XChargeWk] (
    [Period] [int] NOT NULL ,
    [Seq] [int] NOT NULL ,
    [Employee] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Project] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Task] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [TransDate] [datetime] NULL ,
    [LaborCode] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RegAmt] [float] NULL ,
    [OvtAmt] [float] NULL ,
    [EmpProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ProjProfCtr] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [Multiplier] [float] NULL ,
    [Method] [smallint] NULL ,
    [MethodSource] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [RegHrs] [float] NULL ,
    [OvtHrs] [float] NULL ,
    [Rate] [float] NULL ,
    [OvtPct] [float] NULL ,
    [BillingCategory] [smallint] NULL ,
    [ProjectType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CreditProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CreditTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DebitProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DebitTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FromProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [FromTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ToProject] [varchar] (12) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ToTask] [varchar] (5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [DebitAmt] [float] NULL ,
    [CreditAmt] [float] NULL ,
    [DebitAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [CreditAccount] [varchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ChargeType] [varchar] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [ErrorMsg] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL ,
    [SpecialOvtAmt] [float] NULL ,
    [SpecialOvtHrs] [float] NULL ,
    [SpecialOvtPct] [float] NULL ,
    CONSTRAINT [XChargeWkPK] PRIMARY KEY NONCLUSTERED
    (
        [Period],
        [Seq]
    ) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

Deltek Advantage 9.0 Database


%%LocalItemTitle%%

XChargeWk Table | Deltek Advantage 9.0 Database

XChargeWkPK Index

Properties

File Group | PRIMARY
Space Used | 16 KB
Fill Factor | 90
Do not Recompute Statistics |
Full Text Key |
Clustered Index |
Primary Key Index |
Unique Index |
Pad Index |

Columns

 | Column | Description | Sort Order
Primary Key | Period |  | Ascending
Primary Key | Seq |  | Ascending

Index Statistics

Average key length
Density
Rows in the Table
Rows Sampled
Distribution Steps
Updated

See Also

XChargeWk Table | Deltek Advantage 9.0 Database